Autor Tema: parches que vais a necesitar en 3.8 en adelante  (Leído 34832 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #100 en: 04-09-2013, 03:20 (Miércoles) »
este es el aufs


ORIGINAL rcN -->> http://www.multiupload.nl/J0LEC1RJV0

Que tampoco aplica.

el tuyo falla en la 37 y el original rcN en la 36

Hunk #1 FAILED at 36.
1 out of 1 hunk FAILED -- saving rejects to file fs/file_table.c.rej


« Última modificación: 04-09-2013, 03:22 (Miércoles) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #101 en: 04-09-2013, 03:28 (Miércoles) »
fichero  file_table.c  hasta la linea 60

Código: [Seleccionar]
/*
 *  linux/fs/file_table.c
 *
 *  Copyright (C) 1991, 1992  Linus Torvalds
 *  Copyright (C) 1997 David S. Miller (davem@caip.rutgers.edu)
 */

#include <linux/string.h>
#include <linux/slab.h>
#include <linux/file.h>
#include <linux/fdtable.h>
#include <linux/init.h>
#include <linux/module.h>
#include <linux/fs.h>
#include <linux/security.h>
#include <linux/eventpoll.h>
#include <linux/rcupdate.h>
#include <linux/mount.h>
#include <linux/capability.h>
#include <linux/cdev.h>
#include <linux/fsnotify.h>
#include <linux/sysctl.h>
#include <linux/lglock.h>
#include <linux/percpu_counter.h>
#include <linux/percpu.h>
#include <linux/hardirq.h>
#include <linux/task_work.h>
#include <linux/ima.h>

#include <linux/atomic.h>

#include "internal.h"

/* sysctl tunables... */
struct files_stat_struct files_stat = {
.max_files = NR_FILE
};

DEFINE_LGLOCK(files_lglock);
EXPORT_SYMBOL(files_lglock);

/* SLAB cache for file structures */
static struct kmem_cache *filp_cachep __read_mostly;

static struct percpu_counter nr_files __cacheline_aligned_in_smp;

static void file_free_rcu(struct rcu_head *head)
{
struct file *f = container_of(head, struct file, f_u.fu_rcuhead);

put_cred(f->f_cred);
kmem_cache_free(filp_cachep, f);
}

static inline void file_free(struct file *f)
{
percpu_counter_dec(&nr_files);
file_check_state(f);
call_rcu(&f->f_u.fu_rcuhead, file_free_rcu);
}

alist3r

  • Visitante
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #102 en: 04-09-2013, 03:36 (Miércoles) »
muestrame el archivo .rej

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #103 en: 04-09-2013, 03:46 (Miércoles) »
 :P

ahora me aplica bien el rcN , no hay FAILED , por si acaso busque fciehros *.rej en el souce y no hay , asi que aplica limpio ..ahora a ver si despues de compilar el kernel arranca el aufs.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #104 en: 04-09-2013, 04:10 (Miércoles) »
fs/aufs/mvdown.c: En la función ‘au_mvd_args_busy’:
fs/aufs/mvdown.c:302:18: error: ‘struct dentry’ no tiene un miembro llamado ‘d_count’
fs/aufs/mvdown.c:310:2: error: ‘struct dentry’ no tiene un miembro llamado ‘d_count’
  CC [M]  fs/autofs4/symlink.o
make[2]: *** [fs/aufs/mvdown.o] Error 1
make[1]: *** [fs/aufs] Error 2
make[1]: *** Se espera a que terminen otras tareas....
  CC [M]  fs/autofs4/waitq.o
  CC      crypto/api.o
  LD      security/built-in.o
  CC [M]  fs/autofs4/expire.o
  CC      block/elevator.o
  CC      block/blk-core.o
  CC      crypto/cipher.o
  CC [M]  fs/autofs4/dev-ioctl.o
  CC      crypto/compress.o
  CC      crypto/algapi.o
  LD [M]  fs/autofs4/autofs4.o
make: *** [fs] Error 2
make: *** Se espera a que terminen otras tareas....
  CC      crypto/scatterwalk.o
  CC      block/blk-tag.o
  CC      block/blk-sysfs.o


por mi parte no pruebo ya nada mas.

el 3.11.rc7 compilaba con el aufs rcN ( Aunque tampoco funcionaba aufs )    , pero el mainline NO.

alist3r

  • Visitante
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #105 en: 04-09-2013, 04:47 (Miércoles) »
no uses el aufs rcN

el 3 de julio se cambio d_count por d_refcount
http://www.spinics.net/lists/ceph-devel/msg15503.html

si te limitas a agarrar los parches de 3.10 y los modificas, te irá todo bien.
si agarras los rc, a juzgar por la presencia de d_count, son mas viejos. no cabe duda.
si has tenido un error aplicando aufs 3.10 lo arreglamos, pero si te haces otro procedimiento diferente al que yo hice, ahi si que me pierdo, y visto lo visto, mejor olvidate de aufs3x-rc

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #106 en: 04-09-2013, 05:16 (Miércoles) »
bueno , pues are lo siguiente , ...

cogere el aufs3.10  , e intentare aplicarlo .. si falla , reviso y miramos a ver.

alist3r

  • Visitante
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #107 en: 04-09-2013, 05:24 (Miércoles) »
okis.
mañana me cuentas

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #108 en: 04-09-2013, 05:25 (Miércoles) »
Tu aufs parcheado ..FAILED line 37

sobre 3.11 mainline

Código: [Seleccionar]
patching file fs/file_table.c
Hunk #1 FAILED at 37.
Hunk #2 succeeded at 406 (offset 1 line).
1 out of 2 hunks FAILED -- saving rejects to file fs/file_table.c.rej

y el fichero reject contiene ....


Código: [Seleccionar]
--- fs/file_table.c
+++ fs/file_table.c
@@ -37,6 +37,7 @@
 };
 
 DEFINE_LGLOCK(files_lglock);
+EXPORT_SYMBOL(files_lglock);
 
 /* SLAB cache for file structures */
 static struct kmem_cache *filp_cachep __read_mostly;

alist3r

  • Visitante
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #109 en: 04-09-2013, 11:40 (Miércoles) »
busca en filetable la linea que dice:
DEFINE_LGLOCK(files_lglock);

y mete justo debajo esta linea:
EXPORT_SYMBOL(files_lglock);

sin quitar ninguna. solo añadir.

y listo
« Última modificación: 04-09-2013, 11:41 (Miércoles) por alister »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #110 en: 04-09-2013, 23:11 (Miércoles) »
tras aplicar tu pareche la linea

DEFINE_LGLOCK(files_lglock);

NO EXISTE , por eso es facil que falle...

tras tu parche la funcion queda asi....

Código: [Seleccionar]
/* sysctl tunables... */
struct files_stat_struct files_stat = {
.max_files = NR_FILE
};

DEFINE_STATIC_LGLOCK(files_lglock);

/* SLAB cache for file structures */







Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #111 en: 04-09-2013, 23:16 (Miércoles) »
Creo que definitivamente dejare el 3.11 para cuando salga como "stable"   ...por que aun aparece solo como mainline.


Ademas hoy probe de instalar los drivers ati en el 3.10.10


ati 13.1 -->  Fail , muchos ficheros han cambiado de sitio en als kernel sources y sus funciones tambien
ati 13.4 -->> fail , llega casi hasta el final y falla ....
ati 13.8 BETA -->> YEA , este si , tengo que mirar si sale la marca de agua tipica de driver beta , y de ser asi ...firmar el driver ...es un fichero que esta en  /etc/ati    y que solo contiene el digito "0"  unsigned t cambiarlo a "1"  signed   ;D  , y desaparece la marca de agua.

Imagina ene un 3.11  ;D

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #112 en: 05-09-2013, 03:12 (Jueves) »
la rama de kernel 3.10 parece que va a ser la proxima longterm ....con soporte garantizado durante 2 años.


Creo que lo veo claro ...  ;)

http://www.kroah.com/log/blog/2013/08/04/longterm-kernel-3-dot-10/

alist3r

  • Visitante
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #113 en: 05-09-2013, 10:35 (Jueves) »
voy a probar aincorporar ati 13.8 beta en mi repo corporate, aunque nosotros notenemos maquinas con ati y no nos interesa, pero por compromiso con la audiencia, a ver si me sale bien.

PD: si n ofuera por el tema wireless que evoluciona rapido, quedarse en 3.10 seria interesante. pero como te digo, seria para otro tipo de distro, para algo tan dinamico y cambiante, quizas no te interesa tanto quedarte atrás. o tienes que volver a incorporar el stack backports (el viejo compat-wireless) a mano y por encima del kernel.
« Última modificación: 05-09-2013, 10:37 (Jueves) por alister »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #114 en: 05-09-2013, 20:47 (Jueves) »
Bueno , pues comento ,..

con kernel 3.10.10 PAE ..al reiniciar si eligo de nuevo el pendrive ...

"ERROR CHECKING MACHINE"

con el normal no pasa...


He compilado un 3.9.11 y PERFECTO

pero un parche no le aplica.... ¿ puedes adaptarlo ?

Código: [Seleccionar]
--- a/net/mac80211/cfg.c 2013-09-01 14:53:24.117850300 +0200
+++ b/net/mac80211/cfg.c 2013-09-01 18:17:40.909079242 +0200
@@ -3381,22 +3381,23 @@
  struct ieee80211_chanctx_conf *chanctx_conf;
  int ret = -ENODATA;
 
- rcu_read_lock();
- chanctx_conf = rcu_dereference(sdata->vif.chanctx_conf);
- if (chanctx_conf) {
- *chandef = chanctx_conf->def;
- ret = 0;
- } else if (local->open_count > 0 &&
-    local->open_count == local->monitors &&
-    sdata->vif.type == NL80211_IFTYPE_MONITOR) {
- if (local->use_chanctx)
+ if (!wdev)
+ return -EOPNOTSUPP;
+
+ switch (wdev->iftype) {
+ case NL80211_IFTYPE_MONITOR:
  *chandef = local->monitor_chandef;
- else
- *chandef = local->_oper_chandef;
- ret = 0;
+ ret = 0;
+ break;
+ default:
+ rcu_read_lock();
+ chanctx_conf = rcu_dereference(sdata->vif.chanctx_conf);
+ if (chanctx_conf) {
+ *chandef = chanctx_conf->def;
+ ret = 0;
+ }
+ rcu_read_unlock();
  }
- rcu_read_unlock();
-
  return ret;
 }

aqui dejo en  cfg.c  ORIGINAL del 3.9.11

http://www.multiupload.nl/81I6XT4MQO


_________________________

Lo logico seria en vez de bajar de rama subir, pero no soy capaz de cocinar un 3.11 , siempre me peta la compilacion o el arranque aufs.

alist3r

  • Visitante
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #115 en: 06-09-2013, 12:56 (Viernes) »
si dentro de un tiempo aun no te has salido con el 3.11, y no han salido versiones oficiales de parches, tomas las fuentes de mi repo corporativo y listo.

de momento, ¿vas haciendo?

alist3r

  • Visitante
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #116 en: 06-09-2013, 12:57 (Viernes) »
no te aplica ese parche? puedes mostrarme los archivos .REJ?

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #117 en: 06-09-2013, 23:03 (Viernes) »
no te aplica ese parche? puedes mostrarme los archivos .REJ?


es al querer aplicarlo sobre un 3.9.X

creo que deberas crear directorios con parches especificos en cada rama.


el de asus parchea bien tanto rama 3.9 como 3.10  3.11 no lo necesita

el wireless todos van bien en 3.10 y 3.11 , pero falla la parte que te mostre en las ramas 3.9
« Última modificación: 07-09-2013, 00:55 (Sábado) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14478
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #118 en: 07-09-2013, 00:55 (Sábado) »
si dentro de un tiempo aun no te has salido con el 3.11, y no han salido versiones oficiales de parches, tomas las fuentes de mi repo corporativo y listo.

de momento, ¿vas haciendo?

de momento el candidato es el 3.10.8

alist3r

  • Visitante
Re: parches que vais a necesitar en 3.8 en adelante
« Respuesta #119 en: 07-09-2013, 17:23 (Sábado) »
te sugiero que te descargues todo el repositorio git del kernel linux.
aunque son mas de 300 megas, es la fuente de información mas valiosa que podrás disponer para entender qué pasa en el kernel, cambio por cambio, commit por commit, parche por parche.

el programa "gitk", aunque es viejito (está hecho en TK), es de lo mejor para navegar por la historia de cambios y comprenderlos. Lo ejecutas dentro del directorio git que has clonado, y ya te sale toda la informacion lista para consultar, de unos cuantos años atrás hasta hoy dia.