Autor Tema: Necesito ha alguien con grafica nvidia para pruebas.  (Leído 4292 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14470
Necesito ha alguien con grafica nvidia para pruebas.
« en: 15-09-2015, 22:39 (Martes) »
Bien , necesito que alguien con grafica nvidia , cargue el modulo del driver en modules

y ...ATENCION

arrancar en modo texto...

y despues de


root/toor

ejecute

Código: [Seleccionar]
nvidia-xconfig
es la aplicacion que intentara configurar el driver nvidia ..

lo que necesito que me digais es si ...cuando lo ejecutamos nos pide confirmar la accion..

es decir si sale un dialogo , tipo ..voy a crear un fichero config ..continuar?  y/n

creo que si que salia , y en dicho caso , tendre que hacer un ajuste ,por que el driver simplemente lo ejecuta ,pero si no confirmas la ccion no hara el xorg.conf



vk496

  • Visitante
Re: Necesito ha alguien con grafica nvidia para pruebas.
« Respuesta #1 en: 15-09-2015, 22:41 (Martes) »
No tengo gráfica NVIDIA...

Pero si pide eso, debería bastar con

Código: [Seleccionar]
yes | nvidia-xconfig
Salu2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14470
Re: Necesito ha alguien con grafica nvidia para pruebas.
« Respuesta #2 en: 15-09-2015, 22:43 (Martes) »
No tengo gráfica NVIDIA...

Pero si pide eso, debería bastar con

Código: [Seleccionar]
yes | nvidia-xconfig
Salu2

ese es el plan ...pero antes quiero saber si pide confirmar la accion ...

ferlan

  • Visitante
Re: Necesito ha alguien con grafica nvidia para pruebas.
« Respuesta #3 en: 15-09-2015, 23:56 (Martes) »
lo que necesito que me digáis es si ...cuando lo ejecutamos nos pide confirmar la acción..

No pide confirmación y suelta esto:
Código: [Seleccionar]
Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup
New X configuration file written to '/etc/X11/xorg.conf'

Si continúo con startx, suelta la tira y algo sobre el error. Y en mi caso, no arranca, por supuesto.
« Última modificación: 15-09-2015, 23:57 (Martes) por ferlan »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14470
Re: Necesito ha alguien con grafica nvidia para pruebas.
« Respuesta #4 en: 16-09-2015, 00:17 (Miércoles) »
creo que en el modulo de nvidia hay un xorg.conf


entonces intenta eliminandolo antes...


rm -rf /etc/X11/xorg.conf

y despues crea uno nuevo con

nvidia-xconfig

ferlan

  • Visitante
Re: Necesito ha alguien con grafica nvidia para pruebas.
« Respuesta #5 en: 16-09-2015, 00:54 (Miércoles) »
Lo he hecho tal como dices e incluso editando el módulo y quitando el xorg.conf

De las dos formas, el resultado es el mismo que antes.

No sé si interesara todo lo que suelta al arrancar, pero sólo veo la última parte, pues no sé si se puede hacer algo para detener la ejecución e ir viendo todo lo que tira.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14470
Re: Necesito ha alguien con grafica nvidia para pruebas.
« Respuesta #6 en: 16-09-2015, 01:01 (Miércoles) »
Lo he hecho tal como dices e incluso editando el módulo y quitando el xorg.conf

De las dos formas, el resultado es el mismo que antes.

No sé si interesara todo lo que suelta al arrancar, pero sólo veo la última parte, pues no sé si se puede hacer algo para detener la ejecución e ir viendo todo lo que tira.


en modo texto , es para hacer pruebas....

Código: [Seleccionar]
X -configure
para que xorg intente crear el fichero  config a ver si hay suerte ..

y si no , poner el error que da , ayudaria.

ferlan

  • Visitante
Re: Necesito ha alguien con grafica nvidia para pruebas.
« Respuesta #7 en: 16-09-2015, 01:59 (Miércoles) »
Pues no, no hay suerte. Esto es la última parte de lo que tira. El resto, ni lo veo de rápido que va el scroll de pantalla.

Código: [Seleccionar]
...
...
voodoo
vesa
fbdeb
modesetting
(EE) module ABI major version (15) doesn't match the server's version (18)
(EE) module ABI major version (15) doesn't match the server's version (18)
(EE) module ABI major version (15) doesn't match the server's version (18)
(++) Using config file: "/root/xorg.conf.new"
(==) Using config directory: "/etc/X11/xorg.conf.d
(==) Using system config directory "/usr/share/X11/xorg.conf.d
Number of created screens does not match number of detected devices.
Configuration failed.
(EE) Server terminated with error (2) Closing log file.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14470
Re: Necesito ha alguien con grafica nvidia para pruebas.
« Respuesta #8 en: 16-09-2015, 02:55 (Miércoles) »
prueba sin nada de ficheros

Código: [Seleccionar]
rm -rf /etc/X11/xorg.conf*
hay pone que el numero de pantallas detectados no coincide con el del fichero de config ...

¿tienes mas de un monitor?

Desconectado pepe10000

  • *******
  • Mensajes: 565
Re: Necesito ha alguien con grafica nvidia para pruebas.
« Respuesta #9 en: 16-09-2015, 12:54 (Miércoles) »
lo que necesito que me digáis es si ...cuando lo ejecutamos nos pide confirmar la acción..

No pide confirmación y suelta esto:
Código: [Seleccionar]
Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup
New X configuration file written to '/etc/X11/xorg.conf'
Si continúo con startx, suelta la tira y algo sobre el error. Y en mi caso, no arranca, por supuesto.

Lo mismo me pone a mi, y después suelta el error (picar en las imágenes para ampliar):



Citar
creo que en el modulo de nvidia hay un xorg.conf


entonces intenta eliminandolo antes...


rm -rf /etc/X11/xorg.conf

y despues crea uno nuevo con

nvidia-xconfig





Citar
prueba sin nada de ficheros


Código:

rm -rf /etc/X11/xorg.conf*



Te recuerdo que la TV está conectada al PC por HDMI (por si fuese relevante).

Un saludo.


« Última modificación: 16-09-2015, 12:59 (Miércoles) por pepe10000 »

KaitoMX

  • Visitante
Re: Necesito ha alguien con grafica nvidia para pruebas.
« Respuesta #10 en: 16-09-2015, 13:10 (Miércoles) »
ami en la gtx550ti que tengo en un equipo me sale el mismo error con la gtx 970ti del otro no no me lo arranca da un error de dispositivo no encontrado cuando empieza la carga de los modulos (y aunque la ponga en el equipo en el que tengo la 550 pasa lo mismo sera cosa de la grafica)

ferlan

  • Visitante
Re: Necesito ha alguien con grafica nvidia para pruebas.
« Respuesta #11 en: 16-09-2015, 14:59 (Miércoles) »
prueba sin nada de ficheros

Código: [Seleccionar]
rm -rf /etc/X11/xorg.conf*
Ahí pone que el numero de pantallas detectados no coincide con el del fichero de config ...

¿Tienes más de un monitor?

El escenario es un portátil sin nada conectado al mismo y Wifislax-4.11.1 live USB limpio, con sólo el módulo NVIDIA añadido.

Si tras el logueo hago rm -rf /etc/X11/xorg.conf* y después directamente starx veo pasar unos cuadros blanco y negro entrelazados y arranca, pero aparentemente, igual que cuando arrancas directamente en modo Vesa KDE.

Dice el refrán que mal de muchos consuelo de tontos, pero bueno, ya veo que no soy el único con el mismo problema. Las imágenes concuerdan con lo que me sale a mí arrancando inmediatamente después del logueo o haciéndolo después de eliminar con rm -rf /etc/X11/xorg.conf y hacer nvidia-xconfig

Gracias por el curre y si hace falta hacer más pruebas no te cortes.