Autor Tema: modulo hydra (no se lanzarlo)  (Leído 10240 veces)

0 Usuarios y 1 Visitante están viendo este tema.

teik

  • Visitante
Re: modulo hydra (no se lanzarlo)
« Respuesta #20 en: 26-08-2012, 19:37 (Domingo) »
lo he copiado y lanzo desde el menu xhydra.... me sale pero me da este error!!


Hydra v7.3 (c)2012 by van Hauser/THC & David Maciejak - for legal purposes only

Hydra (http://www.thc.org/thc-hydra) starting at 2012-08-26 19:35:52
[ERROR] Compiled without LIBAFP support, module not available!



estoy cansado!! te lo pido ya como un favor personal... puedes hacer el moudlo? creo que me apure ya hasta el maximo pero esque .... esto ya me sobrepasa.  :'(



lordferranator

  • Visitante
Re: modulo hydra (no se lanzarlo)
« Respuesta #21 en: 26-08-2012, 20:25 (Domingo) »
no lo entiendo ¿si me faltan esas carpetas como es que me funciona el modulo?



Uploaded with ImageShack.us

teik

  • Visitante
Re: modulo hydra (no se lanzarlo)
« Respuesta #22 en: 26-08-2012, 20:30 (Domingo) »
te funciona eso... pero lo lanzas y te sale el error!!

lordferranator

  • Visitante
Re: modulo hydra (no se lanzarlo)
« Respuesta #23 en: 26-08-2012, 20:57 (Domingo) »
ok, gracias

Hydra (http://www.thc.org/thc-hydra) starting at 2012-08-26 19:35:52
[ERROR] Compiled without LIBAFP support, module not available!

ahí lo que dice es que se ha compilado sin soporte LIBAFP, supongo que eso debe ser alguna dependencia que no lleva Wifislax.

estoy mirando de encontrar qu es eso y como instalarlo, si consigo os lo hago saber.


lordferranator

  • Visitante
Re: modulo hydra (no se lanzarlo)
« Respuesta #24 en: 26-08-2012, 21:54 (Domingo) »
Revisando el ./configure veo que faltan unas cuantas librerias, supongo que hay qu instalarlas todas para que el Hydra funcione ¿es asi?

Código: [Seleccionar]
wifislax hydra-7.3 # ./configure --prefix=/root/hydra-7.3/BUILD/

Starting hydra auto configuration ...
Detected 32 Bit Linux OS

Checking for openssl (libssl, libcrypto, ssl.h, sha.h) ...
                                                       ... found
Checking for idn (libidn.so) ...
                             ... NOT found, unicode logins and passwords will not be supported
Checking for pcre (libpcre.so, pcre.h) ...
                                       ... NOT found, server response checks will be less reliable
Checking for Postgres (libpq.so, libpq-fe.h) ...
                                             ... NOT found, module postgres disabled
Checking for SVN (libsvn_client-1 libapr-1.so libaprutil-1.so) ...
                                                               ... found
Checking for firebird (libfbclient.so) ...
                                       ... NOT found, module firebird disabled
Checking for MYSQL client (libmysqlclient.so, math.h) ...
                                                      ... NOT found, module Mysql will not support version > 4.x
Checking for AFP (libafpclient.so) ...
                                   ... NOT found, module Apple Filing Protocol disabled - Apple sucks anyway
Checking for NCP (libncp.so / nwcalls.h) ...
                                         ... NOT found, module NCP disabled
Checking for SAP/R3 (librfc/saprfc.h) ...
                                      ... NOT found, module sapr3 disabled
Get it from http://www.sap.com/solutions/netweaver/linux/eval/index.asp                   
Checking for libssh (libssh/libssh.h) ...                                                 
                                      ... NOT found, module ssh disabled                               
Get it from http://www.libssh.org                                                                       
Checking for Oracle (libocci.so libclntsh.so / oci.h and libaio.so) ...                                 
                                                                    ... NOT found, module Oracle disabled
Get basic and sdk package from http://www.oracle.com/technetwork/database/features/instant-client/index.html
Checking for GUI req's (pkg-config, gtk+-2.0) ...
                                              ... found

Hydra will be installed into .../bin of: /root/hydra-7.3/BUILD/
  (change this by running ./configure --prefix=path)

Writing Makefile.in ...
now type "make"

me da que hacer que te funcione te va a llevar unas cuantas horas :-\