Autor Tema: Iso para testeo wifislax-1.1-31032018  (Leído 6831 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #40 en: 01-04-2018, 21:06 (Domingo) »
pero de esos que no tengan para opencl serán pocos casos.

que te hace exactamente opencl?
poner pyrit sin opencl es como no poner nada, es achicharrar la maquina.
a unas malas pon la versión de siempre la 0.4 con el plugin de opencl

ninguna de las versiones de 64 bits ha tenido dicho plugin y nadi ha llorado , puesto qu si hashcat funcione, pues ya no necesitan pyrit.

la version da igual , de momento obtengo mensaje de error si una maquina no tiene un componence usable para opencl , y paso de explicar eso 8 millones de veces en el foro.

nadie os ha cortado la mano , para hacer un

Código: [Seleccionar]
python setup.py install
A MI me gustaria que por defecto tenga el maximo de opciones disponibles, asi que solo digo que de momento no he conseguido gran cosa , pero solo mire un poco esta mañana , ya que estoy de noche a turnos de 12 horas y mi tiempor ahora mismo es inexistente.



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #41 en: 02-04-2018, 06:26 (Lunes) »
parece que he avanzado algo , ....

el error que me salia cuando no hay ningun dispositivo usable para opencl era este

pyrit list_cores
Failed to load Pyrit's OpenCL-core ('Failed to enumerate OpenCL-platforms (Unknown CLresult)').


curioso cuanto menos , ya que ni siquera en la config va activado el opencl por defecto ... no deberia salir.

esa parte ya la he solventado ,

03 - Recompilado paquete mesa
     --enable-opencl
     --enable-opencl-icd


Me parece un poco absurdo , pero bueno , el error inicial sin activar opencl , ya no sale ..

Lo normal es que salga algun tipo de error , cuando activamos opencl en la config , y no detecte nada usanle , y tampoco da error, si no un mensaje que acaba en..

Failed to enumerate devices on this platform (CL_DEVICE_NOT_FOUND)

eso si es lo normal .. mensaje si activas opencl y no hay nada usable.

ahora faltara probar que pasa si beignet , esta en el sistema ...

Tengo que recompilar qt5 , por que suprimi la libreria waylan , y poco mas , mañana si puedo subo iso pronto.

« Última modificación: 02-04-2018, 06:28 (Lunes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #42 en: 02-04-2018, 06:30 (Lunes) »
esto que aparece en el log de sol666 , no es muy esperanzador en cuanto a que beignet este por defecto , ya que al tratar de usarlo y no encontrarse un cpu intel con GPU integrada , salen cosas asi

X server found. dri2 connection failed!
Device open failed, aborting...


que tampoco molan.

solo me faltara ver eso ...  ;)

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #43 en: 02-04-2018, 06:33 (Lunes) »
changelog desde esta iso , a lo que llevo en el pincho ahora mismo ...

POR FAVOR , los que usais drivers rtl8812/8814  , probar si los drivers por defecto 4.3.21 van bien o si os van mejor los 5.1.5 , podeis usar el updater para cambiar de rama.



02/04/2018
01 - Removido wayland + egl + protocols
02 - Recompilados drivers wifi para kernel 4.14.32
     rtl8192eu-5.2.7_d45df0e
     rtl8812au_4.3.21-4.3.21_e2fee81
     rtl8814au_4.3.21-4.3.21_e2fee81
03 - Recompilado paquete mesa
     --enable-opencl
     --enable-opencl-icd

01/04/2018
01 - Removido servicio microcodigo INTEL
     intel-microcode
     microcode_ctl
     iucode_tool
02 - Recompilados los siguientes paquetes
     opencl-headers
     ocl-icd
     beignet
     hashcat
03 - Aplicado parche de seguridad slackware dia 1 abril 2018
04 - Actualizado kernel 4.14.31 --> 4.14.32
05 - Removido beignet

guest178389

  • Visitante
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #44 en: 02-04-2018, 06:46 (Lunes) »
a lo del beignet no se puede habilitar o deshabilitar cuando esta instalado?
o parar su servicio, para que no te cause conflictos.?

o dejarlo en un paquete semi instalado y que el usuario lo pueda activar si lo necesita.

no sé es por darte alguna idea,
no se como funciona a nivel interno con el tema de las instalaciones slax.

pero si puedo ayudarte en algo dímelo.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #45 en: 02-04-2018, 08:01 (Lunes) »
a lo del beignet no se puede habilitar o deshabilitar cuando esta instalado?
o parar su servicio, para que no te cause conflictos.?

o dejarlo en un paquete semi instalado y que el usuario lo pueda activar si lo necesita.

no sé es por darte alguna idea,
no se como funciona a nivel interno con el tema de las instalaciones slax.

pero si puedo ayudarte en algo dímelo.

Na , ya lo tengo decidido , acabo de probar en casa , cuando beignet esta en el sistema intenta usar un dispositivo GPU intel , y como no lo hay , pues error , no fatal , pero no mola verlos.

Para entenderlo facil , es como si en un pc con grafica AMD  , le instalas los drivers NVIDIA , o los dos a la vez ...  creas un conflicto y hay errores ;D


igual que los de nvidia y amd bajan el driver extra , los que tengan GPU intel y probar suerte , pues bajaran un modulo con beignet y ya esta , o si lo prefieren .. lo compilan ellos mismos.

Código: [Seleccionar]
slapt-src -u
slapt-src -i beignet

zero dramas , voy a recompilar las qt5  ;D

guest178389

  • Visitante
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #46 en: 02-04-2018, 08:42 (Lunes) »
ok, me parece bien así.

sol666

  • Visitante
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #47 en: 02-04-2018, 14:05 (Lunes) »
por mi parte igual,si tengo beinet pyrit no me funciona ni con el pc de escritorio ni en el portatil pero si lo desinstalo ya funciona y detecta la amd mientras que en el portatil da el warning pero funciona.

susaniita

  • Visitante
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #48 en: 02-04-2018, 15:19 (Lunes) »
Cita de: USUARIONUEVO
31/03/2018
01 - De serie se incluyen drivers wifi extras
     rtl8192eu-5.2.7_d45df0e
     rtl8812au_4.3.21-4.3.21_e2fee81
     rtl8814au_4.3.21-4.3.21_e2fee81
ha costado, pero por fin  >:(

una pregunta, es el de kimocoder no? (el que está en aircrack) porqué no usar mejor la rama default que es 5.1.5?


edit: ok te acabo de leer en el otro hilo. El de astsam sigue funcionando en kernels nuevos?  ???

a ver .. este es uno de esos cambios ...

el de astsam , no compila , pero los chicos de aircrack , tienen ese driver parcheado (4.3.21) , es el que todos deciis que va mejor , por eso use esa rama.

de todas formas .. en updaters esta el script ... sale un menu de si quieres 4.3.21 o  5.1.5 , si quieres probar el 5.1.5 , solo lanza el script y elige ese.

mas facil no os lo puedo poner , ahora si me dices que el 5.1.5  ahora funciona mejor que el 4.3.21 ya es otra cosa , yo no tengo ninguna tarjeta que use esos drivers asi que no se mas que lo que va diciendo la gente y la mayoria coinciden en que les va mejor un 4.3.21 que el otro.

Tambien vi que hay uno 5.2.9 , que me compilaba pero con un warning al final ,,, y luego el driver no se podia cargar , po eso esa opcion no aparecera en los scripts.

gracias, veo que te sirvio mi hilo para algo constructivo....

en efecto el 5.2.9 no vale para las 8814au es solo para las 8812au

a probar y comento lo que quieras, yo tengo la 8814a
p.d: estan metidas las dependencias parra hostbase?

despues de un tiempo....
descargado y probado: no arranca con vmware
despues de pruebas....
no funciona con vmware
y a la pregunta de las dependencias de hostbase, respuesta:

« Última modificación: 02-04-2018, 19:45 (Lunes) por susaniita »

dynyly

  • Visitante
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #49 en: 02-04-2018, 20:36 (Lunes) »
salu2

creo que esa version es la ultima y aunque metas hostapd necesitaras las gemas de ruby
lo mejor bajate iso ultima tendra todas las dependencias

que version usas de wifislax la de testeo porque de ser asi es problema de hostbase que puso cierta version para que la acepte
« Última modificación: 02-04-2018, 20:40 (Lunes) por dynyly »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #50 en: 02-04-2018, 20:40 (Lunes) »
@susanita

a ver , el 90% de veces que alguien dijo , no me anda en vmware o similar , fue por qu lo configuraban con poca ram.

las dependencias de hostbase si que estan , pero si ves, es un error que lanza el propio script por que ve que la iso no es la que el busca en concreto ya que esta es mas nueva.

lo ideal seria remover eso , ya que las dependencias en ruby estan y no las voy a quitar ni cambiar ni nada , vamos que funcionara siempre...pero eso no es cosa mia.

Lo que me interesaba saber de los drivers , es si va mejor el 5.1.5 o el que lleva la iso 4.3.21 , para saber si por defecto meto uno u otro.

El tema pyrit esta claro tambien.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #51 en: 02-04-2018, 20:42 (Lunes) »
salu2

creo que esa version es la ultima y aunque metas hostapd necesitaras las gemas de ruby
lo mejor bajate iso ultima tendra todas las dependencias

que version usas de wifislax la de testeo porque de ser asi es problema de hostbase que puso cierta version para que la acepte

No metais ni toqueis nada , mas alla de lo que os de yo , la iso ya tiene hostapd parcheado y las gemas ruby , no metais nada.

Joer que solo hay que leer el fichero cambios ...
« Última modificación: 02-04-2018, 20:46 (Lunes) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #52 en: 02-04-2018, 20:45 (Lunes) »
13/02/2018
01 - Actualizado kernel 4.14.18 --> 4.14.19
02 - Actualizados firmwares de sistema
03 - Actualizado aircrack-ng-1.2_rc4_r3007 --> r3008
04 - Incluido soporte gtk2 para ruby
05 - Actualizado Google-chrome-64.0.3282.140 --> 64.0.3282.167



20/02/2018
01 - Sustituido paquete hostapd-2.6 de slackbuilds por
     uno custom wifislax, cona mas opciones activadas
     y algunos parches de seguridad.

dynyly

  • Visitante
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #53 en: 02-04-2018, 20:49 (Lunes) »
 ;D ;D ;D
no te enfades  ;D ;D
una equivocacion gracias por compartir
voy a probrar lo de piryt

TheWolf

  • Visitante
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #54 en: 02-04-2018, 20:55 (Lunes) »
Buenas

He modificado eso ayer en la noche para que no da mas fallos  ;) tambien dynyly si lees este topic ya veras que he pedido ya a usarionuevo si el nueveo ISO tiene las dependencias para usar hostbase  ^-^

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #55 en: 02-04-2018, 21:00 (Lunes) »
Buenas

He modificado eso ayer en la noche para que no da mas fallos  ;) tambien dynyly si lees este topic ya veras que he pedido ya a usarionuevo si el nueveo ISO tiene las dependencias para usar hostbase  ^-^

Por normal general , cuando algo entra a la iso , ya no sale, a menos que haya algun conflicto ,  con lo que puedes estar tranquilo con eso , no voy a quitar las gemas gtk2 de ruby , y menos aun , quitar el hostapd ,ya que tiene funcionalidad extendida , gracias a tus recomendaciones de config , y esta parcheado de algunos problemas cve.

@dinyly
no me enfado , pero me da un poco de mala ostia , por que las iso de desarrollo , son para testearlas como estan , y reportar fallos , si les empezais a tocar y a salir fallos, yo ya no sabre que pasa o me sera mucho mas deficil deducir el problema.

Solo mira lo de pyrit , ... es un buen ejemplo , como salto la liebre en la iso sin modificar , pude reproducir los sintomas y tomar acciones al respecto.  ;D

susaniita

  • Visitante
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #56 en: 02-04-2018, 21:13 (Lunes) »
confirmado es cierto, si que rula el hostbase, es problema del script que tendra que cambiar lo de la version

con lo del tema de las rtl881x, las dos andan bien, pero la 4.1.23 un poco menos fallos
yo lo dejaria tal y como lo has planteado


gracias

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #57 en: 02-04-2018, 21:16 (Lunes) »
creo que tengo todo controlado , esta noche mirare cosillas a ver , y si veo todo ok, subire iso , todabia como de desarrollo , esto es perfilando a una rc1  ;)

Tengo que testear que los updaters estan bien y compila todo , pero eso lo puedo ir mirando tranquilamente cuando suba iso nueva.

Me resulta curioso , ... nadi dice nada del tamaño de fuente , eso es que no esta tan mal  ;D

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #58 en: 02-04-2018, 21:17 (Lunes) »
confirmado es cierto, si que rula el hostbase, es problema del script que tendra que cambiar lo de la version

con lo del tema de las rtl881x, las dos andan bien, pero la 4.1.23 un poco menos fallos
yo lo dejaria tal y como lo has planteado


gracias

oido cocina  ;)

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14237
Re: Iso para testeo wifislax-1.1-31032018
« Respuesta #59 en: 02-04-2018, 21:58 (Lunes) »
@crashandburn

Se que has sacado el tema de crack-keys alguna vez, y abriste un hilo y tal.

Si no lo he metido es por que no me gustan los "all-in-one" , que usan un monton de apps, que ya estan en wifislax.

No te enfades , te explico , ..

Comprendo perfectamente que para asegurar su funcionamiento , tengas algo asi con un "todo en uno" , y tires de usar internamente esas apps de tu carpeta , asi zero dramas de me falta esto o aquello y como lo instalo y bla bla bla.

Pero cuando el 99% de esas tools ya estan en sistema , me resulta un poco "drama" , gastar un xzm de otros 50-60 megas , por que son cosas que ya van en wifislax.

No digo que cambies eso , como digo comprendo ese pensamiento de asegurar que vaya a funcionar en cualquier linux , respetando la arquitectura (x86  o x64_x86)

Podrias tener dos ramas , o mas , una con el todo en uno , y otra con un script , que mire lo que necesita y marque ok o error si algo no esta , ...

Código: [Seleccionar]
if which aircrack-ng ; then echo si ;fi
nos responde si , y ademas la ruta ...

Código: [Seleccionar]
/usr/bin/aircrack-ng
si

puedes evitar la salida de la ruta..

Código: [Seleccionar]
if which aircrack-ng &>null; then echo si ;fi
Bueno , eso , que si te animas a algo mas sencillo , podria ponerlo en iso , el todo en uno , me parece excesivo en tamaño y funcionalidad en el sentido de apps repetidas , no es lo mismo que metasploit u otros casos, donde te meten muchas cosas , pero suelen ser librerias o gemas ruby.

Solo es para que sepas por que me freno , de ponerlo en la iso , he insisto , el todo en uno es perfecto para quitarse complicaciones , y para usar en linux en general ya que lleva todo en su carpeta , solo me gustaria algo mas sencillo , si no te apetece , o no lo ves, siempre se podra descargar del git y ya esta , comentario constructivo , nada mas.