Autor Tema: sugerencia de modulos  (Leído 12465 veces)

0 Usuarios y 1 Visitante están viendo este tema.

teik

  • Visitante
sugerencia de modulos
« en: 03-06-2012, 11:16 (Domingo) »
Bueno para que no caiga en saco roto.. queria hacer mi peticion!!

Me gustaria que el script de yamas que trae la nueva verison y algunas versiones nuevas ...que se incorporaron a la nueva version de 64 bits.. no se olvidaran y se dejasen fuera de la de 32 bits! ya que algunos no podemos incorporar por problemas de CPU .. ais que aqui queda registrada mi peticion! Se que teneis mucho trabajo y que sois personas, por eso no exijo sino que pido!  :-[



juvalgot86

  • Visitante
Re: sugerencia de modulos
« Respuesta #1 en: 26-06-2012, 03:18 (Martes) »
yo quisiera pedir si alguien pude compilar el wine32 y 64 bits para el wifislax x64, el wine64 se puede compilar sin problemas, pero este no permite ejecutar programas de 32 bit, al querer compilar wine32 bit en wifislax x64 dice:
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.
ya busque y al parecer lo que pide se instala con esto http://winezeug.googlecode.com/svn/trunk/install-wine-deps.sh
pero solo para algunas distribuciones de linux, también intente con las que están aquí http://www.archlinux.org/packages/multilib/x86_64/wine/ -- no funciona.

también compile el wine32 en wifislax 4.1 y wine64 en wifislax x64, aparentemente funciona pero sale con errores y si usas el wine32 cuando quieres usar el wine64 este ya no funciona

si alguien pudiera compilarlo o almenos conseguir instalar las dependencias necesarias para compilar el wine32 bits, gracias de antemano.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: sugerencia de modulos
« Respuesta #2 en: 26-06-2012, 17:36 (Martes) »
@teik ya se hizo el modulo de yamas para Wifislax 4.1 https://foro.seguridadwireless.net/live-wifislax/modulos-para-wifislax-4-1-1/msg245763/#msg245763

@juvalgot86 para compilar wine de 32 bits en Wifislax x64 te hace falta esto http://www.slacky.eu/asche64/pkgs/index.php?ver=15&pkg=288

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

juvalgot86

  • Visitante
Re: sugerencia de modulos
« Respuesta #3 en: 27-06-2012, 02:58 (Miércoles) »
olvide mencionarlo, ya avia intentado con compat32-libraries-1.1.02_13.37-x86_64-1sl, y acabo de probar nuevamente y no funciona.

Desconectado geminis_demon

  • Colaborador
  • *
  • Mensajes: 2377
  • Prácticas precisas precisan práctica
Re: sugerencia de modulos
« Respuesta #4 en: 27-06-2012, 23:22 (Miércoles) »
Tienes razón, para compilar hacen falta mas cosas, el mismo mensaje de error te lo dice pero no me fije bien.

Lo mas fácil es bajarte el paquete txz y convertirlo a modulo.

http://pkgs.org/slackware-13.37/slackers-i686/wine-1.5.7-i686-1cf.txz/download/

La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15360
Re: sugerencia de modulos
« Respuesta #5 en: 28-06-2012, 01:45 (Jueves) »
lo que no tengo claro es que se puedan manejar la version de 32 y de 64 bits sobre el mismo sistema, sin hacer algun tipo de apaño.

como por ejemplo en opt, crear carpetas individuales para wine de 32 y de 64 ..o renombrar el ejecutable de alguno de ellos ...no se...igual se puede ,epro dudo que sea asi de simple tener los dos simultaneamente.

juvalgot86

  • Visitante
Re: sugerencia de modulos
« Respuesta #6 en: 29-06-2012, 20:23 (Viernes) »
tras compilar quedan dos ejecutables wine y wine64 que ejecutan programas de 32 y 64 bit respectivamente, ahora encotre uno que se puede descargar aqui http://sourceforge.net/projects/wine/files/Slackware%20Packages/1.5.7/x86_64/ pero lo estube probando abre algunos programas y otros no

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15360
Re: sugerencia de modulos
« Respuesta #7 en: 29-06-2012, 22:27 (Viernes) »
tras compilar quedan dos ejecutables wine y wine64 que ejecutan programas de 32 y 64 bit respectivamente, ahora encotre uno que se puede descargar aqui http://sourceforge.net/projects/wine/files/Slackware%20Packages/1.5.7/x86_64/ pero lo estube probando abre algunos programas y otros no

a ver...wine es muy complejo ...y doy por sentado que por ejemplo sabras que los programas que requieran net framework habra que instalarlo..asi como librerias directx , y vaya usted a saber todo lo que se puede llegar a necesitar.

juvalgot86

  • Visitante
Re: sugerencia de modulos
« Respuesta #8 en: 18-08-2012, 03:40 (Sábado) »
quisiera pedir un modulo con las librerias de qt4 para poder compilar programas basados en este lenguaje, ya que tengo errores al momento de compilar


-- Phonon includes NOT found!
CMake Error at cmake/FindPhonon.cmake:63 (message):
  Phonon library or includes NOT found!
Call Stack (most recent call first):
  CMakeLists.txt:10 (find_package)

teik

  • Visitante
Re: sugerencia de modulos
« Respuesta #9 en: 18-08-2012, 17:07 (Sábado) »
Pues yo echo en falta la aplicacion hydra.... que suelo tener siempre mucho liado con el programa y en esta version no lo encontre.... y en gsplat tampoco. pueden hacerlo?

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15360
Re: sugerencia de modulos
« Respuesta #10 en: 18-08-2012, 20:27 (Sábado) »
Pues yo echo en falta la aplicacion hydra.... que suelo tener siempre mucho liado con el programa y en esta version no lo encontre.... y en gsplat tampoco. pueden hacerlo?

si no recuerdo mal..habia alguno hecho ...pero como para encontrarlo.. :-\
en los modulos de wifiway seguro que habia uno o dos.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15360
Re: sugerencia de modulos
« Respuesta #11 en: 18-08-2012, 20:29 (Sábado) »
quisiera pedir un modulo con las librerias de qt4 para poder compilar programas basados en este lenguaje, ya que tengo errores al momento de compilar


-- Phonon includes NOT found!
CMake Error at cmake/FindPhonon.cmake:63 (message):
  Phonon library or includes NOT found!
Call Stack (most recent call first):
  CMakeLists.txt:10 (find_package)


las qt4 y phonon estan...

¿bajo que version te pasa esto ? , ¿ wifislax 4.2 ?

juvalgot86

  • Visitante
Re: sugerencia de modulos
« Respuesta #12 en: 18-08-2012, 22:55 (Sábado) »
si, en wifislax 4.2, estaba compilando Silicon Empire y k3b y me salio ese error.
he compilado umplayer perfectamente pero estos dos no puedo compilar
y esto sucede con el Silicon Empire:

[spoiler]-- The C compiler identification is GNU 4.6.1
-- The CXX compiler identification is GNU 4.6.1
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt4: /usr/bin/qmake (found version "4.8.2")
-- Taglib found: -L/usr/lib -ltag
-- Phonon includes NOT found!
CMake Error at cmake/FindPhonon.cmake:63 (message):
  Phonon library or includes NOT found!
Call Stack (most recent call first):
  CMakeLists.txt:10 (find_package)


-- Configuring incomplete, errors occurred!
[/spoiler]

quise compilar qt para resolver el problema, ademas tengo el qt creator y no puedo hacer nada por que qt esta recortada, la necesito completa

porfavor ayudame con los parametros de compilacion del qt, estoy usandos estos:

[spoiler]./configure -prefix /usr \
            -fast \
            -opensource \
            -confirm-license \
            -release \
            -embedded x86 \
            -nomake examples \
            -nomake demos \
            -no-nis \
            -system-sqlite \
            -continue[/spoiler]

tardo como 1 hora y media, parece que con errores, quise compilar el cmake 2.8.9 con --qt-gui (antes de compilar qt, el cmake se compila correctamente con --qt-gui ), llega 98% y error y con el Silicon Empire igual llega a un porcentaje y error

estoy por probar estos parametros, espero que salga mejor

[spoiler]./configure -prefix /usr      \
            -release          \
            -nomake examples  \
            -nomake demos     \
            -system-sqlite    \
            -no-nis           \
            -opensource       \
            -continue         \
            -qmake            \
            -confirm-license[/spoiler]

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15360
Re: sugerencia de modulos
« Respuesta #13 en: 18-08-2012, 23:33 (Sábado) »
http://slackware.mirrors.tds.net/pub/slackware/slackware-current/slackware/l/qt-4.8.2-i486-2.txz

LAS VECES QUE YO COMPILE QT4 , ME BASTO CON FIJAR A USR ..NUNCA PUSE MAS DE ESE PARAMETRO.

hay que empezar a buscar las librerias en

slackware-current
http://slackware.mirrors.tds.net/pub/slackware/slackware-current/slackware/


el paquete que puse no vale., se queda kde pillado en la entrada.

« Última modificación: 19-08-2012, 01:24 (Domingo) por USUARIONUEVO »

juvalgot86

  • Visitante
Re: sugerencia de modulos
« Respuesta #14 en: 19-08-2012, 17:17 (Domingo) »
ya termine de compilar qt4 con parametros:

./configure -prefix /usr && gmake && gmake install

no se si esta bueno, si puedes prubalo
http://www.mediafire.com/?4h1cqs1xmx88vkb

por el momento he compilado sin problemas el cmake con parametro:
./configure --prefix=/usr --qt-gui

cuando compilo Silicon-Empire, tengo este error: (mkdir build && cd build && cmake -DCMAKE_INSTALL_PREFIX=/usr ../)

[spoiler][ 34%] Building CXX object SApplications/TagargPlayer/CMakeFiles/TagargPlayer.dir/playlist.cpp.o                                                               
/mnt/sda2/linux/app/Silicon-Empire/silicon-1.8.1/SApplications/TagargPlayer/playlist.cpp:18:17: error fatal: tag.h: No existe el fichero o el directorio
compilación terminada.
make[2]: *** [SApplications/TagargPlayer/CMakeFiles/TagargPlayer.dir/playlist.cpp.o] Error 1
make[1]: *** [SApplications/TagargPlayer/CMakeFiles/TagargPlayer.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....


Linking CXX shared library libLimoo.so
[ 37%] Building CXX object Libs/SiDi/CMakeFiles/SiDi.dir/sdevicelist.cpp.o
[ 37%] Built target Limoo


[ 38%] Building CXX object Libs/SiDi/CMakeFiles/SiDi.dir/sconverter.cpp.o
/mnt/sda2/linux/app/Silicon-Empire/silicon-1.8.1/Libs/SiDi/sidi_prev.cpp:13:17: error fatal: tag.h: No existe el fichero o el directorio
compilación terminada.
make[2]: *** [Libs/SiDi/CMakeFiles/SiDi.dir/sidi_prev.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [Libs/SiDi/CMakeFiles/SiDi.dir/all] Error 2
make: *** [all] Error 2[/spoiler]

y cuando compilo k3b sale esto: (mkdir build && cd build && cmake ../)

[spoiler]wifislax k3b-2.0.2 # mkdir build && cd build && cmake ../
-- The C compiler identification is GNU 4.6.1
-- The CXX compiler identification is GNU 4.6.1
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (MESSAGE):
  ERROR: cmake/modules/FindKDE4Internal.cmake not found in
  /root/.kde/share/apps;/usr/share/apps
Call Stack (most recent call first):
  CMakeLists.txt:52 (find_package)


-- Configuring incomplete, errors occurred![/spoiler]

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15360
Re: sugerencia de modulos
« Respuesta #15 en: 19-08-2012, 20:01 (Domingo) »
tag.h

los ficheros   .h  son siempre parte de alguna libreria en /usr/include

parece ser que te falta los include de la librerias id3tag , o algo asi se llama...busca una libreria que tenga un nombre parecido en la carpèta  /var/log/packages , bajatela ,y coge la tarde /usr/include


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 15360
Re: sugerencia de modulos
« Respuesta #16 en: 19-08-2012, 20:08 (Domingo) »
ya termine de compilar qt4 con parametros:

./configure -prefix /usr && gmake && gmake install

no se si esta bueno, si puedes prubalo
http://www.mediafire.com/?4h1cqs1xmx88vkb

por el momento he compilado sin problemas el cmake con parametro:
./configure --prefix=/usr --qt-gui

cuando compilo Silicon-Empire, tengo este error: (mkdir build && cd build && cmake -DCMAKE_INSTALL_PREFIX=/usr ../)

[spoiler][ 34%] Building CXX object SApplications/TagargPlayer/CMakeFiles/TagargPlayer.dir/playlist.cpp.o                                                               
/mnt/sda2/linux/app/Silicon-Empire/silicon-1.8.1/SApplications/TagargPlayer/playlist.cpp:18:17: error fatal: tag.h: No existe el fichero o el directorio
compilación terminada.
make[2]: *** [SApplications/TagargPlayer/CMakeFiles/TagargPlayer.dir/playlist.cpp.o] Error 1
make[1]: *** [SApplications/TagargPlayer/CMakeFiles/TagargPlayer.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....


Linking CXX shared library libLimoo.so
[ 37%] Building CXX object Libs/SiDi/CMakeFiles/SiDi.dir/sdevicelist.cpp.o
[ 37%] Built target Limoo


[ 38%] Building CXX object Libs/SiDi/CMakeFiles/SiDi.dir/sconverter.cpp.o
/mnt/sda2/linux/app/Silicon-Empire/silicon-1.8.1/Libs/SiDi/sidi_prev.cpp:13:17: error fatal: tag.h: No existe el fichero o el directorio
compilación terminada.
make[2]: *** [Libs/SiDi/CMakeFiles/SiDi.dir/sidi_prev.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [Libs/SiDi/CMakeFiles/SiDi.dir/all] Error 2
make: *** [all] Error 2[/spoiler]

y cuando compilo k3b sale esto: (mkdir build && cd build && cmake ../)

[spoiler]wifislax k3b-2.0.2 # mkdir build && cd build && cmake ../
-- The C compiler identification is GNU 4.6.1
-- The CXX compiler identification is GNU 4.6.1
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (MESSAGE):
  ERROR: cmake/modules/FindKDE4Internal.cmake not found in
  /root/.kde/share/apps;/usr/share/apps
Call Stack (most recent call first):
  CMakeLists.txt:52 (find_package)


-- Configuring incomplete, errors occurred![/spoiler]


¿¿ como las mandaste a un directorio controlado ?? .......a mi no me dejaba.

yo al final tengo funcionando las 4.8.2-i486-2 pero es por que he actualizado medio sistema... >:D


xexudj89

  • Visitante
Re: sugerencia de modulos
« Respuesta #18 en: 20-08-2012, 15:47 (Lunes) »
echo de menos le programa el fern wifi cracker,luego el feedingbottle para wps.ya ire poniendo mas cosas que se echan de menos.