Autor Tema: drivers nvidia para wifislax-4.8  (Leído 11311 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
drivers nvidia para wifislax-4.8
« en: 23-01-2014, 15:36 (Jueves) »
pues lo de siempre...vamos a hacer los drivers ...  ;D



ISO NECESARIA -->> http://www.downloadwireless.net/isos-fase-testing/wifislax-current/wifislax-4.8-23012014.iso

MODULO DE DRIVER INSTALADOR -->> http://www.downloadwireless.net/modulos-fase-testing/Crear-modulo-NVIDIA/instalador-nvidia-wifislax-4.8.xzm


Lo de siempre

modo texto

root/toor

/root/Desktop/NVIDIA.run

al acabar startx

ir a la carpeta de changes..click derecho ..crear xzm

asi en normal y pae.



Desconectado pepe10000

  • *******
  • Mensajes: 565
Re: drivers nvidia para wifislax-4.8
« Respuesta #1 en: 23-01-2014, 16:04 (Jueves) »
Oído cocina.

Descargando ISO y en una horita mas o menos los tendré listos ya que mi conexión es lentita.

Editado:

Algo va mal, capturas del error (picar en la imagen para ampliar):





De todas formas he creado los XZM pero no me cuadra el tamaño, son de 3 Mb.

Normal:

http://www.multiupload.nl/MNDPX9CI5U

PAE:

http://www.multiupload.nl/LUTNXF4C8B

He repetido el proceso mas de 6 veces por si acaso, incluso lo he intentado añadiendo el disable-nouveau.xzm pero nada, siempre igual.

Un saludo.
« Última modificación: 23-01-2014, 17:51 (Jueves) por pepe10000 »

sol666

  • Visitante
Re: drivers nvidia para wifislax-4.8
« Respuesta #2 en: 23-01-2014, 21:14 (Jueves) »
pues lo de siempre...vamos a hacer los drivers ...  ;D



ISO NECESARIA -->> http://www.downloadwireless.net/isos-fase-testing/wifislax-current/wifislax-4.8-23012014.iso

MODULO DE DRIVER INSTALADOR -->> http://www.downloadwireless.net/modulos-fase-testing/Crear-modulo-NVIDIA/instalador-nvidia-wifislax-4.8.xzm


Lo de siempre

modo texto

root/toor

/root/Desktop/NVIDIA.run

al acabar startx

ir a la carpeta de changes..click derecho ..crear xzm

asi en normal y pae.
usuarionuevo,si necesitas a alguien para hacer el de ati cuenta conmigo ;D ;D ;D ;D ;D

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: drivers nvidia para wifislax-4.8
« Respuesta #3 en: 23-01-2014, 22:15 (Jueves) »
mañana mirare a ver que pasa , por que es evidente que da error, y no se instala nada.

gracias pepe10000

Desconectado pepe10000

  • *******
  • Mensajes: 565
Re: drivers nvidia para wifislax-4.8
« Respuesta #4 en: 24-01-2014, 08:49 (Viernes) »
mañana mirare a ver que pasa , por que es evidente que da error, y no se instala nada.

gracias pepe10000

De nada, a mandar.

Estaré atento al foro por si hay que hacer cualquier probatura mas.

Un saludo.
« Última modificación: 24-01-2014, 08:50 (Viernes) por pepe10000 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: drivers nvidia para wifislax-4.8
« Respuesta #5 en: 25-01-2014, 14:07 (Sábado) »
ha habido cambios en el acpi , y por eso el driver aunque se instala , no funciona.


un poco mas tarde subiré otro intento , ya que encontré parche , pero no se si va a funcionar lo que pretendo.  ;)

Desconectado pepe10000

  • *******
  • Mensajes: 565
Re: drivers nvidia para wifislax-4.8
« Respuesta #6 en: 25-01-2014, 15:40 (Sábado) »
O.K., cuando quieras lo volvemos a intentar.

Un saludo.

sol666

  • Visitante
Re: drivers nvidia para wifislax-4.8
« Respuesta #7 en: 25-01-2014, 15:59 (Sábado) »
ha habido cambios en el acpi , y por eso el driver aunque se instala , no funciona.


un poco mas tarde subiré otro intento , ya que encontré parche , pero no se si va a funcionar lo que pretendo.  ;)
esos cambios tambien incumben a ati? ayer intente hacer el modulo mas o menos como el de nvidia desde live haciendo el modulo instalador o sea crear un xzm con una carpeta root y dentro otra Desktop con el .run de ati dentro de esta,arranque en liveusb en modo texto,root-toor y /root/Desktop/ati.run,empezo todo bien pero cuando cuando se puso a instalar me dio un error y no se instalo nada.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: drivers nvidia para wifislax-4.8
« Respuesta #8 en: 25-01-2014, 16:34 (Sábado) »
ha habido cambios en el acpi , y por eso el driver aunque se instala , no funciona.


un poco mas tarde subiré otro intento , ya que encontré parche , pero no se si va a funcionar lo que pretendo.  ;)
esos cambios tambien incumben a ati? ayer intente hacer el modulo mas o menos como el de nvidia desde live haciendo el modulo instalador o sea crear un xzm con una carpeta root y dentro otra Desktop con el .run de ati dentro de esta,arranque en liveusb en modo texto,root-toor y /root/Desktop/ati.run,empezo todo bien pero cuando cuando se puso a instalar me dio un error y no se instalo nada.

el de ati hace días que lo tengo ,,también necesita parches..asi que déjalo estar.

aunque quieras aprender no podras por que no se pueden instalar.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: drivers nvidia para wifislax-4.8
« Respuesta #9 en: 25-01-2014, 16:46 (Sábado) »
intento 2


OJO  ..las instrucciones varian...

modo texto
root/toor
cd /root/Desktop/NVIDIA
nvidia-installer



instalador-nvidia-wifislax-4.8-intento2.xzm (38.39 MB)   http://www.multiupload.nl/O41YQKM4EF

me sirve en la iso del 23 o  en la de hoy ..la que quieras pepe.

Desconectado pepe10000

  • *******
  • Mensajes: 565
Re: drivers nvidia para wifislax-4.8
« Respuesta #10 en: 25-01-2014, 18:10 (Sábado) »
Esto marcha, da un par de errores pero el driver se instala y funciona.

Este error lo da una vez (picar en la imagen para ampliar):



Este lo da 4 veces (picar en la imagen para ampliar):



Descarga Normal:

http://www.multiupload.nl/0A33ALI7H4

Descarga PAE:

http://www.multiupload.nl/AQFTONF8FC

Un saludo.
« Última modificación: 25-01-2014, 18:23 (Sábado) por pepe10000 »

sol666

  • Visitante
Re: drivers nvidia para wifislax-4.8
« Respuesta #11 en: 25-01-2014, 19:18 (Sábado) »
ha habido cambios en el acpi , y por eso el driver aunque se instala , no funciona.


un poco mas tarde subiré otro intento , ya que encontré parche , pero no se si va a funcionar lo que pretendo.  ;)
esos cambios tambien incumben a ati? ayer intente hacer el modulo mas o menos como el de nvidia desde live haciendo el modulo instalador o sea crear un xzm con una carpeta root y dentro otra Desktop con el .run de ati dentro de esta,arranque en liveusb en modo texto,root-toor y /root/Desktop/ati.run,empezo todo bien pero cuando cuando se puso a instalar me dio un error y no se instalo nada.

el de ati hace días que lo tengo ,,también necesita parches..asi que déjalo estar.

aunque quieras aprender no podras por que no se pueden instalar.
ok,aparte de enseñarme lo que pretendo es quitarte algo de faena que ya tienes bastante.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: drivers nvidia para wifislax-4.8
« Respuesta #12 en: 25-01-2014, 19:50 (Sábado) »
pepe solo son "warnings" , ...avisos .

el primero ya lleva saliendo desde hace un tiempo y habla acerca de una libreria que en el futuro quitaran pero podra conseguirse a aparte libvpau  ..que no se que hara.


el segundpo habla de que no sabe que arquitectura es ...x86  y todo eso ,, pero si se instala,es suficiente.

tal vez lo segundo sea por que desempaquete el fichero  .run  para parchearlo ... y no sabia ya que sistema tenia entre manos, pero da igual.


voy a bajarlos y a dejar lo necesario ...a ver si sale bien a la primera.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: drivers nvidia para wifislax-4.8
« Respuesta #13 en: 25-01-2014, 20:15 (Sábado) »
cocinado..

029-Driver_nvidia-331.38-i486-1sw_wifislax_4_8.xzm (45.23 MB)   http://www.multiupload.nl/EGMSTKNLJV

Desconectado pepe10000

  • *******
  • Mensajes: 565
Re: drivers nvidia para wifislax-4.8
« Respuesta #14 en: 25-01-2014, 20:43 (Sábado) »
cocinado..

029-Driver_nvidia-331.38-i486-1sw_wifislax_4_8.xzm (45.23 MB)   http://www.multiupload.nl/EGMSTKNLJV

Perfecto, driver testeado y funcionando.

Normal + KDE = O.K.
Normal + XFCE = O.K.
PAE + KDE = O.K.
PAE + XFCE = O.K.
Hascat = O.K.
Distintas Resoluciones Admitidas = O.K.

Un saludo.
« Última modificación: 25-01-2014, 20:43 (Sábado) por pepe10000 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: drivers nvidia para wifislax-4.8
« Respuesta #15 en: 25-01-2014, 21:03 (Sábado) »
cocinado..

029-Driver_nvidia-331.38-i486-1sw_wifislax_4_8.xzm (45.23 MB)   http://www.multiupload.nl/EGMSTKNLJV

Perfecto, driver testeado y funcionando.

Normal + KDE = O.K.
Normal + XFCE = O.K.
PAE + KDE = O.K.
PAE + XFCE = O.K.
Hascat = O.K.
Distintas Resoluciones Admitidas = O.K.

Un saludo.

OK,  GRACIAS.   >:(

Fr3dY

  • Visitante
Re: drivers nvidia para wifislax-4.8
« Respuesta #16 en: 10-02-2014, 22:15 (Lunes) »
Buenas,

Hay algo que no tengo muy claro... ¿hay que crear 2 módulos NVIDIA, cada uno compilado con un kernel (normal y PAE)? ¿Dónde está el módulo para PAE?
Estoy modificando los menús para hacer Wifislax booteable con y sin drivers (tanto de nvidia como de ati), pero cuando cargo el módulo con kernel PAE en 4.8rc4 aparecen errores de dependencias y falla.



Saludos

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: drivers nvidia para wifislax-4.8
« Respuesta #17 en: 10-02-2014, 22:29 (Lunes) »
Buenas,

Hay algo que no tengo muy claro... ¿hay que crear 2 módulos NVIDIA, cada uno compilado con un kernel (normal y PAE)? ¿Dónde está el módulo para PAE?
Estoy modificando los menús para hacer Wifislax booteable con y sin drivers (tanto de nvidia como de ati), pero cuando cargo el módulo con kernel PAE en 4.8rc4 aparecen errores de dependencias y falla.



Saludos

dentro del modulo navidia ya va la version normal y pae ... en su dia me calente la cabeza justo para no necesitar 2 modulos de drivers ..


para el PAE , tu simplemente carga el modulo igual que para kernel NORMAL  ,

load=nvidia ..bla bla bla

te valdra el mismo parametro para los dos kernels ... y con el de ati lo mismo.


Te recuerdo que la unica razon por la que cargar esos drivers , es por usar ohc-hashcat  ..si no vas a usarlo , no los necesitas.


Fr3dY

  • Visitante
Re: drivers nvidia para wifislax-4.8
« Respuesta #18 en: 10-02-2014, 22:50 (Lunes) »
Pues no funciona, aparecen mensajes de error sobre dependencias de módulos cuando utilizo PAE (cargándolo sobre el kernel Normal no ocurre) :(

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14480
Re: drivers nvidia para wifislax-4.8
« Respuesta #19 en: 11-02-2014, 01:30 (Martes) »
Pues no funciona, aparecen mensajes de error sobre dependencias de módulos cuando utilizo PAE (cargándolo sobre el kernel Normal no ocurre) :(

EL MODULO FINAL ESTA MAS QUE TESTADO  ...

si te pide alguna dependecia el hashcat es por que en realidad no has cargado el modulo ...


puedes mirar que modulos se han cargado en la ruta

/mnt/live/memory/images

hay puedes ver los modulos descomprimidos que se han cargado ... mira si esta el de nvidia.


imagino que ya sabes que solo puedes usar el modulo expreso para la 4.8     ,  

si en el kernel normal consigues ponerlo ,solo pon el mismo parametro en el menu de PAE ....


con los menus te quedara tal vez mas comodo , pero ...

cuando estas ante el menu y vas a elegir por ejemplo arrancar kde ...

si pulsas tabulador  ...aparecera debajo la linea de carga ...

dejandote los modulos en  optional

podrias añadir a esa linea de carga


Código: [Seleccionar]
load=029-Driver_nvidia
« Última modificación: 11-02-2014, 01:32 (Martes) por USUARIONUEVO »