Autor Tema: convirtiend0 el instalador hd a formato sq4.  (Leído 23563 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #40 en: 06-05-2012, 16:26 (Domingo) »
Entonces el comando de copiar esta mal... Si me pasaras el comando exacto lo arreglarimos al instante

cuando copia el mnt lo unico que ha de hacer es crear las carpetas..sin copiar el contenido.

si tenemos

/mnt/sda1     

en la copai se haria mnt y dentro una carpeta vacia con el nombre de la particion sda1



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #41 en: 06-05-2012, 16:32 (Domingo) »
creo que lo que buscamos es esto

cat etc/fstab |egrep -o "/mnt/[a-z0-9]+" | cut -b 2- |xargs mkdir


pero me parece que antes del etc le falta /


cat /etc/fstab |egrep -o "/mnt/[a-z0-9]+" | cut -b 2- |xargs mkdir


supremo12345

  • Visitante
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #42 en: 06-05-2012, 19:44 (Domingo) »
Me referia al comando de copiat que averigua la lista de directorios a copiar (empieza con un foreach en el codigo del kmdr). No puedo escribirte exctamente el pseudocomando xk estoy con el mv

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #43 en: 06-05-2012, 21:06 (Domingo) »
Me referia al comando de copiat que averigua la lista de directorios a copiar (empieza con un foreach en el codigo del kmdr). No puedo escribirte exctamente el pseudocomando xk estoy con el mv


pues voy a buscarlo.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #44 en: 06-05-2012, 21:19 (Domingo) »
a ver si lo he puesto bien,  esa funcion se podia leer en otro kmdr ...llamado

copy-wifislax

http://pastebin.com/tJfABSGJ

supremo12345

  • Visitante
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #45 en: 06-05-2012, 22:46 (Domingo) »
a ver si lo he puesto bien,  esa funcion se podia leer en otro kmdr ...llamado

copy-wifislax

http://pastebin.com/tJfABSGJ

Ya se el problema. No funcionan bien las tuberias desde un proceso externo lanzado desde la GUI. Lo bueno es que ya se como solucionarlo.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #46 en: 06-05-2012, 23:05 (Domingo) »
a ver si lo he puesto bien,  esa funcion se podia leer en otro kmdr ...llamado

copy-wifislax

http://pastebin.com/tJfABSGJ

Ya se el problema. No funcionan bien las tuberias desde un proceso externo lanzado desde la GUI. Lo bueno es que ya se como solucionarlo.

 >:(

supremo12345

  • Visitante
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #47 en: 06-05-2012, 23:10 (Domingo) »
Bueno, ya funciona aparentemente.

he sacado todos los comandos a scripts, que se invocan desde la GUI. Los scripts deben estar en el mismo directorio que el ejecutable.

Asique si ves que hay algun script erroneo o que deberia hacer algo mas, puedes, puedes modificarlo.

Los nombres de los scripts son bastante descriptivos.


https://rapidshare.com/files/3083852721/wifislax2-v3.zip

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #48 en: 06-05-2012, 23:37 (Domingo) »
AMOS A PROBAR

 ;D

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #49 en: 07-05-2012, 00:16 (Lunes) »
MEN esta casi...


NO SE COPIA EL DIRECTORIO


bin


con lo que el sistema despues...no inicia  ;D

el proceso lo hace todo perfecto ..yo creo que ya solo falta eso..que copie el directorio bin.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #50 en: 07-05-2012, 00:20 (Lunes) »
no se si sera casualidad ,pero el instalador y los scripts los tengo en bin

voy a probar desde otra ruta..en opt ,por ejemplo.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #51 en: 07-05-2012, 00:27 (Lunes) »
en opt lo mismo , ...no se copia el directorio bin

ademas durante la instalacion , en los mensajes de copaindo ...  , la ruta bin , no sale.

me di cuenta por que la live tenia 18 directorios y al copiar a la particion solo veia 17

eso despues de ver que el sistema no arrancaba ...y vi que "bin", no estaba.

he probado 3 o 4 veces , e incluso deje un poco de rato por si , necesitara mas tiempo ,pero que va..no la copia.

supremo12345

  • Visitante
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #52 en: 07-05-2012, 00:29 (Lunes) »
Si los scripts estan en el mismo sitio que el instalador da igual, debe funcionar.

Revisa los scripts:

listaDirectoriosCopiar.sh -> este te deberia devolver /bin, lo hace?
Código: [Seleccionar]
ls -1 / | egrep -v "^dev"  | egrep -v "^proc" | egrep -v "^mnt" | egrep -v "^boot"  | egrep -v "^sys"  | egrep -v "^tmp"

despuesDeCopiar.sh (se le pasa como argumento la ruta elegida, por ejemplo /dev/sda1
Código: [Seleccionar]
mkdir -p $1/{tmp,boot,mnt,dev,sys,proc}
cd $1/ && cat etc/fstab |egrep -o "/mnt/[a-z0-9]+" | cut -b 2- |xargs mkdir
device=$(cat /proc/mounts |grep $1 |cut -d " " -f 1) && echo "$device / auto defaults 1 1" >$1/etc/fstab && cat /etc/fstab | grep -v $device >>$1/etc/fstab
rm $1/etc/mtab
cp -Rp $1/etc/rc.d/rc.langconf  $1/etc/rc.d/rc.langconf-
cp -rf $1/etc/rc.d/rc.langconf
touch $1/etc/rc.d/rc.langconf
cp /boot/vmlinuz $1/boot
cp --preserve -R /dev/null $1/dev
cp --preserve -R /dev/console $1/dev
mount -o bind /dev $1/dev
mount -t proc proc $1/proc
sync
umount $1/dev
umount $1/proc
« Última modificación: 07-05-2012, 00:31 (Lunes) por supremo12345 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #53 en: 07-05-2012, 00:31 (Lunes) »
los scripts los tengo en la misma ruta ...el caso es que copia todo y hace todo bien ,pero bin , no lo copia

voy revisar el codigo, aver si coincide cone se que pones tu.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #54 en: 07-05-2012, 00:36 (Lunes) »
el codigo es el mismo ..asi que algo raro hay

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #55 en: 07-05-2012, 00:39 (Lunes) »
he copiado a mano , el directorio bin , y el sistema arranca y esta todo en su sitio ,asi que solo falta saber

por que no se copia el directorio ese.

en cuanto bin se copie,,ya estara acabado.

supremo12345

  • Visitante
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #56 en: 07-05-2012, 00:40 (Lunes) »
tranquilo, en media hora lo arreglo. Es que me cuesta mucho trabajar con la maquina virtual y copiar todos los cambios con scp de la maquina virtual a mi maquina. Imaginate que con cada cambio lo tengo que hacer pa probar.


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #57 en: 07-05-2012, 00:41 (Lunes) »
creo que te levantabas pronto a currar...asi que dejalo , y mañana se sigue.

ire mirando el code a ver si veo algo..pero el comando en la shell ...si que muestar el directorio bin,,asi que si que grep lo captura..pero despues na.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14460
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #58 en: 07-05-2012, 00:42 (Lunes) »
yo estare toda la noche , por que estoy trabajando , y no me queda otra.


gracias de verdad.

supremo12345

  • Visitante
Re: convirtiend0 el instalador hd a formato sq4.
« Respuesta #59 en: 07-05-2012, 00:44 (Lunes) »
Que va tranqui sin problema, lo voy a mirar ahora. Es que con solo mirar el codigo sin probar ya se lo que es xD