Autor Tema: Problema con airsnarf (ya es personal...)  (Leído 5541 veces)

0 Usuarios y 1 Visitante están viendo este tema.

jositomi

  • Visitante
Problema con airsnarf (ya es personal...)
« en: 24-08-2011, 01:01 (Miércoles) »
Buenas noches,
no suelo escribir mucho como podeis comprobar ,me gusta mas empaparme y leer..
En fin el tema es que llevo ya una semana intentando hacer funcionar airsnarf,
primero fue con ubuntu ,pero me parece que con dhcp-3 no corre...
En fin lo intente con Bt3 que parece que era el mas apropiado,pero despues de leerme paginas y paginas,
curiosamente todos los links archivos que hay que cambiar estan caidos...
Asi que lo hice a pelo,rc.dhcp y rc.httpd en unos foros que vi por ahi..
Lo cambie,tambien para que escribiera password en pentest,dns ..etc..
El caso es que me asigna direcciones dhcp y demas pero no me redirecciona...
Con esto quiero decir que si me conecto desde otro ordenador y pongo la puerta de enlace veo perfectamente la entrada de airsnarf ,para meter usuario y login,pero al poner www.google.com pagina no encontrada o pagina no encontrada en el servidor....
Me tiene ya ofuscado porque llevo dias y no lo consigo...me he leido todo lo que hay y mas,excepto un enlace en la wiki de bactrack que esta caido...(que suerte:)).
No se si hay que tocar algo en el apache o que...
Muchisimas gracias a quien me pueda echar un cable,de verdad,porque me interesa mucho este tema,y no avanzo...
Un saludo a todos y gracias de nuevo.



alist3r

  • Visitante
Re: Problema con airsnarf (ya es personal...)
« Respuesta #1 en: 25-08-2011, 04:37 (Jueves) »
acabemos antes.
ese script por lo que veo es mas redhatero y habria que tocar codigo para adaptarlo.

no reinventemos la rueda, pásate a airssl, que lo tenemos adaptado y funcionando en sistemas debianitas.

dime que sistema utilizas. sid? wheezy? ubuntu? bt5?
« Última modificación: 25-08-2011, 04:42 (Jueves) por alist3r »

jositomi

  • Visitante
Re: Problema con airsnarf (ya es personal...)
« Respuesta #2 en: 25-08-2011, 19:20 (Jueves) »
Gracias por responder alist3r .
Ahora mismo utilizo el bt 3 con el codigo adaptado,
Me he dado cuenta que al poner una direccion simple,por ejemplo www.google.es,
lo hace correctamente,pero si la direccion es por ejemplo www.google.es/lo_que_sea,
da el tipico error 404 pagina no encontrada en el servidor,
No se si esto sera asi,o hago algo mal...pero esas paginas no las redirecciona,por lo que se reducen las posibilidades de posibles clientes...
Intente tocar algunos parametros del apache pero nada...me imagino que funcionara asi el script de perl...

En fin si alguien me puede dar un poco de luz lo agradeceria,como digo ya es un tema personal que me tiene ofuscado...

Por otro lado no conocia el airssl,si hotspotter y alguno mas.
Si me das algo mas de informacion,como si se puede utilizar tambien para que salga una pagina de logueo simulando un portal captivo,  te lo agradezco.
Un saludo

« Última modificación: 25-08-2011, 19:23 (Jueves) por jositomi »

alist3r

  • Visitante
Re: Problema con airsnarf (ya es personal...)
« Respuesta #3 en: 25-08-2011, 19:23 (Jueves) »
con el airssl y el fakeap_pwn no hemos advertido problemas similares.

qué raro...

pero desde luego no es algo deseable.

podria ser un fallo de apache, si. del mismo apache seguramente, mas que de la gestión que hace el script, porque el script solo lanza los procesos y luego se aparta del medio.

la verdad es que no se puede decir nada seguro sin depurar el código y ver qué pasa.

joer...

bueno, tenemos otros scripts cuando te canses de ese, pidelos que por aqui los amigos dudux y berni69 creo que no tendran problemas en pasarte sus adaptaciones.

jositomi

  • Visitante
Re: Problema con airsnarf (ya es personal...)
« Respuesta #4 en: 30-08-2011, 17:49 (Martes) »
Gracias de nuevo alist3r .
Ya he dado con el problema, por si a alguien mas le pasa (seguramente)....
Simplemente hay que redireccionar el error 404 en httpd.conf añadiendo esta simple linea:
ErrorDocument 404 /index.html
Asi cada vez que se de ese error simplemente nos devolvera a la pagina de inicio/logueo.

Espero haber ayudado a alguien.

Por otro lado alist3r si me puedes pasar algun buen manual del  airssl y el fakeap_pwn  estaria muy agradecido.

Un saludo.

alist3r

  • Visitante
Re: Problema con airsnarf (ya es personal...)
« Respuesta #5 en: 31-08-2011, 12:49 (Miércoles) »
Gracias de nuevo alist3r .
Ya he dado con el problema, por si a alguien mas le pasa (seguramente)....
Simplemente hay que redireccionar el error 404 en httpd.conf añadiendo esta simple linea:
ErrorDocument 404 /index.html
Asi cada vez que se de ese error simplemente nos devolvera a la pagina de inicio/logueo.

Espero haber ayudado a alguien.

Por otro lado alist3r si me puedes pasar algun buen manual del  airssl y el fakeap_pwn  estaria muy agradecido.

Un saludo.

ostras, pues no hemos encontrado ningun manual, creo. es que los creadores de estas cosas son gente de nivel alto, y claro, digamos que hacn sus desarrollos por y para hackers que no necesitan explicaciones técnicas de ningun asunto.

nosotros hemos ido analizando el código a ojo para comprenderleo y modificarlo segun nuestras necesidades.

si las paginas oficiales no presentan manuales, y si *dudux y berni69 que son los que tambien han estado metiendo mano a estos scripts, no tienen nada... entonces es dificil que se haya escrito literatura sobre eso.

berni69

  • Visitante
Re: Problema con airsnarf (ya es personal...)
« Respuesta #6 en: 31-08-2011, 13:33 (Miércoles) »
La verdad es que manual no encontre para airpwn hay algun post donde se expresan fallos y errores pero poca cosa mas tanto de fake como de airssl

//FINAL Y MÁS DOS RESPUESTAS