Autor Tema: Wisacom Zydas  (Leído 5430 veces)

0 Usuarios y 1 Visitante están viendo este tema.

garvarma

  • Visitante
Wisacom Zydas
« en: 05-05-2009, 14:49 (Martes) »
Hola a todos,
Tengo una tarjeta wisacom con chipset Zydas para poder realizar auditorias en linux, más concretamente Ubuntu 8.10 con kernel 2.6.27-11.

net:~$ uname -r
2.6.27-11-generic


Cuando conecto el usb veo que Ubuntu ya me lo reconoce:

net:~$ lsusb
Bus 005 Device 004: ID 0ace:1215 ZyDAS WLA-54L WiFi
Bus 005 Device 002: ID 064e:d101 Suyin Corp.
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


y los modulos también:

net:~$ lsmod
Module                  Size  Used by
arc4                    9984  2
ecb                    10880  2
crypto_blkcipher       25476  1 ecb
zd1211rw               53380  0
mac80211              216820  1 zd1211rw
cfg80211               32392  1 mac80211
nls_iso8859_1          12032  1
nls_cp437              13696  1
vfat                   18944  1
fat                    57376  1 vfat
wlan_wep               14208  0
i915                   38656  2
drm                    86056  3 i915
pciehp                 40600  0
binfmt_misc            16904  1
sco                    18308  2
bridge                 56980  0
stp                    10628  1 bridge
bnep                   20480  2
rfcomm                 44560  0
l2cap                  30464  6 bnep,rfcomm
bluetooth              61924  6 sco,bnep,rfcomm,l2cap
ppdev                  15748  0
acpi_cpufreq           15500  1
cpufreq_powersave       9856  0
cpufreq_conservative    14600  0
cpufreq_stats          13188  0
cpufreq_userspace      11396  0
cpufreq_ondemand       14988  1
freq_table             12672  3 acpi_cpufreq,cpufreq_stats,cpufreq_ondemand
pci_slot               12680  0
sbs                    19464  0
container              11520  0
sbshc                  13440  1 sbs
ipv6                  263972  10
af_packet              25728  4
iptable_filter         10752  0
ip_tables              19600  1 iptable_filter
x_tables               22916  1 ip_tables
wlan_scan_sta          21504  0
ath_rate_sample        21248  1
ath_pci               216632  0
wlan                  240880  5 wlan_wep,wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal               312288  3 ath_rate_sample,ath_pci
parport_pc             39332  0
lp                     17156  0
parport                42604  3 ppdev,parport_pc,lp
joydev                 18368  0
mmc_block              17924  2
snd_hda_intel         384176  4
snd_pcm_oss            46848  0
snd_mixer_oss          22784  2 snd_pcm_oss
snd_pcm                83204  2 snd_hda_intel,snd_pcm_oss
snd_seq_dummy          10884  0
acer_wmi               19008  0
led_class              12164  1 acer_wmi
uvcvideo               63624  0
compat_ioctl32          9344  1 uvcvideo
videodev               41344  1 uvcvideo
v4l1_compat            22404  2 uvcvideo,videodev
evdev                  17696  11
video                  25232  0
output                 11008  1 video
snd_seq_oss            38528  0
snd_seq_midi           14336  0
wmi                    14504  1 acer_wmi
psmouse                45200  0
snd_rawmidi            29824  1 snd_seq_midi
serio_raw              13444  0
snd_seq_midi_event     15232  2 snd_seq_oss,snd_seq_midi
sdhci_pci              15360  0
sdhci                  23940  1 sdhci_pci
snd_seq                57776  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
mmc_core               58268  2 mmc_block,sdhci
snd_timer              29960  2 snd_pcm,snd_seq
snd_seq_device         15116  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
battery                18436  0
ac                     12292  0
snd                    63268  15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
button                 14224  0
iTCO_wdt               18596  0
pcspkr                 10624  0
iTCO_vendor_support    11652  1 iTCO_wdt
soundcore              15328  2 snd
snd_page_alloc         16136  2 snd_hda_intel,snd_pcm
intel_agp              33724  1
shpchp                 38036  0
pci_hotplug            34976  2 pciehp,shpchp
agpgart                42184  3 drm,intel_agp
ext3                  133256  1
jbd                    55828  1 ext3
mbcache                16004  1 ext3
sd_mod                 42392  3
crc_t10dif              9984  1 sd_mod
sg                     39732  0
pata_acpi              12160  0
ata_generic            12932  0
ata_piix               24708  2
libata                178208  3 pata_acpi,ata_generic,ata_piix
ehci_hcd               43788  0
uhci_hcd               30864  0
scsi_mod              155212  3 sd_mod,sg,libata
dock                   16656  1 libata
usbcore               149488  5 zd1211rw,uvcvideo,ehci_hcd,uhci_hcd
r8169                  36100  0
mii                    13440  1 r8169
thermal                23708  0
processor              42156  4 acpi_cpufreq,thermal
fan                    12548  0
fbcon                  47648  0
tileblit               10880  1 fbcon
font                   16512  1 fbcon
bitblit                13824  1 fbcon
softcursor              9984  1 bitblit
fuse                   60828  3


1º- Entonces el primer problema que tengo es que cuando abro Wicd me aparecen mi wifi y de otros vecinos, pero en potencia en todas me pone -1dBm (ojala esto fuera cierto) ya que he provado otro usb y me da valores más dispares entre los wifis que encuentra.

2º- El segundo problema que me encuentro es que si me intento contectar a mi wifi que no tiene aún configurada ningún tipo de clave, la conexión se vuelve muy inestable y no puedo navegar por internet.

Hasta aqui el problema de conexión....

Ahora cuando voy a probar la auditoria con mi wifi veo que la interfaz aparece en mi ubuntu

net:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wifi0     no wireless extensions.

pan0      no wireless extensions.

wmaster0  no wireless extensions.

wlan1     IEEE 802.11bg  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=0 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


La pongo en modo monitor con el comando sudo iwconfig wlan1 mode monitor, escaneo redes wifi mediante airodump-ng y encuentro unas pocas

wlan1     IEEE 802.11bg  Mode:Monitor  Frequency:2.457 GHz  Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


CH  1 ][ Elapsed: 32 s ][ 2009-05-05 14:23                                         
                                                                                       
 BSSID              PWR  Beacons    #Data, #/s  CH  MB  ENC  CIPHER AUTH ESSID
                                                                                       
 XX:XX:XX:XX:XX:XX   52       47        0    0   1  54. WPA  CCMP   PSK  <length:  4> 
 XX:XX:XX:XX:XX:XX   27       42        0    0   1  54  WPA  TKIP   PSK  Orange-73FB   
 XX:XX:XX:XX:XX:XX   26       37        0    0   1  54. WPA  CCMP   PSK  <length:  4> 
 XX:XX:XX:XX:XX:XX   21       51        0    0  11  54. WEP  WEP         WLAN_82       
 XX:XX:XX:XX:XX:XX   14       36        1    0  10  54. WEP  WEP         WLAN_C5       
 XX:XX:XX:XX:XX:XX    9       15        0    0   6  54. WPA  TKIP   PSK  YOP!!         
 XX:XX:XX:XX:XX:XX    6       15        0    0  12  54  WEP  WEP         WLAN_B8


finalmente intento inyectar trafico a mi wifi que esta en la otra punta de la casa, pero que aun tengo algo bueno de señal...:

net:/$ sudo aireplay-ng -1 0 -e WLAN_82 -a XX:XX:XX:XX:XX:XX -h xx:xx:xx:xx:xx:xx wlan1
14:33:44  Waiting for beacon frame (BSSID: XX:XX:XX:XX:XX:XX) on channel 11

14:33:44  Sending Authentication Request (Open System)

14:33:46  Sending Authentication Request (Open System)

14:33:48  Sending Authentication Request (Open System)

14:33:50  Sending Authentication Request (Open System)

14:33:52  Sending Authentication Request (Open System)

14:33:54  Sending Authentication Request (Open System)

14:33:56  Sending Authentication Request (Open System)

14:33:58  Sending Authentication Request (Open System)

14:34:00  Sending Authentication Request (Open System)


Pero nunca enlaza....

He probado con una Atheros integrada con un portatil de un amigo y funciona a la primera, en cambio con la Wisacom con el chipset Zydas no se enlaza.

Luego probe otras opciones tipo: Wifislax --> no me reconoce el usb y blackback3 y este ultimo si tira algo, pero luego me vuelve a aparecer el problema de la inestabilidad...

He probado para parchear modulos y todo, e instalar drivers pero no se hacerlo del todo bién, ya que ademas mi kernel el bastante nuevo y me da error siempre que hago make o cuando hago un patch.

Así que les agradecería algo de ayuda por favor y sinó como última opción que usb wifi me recomendarian con antena externa tipo RP-SMA para poder trabajar en modo monitor con ubuntu y poder inyectar de forma directa...

Muchas gracias



thedoctor77

  • Visitante
Re: Wisacom Zydas
« Respuesta #1 en: 05-05-2009, 15:10 (Martes) »
prueba esto --> iwconfig wlan1 rate 1M
, e intentate acercar mas porque 20 de power es poquito aunque suficiente dependiendo de la tarjeta, no todas las fabrica el mismo ni tienen la misma sensibilidad ni estabilidad, un saludo!!

chinitiw

  • Visitante
Re: Wisacom Zydas
« Respuesta #2 en: 05-05-2009, 16:36 (Martes) »
pues la verdad te comento un detalle que te puede resultar interesante , lo primero , me imagino aunque no lo se seguro que con ese kernel estarás usando los iw de compat wireless, cosa que esto me confirma:

Citar
zd1211rw               53380  0
mac80211              216820  1 zd1211rw


 , con lo que el comando para ponerlo en modo monitor sería :

airmon-ng start wlan1

y este creará una interfaz mon0 en modo monitor que creo que es la que debes usar, luego prueba cosas como bajar el rate y demás , peor esa mon0 es la que debes de usar, tampoco iría mal que fijes el canal que quieres usar puesto que no lo haces

Un saludo

garvarma

  • Visitante
Re: Wisacom Zydas
« Respuesta #3 en: 06-05-2009, 11:32 (Miércoles) »
Hola de nuevo.

Primero de todo decir gracias a ambos por vuestra ayuda!

He provado lo de poner iwconfig mon0 rate 1M y a la hora de ver si se ha hecho alguna modificacion mediante iwconfig, no he visto nada, asi que he seguido el proceso de siempre, y sigue sin enlazar al hacer aireplay-ng...

Luego también he ejecutado airmong-ng start wlan1 11, para que me configure la interfaz mon0 en el canal 11, y sigue igual sin enlazar mediante aireplay-ng.

Asi que sigue lo mismo...

Por cierto las pruebas las he realizado un poco más cerca con valores de potencia 32-34

gracias, espero más sugerencias, como actualizar drivers, etc.

ironjon

  • Visitante
Re: Wisacom Zydas
« Respuesta #4 en: 06-05-2009, 12:09 (Miércoles) »
Creo que deberias de probar:

Código: [Seleccionar]
airmon-ng start wifi0
Esto te creara una wlanx en modo monitor

Creo que la Zydas esta trabaja con drivers Atheros

ironjon

  • Visitante
Re: Wisacom Zydas
« Respuesta #5 en: 06-05-2009, 12:11 (Miércoles) »
Por cierto se me olvidaba.
Yo he probado este adaptador con Wifiway 1.0 y tiraba de lujo  ;D

garvarma

  • Visitante
Re: Wisacom Zydas
« Respuesta #6 en: 06-05-2009, 12:52 (Miércoles) »
Gracias ironjon,

Ahora estoy en proceso de descargarme Wifiway 1.0, ya que como he comentado wifislax no me lo detectaba...y ya te dire algo.

La inestabilidad la tienes con wifiway?? ya que como he comentado en el primer post, cuando voy a ubuntu, el usb wifi no para de desconectarse y conectarse...

gracias de antemano y ya comentaré una vez provado wifiway en un usb

ironjon

  • Visitante
Re: Wisacom Zydas
« Respuesta #7 en: 06-05-2009, 13:26 (Miércoles) »
Ese adaptador con Ubuntu no lo he probado.
Instale los drivers en Vista y pertenecian a la Atheros AR5007UG por si te sirve de algo pero vamos que con Wifiway 1.0 corria muy bien.