Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
21-10-2017, 19:50 (S?bado)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Sistemas operativos
| |-+  Zona GNU/Linux
| | |-+  Parche para 8187L en ubuntu con kernel 2.6.28 (Solucionado)
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: 1 2 [3] 4 5 Ir Abajo Imprimir
Autor Tema: Parche para 8187L en ubuntu con kernel 2.6.28 (Solucionado)  (Leído 42410 veces)
thedoctor77
Visitante
« Respuesta #40 : 28-04-2009, 04:15 (Martes) »

voy a probar ahora te cuento, por cierto MUCHAS GRACIAS, te estas tomando demasiadas molestias, un saludo!!
 Angry Angry Angry Angry
En línea
thedoctor77
Visitante
« Respuesta #41 : 28-04-2009, 04:39 (Martes) »

estoy haciendo una prueba, parece que va mejor, haber si se pone a inyectar que no quiere!! jaja gracias, ya va. podrias unificarla toda en un post estilo manual, un saludo!!
PD: El pwr a 0!! maldito power
En línea
thedoctor77
Visitante
« Respuesta #42 : 28-04-2009, 04:52 (Martes) »

creo que no inyecta, a ti si?, un saludo!!
En línea
devil_demon
****
Desconectado Desconectado

Mensajes: 73



Ver Perfil WWW
« Respuesta #43 : 28-04-2009, 21:58 (Martes) »

Vamos a llevarnos bien, me estas diciendo que coges los drivers viejos de ieee80211 le copias el archivo de compat-wireless para parchearlo con un parche de mac80211 dentro de la carpeta de los ieee, y luego parcheas con el parche ieee80211 para kernel 2.6.27 cojes e instalas.

A mis ojos lo que pasa es que si, parcheas el archivo de los compat con el parche pues bien, keda parcheado pero de entrada tu lo sacas de la ruta pa q lo encuentre el parche y lo metes en la carpeta de los ieee al instalar los ieee con al make ese archivito parcheado de los compat se la trae floja  que este en la misma carpeta yo creo instalara lo que hay en el make y listo. Vamos que es lo mismo que si cogieras directamente los ieee y los parchearas con el parche 27 sin hacer nada mas. Y eso para inyectar en el kernel 28 no vale, funciona medio mal.

No sera mas facil instalar los compat-wireless y parchearlos con los parches de aircrack para kernel 28?


Una duda que me tiene muy desconcertado, porque publicas a los 4 vientos este tutorial por todos los foros (yo he visto 4 o 5 alomejor hay mas) los de remoteexploit, los de aircrack-ng forum, los de debian, los de ubuntu. este mismo.... etc... y luego al final de este post vas y pones que no que a ti no te interesa la inyeccion que tu lo usas para conectarte nada mas? LOOOLLL

Para conectar sin mas con los mac80211 que incluyen los kernel nuevos (26 27 28 29 etc) ya funciona sin hacer mas pirulas....

En fin yo sigo desesperado por que me funcione la inyeccion en mi alfa que me veo instalando el ubuntu 8.10 de nuevo que iba bien xD Un saludete y si alguien le funciona que diga como lo ha hecho
En línea

Hwagm
Administrador
*
Desconectado Desconectado

Mensajes: 17502



Ver Perfil WWW
« Respuesta #44 : 28-04-2009, 22:59 (Martes) »

joe, como avanzo este post

bueno que muchos compañeros se han explicado pero que mucho mejor que yo.

y mi opinion respecto a sin sonmejores unos u otros que creo haber leido, , mi opinion es esta:

Sinceramente desde que se paso a los mac80211 ha sido un dolor de cabeza, por ejemplo la wifiway -1.0 final se demoro por lo menos 1 año por culpa de estas cosas, BT sinm embargo saco una version con los drivers que habian sacado anteriormente, por eso luego sacaron otra rapida basada en debian.

Hay estaba la duda si en tirar para adelante o para atras, en la 1.0 final tiremos para adelante, por eso entre la beta 2 y la final hay kernel distinto, BT que no se si fue creo la 3, esperaon tambien bastante , respecto a las historias de la bt1 y 2 no se como lo hicieron.

EL caso es que cada kernel nuevo, es un lio con los driver s de auditoria, los clasicos iban perfectos y se compilaban bien.

Y de los iwlagn ya mejor ni hablar, sin embargo los zydas con mac80211 si que han ido bien, curioso


pd: dejo el post con chincheta, que hay buena informacion y buenos comentarios
« Última modificación: 28-04-2009, 23:05 (Martes) por Hwagm » En línea


thedoctor77
Visitante
« Respuesta #45 : 29-04-2009, 04:27 (Mi?rcoles) »

mmm... cuantas mas pruebas hago peor.
La inyeccion no sube de 20, incluso llega a caer, el pwr a 0 (esto es lo de menos). Creo que cojo mas redes que antes, pero, esta es mi situacion:
wifilink 5100 wlan0
alfa wlan1
si desactivo la wifilink ifconfig wlan0 down, se acabo internet.
Creo que falla aqui algo, o soy yo???, un saludo!!
En línea
Qfito
Visitante
« Respuesta #46 : 29-04-2009, 19:51 (Mi?rcoles) »

Suerte!
« Última modificación: 04-05-2009, 19:30 (Lunes) por Qfito » En línea
devil_demon
****
Desconectado Desconectado

Mensajes: 73



Ver Perfil WWW
« Respuesta #47 : 29-04-2009, 21:34 (Mi?rcoles) »

A ver, yo me remito al tuto que tienes tu ahi puesto, y veo que hay drivers y parches mezclados de todos los generos y tamaños, esta bien que la gente aporte cosas pero publicar a los 4 vientos algo que no funciona pues no me parece bien.

Sobre el File to Patch no lo encuentra mas que nada porque ese parche no es para esos drivers, ese parche es para aplicarlo sobre los compat o sobre el modulo entero del kernel antes de compilarlo si se lo metes a mano lo encuentra, pero que mas da si luego instalas otros drivers, aunque tengas ese archivo parcheado dentro de la carpeta de los otros drivers al darle al make no lo compila por mucho que este dentro de la carpeta porque es una cosa de los drivers 80211 que metes dentro de la carpeta ieee802.

Yo no soy un hacedor de parches, veo que tu tampoco, y voy a aportar algo.
Si quieren inyectar bien con la alfa usb rtl8187 pasense al ubuntu 8.10 con el kernel 27 y ahi se aplica el driver del ieee802.11 de la siguiente manera.

Código:
wget http://dl.aircrack-ng.org/drivers/rtl8187_linux_26.1010.zip
unzip rtl8187_linux_26.1010.zip
cd rtl8187_linux_26.1010.0622.2006/
wget http://patches.aircrack-ng.org/rtl8187_2.6.27.patch
tar xzf drv.tar.gz
tar xzf stack.tar.gz
patch -Np1 -i rtl8187_2.6.27.patch
gedit ./beta-8187/r8187.h

Encontrar esta linea
Código:
#include <asm/semaphore.h>

y cambiarla por

Código:
#include <linux/semaphore.h>

Si tienes la tarjeta conectada borrarle el driver rtl8187

Código:
sudo ifconfig wlan0 down
sudo rmmod rtl8187

Compilar e instalar

Código:
make
sudo make install

Y con eso funcionaras bien en el kernel 2.6.27, mucho mejor que con los mac80211 e incluso funciona en el kernel 2.6.28 no muy bien pero mejor que tu metodo, al menos inyecta, funciona fragmentacion aunque el pwr y el rxq esten con numeros raros, con tu metodo el rxq y el pwr estan a 0

Si me dices que no lo quieres para inyectar pues directamente NO HAGAS NADA plug and play enchufar y navegar no necesitas hacer nada, te carga los mac80211 que vienen de serie que no inyectan pero si navegan.

Se agradece que la gente haga aportes pero tambien hay que admitir criticas, si tu metodo no le funciona a nadie no lo pongas en todos los foros.

Un saludete Grin

En línea

thedoctor77
Visitante
« Respuesta #48 : 29-04-2009, 23:06 (Mi?rcoles) »

haya paz, me parece mal esta situacion, cada uno intenta poner soluciones, si no va pues no va. El primer coche que se invento no andaba ni 10 kilometros, pero fue un comienzo, un saludo!!
PD: Es verdad que no funciona, o por lo menos lo que he visto, ahora yo no he echo pruebas con algun programa ni nada. Da igual, incluso en el caso en que no funcione, si dice oye mira no funciona, como lo he dicho yo anteriormente, pero hay que tener en cuenta que esto se tarda un rato en pensar, por lo que me parece mal el desprestigiar a alguien por estar confundido, pero bueno cada uno es hijo de su padre y de su madre, un saludo!!
En línea
devil_demon
****
Desconectado Desconectado

Mensajes: 73



Ver Perfil WWW
« Respuesta #49 : 29-04-2009, 23:16 (Mi?rcoles) »

Vamos a ver Qfito, el parche IEEE80211 para rtl8187 no existe y mientras no exista voy a tirar con ubuntu 8.10, eso que puse ahi ya se que esta repetido pero es la mejor manera de usar la Alfa/Bosslan que existe hasta el momento. Y mi consejo al lector de este post es que si quiere sacar el maximo provecho de su tarjeta, use ubuntu 8.10 o wifislax o cualquier cosa que use drivers IEEE80211, los MAC80211 no van bien ni parcheandolos.

Respecto a tu aporte hiziste bien en borrarlo porque no sirve, esta bien que se intente cacharrear pero si no sirve no lo publiques, pruebalo antes mezclas cosas, y me llama la atencion que estes muy orgulloso de haber logrado algo de haber hayado la solucion, cuando tu ni siquiera has provado la inyeccion que es lo que quiere la gente, te repito para conectar no hay que hacer nada.

Dices que yo no hago nada para solucionarlo pero te repito yo no se hacer parches mi nivel de linux no da para tanto para eso estan los chicos de aircrack-ng trabajando en ello supongo por eso espero a que lo hagan o sino uso un kernel que sirva.

Si bien es cierto que existen unos parches para MAC80211 algunos de ellos los aplica Qfito mezclando unos drivers con otros etc pero segun http://aircrack-ng.org/doku.php?id=rtl8187 hay que aplicarlos sobre el driver  " mac80211 driver for RTL8187L and RTL8187B. Rtl8187 is part of the official Linux kernel"

sobre MAC80211!!

Y la forma de aplicarlos seria sobre el modulo del kernel correspondiente aplicar este parche http://patches.aircrack-ng.org/rtl8187-mac80211-injection-speed-2.6.28-rc6.patch

Y a mayores este http://patches.aircrack-ng.org/mac80211_2.6.28-rc4-wl_frag+ack_v3.patch para la fragmentacion.

Seria compilando el kernel o el modulo y en la carpeta del source del kernel parchear asi si te encontraria la ruta porque el parche esta preparado para buscar en esa ruta.
La unica web que he encontrado sobre como hacerlo esta medio en chino es esta http://blog.csdn.net/Crob/archive/2009/01/16/3795914.aspx

Otra opcion es usar los Compat Wireless, yo los use y no me dan buen resultado seria aplicando el parche del medio  que en la web de aircrack dice que es recomendable para compat.

Conclusion, si quieres inyeccion de calidad usa IEEE80211 los MAC80211 no van bien para auditoria y los unicos parches que existen son para estos ultimos.

Es una pena tener una Bosslan o una Alfa que son tarjetas caras y potentes trabajando mal con unos drivers malos y unos parches malos.

Es como el tema de las iwlwifi que yo tengo una 4965agn y es un desastre para inyectar porque trabaja sobre los MAC80211.

Respecto a esta pequeña discursion yo no censuro el trabajo de nadie y celebro que se investigue pero me parece mal que algo que no funciona que ni siquiera se ha comprobado si funciona, que es una mezcla de drivers y de parches de distinto tipo se publique sin probar y por los 4 vientos en muchos foros, cuando salga la solucion buena que seria que saquen los de aircrack un parche para IEEE80211 para 2.6.28 pues se publica por los 4 vientos como SOLUCIONADOOO mientras tanto es mejor no publicar nada a publicar algo que va a marear a la gente, que no funciona, si quieren inyectar usen 8.10


haya paz, me parece mal esta situacion, cada uno intenta poner soluciones, si no va pues no va. El primer coche que se invento no andaba ni 10 kilometros, pero fue un comienzo, un saludo!!
PD: Es verdad que no funciona, o por lo menos lo que he visto, ahora yo no he echo pruebas con algun programa ni nada. Da igual, incluso en el caso en que no funcione, si dice oye mira no funciona, como lo he dicho yo anteriormente, pero hay que tener en cuenta que esto se tarda un rato en pensar, por lo que me parece mal el desprestigiar a alguien por estar confundido, pero bueno cada uno es hijo de su padre y de su madre, un saludo!!

Yo no desprestigio solo digo lo mismo que tu, que no va, y que me parece mal que algo que no va se publique a los 4 vientos porque eso marea a la gente, y digo yo que el primer coche antes de patentarlo probarian a ver si anda, nada mas. Saludos
En línea

Qfito
Visitante
« Respuesta #50 : 04-05-2009, 19:38 (Lunes) »

Se me hace increible que una persona como tú; sea moderador (devil_demon) y que paso con mis respuestas a tus estupideces que acaso te hacian ver mal? y es por eso que reabriste este post para borrar lo que no te parecia y manipularlo a tu conveniencia para hacerte ver bien. Lo hubieras dejado como terminó o acaso te molesto que un correcto moderador como el que anteriormente cerro este foro haya dicho que me pase de listo por borrar mis aportes. 
Que lastima que en este foro permitan que gente mediocre y sin ética como tú pueda participar en él.
En línea
βerni69
... Aprendiendo ...
*******
Desconectado Desconectado

Mensajes: 7239


Enllaçats per la llengua


Ver Perfil WWW
« Respuesta #51 : 04-05-2009, 21:03 (Lunes) »

Se me hace increible que una persona como tú; sea moderador (devil_demon) y que paso con mis respuestas a tus estupideces que acaso te hacian ver mal? y es por eso que reabriste este post para borrar lo que no te parecia y manipularlo a tu conveniencia para hacerte ver bien. Lo hubieras dejado como terminó o acaso te molesto que un correcto moderador como el que anteriormente cerro este foro haya dicho que me pase de listo por borrar mis aportes. 
Que lastima que en este foro permitan que gente mediocre y sin ética como tú pueda participar en él.

Lo reabri yo, me parece un post lo suficientemente interesante como para seguir investigando.

si tienes un problema usa los privados, que para algo estan. Y no insultes sin saber. Porque pones en duda la decision de un administrador de hacer moderador a un usuario, creo que se habran basado en algo no?

Si quieres discutir algo lo hacemos por privado, doy este tema por zanjado
En línea

Errar es humano, pero para liar las cosas de verdad se necesita un ordenador

Triste que ..  "Una mentira mil veces repetida....se transforme en verdad"


www.bitsdelocos.es/
Tutorial Swifi keygen + Airwin 2.0 auditorias en windows Comprawifi amenaza a Bitsdelocos
devil_demon
****
Desconectado Desconectado

Mensajes: 73



Ver Perfil WWW
« Respuesta #52 : 05-05-2009, 11:57 (Martes) »

Este es un tema bastante interesante como para dejarlo cerrado sin posiblilidad de que se pueda seguir avanzando en el asunto por usuarios que no aceptan una critica yo ya dije todo lo que tenia que decir sobre este asunto

Todo lo que sea hablar de linux y de estos drivers encantado, pero para entrar en las descalificaciones y criticas personales pues se va un dia a un programa del corazon y ahi a dar rienda suelta al asunto xD

Un saludo Wink
En línea

Samuelongui
*******
Desconectado Desconectado

Mensajes: 1137


masquerade


Ver Perfil
« Respuesta #53 : 25-05-2009, 14:39 (Lunes) »

alguna novedad por el frente?
En línea

Sugarsync: 5'5 Gb almacenamiento gratis: click aquí

I'm Specialized
malomher
Visitante
« Respuesta #54 : 28-05-2009, 11:52 (Jueves) »

Yo tengo ahora ubuntu 8.10 y dos tarjetas , una broadcom que va bien, y una alfa , que es con la que tengo los problemas.


al aplicar los comandos   
      


wget http://dl.aircrack-ng.org/drivers/rtl8187_linux_26.1010.zip
unzip rtl8187_linux_26.1010.zip
cd rtl8187_linux_26.1010.0622.2006/
wget http://patches.aircrack-ng.org/rtl8187_2.6.27.patch
tar xzf drv.tar.gz
tar xzf stack.tar.gz
patch -Np1 -i rtl8187_2.6.27.patch
gedit ./beta-8187/r8187.h


Encontrar esta linea
Código:

#include <asm/semaphore.h>


y cambiarla por

Código:

#include <linux/semaphore.h>


Si tienes la tarjeta conectada borrarle el driver rtl8187

Código:

sudo ifconfig wlan0 down
sudo rmmod rtl8187


Compilar e instalar

Código:

make
sudo make install




me da varios errores.
El primero es que no existe wlan0. Al comprobar el iwconfig resulta que la alfa la ha llamado wlan1 y por tanto he cambiado el comando a wlan1.
Pero mucho me temo que todo el controlador esta diseñado como wlan0.

Copio a continuacion la parte  de la instalacion en que me da error:

~/rtl8187_linux_26.1010.0622.2006$ sudo ifconfig wlan0 down
wlan0: ERROR mientras se obtenían las banderas de interfaz: No existe el dispositivo
p~/rtl8187_linux_26.1010.0622.2006$ sudo rmmod rtl8187



  LD [M]  /home/pp/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_crypt_wep-rtl.ko
make[2]: se sale del directorio `/usr/src/linux-headers-2.6.27-14-generic'
make[1]: se sale del directorio `/home/pp/rtl8187_linux_26.1010.0622.2006/ieee80211'
chmod +x symvers
./symvers

y acaba asi:
make[2]: se sale del directorio `/usr/src/linux-headers-2.6.27-14-generic'
make[1]: se sale del directorio `/home/pp/rtl8187_linux_26.1010.0622.2006/beta-8187'
pp@pp-laptop:~/rtl8187_linux_26.1010.0622.2006$ sudo make install
install -d /lib/modules/2.6.27-14-generic/kernel/drivers/net/wireless/rtl_ieee80211
install -d /lib/modules/2.6.27-14-generic/kernel/drivers/net/wireless/rtl8187
install -m 644 ./ieee80211/*.ko /lib/modules/2.6.27-14-generic/kernel/drivers/net/wireless/rtl_ieee80211
install -m 644 ./beta-8187/*.ko /lib/modules/2.6.27-14-generic/kernel/drivers/net/wireless/rtl8187
depmod -ae


En esencia que no se si ha instalado el controlador o no, ni cual es el error, ademas del de la denominacion wlan0.
Yo no he notado cambios en el funcionamiento  de la alfa  respecto al controlador inicial que traia ubuntu.

1.------------¿Hay alguna forma de saber si el nuevo controlador esta instalado?

2.-¿Cual es el comando para saber en cada momento que controlador esta utilizando cada dispositivo?
En línea
Samuelongui
*******
Desconectado Desconectado

Mensajes: 1137


masquerade


Ver Perfil
« Respuesta #55 : 29-05-2009, 09:59 (Viernes) »

antes de empezar debes ser super usuario:

sudo -s

creo que ese era el comando  Wink
En línea

Sugarsync: 5'5 Gb almacenamiento gratis: click aquí

I'm Specialized
βerni69
... Aprendiendo ...
*******
Desconectado Desconectado

Mensajes: 7239


Enllaçats per la llengua


Ver Perfil WWW
« Respuesta #56 : 04-06-2009, 15:03 (Jueves) »

Citar
sudo ifconfig wlan0 down

normal.. si acabas de deciir que es wlan1 no 0 -.-''''''''

ains...

Por eso te salta ese error  Wink
En línea

Errar es humano, pero para liar las cosas de verdad se necesita un ordenador

Triste que ..  "Una mentira mil veces repetida....se transforme en verdad"


www.bitsdelocos.es/
Tutorial Swifi keygen + Airwin 2.0 auditorias en windows Comprawifi amenaza a Bitsdelocos
BackON
**
Desconectado Desconectado

Mensajes: 3


Ver Perfil
« Respuesta #57 : 06-06-2009, 00:03 (S?bado) »

yo acabo de conseguir meter el driver parcheado al ubuntu 9.04 parcheando el mac80211
como bien dice hay que compilar el kernel pero con que compile los modulos y los instale vale..

Proceso a seguir

Instalamos lo basico para configurar el kernel y compilar

Código:
sudo apt-get install build-essential linux-source kernel-package libncurses5-dev


Una vez instalado todo ello vamos al directorio /usr/src y descomprimimos el archivo

Código:
cd /usr/src
sudo tar xfjv linux-source2.6.28.tar.bz2

Nos bajamos estos dos parches
Código:
sudo wget http://patches.aircrack-ng.org/rtl8187-mac80211-injection-speed-2.6.28-rc6.patch
sudo wget http://patches.aircrack-ng.org/rtl8187_hw_signal_backport_2.6.28.patch

Y los aplicamos
Código:
sudo patch -Np1 -i rtl8187-mac80211-injection-speed-2.6.28-rc6.patch
sudo patch -Np1 -i rtl8187_hw_signal_backport_2.6.28.patch

si nos pide que archivo queremos parchear le decimos este (SI aparece file to patch) ponemos lo siguiente

Código:
/usr/src/linux-source-2.6.28/drivers/net/wireless/rtl8187_dev.c

una vez parcheado con los dos parches los compilamos e instalamos

Código:
sudo make clean && sudo make && sudo make modules_install

y ya tendremos nuestro queridos mac80211 parcheados... yo aaun ando compilando el kernel ya comentare experiencia
En línea
BackON
**
Desconectado Desconectado

Mensajes: 3


Ver Perfil
« Respuesta #58 : 06-06-2009, 14:57 (S?bado) »

No recomiendo para nada utilizar dichos driver bajo mac80211 primero son lentos para escanear y les cuesta coger wifi ... inyeccion tiene segun probe pero no mire la velocidad a la que inyectaba...
En línea
lavitz
**
Desconectado Desconectado

Mensajes: 2


Ver Perfil
« Respuesta #59 : 07-06-2009, 20:41 (Domingo) »

Pues yo como malomher tengo el problema con el "make", uso Kubuntu 9.10 con kernel 2-6-27. He intentado varias veces aplicarle el parche a los driver pero me da el siguiente error al ejecutar el make (el resto funciona perfectamente):

rm -f ieee80211/Module.symvers 2>/dev/null
rm -f ieee80211/Modules.symvers 2>/dev/null
make -C ieee80211 all
make[1]: se ingresa al directorio `/home/fran/Drivers/rtl8187_linux_26.1010.0622.2006/ieee80211'
make -C /lib/modules/2.6.27-14-generic/build M=/home/fran/Drivers/rtl8187_linux_26.1010.0622.2006/ieee80211 modules
make: se ingresa a un directorio desconocido
make: *** /lib/modules/2.6.27-14-generic/build: No existe el fichero ó directorio.  Alto.
make: se sale del directorio desconocido
make[1]: *** [modules] Error 2
make[1]: se sale del directorio `/home/fran/Drivers/rtl8187_linux_26.1010.0622.2006/ieee80211'
make: *** [all] Error 2

He mirado en algunas paginas pero no se a que se puede deber el error. Si alguien sabe algo por favor que me lo diga para probar mas cosas ^^
En línea
Páginas: 1 2 [3] 4 5 Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums