Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
19-11-2017, 20:43 (Domingo)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Sistemas operativos
| |-+  Zona GNU/Linux
| | |-+  Wireless GNU/Linux
| | | |-+  Hostapd sin DHCP
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] 2 Ir Abajo Imprimir
Autor Tema: Hostapd sin DHCP  (Leído 14137 veces)
juänatan
**
Desconectado Desconectado

Mensajes: 40


Ver Perfil
« : 26-08-2014, 00:30 (Martes) »

Buenas a todos, actualmente en mi casa tengo un router principal con DLNA y un disco duro conectado por usb. Este router además gestiona el DHCP.
En la planta de arriba tengo otro router secundario, conectado al router principal por cable de red. Se trata de un Comtrend AR-5387un con un firmware OpenWRT compilado por mí. Este router lo uso como punto de acceso wifi con dhcp deshabilitado, de esta forma todas las IPs están en el mismo rango y comparto DLNA y samba entre todos mis dispositivos independientemente del router al que se encuentren conectados.
Además, aprovechando OpenWRT, el router AP lo uso para descargar torrents que se guardan en el disco duro compartido en red. Creo que le estoy exigiendo demasiado a este router y sufre bastantes fallos. Por ese motivo he pensado en adquirir algo más potente.

Quiero usar una Banana Pi (similar a Raspberry Pi pero GigaLAN) que haga de punto de acceso, servidor de descargas torrents y servidor Plex. Para ello quiero usar Hostapd, el problema es que en todos los tutoriales que veo en internet habilitan DHCP y yo no quiero que el punto de acceso asigne IPs a los clientes. ¿Es posible usar Hostapd con DHCP deshabilitado y que sea el router principal el que se encargue de repartir las IPs?


Enviado desde mi OnePAD 1100x2 usando Tapatalk 2
En línea
warcry
Visitante
« Respuesta #1 : 26-08-2014, 08:31 (Martes) »

de verdad os montais unos tinglaos mas raros, en fin...

creo que te has equivocado de sitio para postear, ya que no se exactamente lo que quieres hacer con hostapd, pero en linux ya te digo que el paquete hostapd no lleva dhcp, si quieres montarle un servidor dhcp tienes que utilizar otro paquete a parte.

luego entiendo que estas tratando de meter algo en un router tipo openwrt o algo similar, luego este post esta fuera de zona
En línea
juänatan
**
Desconectado Desconectado

Mensajes: 40


Ver Perfil
« Respuesta #2 : 26-08-2014, 09:18 (Martes) »

Ya sé que hostapd no lleva dhcp, pero en todos los tutoriales que veo lo instalan a parte.
No estoy tratando de meter nada en un router tipo OpenWRT, sino que quiero usar uma especie de raspberry pi como punto de acceso usando hostapd.
Lo que quiero hacer es algo similar a esto pero sin DHCP:
https://learn.adafruit.com/setting-up-a-raspberry-pi-as-a-wifi-access-point/overview
En línea
warcry
Visitante
« Respuesta #3 : 26-08-2014, 09:29 (Martes) »

pues si sabes que el hostapd no lleva el dhcp, sáltate ese paso en los tutoriales  Azn

depende del sistema linux que le metas a la raspberri tendrás que hacer una cosa u otra, pero la conf del hostapd que yo sepa es la misma.
En línea
juänatan
**
Desconectado Desconectado

Mensajes: 40


Ver Perfil
« Respuesta #4 : 28-08-2014, 20:00 (Jueves) »

Traigo avances. No lograba hacerlo funcionar y no caí que tenía habilitado el firewall de OpenSUSE.
Ahora tengo 2 problemillas:

1 - Los comandos a partir de la división ====== se pierden al reiniciar, por lo que hay que volver a realizarlos tras cada reinicio.

2 - Cuando tengo al equipo funcionando como AP, éste se queda sin internet. Es decir, los clientes conectados al equipo acceden a internet pero el propio equipo no puede navegar.


He estado haciendo las pruebas con un ultraportátil Asus EeePC 900HA con OpenSUSE 12.3 conectado por cable al router. Dispone de tarjeta wifi PCI-Express Atheros AR2427 802.11bg (wlan0) y además, le conecto por usb un adaptador de red inalámbrico Ubiquiti WiFiStation Ext 802.11n [Atheros AR9271] (wlan1).

Los pasos que sigo para crear el Access Point son:

Conseguir privilegios de administrador:
Código:
su

Instalar paquetes:
Código:
zypper in hostapd iw bridge-utils

Obtener nombre de adaptador wireless:
Código:
ifconfig -a
En mi caso es wlan1

Comprobar que el adaptador wireless soporta modo AP mirando el apartado "Supported interface modes":
Código:
iw list

Editar archivo para configurar hostapd:
Código:
nano /etc/hostapd.conf

Introduzco el siguiente contenido y guardo:
Código:
interface=wlan1
driver=nl80211
ssid=test
hw_mode=g
channel=11
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=12345
wpa_key_mgmt=WPA-PSK
rsn_pairwise=CCMP

============================

Ahora se puede crear un Bridge o activar el NAT.
Voy a crear un bridge.
Declarar el Bridge:
Código:
brctl addbr br0
Agregar tarjeta de red al bridge:
Código:
brctl addif br0 eth0
Agregar adaptador de red inalámbrico:
Código:
iw dev wlan1 set 4addr on
brctl addif br0 wlan1
Ahora debe aparecer el bridge al hacer:
Código:
brctl show
Detener el gestor de redes de OpenSUSE:
Código:
service NetworkManager stop
Ir a Yast2 y desactivar firewall
Levantar la interfaz del Bridge:
Código:
ifconfig br0 up
Ejecutar Hostapd:
Código:
service hostapd start


Ahora tengo hostapd funcionando correctamente. Puedo conectarme con mi móvil al AP y navegar. Pero el propio ordenador que ejecuta hostapd se queda sin internet. Sé que tengo hecho un puente entre eth0 y wlan1 y a lo mejor no puedo tener internet por eso, pero todavía me queda una interfaz libre: wlan0. He intentado usar la interfaz wlan0:
Código:
ifconfig wlan0 up
Escanear redes:
Código:
iwlist wlan0 scan
El comando devolverá algo como:
Código:
          Cell 01 - Address: XX:XX:XX:XX:XX:XX
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=54/70  Signal level=-56 dBm 
                    Encryption key:on
                    ESSID:"WLAN_04"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
Como es WPA/WPA2:
Código:
cp /etc/wpa_supplicant/wpa_supplicant.conf /etc/wpa_supplicant/wpa_WLAN_04.conf
nano /etc/wpa_supplicant/wpa_WLAN_04.conf
Añadir:
Código:
network={
ssid="WLAN_04"
psk="CONTRASEÑA"
priority=1
}
Finalmente:
Código:
wpa_supplicant -Dwext -i wlan0 -c/etc/wpa_supplicant/wpa_WLAN_04.conf -K -B
Para comprobar que se ha establecido la conexión:
Código:
iwconfig wlan0
Y aparece conectado.

El problema es que sigo sin internet, si hago un PING:
Código:
ping -I wlan0 www.google.es
Devuelve:
Código:
ping: unknown host www.google.es

Si deshago el puente sí funciona. Para detener el servicio y deshacer el bridge para volver a tener internet tengo que hacer:
Código:
service hostapd stop
ifconfig br0 down
brctl delbr br0
service NetworkManager start
En línea
warcry
Visitante
« Respuesta #5 : 28-08-2014, 20:22 (Jueves) »

dejate de bridges y activa el forwarding

Código:
echo "1" > /proc/sys/net/ipv4/ip_forward

y luego iptables a saco

Código:
# configuracion de iptables

# borrado de reglas de iptables

iptables -F
iptables -X
iptables -Z
iptables -t nat -F

# establecemos politica por defecto

iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -t nat -P PREROUTING ACCEPT
iptables -t nat -P POSTROUTING ACCEPT

# el localhost se deja

iptables -A INPUT -i lo -j ACCEPT

# al firewall tenemos acceso desde la red local

iptables -A INPUT -s 0.0.0.0/0 -i $device -j ACCEPT

# ahora hacemos enmascaramiento de la red local

iptables -t nat -A POSTROUTING -s 0.0.0.0/0 -o $device1 -j MASQUERADE

# Aceptamos que vayan a puertos http

iptables -A FORWARD -s 0.0.0.0/0 -i $device -p tcp --dport 80 -j ACCEPT

# Aceptamos que vayan a puertos https

iptables -A FORWARD -s 0.0.0.0/0 -i $device -p tcp --dport 443 -j ACCEPT

# Aceptamos que vayan a todos los puertos y todos los protocolos

iptables -A FORWARD -s 0.0.0.0/0 -i $device -p tcp --dport 1:65535 -j ACCEPT

iptables -A FORWARD -s 0.0.0.0/0 -i $device -p udp --dport 1:65535 -j ACCEPT

# configuramos la entrada

iptables -A OUTPUT -p tcp -m tcp --dport 1:65535 -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT

iptables -A OUTPUT -p udp -m udp --dport 1:65535 -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT

donde pone $device debes poner la interface que hace de ap

y donde pone $device1 debes poner la interface que tiene internet.

lo que no entiendo es por que no usas wap Huh

https://foro.seguridadwireless.net/wifislax/warcry-access-point-2-0-(wap-v-2-0)/
En línea
juänatan
**
Desconectado Desconectado

Mensajes: 40


Ver Perfil
« Respuesta #6 : 28-08-2014, 23:53 (Jueves) »

He intentado usar WAP en OpenSUSE y me dice: !!! No se puede continuar, modulo incompleto o corrupto !!!

Por otro lado, he realizado el fordwarding tal como lo has puesto en lugar del bridging y no funciona. El ordenador navega pero los clientes conectados al AP no.

En línea
warcry
Visitante
« Respuesta #7 : 29-08-2014, 06:23 (Viernes) »

Olvida wap, luego lo pensé y habría que tocar muchas cosas porque no creo que funcione dhcpcd, supongo que será dhclient, y así con un sin fin de comandos

Los clientes conectados al hostapd reciben un dirección ip correcta del dhcp que tienes centralizado ?
En línea
warcry
Visitante
« Respuesta #8 : 29-08-2014, 08:24 (Viernes) »

dado que no montas dhcp con el hostapd,y siempre y cuando te lleguen bien las ips de tu dhcp, entonces,

igual tienes que añadir estas reglas para poder navegar

Código:
# Permitimos la consulta a un primer DNS
iptables -A INPUT -s 8.8.8.8 -p udp -m udp --sport 53 -j ACCEPT
iptables -A OUTPUT -d 8.8.8.8 -p udp -m udp --dport 53 -j ACCEPT

# Permitimos la consulta a un segundo DNS
iptables -A INPUT -s 8.8.4.4 -p udp -m udp --sport 53 -j ACCEPT
iptables -A OUTPUT -d 8.8.4.4 -p udp -m udp --dport 53 -j ACCEPT

te he puesto los servidores de google, pero si quieres poner otros que te gusten mas.
« Última modificación: 29-08-2014, 08:26 (Viernes) por warcry » En línea
juänatan
**
Desconectado Desconectado

Mensajes: 40


Ver Perfil
« Respuesta #9 : 29-08-2014, 09:18 (Viernes) »

Los clientes conectados al hostapd reciben un dirección ip correcta del dhcp que tienes centralizado ?
No. Si intento conectarme no termina de conectar se queda en el estado "Obteniendo dirección IP". Para poder conectar tengo que configurar la IP manualmente en mi cliente.
De todas formas he añadido las iptables de las DNS y sigue sin navegar.

Gracias por la ayuda que me estás prestando.
En línea
warcry
Visitante
« Respuesta #10 : 29-08-2014, 10:16 (Viernes) »


De todas formas he añadido las iptables de las DNS y sigue sin navegar.

Gracias por la ayuda que me estás prestando.

obvio, si no tienen ip, a quien le mandan los paquetes ?

con esto en teoria deberian poder recibir ip del dhcp

Código:
iptables -I INPUT -i $device1 -p udp --dport 67:68 --sport 67:68 -j ACCEPT
iptables -I OUTPUT -o $device1 -p udp --dport 67:68 --sport 67:68 -j ACCEPT

lo que ahora no me queda muy claro es si en el imput el interface seria la wlan del hostapd y en el output la que esta conectada al dhcp, o al reves.

solucion

Código:
iptables -I INPUT -i wlan0 -p udp --dport 67:68 --sport 67:68 -j ACCEPT
iptables -I OUTPUT -o wlan0 -p udp --dport 67:68 --sport 67:68 -j ACCEPT
iptables -I INPUT -i eth0 -p udp --dport 67:68 --sport 67:68 -j ACCEPT
iptables -I OUTPUT -o eth0 -p udp --dport 67:68 --sport 67:68 -j ACCEPT

suponiendo que la wlan0 sea la que tienes con hostapd y eth0 con el dhcp.

vamos lo que viene siendo abriendolo too para que no me equivoque con el sentido de la peticion dhcp  Grin Grin Grin
« Última modificación: 29-08-2014, 10:34 (Viernes) por warcry » En línea
juänatan
**
Desconectado Desconectado

Mensajes: 40


Ver Perfil
« Respuesta #11 : 29-08-2014, 19:30 (Viernes) »

Siento decir que no funciona. Sigue todo igual.
En línea
warcry
Visitante
« Respuesta #12 : 29-08-2014, 20:18 (Viernes) »

A ver si este finde saco algo de tiempo y hago una prueba rápida
En línea
warcry
Visitante
« Respuesta #13 : 30-08-2014, 12:35 (S?bado) »

llevo toda la mañana y no hay manera de que coja el dhcp.

si meto la interface wlan0 la del hostapd con una ip de la red del dhcp, automanticamente me quedo sin internet en el pc donde se hace el puente, vamos lo que te pasa cuando haces el bridge.

y si la meto en otra subred o la dejo sin ip no trinca dhcp  Tongue


como yo lo veo solo tienes dos opciones, o haces un bridge y te quedas sin internet en el pc, o metes una subred y montas un pequeño dhcp.
En línea
juänatan
**
Desconectado Desconectado

Mensajes: 40


Ver Perfil
« Respuesta #14 : 30-08-2014, 14:45 (S?bado) »

El software WAP cómo lo hace? Crea una subred y asigna dhcp en un rango distinto al del router?
En línea
warcry
Visitante
« Respuesta #15 : 30-08-2014, 15:10 (S?bado) »

"Sip"

Y lo pongo entre comillas porque puedes jugar con el subneting y el superneting para asignar las ip de la subred.

La pregunta que debes hacerte es ¿ puede un equipo con la 192.168.76.24 y mascara de red 255.255.255.0 ver a un equipo co la ip 192.168.76.249 y mascara 255.255.255.248 ?

Si descubres la respuesta entenderás la pregunta
En línea
juänatan
**
Desconectado Desconectado

Mensajes: 40


Ver Perfil
« Respuesta #16 : 30-08-2014, 15:34 (S?bado) »

"Sip"

Y lo pongo entre comillas porque puedes jugar con el subneting y el superneting para asignar las ip de la subred.

La pregunta que debes hacerte es ¿ puede un equipo con la 192.168.76.24 y mascara de red 255.255.255.0 ver a un equipo co la ip 192.168.76.249 y mascara 255.255.255.248 ?

Si descubres la respuesta entenderás la pregunta
No sé de dónde sacas esas IPs y esas máscaras. Hasta donde yo sé la máscara de subred indica qué parte de la IP corresponde a la red y qué parte corresponde al host. Si no tienen la misma máscara no pueden estar en la misma subred aunque las dos empiecen por 192.168.76.XX. ¿es eso?
En línea
warcry
Visitante
« Respuesta #17 : 30-08-2014, 19:28 (S?bado) »

si y no

las ip son solo un ejemplo.

cuando tu no querías meter un dhcp, era porque querías que todas las ip te las diera el dhcp central.

supongo que eso es por algun motivo en concreto no¿?

luego supongo que lo que quieres es que tus maquinas se vean entre si, o que una en concreto pueda supervisar a las demás.

si es correcto lo anterior entonces puedes jugar con el subneting si la maquina que quieres que controle toda la red esta en el lado del dhcp central, o con el superneting si quieres que la maquina este en el lado del hostapd.

si no te importa lo anterior entonces, puedes poner cualquier tipo de subred que no este en la interface del puente.

bueno recapitulando:

1 forwarding

Código:
echo "1" > /proc/sys/net/ipv4/ip_forward

2 configuracion ip del interface que hara de ap con el hostapd

Código:
ifconfig wlan0 192.168.96.1 netmask 255.255.255.0

3 configuracion de las iptables

Código:
# configuracion de iptables

# borrado de reglas de iptables

iptables -F
iptables -X
iptables -Z
iptables -t nat -F

# establecemos politica por defecto

iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -t nat -P PREROUTING ACCEPT
iptables -t nat -P POSTROUTING ACCEPT

# el localhost se deja

iptables -A INPUT -i lo -j ACCEPT

# al firewall tenemos acceso desde la red local

iptables -A INPUT -s 0.0.0.0/0 -i $device -j ACCEPT

# ahora hacemos enmascaramiento de la red local

iptables -t nat -A POSTROUTING -s 0.0.0.0/0 -o $device1 -j MASQUERADE

# Aceptamos que vayan a puertos http

iptables -A FORWARD -s 0.0.0.0/0 -i $device -p tcp --dport 80 -j ACCEPT

# Aceptamos que vayan a puertos https

iptables -A FORWARD -s 0.0.0.0/0 -i $device -p tcp --dport 443 -j ACCEPT

# Aceptamos que vayan a todos los puertos y todos los protocolos

iptables -A FORWARD -s 0.0.0.0/0 -i $device -p tcp --dport 1:65535 -j ACCEPT

iptables -A FORWARD -s 0.0.0.0/0 -i $device -p udp --dport 1:65535 -j ACCEPT

# configuramos la entrada

iptables -A OUTPUT -p tcp -m tcp --dport 1:65535 -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT

iptables -A OUTPUT -p udp -m udp --dport 1:65535 -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT

4 arrancas el hostapd

5 arrancas el dhcp, para lo cual necesitas el paquete dhcpd

una vez que lo tengas configuramos el archivo dhcpd.conf

una posible configuracion podria ser esta

Código:
default-lease-time 600;
max-lease-time 7200;
subnet 192.168.96.0 netmask 255.255.255.0 {
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.96.255;
option routers 192.168.96.1;
option domain-name-servers 8.8.8.8;
range 192.168.96.2 192.168.96.254;
}

observa que en option router, la ip es la de tu interface, no la del router de verdad.

bueno una vez hecho esto ya solo nos queda lanzar el dhcp

Código:
dhcpd -d -f -cf /etc/dhcpd.conf wlan0

en wifislax el archivo dhcpd.conf esta en etc, en tu distribucion ni idea, pero vamos que puedes crearlo donde te de la gana mientras que luego al comando de arranque le pases la ruta de donde lo tienes

y si has seguido mis pasos, tendras internet tanto en el pc que tienes con hostapd como en los clientes.

basicamente esto es lo que hace wap, pero de manera automatica  Grin
En línea
juänatan
**
Desconectado Desconectado

Mensajes: 40


Ver Perfil
Re:
« Respuesta #18 : 31-08-2014, 02:01 (Domingo) »

Mañana lo miro. Necesito que estén en la misma subred para que me funcione el DLNA, Plex y otras cosas que tengo configuradas.
Puede que el supernetting funcione, te detallo mi red local:



Tengo un router ADSL.
A continuación un router neutro Linksys EA6400 que es el que tiene habilitado DHCP, da wifi AC a la planta baja de mi casa pero no llega a la planta alta. También le tengo conectado un disco duro por usb donde almaceno el contenido multimedia y el router hace de servidor DLNA y también tiene Samba habilitado.
Al router tengo conectado un reproductor DLNA/Samba, que a su vez está conectado con una tv.
El la planta de arriba tengo un Switch de 8 puertos.
Al switch, entre otras cosas, conecto una Smart Tv que, al estar en la misma red que el router neutro, puede acceder al contenido del disco duro.
Como el switch no tiene wifi, necesito un AP. Al tener DHCP desabilitado, el servidor Plex se encuentra en la misma red que la SmartTv.
Los móviles que conecto al AP también están en la misma red que la SmartTv y tienen aplicaciones de control remoto, pueden enviar vídeos a la TV, etc.
Por eso necesito que el AP tenga DHCP deshabilitado.
En línea
warcry
Visitante
« Respuesta #19 : 31-08-2014, 10:07 (Domingo) »

pffff que tinglao tienes montado.

¿y vas a tener un ordenador encendido todo el tiempo para que te de wifi al plex y a los moviles?

yo compraría un router baratillo al que se le pueda meter dd-wrt o open-wrt y haría un bridge, con lo cual todo solucionado y encima te ahorras el switch porque la tele se lo metes a uno de los puertos lan del router.

no se si te va a servir el superneting, veo mucho dispositivo de por medio  Undecided
En línea
Páginas: [1] 2 Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums