Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
31-10-2014, 00:51 (Viernes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Taller de Seguridad Inalambrica (Wifislax 4.9)



+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  DNSCrypt para OpenWrt
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Ir Abajo Imprimir
Autor Tema: DNSCrypt para OpenWrt  (Leído 529 veces)
mekkon
**
Desconectado Desconectado

Mensajes: 39


Ver Perfil
« : 24-10-2014, 13:32 (Viernes) »

Buenas,

He estado probando DNSCrypt en una compilación propia de openwrt basado en barrier breaker, he seguido los pasos del wiki:

http://wiki.openwrt.org/inbox/dnscrypt

y lo tengo funcionando, cabe resaltar que el puerto es diferente: 5353

el router esta puesto como bridge, a traves de plc tiene una IP fija y da wifi a una parte del piso, ya que la señal del router principial llega bastante mal.

yendo a la página de test http://www.opendns.com/welcome/ conectado a través del router por wifi (el que tiene DNSCrypt) me sale que no estoy usando su dns, pero si hago un "wget http://www.opendns.com/welcome" desde la consola del router me dice que si.

sé que es una chorrada, y que en la interface 'lan' me he dejado algo.

En línea
vk496
*******
Desconectado Desconectado

Mensajes: 1280



Ver Perfil WWW
« Respuesta #1 : 24-10-2014, 15:50 (Viernes) »

Creo que deberías explicar mejor la topología de tu red para ver donde puede estar el problema...

Muy bueno lo de dns-crypt... Me lo apunto...

Salu2
En línea
mekkon
**
Desconectado Desconectado

Mensajes: 39


Ver Perfil
« Respuesta #2 : 24-10-2014, 16:27 (Viernes) »

Tengo un router principal con adsl, este proporciona Wifi y tiene conectado por ethernet un PLC.

en otra habitación, tengo el router con OpenWrt, este tiene una IP fija sin DNS por el cable ethernet del PLC, y proporciona WIFI al resto del lugar.

todos los aparatos que se conectan por el wifi de OpenWrt funcionan correctamente para navegar por internet.

el caso es que tengo DNSCrypt funcionando en el router, internamente funciona bien desde la consola, pero fuera del router, la DNS que me utilizan es la del router principal estando conectados por el wifi del openwrt.

192.168.1.1 -> gateway del router principal

192.168.1.2 -> router openwrt

Código:
nmcli dev list iface wlan0 | grep IP4
IP4.DIRECCIÓN[1]:                      ip = 192.168.1.206/24, gw = 192.168.1.1
IP4.DNS[1]:                             192.168.1.1

lo que quiero es que cualquier pc, movil, etc... que se conecte por wifi al openwrt utilicen de forma transparente el servicio DNSCrypt.

eso es todo amigos! Wink
« Última modificación: 24-10-2014, 16:30 (Viernes) por mekkon » En línea
mekkon
**
Desconectado Desconectado

Mensajes: 39


Ver Perfil
« Respuesta #3 : 24-10-2014, 16:38 (Viernes) »

el log de arranque de DNSCrypt:

Código:
Fri Oct 24 15:38:41 2014 daemon.notice dnscrypt-proxy[990]: Starting dnscrypt-proxy 1.4.1
Fri Oct 24 15:38:41 2014 daemon.info dnscrypt-proxy[990]: Initializing libsodium for optimal performance
Fri Oct 24 15:38:43 2014 daemon.info dnscrypt-proxy[990]: Generating a new key pair
Fri Oct 24 15:38:44 2014 daemon.info dnscrypt-proxy[990]: Done
Fri Oct 24 15:38:44 2014 daemon.info dnscrypt-proxy[990]: Server certificate #XXXXXXXXXX received
Fri Oct 24 15:38:44 2014 daemon.info dnscrypt-proxy[990]: This certificate looks valid
Fri Oct 24 15:38:44 2014 daemon.info dnscrypt-proxy[990]: Chosen certificate #XXXXXXXXXX is valid from [2014-08-15] to [2015-08-15]
Fri Oct 24 15:38:44 2014 daemon.info dnscrypt-proxy[990]: Server key fingerprint is XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Fri Oct 24 15:38:44 2014 daemon.notice dnscrypt-proxy[990]: Proxying from 127.0.0.1:5353 to 208.67.220.220:443

he quitado los números que habían en certificate y fingerprint
« Última modificación: 24-10-2014, 16:39 (Viernes) por mekkon » En línea
vk496
*******
Desconectado Desconectado

Mensajes: 1280



Ver Perfil WWW
« Respuesta #4 : 24-10-2014, 17:14 (Viernes) »

Has editado /etc/config/dhcp?

Yo tengo una topología casi idéntica (mi OpenWRT no proporciona DHCP)

Siguiendo los pasos de la wiki al pie de la letra (puerto 2053) me ha funcionado prefecto. Lo curioso es que además de funcionar, OpenWRT obliga a la red a coger SU DNS (y no el del router principal).

Salu2 y gracias por el tip
En línea
mekkon
**
Desconectado Desconectado

Mensajes: 39


Ver Perfil
« Respuesta #5 : 24-10-2014, 17:28 (Viernes) »

si, así es como lo tengo:

Código:
config dnsmasq                                                                                                                                                      
        option boguspriv '1'                                                                                                                                        
        option localise_queries '1'                                                                                                                                
        option rebind_protection '1'                                                                                                                                
        option rebind_localhost '1'                                                                                                                                
        option local '/lan/'                                                                                                                                        
        option domain 'lan'                                                                                                                                        
        option expandhosts '1'                                                                                                                                      
        option readethers '1'                                                                                                                                      
        option leasefile '/tmp/dhcp.leases'                                                                                                                        
        option noresolv '1'                                                                                                                                        
        list server '127.0.0.1#5353'                                                                                                                                
        list server '/pool.ntp.org/208.67.222.222'                                                                                                                  
                                                                                                                                                                    
config dhcp 'lan'                                                                                                                                                  
        option interface 'lan'                                                                                                                                      
        option ignore '1'                                                                                                                                          
                                                                                                                                                                    
config dhcp 'wan'                                                                                                                                                  
        option interface 'wan'                                                                                                                                      
        option ignore '1'                                                                                                                                          
                                                                                                                                                                    
config odhcpd 'odhcpd'                                                                                                                                              
        option maindhcp '0'                                                                                                                                        
        option leasefile '/tmp/hosts/odhcpd'                                                                                                                        
        option leasetrigger '/usr/sbin/odhcpd-update'    

cambiaré el puerto a ver...

...nada, sigue igual
« Última modificación: 24-10-2014, 17:42 (Viernes) por mekkon » En línea
vk496
*******
Desconectado Desconectado

Mensajes: 1280



Ver Perfil WWW
« Respuesta #6 : 24-10-2014, 17:44 (Viernes) »

Has abierto ese puerto para que salga a internet? Es decir, el 2053 ,(o el 5353 si es tu caso)

Salu2
En línea
mekkon
**
Desconectado Desconectado

Mensajes: 39


Ver Perfil
« Respuesta #7 : 24-10-2014, 18:04 (Viernes) »

he abierto el puerto para tcp y udp, pero nada, el pc me sigue cogiendo la IP del router principal como DNS
En línea
GLaDOS
Genetic Lifeform and Disk Operating System
*****
Desconectado Desconectado

Mensajes: 157



Ver Perfil
« Respuesta #8 : 25-10-2014, 07:53 (Sbado) »

Pues yo llevo esta noche geek con el tema, y justo me topo con este topic.

Mi intención es poner incluir en mi LAN un VR-3025u que sirva resoluciones DNS requeridas a traves de DNSCrypt a algun server, en mi caso, NO de OpenDNS, (los veo muy OpenDN$) si no OpenNIC o similares.
En línea

Nos vemos entre Bytes!

<<¡Gritad, malditos, gritad! Que las normas que han escrito, deben cambiar y ¿Qué mas da si para ellos somos cifras? Que vean que somos cifras que ya no aguantan más>>.
mekkon
**
Desconectado Desconectado

Mensajes: 39


Ver Perfil
« Respuesta #9 : 26-10-2014, 16:33 (Domingo) »

por mucho que ponga 192.168.1.2 o 127.0.0.1 en el apartado DNS de mi red no me lo pilla.

mi topologia de red es calcada a esta:

http://wiki.openwrt.org/doc/recipes/bridgedap

debería mejor utilizar esta quizás?

http://wiki.openwrt.org/doc/recipes/relayclient

un saludo
En línea
vk496
*******
Desconectado Desconectado

Mensajes: 1280



Ver Perfil WWW
« Respuesta #10 : 26-10-2014, 18:14 (Domingo) »

Yo lo tengo como la primera, y mi OpenWRT solo emite WiFi, todo lo demás lo hace el router principal.

Deberías probar a borrar lo que hayas hecho e intentar hacerlo de nuevo... Seguramente se te haya escapado alguna tontería...

Salu2
En línea
mekkon
**
Desconectado Desconectado

Mensajes: 39


Ver Perfil
« Respuesta #11 : 27-10-2014, 20:08 (Lunes) »

mmm... tiene IPV6 prioridad sobre IPV4?

en la compilación propia que he usado, he eliminado IPV6, el router no tiene ningún paquete con referencia a IPV6, IP6 y no sólo he desmarcado las opciones en menuconfig, sino que también las he deshabilitado en el .config.

el resultado es que si NO pongo el gateway en la interface 'LAN' (que hace bridge entre ethernet y wireless), desde ssh un "ping openwrt.org" del router no tira (como debe ser)

pero... si hago un "ping openwrt.org" desde un pc conectado el wifi del openwrt, me lo resuelve... (aquí ya estaba flipando en colores la verdad), confieso que no soy un experto en redes, pero creía tener al menos una base para hacer 4 cosillas.

¿puede ser que el pc me use IPV6 para resolver el gateway y los DNS? el router principal sí tiene IPV6.

un saludo.
« Última modificación: 27-10-2014, 20:12 (Lunes) por mekkon » En línea
mekkon
**
Desconectado Desconectado

Mensajes: 39


Ver Perfil
« Respuesta #12 : 28-10-2014, 13:49 (Martes) »

Me respondo a mi mismo, así es, desactivando IPV6 en windows, todo funciona como es debido, incluso las DNS Grin

ahora esta el detalle en que el wiki de openwrt no esta accesible  Huh, parece que es cosa de ellos y no mia, uf...

he encontrado una guia para hacer los pasos de forma sencilla:

http://www.techrapid.co.uk/openwrt/how-to-install-dnscrypt-on-openwrt-for-beginners/

supongo que para cambiar el servidor bastará con editar /etc/config/dnscrypt-proxy
« Última modificación: 28-10-2014, 13:52 (Martes) por mekkon » En línea
vk496
*******
Desconectado Desconectado

Mensajes: 1280



Ver Perfil WWW
« Respuesta #13 : 28-10-2014, 15:55 (Martes) »

Muy buena!

No sospechaba que IPV6 tuviese juego en esto...

Salu2
En línea
mekkon
**
Desconectado Desconectado

Mensajes: 39


Ver Perfil
« Respuesta #14 : 28-10-2014, 17:25 (Martes) »

Yo tampoco sospechaba y menos habiéndolo eliminado de la compilación, lo que más me llama la atención es que IPV6 haya pasado por el router y este no se haya enterado de nada, esta claro que la eliminación tiene que ver con ello, pero pensaba que por el hecho de no estar forzaría el uso de IPV4, pero ya veo que no es así.

¿Hay alguna forma de forzar IPV4?
En línea
vk496
*******
Desconectado Desconectado

Mensajes: 1280



Ver Perfil WWW
« Respuesta #15 : 28-10-2014, 19:15 (Martes) »

Creo (bueno, mas bien sospecho) que si quitas IPV6, significa que el router "no sabe" interpretar ese protocolo, por lo que lo deja pasar (para el sera invisible). Sin embargo, si lo reconoce, tendrás la capacidad de denegarlo o algo.

De todas formas, esto es una conspiración contra el universo, así que no me hagas caso en absoluto... xD

Salu2
En línea
mekkon
**
Desconectado Desconectado

Mensajes: 39


Ver Perfil
« Respuesta #16 : Ayer a las 13:36 »

con IPV6 instalado me hace lo mismo, en el router no hay inet, pero en el pc conectado por wifi al router con openwrt, que tiene conexión con cable ethernet al router principal, sí hay internet, y encima con la imagen recién flasheada sin cambiarle ninguna configuración ni nada  Huh
En línea
Páginas: [1] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Powered by SMF 1.1.20 | SMF © 2006-2008, Simple Machines