Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
26-09-2017, 05:50 (Martes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt & LEDE (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)
0 Usuarios y 2 Visitantes están viendo este tema. « anterior próximo »
Páginas: 1 ... 55 56 57 58 59 [60] Ir Abajo Imprimir
Autor Tema: [Desarrollo] OpenWRT para routers Astoria de ya.com (ARV4518/ARV7518)  (Leído 469881 veces)
morcego
**
Desconectado Desconectado

Mensajes: 8


Ver Perfil
« Respuesta #1180 : 09-01-2017, 02:00 (Lunes) »

Me parece que voy a cambiar los condensadores C89 y C74.


Se les ve la coronilla muy abombada. Sobre todo la del C74.


Saludos.


Gracias por tu pronta respuesta raphik , intentaré recuperarlo con tus explicaciones  . Angry

 En cuanto  a lo tuyo evidentemente ese condensador esta abombado y el otro que dices  debes cambiarlos porque son los  que fijan  las tensiones de alimentación  y de filtraje del posible rizado de alterna y estan dañados . Aunque debes revisar los componentes  como reguladores o diodos  adyacentes por si estuvieran en corto pues si cambias los condensadores y no los  revisas pudieran volver a hincharse lo que indica que sigue algo a continuación en corto.

 Los diodos como el que te decia en el comentario anterior suelen ser o de protección o para fijar una tensión junto con un condensador como el que se te ha hinchado .Luego con distintos reguladores de tensiòn ( que son como el U39 que se ve debajo a la izquierda de C74 ,o otros de menor tamaño y potencia se consiguen las distintas tensiones de alimentación que requieren los integrados positivas o negativas ) poniendo las referencias en google puedes encontrar el datasheet de caracteristicas .

Los condesadores no suponen un problema se encuentran con relativa facilidad en una tienda de repuestos electrónica .

El abordar una reparación asi sin esquema es armarse de paciencia e ir siguiendo las pistas aunque al ser de doble cara complica la cosa y confiar que el problema este  en la parte de alimentación .

Espero no haberme liado  mucho y que de alguna manera te sirva de ayuda .De todas formas para lo que te pueda ayudar aqui me tienes .Saludos  y suerte .

morcego .
En línea
morcego
**
Desconectado Desconectado

Mensajes: 8


Ver Perfil
« Respuesta #1181 : 11-01-2017, 01:11 (Mi?rcoles) »

Hola nuevamente apelando a los que saben mas de esto porque estoy atascado y no avanzo . He seguido estos pasos para recuperar el router ARV7518 en el modo UART como me ha indicado raphik y no consigo que en el promt me aparezca  >ARV4518 :

1 - Arrancar el router con los puentes metidos en R65 y R80 , luego de arrancar quitarlos.
2 - Iniciar una sesión como super usuario en minicom con el siguiente codigo :

      sudo minicom -s --device /dev/ttyUSB0 ,meto la contraseña de root y ya tengo permisos para usar el puerto USB0.

3. Sale una indicación de pulsar CRTL - A  + Z para acceder a las teclas especiales y nada más y es ahi cuando tengo la duda, vuelvo a conectar los puentes R65 y R80, quito el yack de alimentación al router y se lo vuelvo a meter y entonces si me aparece el mensaje :

ROM VER: 1.0.3                                                                 
CFG 04                                                                         
Read EEPROMX                                                                   
 X                                                                             
UART


Bien, entiendo que estoy en modo UART, saco los puentes y si intento enviarle el fichero u-boot.ASC abriendo otro terminal con el comando  :

sudo cat u-boot-20120429.asc > /dev/ttyUSB0 

no me deja porque al estar la sesión de minicom activa indica que el puerto USB esta bloqueado.
Entonces lo que hago es acceder pulsando CRTL +A y luego Z al menu de opciones de minicom y hay una que indica Send Files , la marco  y a continuación indica que señale el tipo de envio , si va a ser por zmoden, ymodem, xmodem, y la ultima ASCII ,marcaba esta ultima para enviar el fichero u-boot.ASC y se ve que lo envia a traves del adaptador y se ve los KB de la transferencia en la pantalla ,  incluso se oye un ruidito de que se ha completado la transferencia  y que pulse una tecla , lo hago , pero en la sesión del minicom ,sigue :

ROM VER: 1.0.3                                                                 
CFG 04                                                                         
Read EEPROMX                                                                   
 X                                                                             
UART


y el promt parpadeando pero sigue sin aparecer

ROM VER: 1.0.3                                                                 
CFG 04                                                                         
Read EEPROMX                                                                   
 X                                                                             
UART
ARV4518>

para poder seguir con la carga del fichero u-boot.bin para alojarlo en la memoria flash.

PD ; Tambien he probado en una de las opciones de minicom indica Paste fichero  o algo parecido al marcarla te pide que indique el fichero a pegar , busco en la ruta el fichero u-boot.asc y lo marco , entonces empieza a parpadear de una manera muy espaciada el led del adaptador TTL-Usb como indicando que se esta realizando el envio del fichero , pasado un largo rato para , pero el promt sigue igual no aparece

ARV4518 >

Espero haberme explicado en todos los pasos que he hecho y que me ha sido relativamente sencillo las soldaduras y entrar en modo UART pero ahi me quedo.

Ayuda por favor . Saludos

morcego




En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1721


Ver Perfil
« Respuesta #1182 : 11-01-2017, 10:53 (Mi?rcoles) »

Hola nuevamente apelando a los que saben mas de esto porque estoy atascado y no avanzo . He seguido estos pasos para recuperar el router ARV7518 en el modo UART como me ha indicado raphik y no consigo que en el promt me aparezca  >ARV4518 :

1 - Arrancar el router con los puentes metidos en R65 y R80 , luego de arrancar quitarlos.
2 - Iniciar una sesión como super usuario en minicom con el siguiente codigo :

      sudo minicom -s --device /dev/ttyUSB0 ,meto la contraseña de root y ya tengo permisos para usar el puerto USB0.

3. Sale una indicación de pulsar CRTL - A  + Z para acceder a las teclas especiales y nada más y es ahi cuando tengo la duda, vuelvo a conectar los puentes R65 y R80, quito el yack de alimentación al router y se lo vuelvo a meter y entonces si me aparece el mensaje :

ROM VER: 1.0.3                                                                 
CFG 04                                                                         
Read EEPROMX                                                                   
 X                                                                             
UART


Bien, entiendo que estoy en modo UART, saco los puentes y si intento enviarle el fichero u-boot.ASC abriendo otro terminal con el comando  :

sudo cat u-boot-20120429.asc > /dev/ttyUSB0 

no me deja porque al estar la sesión de minicom activa indica que el puerto USB esta bloqueado.
Entonces lo que hago es acceder pulsando CRTL +A y luego Z al menu de opciones de minicom y hay una que indica Send Files , la marco  y a continuación indica que señale el tipo de envio , si va a ser por zmoden, ymodem, xmodem, y la ultima ASCII ,marcaba esta ultima para enviar el fichero u-boot.ASC y se ve que lo envia a traves del adaptador y se ve los KB de la transferencia en la pantalla ,  incluso se oye un ruidito de que se ha completado la transferencia  y que pulse una tecla , lo hago , pero en la sesión del minicom ,sigue :

ROM VER: 1.0.3                                                                 
CFG 04                                                                         
Read EEPROMX                                                                   
 X                                                                             
UART


y el promt parpadeando pero sigue sin aparecer

ROM VER: 1.0.3                                                                 
CFG 04                                                                         
Read EEPROMX                                                                   
 X                                                                             
UART
ARV4518>

para poder seguir con la carga del fichero u-boot.bin para alojarlo en la memoria flash.

PD ; Tambien he probado en una de las opciones de minicom indica Paste fichero  o algo parecido al marcarla te pide que indique el fichero a pegar , busco en la ruta el fichero u-boot.asc y lo marco , entonces empieza a parpadear de una manera muy espaciada el led del adaptador TTL-Usb como indicando que se esta realizando el envio del fichero , pasado un largo rato para , pero el promt sigue igual no aparece

ARV4518 >

Espero haberme explicado en todos los pasos que he hecho y que me ha sido relativamente sencillo las soldaduras y entrar en modo UART pero ahi me quedo.

Ayuda por favor . Saludos

morcego






Utiliza el minicom para ver en qué estado está el router en cada momento, pero no lo tengas abierto todo el tiempo. Como tú ya has averiguado, bloquea el puerto USB.
Es decir, abre minicom, mira que el router está en modo UART, quita los puentes y cierra minicom para liberar el puerto. Manda el fichero u-boot.asc, y espera a que termine. Vuelve a abrir el minicom y pulsa ENTER. Te debe aparecer el prompt tal y como dices.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
mak_v_
**
Desconectado Desconectado

Mensajes: 1


Ver Perfil
« Respuesta #1183 : 08-02-2017, 16:01 (Mi?rcoles) »

Sorry for my language, 1st

1) I have ARV4510 board with bricked U-boot and UART-cable and this message in console
Código:
ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X
2) I have found J16 (near J6),  I circle it  and have another message
Código:
ROM VER: 1.0.3
CFG 05
Read EEPROMX
 X
SFLASH
X
SFLASH
X
SFLASH
X
3) When i try
Código:
sx ram.asc </dev/ttyUSB0 >/dev/ttyUSB0
Sending ram.asc, 3174 blocks: Give your local XMODEM receive command now.
How can i trigger  load u-boot from UART?



En línea
mitwiz
**
Desconectado Desconectado

Mensajes: 1


Ver Perfil
« Respuesta #1184 : 14-07-2017, 19:33 (Viernes) »

.

Use minicom: configure the serial port to the UART module and use xmodem file transport protocol: Send files > XModem


Citar
3) When i try
Código:
sx ram.asc </dev/ttyUSB0 >/dev/ttyUSB0
Sending ram.asc, 3174 blocks: Give your local XMODEM receive command now.
How can i trigger  load u-boot from UART?

En línea
danitool
*******
Desconectado Desconectado

Mensajes: 581


Ver Perfil
« Respuesta #1185 : 06-08-2017, 13:19 (Domingo) »

Buenas, he estado probando este router (donación de Pteridium) el cual tiene el switch estropeado, pero parece funcionar perfectamente con wifi.

No conozco mucho el target lantiq así que me encontré problemas como por ejemplo, que en Chaos Calmer funcionaba erráticamente el puerto USB, solo funcionaba bien con Barrier Breaker no?

El caso es que la cosa parecía incluso peor en LEDE 17.01 ya que ni mostraba actividad en el puerto USB. Hubo un cambio al driver a dwc2 en LEDE. Después de buscar donde estaba el problema, lo solucioné con este parche:
https://pastebin.com/Xr2iaW2j

Aplicando el parche antes de compilar, y una vez flasheado el firmware generado, el USB funciona perfecto.



También investigué un poco en la placa, para localizar los GPIOs disponibles, aunque esto ya lo hizo alguien previamente, he encontrado más y lo he marcado de forma más clara en esta foto:
https://wiki.openwrt.org/_media/media/astoria/arv7518pw/arv7518pw-gpios_unused.jpg



Por último en esos mismo GPIOs localicé la interfaz SPI, la cual puede servir para conectar una memoria flash SPI, y así tener un poco de espacio de almacenamiento adicional:

https://wiki.openwrt.org/toh/astoria/arv7518pw#spi_nor_flash_chip

También hace falta parchear y compilar el firmware uno mismo, el cual ha de ser basado en LEDE versión mínima 17.01 (anteriores versiones de Openwrt no tienen soporte SPI). Una vez testeado comprobé que funciona perfectamente y la lectura y escrituras en la memoria flash SPI externa es muy rápida.



No puedo hacer muchos más tests sobre este router por tener el switch estropeado. Otro problema que me he encontrado es que el LED USB está siempre encendido, ¿esto no es normal no? presupongo que el SoC debe tener algunos pines internos quemados o dañados.

En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1721


Ver Perfil
« Respuesta #1186 : 06-08-2017, 16:42 (Domingo) »

@danitool, te sientan bien las vacaciones de verano.  Angry Angry Angry
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Páginas: 1 ... 55 56 57 58 59 [60] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums