Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
25-10-2014, 01:07 (Sbado)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Test de potencia en milivatios/dbm de adaptadores usb wifi



+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  DNSCrypt para OpenWrt
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Ir Abajo Imprimir
Autor Tema: DNSCrypt para OpenWrt  (Leído 194 veces)
mekkon
**
Desconectado Desconectado

Mensajes: 28


Ver Perfil
« : Ayer a las 13:32 »

Buenas,

He estado probando DNSCrypt en una compilación propia de openwrt basado en barrier breaker, he seguido los pasos del wiki:

http://wiki.openwrt.org/inbox/dnscrypt

y lo tengo funcionando, cabe resaltar que el puerto es diferente: 5353

el router esta puesto como bridge, a traves de plc tiene una IP fija y da wifi a una parte del piso, ya que la señal del router principial llega bastante mal.

yendo a la página de test http://www.opendns.com/welcome/ conectado a través del router por wifi (el que tiene DNSCrypt) me sale que no estoy usando su dns, pero si hago un "wget http://www.opendns.com/welcome" desde la consola del router me dice que si.

sé que es una chorrada, y que en la interface 'lan' me he dejado algo.

En línea
vk496
*******
Conectado Conectado

Mensajes: 1255



Ver Perfil WWW
« Respuesta #1 : Ayer a las 15:50 »

Creo que deberías explicar mejor la topología de tu red para ver donde puede estar el problema...

Muy bueno lo de dns-crypt... Me lo apunto...

Salu2
En línea
mekkon
**
Desconectado Desconectado

Mensajes: 28


Ver Perfil
« Respuesta #2 : Ayer a las 16:27 »

Tengo un router principal con adsl, este proporciona Wifi y tiene conectado por ethernet un PLC.

en otra habitación, tengo el router con OpenWrt, este tiene una IP fija sin DNS por el cable ethernet del PLC, y proporciona WIFI al resto del lugar.

todos los aparatos que se conectan por el wifi de OpenWrt funcionan correctamente para navegar por internet.

el caso es que tengo DNSCrypt funcionando en el router, internamente funciona bien desde la consola, pero fuera del router, la DNS que me utilizan es la del router principal estando conectados por el wifi del openwrt.

192.168.1.1 -> gateway del router principal

192.168.1.2 -> router openwrt

Código:
nmcli dev list iface wlan0 | grep IP4
IP4.DIRECCIÓN[1]:                      ip = 192.168.1.206/24, gw = 192.168.1.1
IP4.DNS[1]:                             192.168.1.1

lo que quiero es que cualquier pc, movil, etc... que se conecte por wifi al openwrt utilicen de forma transparente el servicio DNSCrypt.

eso es todo amigos! Wink
« Última modificación: Ayer a las 16:30 por mekkon » En línea
mekkon
**
Desconectado Desconectado

Mensajes: 28


Ver Perfil
« Respuesta #3 : Ayer a las 16:38 »

el log de arranque de DNSCrypt:

Código:
Fri Oct 24 15:38:41 2014 daemon.notice dnscrypt-proxy[990]: Starting dnscrypt-proxy 1.4.1
Fri Oct 24 15:38:41 2014 daemon.info dnscrypt-proxy[990]: Initializing libsodium for optimal performance
Fri Oct 24 15:38:43 2014 daemon.info dnscrypt-proxy[990]: Generating a new key pair
Fri Oct 24 15:38:44 2014 daemon.info dnscrypt-proxy[990]: Done
Fri Oct 24 15:38:44 2014 daemon.info dnscrypt-proxy[990]: Server certificate #XXXXXXXXXX received
Fri Oct 24 15:38:44 2014 daemon.info dnscrypt-proxy[990]: This certificate looks valid
Fri Oct 24 15:38:44 2014 daemon.info dnscrypt-proxy[990]: Chosen certificate #XXXXXXXXXX is valid from [2014-08-15] to [2015-08-15]
Fri Oct 24 15:38:44 2014 daemon.info dnscrypt-proxy[990]: Server key fingerprint is XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Fri Oct 24 15:38:44 2014 daemon.notice dnscrypt-proxy[990]: Proxying from 127.0.0.1:5353 to 208.67.220.220:443

he quitado los números que habían en certificate y fingerprint
« Última modificación: Ayer a las 16:39 por mekkon » En línea
vk496
*******
Conectado Conectado

Mensajes: 1255



Ver Perfil WWW
« Respuesta #4 : Ayer a las 17:14 »

Has editado /etc/config/dhcp?

Yo tengo una topología casi idéntica (mi OpenWRT no proporciona DHCP)

Siguiendo los pasos de la wiki al pie de la letra (puerto 2053) me ha funcionado prefecto. Lo curioso es que además de funcionar, OpenWRT obliga a la red a coger SU DNS (y no el del router principal).

Salu2 y gracias por el tip
En línea
mekkon
**
Desconectado Desconectado

Mensajes: 28


Ver Perfil
« Respuesta #5 : Ayer a las 17:28 »

si, así es como lo tengo:

Código:
config dnsmasq                                                                                                                                                      
        option boguspriv '1'                                                                                                                                        
        option localise_queries '1'                                                                                                                                
        option rebind_protection '1'                                                                                                                                
        option rebind_localhost '1'                                                                                                                                
        option local '/lan/'                                                                                                                                        
        option domain 'lan'                                                                                                                                        
        option expandhosts '1'                                                                                                                                      
        option readethers '1'                                                                                                                                      
        option leasefile '/tmp/dhcp.leases'                                                                                                                        
        option noresolv '1'                                                                                                                                        
        list server '127.0.0.1#5353'                                                                                                                                
        list server '/pool.ntp.org/208.67.222.222'                                                                                                                  
                                                                                                                                                                    
config dhcp 'lan'                                                                                                                                                  
        option interface 'lan'                                                                                                                                      
        option ignore '1'                                                                                                                                          
                                                                                                                                                                    
config dhcp 'wan'                                                                                                                                                  
        option interface 'wan'                                                                                                                                      
        option ignore '1'                                                                                                                                          
                                                                                                                                                                    
config odhcpd 'odhcpd'                                                                                                                                              
        option maindhcp '0'                                                                                                                                        
        option leasefile '/tmp/hosts/odhcpd'                                                                                                                        
        option leasetrigger '/usr/sbin/odhcpd-update'    

cambiaré el puerto a ver...

...nada, sigue igual
« Última modificación: Ayer a las 17:42 por mekkon » En línea
vk496
*******
Conectado Conectado

Mensajes: 1255



Ver Perfil WWW
« Respuesta #6 : Ayer a las 17:44 »

Has abierto ese puerto para que salga a internet? Es decir, el 2053 ,(o el 5353 si es tu caso)

Salu2
En línea
mekkon
**
Desconectado Desconectado

Mensajes: 28


Ver Perfil
« Respuesta #7 : Ayer a las 18:04 »

he abierto el puerto para tcp y udp, pero nada, el pc me sigue cogiendo la IP del router principal como DNS
En línea
Páginas: [1] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Powered by SMF 1.1.20 | SMF © 2006-2008, Simple Machines