Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
23-11-2014, 17:55 (Domingo)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Noticias de seguridadwireless.net en google play



+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  [Desarrollo] OpenWrt en Comtrend CT-5365
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: 1 2 3 4 5 6 [7] Ir Abajo Imprimir
Autor Tema: [Desarrollo] OpenWrt en Comtrend CT-5365  (Leído 42215 veces)
quetzalin
****
Desconectado Desconectado

Mensajes: 53


Ver Perfil
« Respuesta #120 : 21-08-2014, 17:33 (Jueves) »

Bueno, ya lo tengo configurado, he tenido que especificar el vid para cada vlan, curioso cuanto menos ¿no?

Código:
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdee:2980:5505::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option force_link '1'
        option ip6assign '60'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option vid '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'eth0'
        option vlan '2'
        option vid '2'
        option ports '0 5t'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '172.16.224.21'
        option netmask '255.255.255.0'
        option gateway '172.16.224.1'
        option dns '8.8.8.8'
        option force_link '1'
« Última modificación: 22-08-2014, 13:33 (Viernes) por quetzalin » En línea

VENDO
Router Astoria Networks ARV7518 con OpenWRT y MOD para dos antenas externas reemplazables (incluye dos antenas TP-Link de 5dBi).
http://i.imgur.com/mkStrnt.jpg
HMDX
**
Desconectado Desconectado

Mensajes: 9


Ver Perfil
« Respuesta #121 : 05-09-2014, 12:38 (Viernes) »

Hola a todos.
Primero que nada agradecer a los que habéis hecho posible que este firm este disponible para este modelo.

Segundo, Me gustaría saber si el firm que hay en el primer post (el de backfire 10.03.1)---> https://drive.google.com/uc?id=0ByrtEG1tVo67RkdRNnRaemNJOTg

Es el mismo que hay disponible en las descargas de openwrt backfire 10.03.1 ---> http://downloads.openwrt.org/backfire/10.03.1/brcm63xx/openwrt-96348GW-generic-squashfs-cfe.bin

En caso de ser el mismo nada mas que preguntar, pero si no son exactamente el mismo, me gustaría saber cual de los dos me iría mejor para usarlo como repetidor de wifi a cable, y en que se diferencian el uno del otro.

Saludos y gracias.
En línea
HMDX
**
Desconectado Desconectado

Mensajes: 9


Ver Perfil
« Respuesta #122 : 11-09-2014, 23:17 (Jueves) »

Nadie me puede aclarar las diferencias?

Es que he visto que la imagen del primer post (10.03.1) pesa lo mismo que la de actitude (12.09) de openwrt.

La del primer post es la imagen oficial de Noltari? La que el aconseja como las mas liviana con luci a mary en la 3ª pagina de este post?
En línea
f_a_b
**
Desconectado Desconectado

Mensajes: 12


Ver Perfil
« Respuesta #123 : 15-10-2014, 21:30 (Mircoles) »

Hola a todos

alguien sabe como instalar el paquete luci-app-wol para encender el pc remotemente, lo estoy intentando via putty con opkg install luci-app-wol y no me deja lo mismo me pasa con el paquete luci-app-ddns.
En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 601


Ver Perfil
« Respuesta #124 : 16-10-2014, 08:02 (Jueves) »

Hola a todos

alguien sabe como instalar el paquete luci-app-wol para encender el pc remotemente, lo estoy intentando via putty con opkg install luci-app-wol y no me deja lo mismo me pasa con el paquete luci-app-ddns.

¿Qué error te sale? "no me deja" no es muy descriptivo...
Sin signos de puntuación, nadie diría que lo que has hecho, es hacer una pregunta...
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
f_a_b
**
Desconectado Desconectado

Mensajes: 12


Ver Perfil
« Respuesta #125 : 16-10-2014, 15:21 (Jueves) »

Gracias por tu rapida  respuesta tki2000.
El error que me da es este:
opkg_install_cmd: cannot install package luci-app-wol
lo mismo me pasa con el paquete luci-app-ddns, ¿puede ser por que no esten en la lista de paquetes a instalar? El paquete luci-app-i18n spanish si que me dejo instalarlo. Lo hago con putty atraves de windows 7
gracias
« Última modificación: 16-10-2014, 15:24 (Jueves) por f_a_b » En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 601


Ver Perfil
« Respuesta #126 : 16-10-2014, 16:07 (Jueves) »

Gracias por tu rapida  respuesta tki2000.
El error que me da es este:
opkg_install_cmd: cannot install package luci-app-wol
lo mismo me pasa con el paquete luci-app-ddns, ¿puede ser por que no esten en la lista de paquetes a instalar? El paquete luci-app-i18n spanish si que me dejo instalarlo. Lo hago con putty atraves de windows 7
gracias


Junto a esa línea debe haber más. Te debe decir por qué no puede instalarlo. ¿Podrías poner todo lo que sale?
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
f_a_b
**
Desconectado Desconectado

Mensajes: 12


Ver Perfil
« Respuesta #127 : 16-10-2014, 16:52 (Jueves) »

Unknown package 'luci-app-wol'
Collected errors:
opkg_install_cmd: cannot install package luci-app-wol

Eso todo lo que sale una vez tecleado: opkg install luci-app-wol
La version que tengo instalada es la Backfire 10.03.1
Probe a instslar otras versiones mas actuales pero son muy pesadas para este router,  metia la contraseña y hay se quedaba, no podia ni cargar la primera pagina.
« Última modificación: 16-10-2014, 16:59 (Jueves) por f_a_b » En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 601


Ver Perfil
« Respuesta #128 : 17-10-2014, 13:21 (Viernes) »

Unknown package 'luci-app-wol'
Collected errors:
opkg_install_cmd: cannot install package luci-app-wol

Eso todo lo que sale una vez tecleado: opkg install luci-app-wol
La version que tengo instalada es la Backfire 10.03.1
Probe a instslar otras versiones mas actuales pero son muy pesadas para este router,  metia la contraseña y hay se quedaba, no podia ni cargar la primera pagina.

1.- Comprueba que el router tiene conexión a internet. Prueba a hacer un ping google.com y ver si contesta.
2.- Haz un opkg update y mira si se descarga la lista de paquetes de internet
3.- Vuelve a relizar el opkg install luci-app-wol

Contesta si se ha realizado bien o en qué punto ha dado error.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
f_a_b
**
Desconectado Desconectado

Mensajes: 12


Ver Perfil
« Respuesta #129 : 17-10-2014, 21:09 (Viernes) »

El lunes lo pruebo y te comento, ahora no tengo el router aqui.
En línea
f_a_b
**
Desconectado Desconectado

Mensajes: 12


Ver Perfil
« Respuesta #130 : 22-10-2014, 22:21 (Mircoles) »

ha funcionado  Angry he podido instalar los dos paquetes luci-app-wol y luci-app-ddns siguiendo los pasos que dijiste.

Ahora me da otro error al instalar el paquete swconfig,

root@OpenWrt:~# opkg install swconfig
Installing swconfig (9) to root...
Downloading http://downloads.openwrt.org/backfire/10.03.1/brcm63xx/packages/swco             nfig_9_brcm63xx.ipk.
Collected errors:
 * check_data_file_clashes: Package swconfig wants to install file /lib/network/             switch.sh
        But that file is already provided by package  * kmod-switch
 * opkg_install_cmd: Cannot install package swconfig.

Gracias
En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 601


Ver Perfil
« Respuesta #131 : 23-10-2014, 07:18 (Jueves) »

ha funcionado  Angry he podido instalar los dos paquetes luci-app-wol y luci-app-ddns siguiendo los pasos que dijiste.

Ahora me da otro error al instalar el paquete swconfig,

root@OpenWrt:~# opkg install swconfig
Installing swconfig (9) to root...
Downloading http://downloads.openwrt.org/backfire/10.03.1/brcm63xx/packages/swco             nfig_9_brcm63xx.ipk.
Collected errors:
 * check_data_file_clashes: Package swconfig wants to install file /lib/network/             switch.sh
        But that file is already provided by package  * kmod-switch
 * opkg_install_cmd: Cannot install package swconfig.

Gracias


Te está diciendo que el fichero switch.sh ya está en el router y no lo sobreescribe por precaución, ya que el paquete kmod-switch ya lo ha instalado.
Y menos mal, ya que tras mirar ambos ficheros switch.sh en ambos paquetes, los contenidos son totalmente diferentes, así que no sé si al reinstalarlo te dejará de funcionar el switch.
¿Es necesario que instales ese paquete?
Mira si tienes este fichero: /sbin/swconfig
Si ya lo tienes allí, no es necesario que reinstales ese paquete.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
f_a_b
**
Desconectado Desconectado

Mensajes: 12


Ver Perfil
« Respuesta #132 : 23-10-2014, 15:27 (Jueves) »

Querria instalar el paquete swconfig para poder configurar un puerto lan como wan, si es posible, para poder acceder al router desde el exterior.

No tengo el archivo que dices, estos son los tengo en el directorio /sbin

root@OpenWrt:/sbin# ls
blkid              ifup               mtd                sysctl
crda               init               pivot_root         syslogd
firstboot          insmod             poweroff           sysupgrade
fw                 klogd              reboot             uci
halt               led.sh             rmmod              udevtrigger
hotplug-call       logread            route              udhcpc
hotplug2           lsmod              start-stop-daemon  vconfig
hwclock            luci-reload        swapoff            watchdog
ifconfig           mkswap             swapon             wifi
ifdown             mount_root         switch_root
En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 601


Ver Perfil
« Respuesta #133 : 23-10-2014, 16:09 (Jueves) »

Querria instalar el paquete swconfig para poder configurar un puerto lan como wan, si es posible, para poder acceder al router desde el exterior.

No tengo el archivo que dices, estos son los tengo en el directorio /sbin

root@OpenWrt:/sbin# ls
blkid              ifup               mtd                sysctl
crda               init               pivot_root         syslogd
firstboot          insmod             poweroff           sysupgrade
fw                 klogd              reboot             uci
halt               led.sh             rmmod              udevtrigger
hotplug-call       logread            route              udhcpc
hotplug2           lsmod              start-stop-daemon  vconfig
hwclock            luci-reload        swapoff            watchdog
ifconfig           mkswap             swapon             wifi
ifdown             mount_root         switch_root


Pues para instalarlo lo único que se me ocurre es que hagas una copia de seguridad del fichero lib/network/switch.sh en otro sitio, instales el paquete con opkg --force-overwrite install swconfig y después vuelvas a sobreescribir el fichero en caso de que no funcionara bien. Si funciona al instalarlo entonces no hace falta que lo sobreescribas, pero más vale guardarlo aparte por si acaso...
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
f_a_b
**
Desconectado Desconectado

Mensajes: 12


Ver Perfil
« Respuesta #134 : 23-10-2014, 17:11 (Jueves) »

lo he podido instalar forzandolo a sobreescribir, como me has dicho, no me ha dado ningun error, en la lista de software instalado aparece como instalado; pero no me aparece la pestaña "switch" dentro de la de "red" tendria que aparecer la pestaña "switch" para poder configurar la LAN como WAN.
En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 601


Ver Perfil
« Respuesta #135 : 24-10-2014, 07:23 (Viernes) »

lo he podido instalar forzandolo a sobreescribir, como me has dicho, no me ha dado ningun error, en la lista de software instalado aparece como instalado; pero no me aparece la pestaña "switch" dentro de la de "red" tendria que aparecer la pestaña "switch" para poder configurar la LAN como WAN.

No sé si en Backfire se podía configurar el switch desde LuCi. ¿Alguien que lo haya hecho que arroje luz sobre este tema?

De momento, lo que he encontrado es una configuración similar a la que quieres hacer para el router HG536, aquí: http://free.okupaweb.com/punk/varios/openwrt-comtrend-hg536/openwrt-backfire-comtrend-hg536.html
La configuración hay que ponerla a mano y tendrás que editar unas cuantas cosas para adaptarlas a tu configuración, pero la configuración del switch puede que te sirva de ayuda, o para empezar a trastear.

Fíjate también en la configuración de quetzalin unos post más atrás...
« Última modificación: 24-10-2014, 07:25 (Viernes) por Tki2000 » En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
f_a_b
**
Desconectado Desconectado

Mensajes: 12


Ver Perfil
« Respuesta #136 : 24-10-2014, 23:24 (Viernes) »

ufff es mucho para mi, de momento voy a esperar a ver si alguien sabe algo mas, algo he leido por ahi pero es para otro router,  De poco me sirven el wake on lan o el app-ddns si no puedo configurar un pueto wan para dirigir el trafico del router principal,  no Huh

Gracias
En línea
Cuprum
**
Desconectado Desconectado

Mensajes: 4


Ver Perfil
« Respuesta #137 : 11-11-2014, 02:10 (Martes) »

Hola,
Os comento una configuración que he hecho con este router que me ha funcionado muy bien, por si a alguien le puede ser de utilidad.

Tenía que difundir dos SSIDs distintas que me llegan en dos vlanes distintas por uno de los puertos cableados del router. La Vlan 1 corresponde con el SSID-1 y llega por el puerto 0 sin tagear.  Por el mismo puerto, llega la Vlan 2 tageada que corresponde a la SSID-2.

El router tiene dirección 192.168.1.244 en la LAN-1 y 192.168.2.2 en la LAN-2

Este router está muy limitado de procesador y memoria, así que las últimas versiones de openwrt, no van fluidas, incluso sin Luci.  Así que he compilado la revisión r30819 con el driver propietario broadcom para poder tener multi-ssid, puesto que el b43 no lo permite (hasta donde yo sé).  Lo he compilado sin Luci, puesto que toda la configuración la iba a hacer a pelo con los archivos de configuración.  No tenía mucho sentido perder memoria y capacidad metiéndole Luci.

El resultado es que el router lleva funcionando en esta configuración un par de meses y funciona muy bien, aunque no he hecho análisis más profundos.

El firmware que he compilado para el router CT-5365, con soporte vlan, y sin Luci está en:

openwrt-96348A-122-gen-squashfs-cfe.bin   https://drive.google.com/file/d/0BzcWdJ1N76BEZWQtdVRTWWg2Nzg/view?usp=sharing

Pongo también los archivos de configuración por si a alguien les sirve:

Código:
#-----------------------------------
#  /etc/config/network
#-----------------------------------

config interface loopback
    option ifname   lo
    option proto    static
    option ipaddr   127.0.0.1
    option netmask  255.0.0.0

config interface lan
    option type     bridge
    option ifname   eth0.1
    option proto    static
    option ipaddr   192.168.1.244
    option netmask  255.255.255.0
    option gateway  192.168.1.1
    option dns      192.168.1.1
   
config interface lan2
    option type     bridge
    option ifname   eth0.2
    option proto    static
    option ipaddr   192.168.2.2
    option netmask  255.255.255.0

config switch eth0
    option enable   1
    option reset    1
    option enable_vlan 1
   
config switch_vlan
    option device   eth0
    option vlan     1
    option ports    '0 1 2 3 5t'
   
config switch_vlan
    option device   eth0
    option vlan     2
    option ports    '0t 5t'

#-----------------------------------
#  /etc/config/wireless
#-----------------------------------

config wifi-device  wl0
option type     broadcom
option channel  11
option disabled 0
option txpower 18
option hwmode 11bg

config wifi-iface
option device   wl0
option network lan
option mode     ap
option ssid     SSID-1
option encryption psk2
option key      'password.ssid-1'

config wifi-iface
        option device   wl0
        option network  lan2
        option mode     ap
        option ssid     SSID-2
        option encryption psk2
        option key      'password.ssid-2'

#-----------------------------------
#  /etc/config/dhcp
#-----------------------------------

config dnsmasq
option domainneeded 1
option boguspriv 1
option filterwin2k 0  # enable for dial on demand
option localise_queries 1
option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
option rebind_localhost 1  # enable for RBL checking and similar services
#list rebind_domain example.lan  # whitelist RFC1918 responses for domains
option local '/lan/'
option domain 'lan'
option expandhosts 1
option nonegcache 0
option authoritative 1
option readethers 1
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
#list server '/mycompany.local/1.2.3.4'
#option nonwildcard 1
#list interface br-lan
#list notinterface lo
#list bogusnxdomain     '64.94.110.11'

config dhcp lan
option interface lan
option ignore 1
option start 100
option limit 150
option leasetime 12h

config dhcp wan
option interface wan
option ignore 1
En línea
xpepe
**
Desconectado Desconectado

Mensajes: 16


Ver Perfil
« Respuesta #138 : 18-11-2014, 23:18 (Martes) »

Le puse la versión 12.09 pero se arrastra.. una pena.
En línea
Páginas: 1 2 3 4 5 6 [7] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Powered by SMF 1.1.20 | SMF © 2006-2008, Simple Machines