Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
29-05-2017, 00:05 (Lunes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.0 version final para descargar



+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  [Desarrollo] OpenWrt en Comtrend AR-5387un
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] 2 3 4 5 6 ... 71 Ir Abajo Imprimir
Autor Tema: [Desarrollo] OpenWrt en Comtrend AR-5387un  (Leído 503211 veces)
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1242



Ver Perfil WWW
« : 18-07-2012, 20:49 (Mi?rcoles) »

Firmwares Originales de Jazztel (sin bootloader CFE)
AR-5387un-A731-410JAZ-C04_R02
AR-5387un-A731-406JAZ-C02_R01

Wiki
http://wiki.openwrt.org/toh/comtrend/ar5387un

Código Fuente
Repositorio oficial: r33894

Compilaciones Openwrt

Barrier Breaker 14.07-rc3{Con LuCI}
Trunk {Paquetes básicos. Sin LuCI}
Barrier Breaker 14.07 RC2 {Con LuCI}

Estado
Los parches para que el WiFi funcione no han sido aún integrados en el repositorio oficial de OpenWrt, por lo que cualquier compilación del repositorio oficial no dispondrá de WiFi.
El driver brcmsmac funciona tanto en modo Station (cliente) como en modo AP. Por tanto, a partir de ahora sólo compilaré firmwares con brcmsmac, dado que funciona muchísimo mejor que b43.
Funciona el ethernet (swconfig VLANs).
Funcionan botones y LEDs.
Funciona el USB.

Para instalar OpenWrt (o para volver al firmware original):
Citar
Encendemos el router con el botón de reset pulsado y lo mantenemos apretado durante 30 segundos.

Configuramos la ip de nuestra tarjeta de red dentro del rango 192.168.1.x (podemos usar la 192.168.1.2 en adelante) con máscara de red
255.255.0.0 (no es necesario configurar puerta de enlace ni nada más).
Abrimos nuestro navegador y tecleamos la ip 192.168.1.1. Una vez en el CFE, cargamos el firmware que queramos.

Saludos.
« Última modificación: 17-08-2014, 13:21 (Domingo) por jar229 » En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1242



Ver Perfil WWW
« Respuesta #1 : 18-07-2012, 21:03 (Mi?rcoles) »

Averiguar LEDs/botones de este router:
Repetir para 0,1,2,3...29,30,31 (32 pruebas)

Botones
echo $N > /sys/class/gpio/export
cat /sys/class/gpio/gpio$N/value
Si al pulsarlo devuelve 0 y al no estar pulsado devuelve 1, botón active low.
Si al pulsarlo devuelve 1 y al no estar pulsado devuelve 0, botón active high.

LEDs
Creamos el gpio
echo $N > /sys/class/gpio/export

Cambiamos la dirección a salida porque se trata de un LED.
echo out > /sys/class/gpio/gpio$N/direction

Si el LED se apaga con el siguiente comando es active low, si se enciende es active high.
echo 1 > /sys/class/gpio/gpio$N/value

Si el LED se apaga con el siguiente comando es active high, si se enciende es active low.
echo 0 > /sys/class/gpio/gpio$N/value

Saludos.
« Última modificación: 18-07-2012, 22:24 (Mi?rcoles) por Noltari » En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


phullock
**
Desconectado Desconectado

Mensajes: 25


Ver Perfil
« Respuesta #2 : 19-07-2012, 00:39 (Jueves) »

Anda, el OpenWRT en el Comtrend ar5387un, eso sí que sería un notición por el puerto usb que viene ya instalado.

Suerte.
En línea
jar229
Moderador
*
Desconectado Desconectado

Mensajes: 4551



Ver Perfil
« Respuesta #3 : 19-07-2012, 10:12 (Jueves) »

Botones.
Solo hay uno además del power  Grin

Reset:

Código:
root@OpenWrt:~# cat /sys/class/gpio/gpio23/value
1
root@OpenWrt:~# cat /sys/class/gpio/gpio23/value
0


Led's

Led Internet:

Código:
root@OpenWrt:~# echo 7 > /sys/class/gpio/export
root@OpenWrt:~# echo out > /sys/class/gpio/gpio7/direction
root@OpenWrt:~# echo 1 > /sys/class/gpio/gpio7/value

El último valor lo enciende

Código:
root@OpenWrt:~# echo 0 > /sys/class/gpio/gpio7/value

Y este lo apaga


Led de Power:

Código:
root@OpenWrt:~# echo 8 > /sys/class/gpio/export
root@OpenWrt:~# echo out > /sys/class/gpio/gpio8/direction
root@OpenWrt:~# echo 1 > /sys/class/gpio/gpio8/value

El último valor lo enciende

Código:
root@OpenWrt:~# echo 0 > /sys/class/gpio/gpio8/value

Y este lo apaga


Led de DSL

Código:
root@OpenWrt:~# echo 11 > /sys/class/gpio/export
root@OpenWrt:~# echo out > /sys/class/gpio/gpio11/direction

Al poner dar a entener después de la segunda linea, ya lo enciende  Huh

Código:
root@OpenWrt:~# echo 1 > /sys/class/gpio/gpio11/value

Con este lo apaga

Código:
root@OpenWrt:~# echo 0 > /sys/class/gpio/gpio11/value

Y con este lo vuelve a encender

Y el de WLAN no consigo localizarlo  Embarrassed
Lo más curioso, es que desde LuCi, si activo o desactivo el wifi, el led parpadea un segundo y se apaga  Azn

Puede variar el valor dependiendo de si la tengo encendida o apagada desde LuCi ?
En línea

En venta:

Portátil HP Elitebook 8470p

Intel Core i5 3360M a 2.8 GHz (Turbo 3.5 GHz)
8 GB RAM DDR3  PC3-12800
Disco duro de 320 GB SATA-300 7200 RPM
Grabadora de DVD
Pantalla panorámica MATE de 14 pulgadas 1366 x 768
Intel HD Graphics 4000
Audio Stereo SRS Premium Sound Pro
Webcam
Luz de lectura
Wifi Dual Band a/g/n
Bluetooh 4.0 EDR
Lan Gigabit
Lector de tarjetas
Lector de huellas
1 x ExpressCard/54, VGA, Displayport, firefiwire, USB 2.0
2 x USB 3.0
1 X USB 2.0/eSATA
Teclado francés, convertido en español con vinilos de alta calidad
Batería de 6 celdas en muy buen estado
Cargador original

Muy buen estado estético

245€ env.inc.
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1242



Ver Perfil WWW
« Respuesta #4 : 19-07-2012, 12:45 (Jueves) »

Muchas gracias por los LEDs y los botones Cheesy.

Nuevo firmware con LEDs, botones, driver brcmsmac para el wifi y una sorpresa, que no sé si va a funcionar Tongue.
https://dl.dropbox.com/u/4708147/openwrt/AR5387un/openwrt-96328A-1441N1-generic-squashfs-cfe_r32777.bin

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


jar229
Moderador
*
Desconectado Desconectado

Mensajes: 4551



Ver Perfil
« Respuesta #5 : 19-07-2012, 13:37 (Jueves) »

Muchas gracias por los LEDs y los botones Cheesy.

Nuevo firmware con LEDs, botones, driver brcmsmac para el wifi y una sorpresa, que no sé si va a funcionar Tongue.
https://dl.dropbox.com/u/4708147/openwrt/AR5387un/openwrt-96328A-1441N1-generic-squashfs-cfe_r32777.bin

Saludos.

Probado.
Con el nuevo driver wifi, se pone a la par del ADB  Angry



La sorpresa, no funciona  Embarrassed Embarrassed Embarrassed ... y mira que le he 'pinchado' tres pendrives diferentes y hasta un disco externo ...

El tema de los leds, hay dos que los has definido como orange (cuando son green), así que no se encienden   Wink

Enviado log a tu email  Wink
En línea

En venta:

Portátil HP Elitebook 8470p

Intel Core i5 3360M a 2.8 GHz (Turbo 3.5 GHz)
8 GB RAM DDR3  PC3-12800
Disco duro de 320 GB SATA-300 7200 RPM
Grabadora de DVD
Pantalla panorámica MATE de 14 pulgadas 1366 x 768
Intel HD Graphics 4000
Audio Stereo SRS Premium Sound Pro
Webcam
Luz de lectura
Wifi Dual Band a/g/n
Bluetooh 4.0 EDR
Lan Gigabit
Lector de tarjetas
Lector de huellas
1 x ExpressCard/54, VGA, Displayport, firefiwire, USB 2.0
2 x USB 3.0
1 X USB 2.0/eSATA
Teclado francés, convertido en español con vinilos de alta calidad
Batería de 6 celdas en muy buen estado
Cargador original

Muy buen estado estético

245€ env.inc.
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1242



Ver Perfil WWW
« Respuesta #6 : 19-07-2012, 13:48 (Jueves) »

Muchas gracias por los LEDs y los botones Cheesy.

Nuevo firmware con LEDs, botones, driver brcmsmac para el wifi y una sorpresa, que no sé si va a funcionar Tongue.
https://dl.dropbox.com/u/4708147/openwrt/AR5387un/openwrt-96328A-1441N1-generic-squashfs-cfe_r32777.bin

Saludos.

Probado.
Con el nuevo driver wifi, se pone a la par del ADB  Angry



La sorpresa, no funciona  Embarrassed Embarrassed Embarrassed ... y mira que le he 'pinchado' tres pendrives diferentes y hasta un disco externo ...

El tema de los leds, hay dos que los has definido como orange (cuando son green), así que no se encienden   Wink

Enviado log a tu email  Wink
Ok, pues descartamos lo del USB en la cpu 6328 hasta nueva actualización del kernel de linux...

Voy a unificar los parches del ADB y de este router, ya que son prácticamente idénticos y hago un firmware para que confirmes que todo funciona corretamente.

Sobre los LEDs pensaban que eran naranjas en vez de verdes, pero eso no debería influir en su correcto funcionamiento :$, es simplemente un nombre descriptivo :$...

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1242



Ver Perfil WWW
« Respuesta #7 : 19-07-2012, 14:21 (Jueves) »

Cuando puedas los pruebas y me comentas  ^^:
https://dl.dropbox.com/u/4708147/openwrt/6328/openwrt-96328A-1441N1-generic-squashfs-cfe_r32777.bin

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1242



Ver Perfil WWW
« Respuesta #8 : 19-07-2012, 19:10 (Jueves) »

Okay, los parches funcionan bien, así que los he publicado en el primer post.
Aplicando estos parches se generarán imágenes tanto para el Comtend AR5387un como para el ADB P.DG A4001N.

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


jar229
Moderador
*
Desconectado Desconectado

Mensajes: 4551



Ver Perfil
« Respuesta #9 : 19-07-2012, 19:12 (Jueves) »

Okay, los parches funcionan bien, así que los he publicado en el primer post.
Aplicando estos parches se generarán imágenes tanto para el Comtend AR5387un como para el ADB P.DG A4001N.

Saludos.

 Grin Grin


Probado  Wink
El wifi, igual que el anterior.
Los leds ... sólo consigo que se encienda el de DSL  Huh
En línea

En venta:

Portátil HP Elitebook 8470p

Intel Core i5 3360M a 2.8 GHz (Turbo 3.5 GHz)
8 GB RAM DDR3  PC3-12800
Disco duro de 320 GB SATA-300 7200 RPM
Grabadora de DVD
Pantalla panorámica MATE de 14 pulgadas 1366 x 768
Intel HD Graphics 4000
Audio Stereo SRS Premium Sound Pro
Webcam
Luz de lectura
Wifi Dual Band a/g/n
Bluetooh 4.0 EDR
Lan Gigabit
Lector de tarjetas
Lector de huellas
1 x ExpressCard/54, VGA, Displayport, firefiwire, USB 2.0
2 x USB 3.0
1 X USB 2.0/eSATA
Teclado francés, convertido en español con vinilos de alta calidad
Batería de 6 celdas en muy buen estado
Cargador original

Muy buen estado estético

245€ env.inc.
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1242



Ver Perfil WWW
« Respuesta #10 : 19-07-2012, 19:21 (Jueves) »

Okay, los parches funcionan bien, así que los he publicado en el primer post.
Aplicando estos parches se generarán imágenes tanto para el Comtend AR5387un como para el ADB P.DG A4001N.

Saludos.

 Grin Grin


Probado  Wink
El wifi, igual que el anterior.
Los leds ... sólo consigo que se encienda el de DSL  Huh

Estás seguro de que cada LED era como me habías descrito (active high/low) y no al revés? :$
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1242



Ver Perfil WWW
« Respuesta #11 : 19-07-2012, 20:14 (Jueves) »

A ver si con este te funcionan los LEDs:
https://dl.dropbox.com/u/4708147/openwrt/6328/openwrt-96328A-1441N1-generic-squashfs-cfe_r32779.bin

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


jar229
Moderador
*
Desconectado Desconectado

Mensajes: 4551



Ver Perfil
« Respuesta #12 : 19-07-2012, 20:37 (Jueves) »


Verás ... probando el nuevo firm me acabo de dar cuenta de algo ...  y es que algunos leds encienden en rojo  Huh Huh
Tengo el router en un lateral de la mesa (bastane separado de mí), y los leds verdes se ven perfectamente, pero cuando se encienden en rojo, o estás justo encima  o no se ven  Embarrassed
Mañana con el router en mejor posición vuelvo a probar todos los leds (seguro que el de wlan también funciona).

Y porqué me emperraría yo en que encendian solo en verde  Evil
En línea

En venta:

Portátil HP Elitebook 8470p

Intel Core i5 3360M a 2.8 GHz (Turbo 3.5 GHz)
8 GB RAM DDR3  PC3-12800
Disco duro de 320 GB SATA-300 7200 RPM
Grabadora de DVD
Pantalla panorámica MATE de 14 pulgadas 1366 x 768
Intel HD Graphics 4000
Audio Stereo SRS Premium Sound Pro
Webcam
Luz de lectura
Wifi Dual Band a/g/n
Bluetooh 4.0 EDR
Lan Gigabit
Lector de tarjetas
Lector de huellas
1 x ExpressCard/54, VGA, Displayport, firefiwire, USB 2.0
2 x USB 3.0
1 X USB 2.0/eSATA
Teclado francés, convertido en español con vinilos de alta calidad
Batería de 6 celdas en muy buen estado
Cargador original

Muy buen estado estético

245€ env.inc.
jar229
Moderador
*
Desconectado Desconectado

Mensajes: 4551



Ver Perfil
« Respuesta #13 : 20-07-2012, 09:20 (Viernes) »

Lo primero, comentar que este router con OpenWRT (con el firm original es diferente), cuando arranca lo hace con el led de internet encendido (en rojo, pero con poca intensidad). Además, mientras que está cargando el sistema la lud de power (en rojo, también con poca intesidad) está parpadeando. Cuando ya está 'listo', el led de power se apaga completamente.

Código:
root@OpenWrt:~# echo 1 > /sys/class/gpio/export
root@OpenWrt:~# echo out > /sys/class/gpio/gpio1/direction

Apaga el led rojo de internet (recuerdo: está con poca 'intensidad')

Código:
root@OpenWrt:~# echo 1 > /sys/class/gpio/gpio1/value

Lo enciende en rojo con intensidad normal

Código:
root@OpenWrt:~# echo 0 > /sys/class/gpio/gpio1/value

Lo vuelve a apagar

Código:
root@OpenWrt:~# echo 4 > /sys/class/gpio/export
root@OpenWrt:~# echo out > /sys/class/gpio/gpio4/direction

Enciende en verde con intensidad normal el led de Power

Código:
root@OpenWrt:~# echo 1 > /sys/class/gpio/gpio4/value

Lo apaga

Código:
root@OpenWrt:~# echo 0 > /sys/class/gpio/gpio4/value

Lo vuelve a encender

El de WLAN me tiene manía  Embarrassed
En línea

En venta:

Portátil HP Elitebook 8470p

Intel Core i5 3360M a 2.8 GHz (Turbo 3.5 GHz)
8 GB RAM DDR3  PC3-12800
Disco duro de 320 GB SATA-300 7200 RPM
Grabadora de DVD
Pantalla panorámica MATE de 14 pulgadas 1366 x 768
Intel HD Graphics 4000
Audio Stereo SRS Premium Sound Pro
Webcam
Luz de lectura
Wifi Dual Band a/g/n
Bluetooh 4.0 EDR
Lan Gigabit
Lector de tarjetas
Lector de huellas
1 x ExpressCard/54, VGA, Displayport, firefiwire, USB 2.0
2 x USB 3.0
1 X USB 2.0/eSATA
Teclado francés, convertido en español con vinilos de alta calidad
Batería de 6 celdas en muy buen estado
Cargador original

Muy buen estado estético

245€ env.inc.
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1242



Ver Perfil WWW
« Respuesta #14 : 20-07-2012, 12:14 (Viernes) »

Lo primero, comentar que este router con OpenWRT (con el firm original es diferente), cuando arranca lo hace con el led de internet encendido (en rojo, pero con poca intensidad). Además, mientras que está cargando el sistema la lud de power (en rojo, también con poca intesidad) está parpadeando. Cuando ya está 'listo', el led de power se apaga completamente.

Código:
root@OpenWrt:~# echo 1 > /sys/class/gpio/export
root@OpenWrt:~# echo out > /sys/class/gpio/gpio1/direction

Apaga el led rojo de internet (recuerdo: está con poca 'intensidad')

Código:
root@OpenWrt:~# echo 1 > /sys/class/gpio/gpio1/value

Lo enciende en rojo con intensidad normal

Código:
root@OpenWrt:~# echo 0 > /sys/class/gpio/gpio1/value

Lo vuelve a apagar

Código:
root@OpenWrt:~# echo 4 > /sys/class/gpio/export
root@OpenWrt:~# echo out > /sys/class/gpio/gpio4/direction

Enciende en verde con intensidad normal el led de Power

Código:
root@OpenWrt:~# echo 1 > /sys/class/gpio/gpio4/value

Lo apaga

Código:
root@OpenWrt:~# echo 0 > /sys/class/gpio/gpio4/value

Lo vuelve a encender

El de WLAN me tiene manía  Embarrassed
Pues no me queda claro como van los LEDs, sinceramente, estoy hecho un lío :$...

Ahora mismo esto es lo que tengo:
Power (Verde): 4 / Active Low
Stop (Power Rojo): 8 / Active High
DSL (Verde): 11 / Active Low
Inet (Verde): 7 / Active High
Inet-fail (Inet Rojo): 1 / Active High

Código:
+ {
+ .name = "96328A-1441N1:green:power",
+ .gpio = 4,
+ .default_trigger = "default-on",
+ .active_low = 1,
+ },
+ {
+ .name = "96328A-1441N1:red:stop",
+ .gpio = 8,
+ },
+ {
+ .name = "96328A-1441N1:green:inet",
+ .gpio = 7,
+ },
+ {
+ .name = "96328A-1441N1:red:inet-fail",
+ .gpio = 1,
+ },
+ {
+ .name = "96328A-1441N1:green:dsl",
+ .gpio = 11,
+ .active_low = 1,
+ },

Saludos.
« Última modificación: 20-07-2012, 12:24 (Viernes) por Noltari » En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1242



Ver Perfil WWW
« Respuesta #15 : 20-07-2012, 13:22 (Viernes) »

Cuando puedas prueba este firmware:
https://dl.dropbox.com/u/4708147/openwrt/6328/openwrt-96328A-1441N1-generic-squashfs-cfe_r32782.bin

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


jar229
Moderador
*
Desconectado Desconectado

Mensajes: 4551



Ver Perfil
« Respuesta #16 : 20-07-2012, 13:57 (Viernes) »

Hoy estoy un poco 'gafado' mejor lo dejamos para otro día ... https://foro.seguridadwireless.net/openwrt/openwrt-en-routers-de-telefonica-home-station-alpha-asl26555-y-adb-p-dg-a4001n1/msg247809/#msg247809

 Wink
En línea

En venta:

Portátil HP Elitebook 8470p

Intel Core i5 3360M a 2.8 GHz (Turbo 3.5 GHz)
8 GB RAM DDR3  PC3-12800
Disco duro de 320 GB SATA-300 7200 RPM
Grabadora de DVD
Pantalla panorámica MATE de 14 pulgadas 1366 x 768
Intel HD Graphics 4000
Audio Stereo SRS Premium Sound Pro
Webcam
Luz de lectura
Wifi Dual Band a/g/n
Bluetooh 4.0 EDR
Lan Gigabit
Lector de tarjetas
Lector de huellas
1 x ExpressCard/54, VGA, Displayport, firefiwire, USB 2.0
2 x USB 3.0
1 X USB 2.0/eSATA
Teclado francés, convertido en español con vinilos de alta calidad
Batería de 6 celdas en muy buen estado
Cargador original

Muy buen estado estético

245€ env.inc.
phullock
**
Desconectado Desconectado

Mensajes: 25


Ver Perfil
« Respuesta #17 : 20-07-2012, 22:04 (Viernes) »

Si necesitáis tester, voy a pedir a Jazztel que me mande uno. Aunque ahora me acaba de llegar el raspberry y voy a dedicarle mínimo esta semana XD
« Última modificación: 20-07-2012, 22:06 (Viernes) por phullock » En línea
jar229
Moderador
*
Desconectado Desconectado

Mensajes: 4551



Ver Perfil
« Respuesta #18 : 21-07-2012, 12:06 (S?bado) »

phullock , toda ayuda siempre será bien recibida  Wink

A ver si tienes suerte y jazztel te lo manda, que no siempre lo hacen  Grin

Si quieres contarnos algo de tus aventuras con el raspberry, puedes abrir un tema en off topic  Evil

Esta tarde, mañana a lo sumo, pruebo el nuevo firm.

Noltari, tengo que verificar algo en concreto ?
En línea

En venta:

Portátil HP Elitebook 8470p

Intel Core i5 3360M a 2.8 GHz (Turbo 3.5 GHz)
8 GB RAM DDR3  PC3-12800
Disco duro de 320 GB SATA-300 7200 RPM
Grabadora de DVD
Pantalla panorámica MATE de 14 pulgadas 1366 x 768
Intel HD Graphics 4000
Audio Stereo SRS Premium Sound Pro
Webcam
Luz de lectura
Wifi Dual Band a/g/n
Bluetooh 4.0 EDR
Lan Gigabit
Lector de tarjetas
Lector de huellas
1 x ExpressCard/54, VGA, Displayport, firefiwire, USB 2.0
2 x USB 3.0
1 X USB 2.0/eSATA
Teclado francés, convertido en español con vinilos de alta calidad
Batería de 6 celdas en muy buen estado
Cargador original

Muy buen estado estético

245€ env.inc.
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1242



Ver Perfil WWW
« Respuesta #19 : 21-07-2012, 12:14 (S?bado) »

phullock , toda ayuda siempre será bien recibida  Wink

A ver si tienes suerte y jazztel te lo manda, que no siempre lo hacen  Grin

Si quieres contarnos algo de tus aventuras con el raspberry, puedes abrir un tema en off topic  Evil

Esta tarde, mañana a lo sumo, pruebo el nuevo firm.

Noltari, tengo que verificar algo en concreto ?

Pues me gustaría dejar zanjado el tema de los LEDs, ya que de momento es lo único que nos queda por solucionar de las cosas que podemos solucionar Tongue.

Te recuerdo que para probar los LEDs, una vez identificados y definidos en la estructura de la placa, no vale utilizar el gpio export.

Encender el LED de Power en VERDE.
echo 1 > /sys/class/leds/96328A-1441N1\:green\:power/brightness
Apagar el LED de Power en VERDE:
echo 0 > /sys/class/leds/96328A-1441N1\:green\:power/brightness

Encender el LED de Power en ROJO.
echo 1 > /sys/class/leds/96328A-1441N1\:red\:stop/brightness
Apagar el LED de Power en ROJO:
echo 0 > /sys/class/leds/96328A-1441N1\:red\:stop/brightness

Encender el LED de Internet en VERDE.
echo 1 > /sys/class/leds/96328A-1441N1\:green\:inet/brightness
Apagar el LED de Internet en VERDE:
echo 0 > /sys/class/leds/96328A-1441N1\:green\:inet/brightness

Encender el LED de Internet en ROJO.
echo 1 > /sys/class/leds/96328A-1441N1\:red\:inet-fail/brightness
Apagar el LED de Internet en ROJO:
echo 0 > /sys/class/leds/96328A-1441N1\:red\:inet-fail/brightness

Encender el LED de DSL en VERDE.
echo 1 > /sys/class/leds/96328A-1441N1\:green\:dsl/brightness
Apagar el LED de DSL en VERDE:
echo 0 > /sys/class/leds/96328A-1441N1\:green\:dsl/brightness

Si algún LED funciona al revés es que es active high si está definido como active low y es active low si está definido como active high.
Si hay algún LED intercambiado avisa también (que el Power encienda el de DSL).

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


Páginas: [1] 2 3 4 5 6 ... 71 Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums