Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
21-08-2017, 12:01 (Lunes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt & LEDE (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  [Desarrollo] OpenWrt en Comtrend WAP-5813n
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: 1 [2] 3 4 5 6 7 ... 31 Ir Abajo Imprimir
Autor Tema: [Desarrollo] OpenWrt en Comtrend WAP-5813n  (Leído 258258 veces)
aguera-competicion
*****
Desconectado Desconectado

Mensajes: 197


Ver Perfil
« Respuesta #20 : 11-07-2012, 22:52 (Mi?rcoles) »

La verdad que el compañero Noltari se lo esta currando .
A ver si termino unas cosas este mes y me pongo a  probar los Firmware que compila el compi 5813n +  hg556a + cable seria  Azn menudo cacharreo me espera.
« Última modificación: 11-07-2012, 22:54 (Mi?rcoles) por aguera-competicion » En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #21 : 12-07-2012, 00:31 (Jueves) »

Eres un fenomeno!!!!!  Angry

Gracias por el trabajo que haces, me gustaria que me aclarases algunas dudas con este router:

El switch no se puede configurar, pero sigue haciendo de switch? es decir si conecto 2 pcs por lan,se ven entre ellos y tendran internet?
Mi intencion es conectar una xbox y un htpc por red al router y este conectado via wifi al principal que sirve internet (un linksys)
Como cargo el firm al router? me lo dio un familiar al cerrar el negocio y no dispongo de la clave par acceder via web al router.
Has conseguido algo del usb?

Gracias y un salu2
USB nada, además habría que soldárselo (al menos a la versión de Movistar, que es la que yo tengo), porque no lo trae de serie.
Sí, cuando digo que el switch no se puede configurar es que no se pueden crear VLANs, es decir, redes locales virtuales entre determinados puertos ethernet del switch. Sin embargo, sigue siendo un switch, y su funcionamiento por defecto es aquél relacionado con la capa 2, es decir, transmitir paquetes a sus determinados destinatarios en base a direcciones MAC.

Para cargar el firmware al router se hace como en todos los routers con bootloader CFE, es decir, configurando la IP del PC a 192.168.1.2, la máscara de subred a 255.255.255.0 y la puerta de enlace a 192.168.1.1. Después, con el router apagado, mantienes presionado el botón de reset, enciendes el router y pasados unos 20-30 segundos lo sueltas. En el PC vas a la url http://192.168.1.1/ y te aparecerá un formulario para subir el firmware al router.

Saludos Wink.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


krasny
****
Desconectado Desconectado

Mensajes: 86


Ver Perfil
« Respuesta #22 : 20-07-2012, 18:33 (Viernes) »

Hola

Muchas gracias por tu curro Noltari, tengo uno de estos en el armario y muchas gracias de probar OpenWRT en el Smiley En cuanto le meta mano os cuento, aunque como mucho os puedo servir de tester.

Un saludete!
En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #23 : 20-07-2012, 19:01 (Viernes) »

Hola

Muchas gracias por tu curro Noltari, tengo uno de estos en el armario y muchas gracias de probar OpenWRT en el Smiley En cuanto le meta mano os cuento, aunque como mucho os puedo servir de tester.

Un saludete!
De nada hombre. Precisamente en este router es en el que menos testers necesito, porque tengo uno Tongue.

Mi objetivo es conseguir un port completamente funcional de Openwrt en él y utilizarlo como router principal y único para Movistar FTTH.
He intentado usar un 5365, pero como mucho consigo 36 Mbps de los 100Mbps que debería así que no es una opción xD.

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


krasny
****
Desconectado Desconectado

Mensajes: 86


Ver Perfil
« Respuesta #24 : 26-07-2012, 01:47 (Jueves) »

Hola otra vez!

Estoy intentando probar tu versión del openwrt, sin embargo después de flashearla vía CFE el router se queda muerto, se supone que con la última versión funcionan los puertos LAN verdad?

Puede tener que ver con que yo tengo  otra versión del CFE? (la mia es 1.0.37-106.5-6), la cambié pq instalé un firm de un proveedor lithuano (TEO) con la esperanza de que fuese el firm de comtrend sin tocar, pero no, y ahora no puedo volver al CFE de telefonica Sad Tampoco me funciona el portal alejandra

Muchas gracias!
« Última modificación: 26-07-2012, 02:29 (Jueves) por krasny » En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #25 : 26-07-2012, 03:08 (Jueves) »

Hola otra vez!

Estoy intentando probar tu versión del openwrt, sin embargo después de flashearla vía CFE el router se queda muerto, se supone que con la última versión funcionan los puertos LAN verdad?

Puede tener que ver con que yo tengo  otra versión del CFE? (la mia es 1.0.37-106.5-6), la cambié pq instalé un firm de un proveedor lithuano (TEO) con la esperanza de que fuese el firm de comtrend sin tocar, pero no, y ahora no puedo volver al CFE de telefonica Sad Tampoco me funciona el portal alejandra

Muchas gracias!
Pues vaya cagada...
Intenta instalar primero esta versión antigua, que te bajará la versión del bootloader a otra anterior:
https://dl.dropbox.com/u/4708147/comtrend/WAP-5813n-CFE-P401-402TLF-C01_R05.bin

Después, instala esta otra versión y resetea la configuración a ver si sincroniza con alejandra:
https://dl.dropbox.com/u/4708147/comtrend/WAP-5813n-P401-402TLF-C02_R23.BIN

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


krasny
****
Desconectado Desconectado

Mensajes: 86


Ver Perfil
« Respuesta #26 : 26-07-2012, 11:11 (Jueves) »

Hola Noltari!

Muchas gracias por tu ayuda. Ayer después de escribir el post me quedé trasteando hasta las tantas y justo he probado a hacer eso (me encontré con tu post de soporte en el foro de movistar sobre la R05 xD). El caso es que he podido bajar el firmware a la 1.0.37-102.1-2, pero no hay manera de poner la 1.0.37-102.1-5, q es la que llevan los R23 y R35 Sad Se te ocurre alguna manera más? Con lo sencillo que sería que los de telefónica subiesen los firmwares del router!!!!
En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #27 : 26-07-2012, 13:11 (Jueves) »

Hola Noltari!

Muchas gracias por tu ayuda. Ayer después de escribir el post me quedé trasteando hasta las tantas y justo he probado a hacer eso (me encontré con tu post de soporte en el foro de movistar sobre la R05 xD). El caso es que he podido bajar el firmware a la 1.0.37-102.1-2, pero no hay manera de poner la 1.0.37-102.1-5, q es la que llevan los R23 y R35 Sad Se te ocurre alguna manera más? Con lo sencillo que sería que los de telefónica subiesen los firmwares del router!!!!
Estás seguro de que con ese bootloader no te sincroniza con alejandra?
Yo siempre flasheo la R23 , reseteo la configuración y automáticamente el router flashea la R35 directamente desde la central.

Por cierto, la próxima vez que vayas a trastear con firmwares asegúrate de que las imágenes no llevan el bootloader cfe (siempre puedes modificar el firmware y quitar el cfe). O eso o haz un backup del cfe.

A mi personalmente me da cosilla tocar el cfe, aunque tenga un backup xD.

Por cierto, podría hacer una R23 o R35 con mi backup del cfe, quitándole la configuración y la mac address pero igual la liamos y te quedas sin router :/...

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #28 : 26-07-2012, 13:46 (Jueves) »

Resulta que la aplicación que utilicé para generar las imágenes del firmware a partir de los datos que extraje de la flash también puede limpiar el nvram del cfe.

Así que he generado imágenes de los últimos firmwares con el bootloader cfe incluido:
https://dl.dropbox.com/u/4708147/comtrend/WAP-5813n-CFE-P401-402TLF-C02_R23.BIN
https://dl.dropbox.com/u/4708147/comtrend/WAP-5813n-CFE-P401-402TLF-C02_R35.BIN

Al haber limpiado la dirección mac y la configuración del cfe la misma aplicación ahora tengo más confianza, pero no te puedo asegurar al 100% que el router no se vaya a morir...

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


krasny
****
Desconectado Desconectado

Mensajes: 86


Ver Perfil
« Respuesta #29 : 26-07-2012, 16:03 (Jueves) »

Hola otra vez!

Muchiiiiiiisimas gracias por tu ayuda Noltari. Vuelvo a tener el router operativo de cara al portal alejandra, con el bootloader de telefonica. No era nada grave, puesto que hace mucho que lo cambie por un router con tomato, pero no esta de mas tenerlo por ahi por si falla algo. Le flashee la R23 y funciono todo como la seda, si alguien se ve en la misma situacion que yo puede flashearlo sin obtener un pisapapeles.

Ahora el problema que tenia flasheando OpenWRT persiste. Lo flasheo, se reinicia y soy incapaz de acceder mediante cable de red al router, ni da direccion por dhcp ni configurando una en el rango 192.168.1.x me encuentra nada en el 192.168.1.1 (direccion por defecto del router, que entiendo q es esa). Al encender hace las comprobaciones de las luces y luego se queda la de power encendida. Tengo q acceder por el puerto de serie / jtag? pa ir desempolvando la herramienta Smiley

Un saludete y mil gracias de nuevo
En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #30 : 26-07-2012, 16:15 (Jueves) »

Hola otra vez!

Muchiiiiiiisimas gracias por tu ayuda Noltari. Vuelvo a tener el router operativo de cara al portal alejandra, con el bootloader de telefonica. No era nada grave, puesto que hace mucho que lo cambie por un router con tomato, pero no esta de mas tenerlo por ahi por si falla algo. Le flashee la R23 y funciono todo como la seda, si alguien se ve en la misma situacion que yo puede flashearlo sin obtener un pisapapeles.

Ahora el problema que tenia flasheando OpenWRT persiste. Lo flasheo, se reinicia y soy incapaz de acceder mediante cable de red al router, ni da direccion por dhcp ni configurando una en el rango 192.168.1.x me encuentra nada en el 192.168.1.1 (direccion por defecto del router, que entiendo q es esa). Al encender hace las comprobaciones de las luces y luego se queda la de power encendida. Tengo q acceder por el puerto de serie / jtag? pa ir desempolvando la herramienta Smiley

Un saludete y mil gracias de nuevo
Has flasheado la R23 con CFE del post anterior verdad?

Al intentar acceder al router con openwrt estás seguro de que has configurado la dirección ip del ordenador manualmente y eso no?
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


krasny
****
Desconectado Desconectado

Mensajes: 86


Ver Perfil
« Respuesta #31 : 26-07-2012, 16:24 (Jueves) »

Sip

He flasheado la R23 con el CFE del post anterior, luego se actualizo a la R35 automatico y ya me dejaba entrar en alejandra.

Si, he configurado manualmente la ip, 192.168.1.2 y conectado el pc al switch del 5813 y ni telnet, ping, http ni na de na :S

eth0      Link encap:Ethernet  HWaddr 1c:6f:65:d8:c2:21 
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::1e6f:65ff:fed8:c221/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11634 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8484 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:13911949 (13.9 MB)  TX bytes:1101101 (1.1 MB)
          Interrupt:42 Base address:0x4000
« Última modificación: 26-07-2012, 16:26 (Jueves) por krasny » En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #32 : 27-07-2012, 03:09 (Viernes) »

Sip

He flasheado la R23 con el CFE del post anterior, luego se actualizo a la R35 automatico y ya me dejaba entrar en alejandra.

Si, he configurado manualmente la ip, 192.168.1.2 y conectado el pc al switch del 5813 y ni telnet, ping, http ni na de na :S

eth0      Link encap:Ethernet  HWaddr 1c:6f:65:d8:c2:21 
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::1e6f:65ff:fed8:c221/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11634 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8484 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:13911949 (13.9 MB)  TX bytes:1101101 (1.1 MB)
          Interrupt:42 Base address:0x4000

Mañana si puedo lo miro.

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #33 : 31-07-2012, 14:51 (Martes) »

El problema era que la imagen debe ocupar al menos 4 MB (la mitad de la flash para que sea flasheada en el lugar correcto). Lo siento, pero yo sólo había hecho pruebas con ramdisks...

Nuevo firmware probado y funcionando 100%:
https://dl.dropbox.com/u/4708147/openwrt/ct5813/openwrt-CT5813n-squashfs-cfe_r32910.bin

Actualizados parches para el SVN (los podéis encontrar en el post principal).

Añadidos al post principal los firmwares oficiales con bootloader CFE: USADLOS SÓLO SI HABÉIS CAMBIADO EL BOOTLOADER CON FIRMWARES DE OTROS ROUTERS.

Recordad que no se puede utilizar aún para la fibra óptica ya que no hay soporte para VLANs.

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


krasny
****
Desconectado Desconectado

Mensajes: 86


Ver Perfil
« Respuesta #34 : 01-08-2012, 15:58 (Mi?rcoles) »

Hola noltari!

Gracias por tu trabajo, ya lo he probado, y ahora si se flashea correctamente y funciona Smiley El mayor problema que queda ahora por resolver es que sea configurable el switch para poder configurar el puerto WAN.


Sigue así, eres un crack
En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #35 : 01-08-2012, 22:26 (Mi?rcoles) »

Hola noltari!

Gracias por tu trabajo, ya lo he probado, y ahora si se flashea correctamente y funciona Smiley El mayor problema que queda ahora por resolver es que sea configurable el switch para poder configurar el puerto WAN.


Sigue así, eres un crack
Me alegro de que te funcione Wink.

Cuando jogo termine el driver b53 podremos configurar el switch de este router.
La verdad es que he probado por encima el firmware y va bastante fluido, aunque claro, lo estoy comparando con un Comtrend 5365, que no tiene nada que ver xD.

Estoy deseando que lleguen novedades a openwrt/bcm63xx como el soporte SMP (así podremos utilizar el dual core en los procesadores de estos routers Cheesy) y el device tree, mediante el cual el kernel será más ligero porque se compilará el firmware específicamente para cada dispostivo.

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


krasny
****
Desconectado Desconectado

Mensajes: 86


Ver Perfil
« Respuesta #36 : 01-08-2012, 22:50 (Mi?rcoles) »

Hola otra vez!

A lo mejor digo una tonteria, pero el switch externo del router parece ser el bcm53115 segun el bootlog original que colgaste en el wiki del openwrt, no bastaria con hacer que el router lo reconozca como tal para que funcionase? He encotrado que el wrt610 usa el mismo switch y aqui esta el parche q hizo q lo reconociese: (aunq el chip que usa es diferente)

https://dev.openwrt.org/changeset/17433

La verdad esque todas esas mejoras que comentas suenan francamente bien, a ver cuando podemos verlas en este router :-)

Gracias de nuevo
En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #37 : 01-08-2012, 23:29 (Mi?rcoles) »

Hola otra vez!

A lo mejor digo una tonteria, pero el switch externo del router parece ser el bcm53115 segun el bootlog original que colgaste en el wiki del openwrt, no bastaria con hacer que el router lo reconozca como tal para que funcionase? He encotrado que el wrt610 usa el mismo switch y aqui esta el parche q hizo q lo reconociese: (aunq el chip que usa es diferente)

https://dev.openwrt.org/changeset/17433

La verdad esque todas esas mejoras que comentas suenan francamente bien, a ver cuando podemos verlas en este router :-)

Gracias de nuevo
El wrt610 si no recuerdo mal es de la plataforma bcm47xx. El problema es que hay ciertos drivers para unas plataformas que aún no han sido portados a otras.

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


coiae
**
Desconectado Desconectado

Mensajes: 4


Ver Perfil
« Respuesta #38 : 18-08-2012, 17:48 (S?bado) »

Noltari,
He actualizado desde la version de firmware WAP-5813n-CFE-P401-402TLF-C01_R05 de telefonica con boot loader CFE v1.0.37-102.1-5) y va como un tiro. Lo utilizo para una conexion cable y como va conectado a un cable-modem (modo brigde)  no me hace falta el tema de la VLAN 4 de FTTH de movistar.
MUCHISIMAS  GRACIAS POR TODO...
Por cierto como activo el eth4 para configurarlo con WAN...Como puedes ver con el interface WEB Luci no me manejo, pero menos con la "consola" de comandos.
« Última modificación: 18-08-2012, 19:36 (S?bado) por coiae » En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #39 : 18-08-2012, 19:58 (S?bado) »

Noltari,
He actualizado desde la version de firmware WAP-5813n-CFE-P401-402TLF-C01_R05 de telefonica con boot loader CFE v1.0.37-102.1-5) y va como un tiro. Lo utilizo para una conexion cable y como va conectado a un cable-modem (modo brigde)  no me hace falta el tema de la VLAN 4 de FTTH de movistar.
MUCHISIMAS  GRACIAS POR TODO...
Por cierto como activo el eth4 para configurarlo con WAN...Como puedes ver con el interface WEB Luci no me manejo, pero menos con la "consola" de comandos.
No se pueden configurar los puertos del router porque no hay soporte de VLANs. Todos los puertos actúan como un switch (incluido el WAN). Lo único que puedes hacer es configurar la LAN en el router con una IP de la misma subred del modem de ONO. De esta forma, tendrás más puertos ethernet y la posibilidad de activar el wifi con el comtrend 5813n.

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


Páginas: 1 [2] 3 4 5 6 7 ... 31 Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums