Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
24-02-2018, 05:35 (S?bado)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Descubierto fallo de seguridad en routers Sercomm H500-S de Vodafone

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt & LEDE (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  Mesh en openwrt
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Ir Abajo Imprimir
Autor Tema: Mesh en openwrt  (Leído 1261 veces)
jmcabgam
**
Desconectado Desconectado

Mensajes: 42


Ver Perfil
« : 14-01-2018, 13:26 (Domingo) »

Muy buenas

He buscado info sobre la posibilidad de crear una mesh wifi con openwrt (concretamente lo buscaba para el HG556a) pero no encuentro información, no hay nada por ahí?

Digamos que buscaba algo semejante al Aimesh de asus... ya que actualmente tengo un HG556a generando una wifi en el fondo de la casa y otro al principio, pero tengo que cambiar manualmente de la wifi del primer router al segundo (o viceversa) cuando me muevo entre las diversas coberturas wifis. La idea es que esto se haga automáticamente y sea transparente para el cliente.

Muchas gracias!!!

En línea
Ficht
*******
Desconectado Desconectado

Mensajes: 538



Ver Perfil
« Respuesta #1 : 14-01-2018, 13:47 (Domingo) »

Muy buenas

He buscado info sobre la posibilidad de crear una mesh wifi con openwrt (concretamente lo buscaba para el HG556a) pero no encuentro información, no hay nada por ahí?

Digamos que buscaba algo semejante al Aimesh de asus... ya que actualmente tengo un HG556a generando una wifi en el fondo de la casa y otro al principio, pero tengo que cambiar manualmente de la wifi del primer router al segundo (o viceversa) cuando me muevo entre las diversas coberturas wifis. La idea es que esto se haga automáticamente y sea transparente para el cliente.

Muchas gracias!!!
Yo lo tengo así.
Es decir dos puntos AP (pero cableados, no repetidor) y como más rápido cambian de acceso los dispositivos entre los AP es configurando mismo canal, nombre y contraseña, luego la potencia si la bajo lo justo para que no se piden demasiado (o lo mínimo que necesito)
El cambio se hace instantáneo.

Enviado desde mi PRA-LX1 mediante Tapatalk

En línea
jmcabgam
**
Desconectado Desconectado

Mensajes: 42


Ver Perfil
« Respuesta #2 : 14-01-2018, 14:32 (Domingo) »

Gracias por tu respuesta, Ficht. Me explico mejor cómo lo tengo en casa de mis padres:

El router principal es un livebox de orange (adsl 20m con voip), que tiene habilitado el dhcp y genera una wifi_salita, por cable está conectado al hg556a con openwrt lede (sin dhcp) y éste genera otra wifi_pasillo (con distinto nombre), aunque está en el mismo canal y con la misma clave.

Tengo el nombre de la wifi cambiado (_salida y _pasillo) para poder hacer el cambio manual, porque si le pongo el mismo no puedo cambiarlo yo y por la intensidad de señal detecto que no ha cambiado... La intensidad de la wifi del hg556 la tengo muy bajita (5dBm 7mW) , pero la del livebox no puedo modificarla...

Por eso buscaba la posibilidad de poner un par de routers que me generaran una malla wifi para ver si funcionaría mejor que lo te tengo actualmente, que no va muy fino.

Gracias!
En línea
raphik
******
Desconectado Desconectado

Mensajes: 481



Ver Perfil
« Respuesta #3 : 14-01-2018, 18:10 (Domingo) »

La configuración de Fitch es parecida a la que se explica en este post: Ampliar la cobertura Wi-Fi con dos routers conectados por cable. Es una configuración que yo personalmente he probado y puedo decir que funciona.

No obstante, me apunto a explorar las posibilidades de una red mesh. A bote pronto, que yo sepa están las opciones 802.11s y B.A.T.M.A.N.

En OpenWrt, el estándar IEEE 802.11s se puede manejar desde LuCI: Menú - Wifi - Botón Edit. En la ventana Wireless Network, Sección Interface Configuration, Pestaña General Setup, seleccionar Mode 802.11s.


Aunque pudiera parecerlo, actualmente no es posible configurar el modo 802.11s (mesh) desde LuCI.
« Última modificación: 21-01-2018, 20:24 (Domingo) por raphik » En línea
ea1kt
**
Desconectado Desconectado

Mensajes: 3


Ver Perfil
« Respuesta #4 : 14-01-2018, 22:01 (Domingo) »

Tengo el mismo problema que vosotros. Lo he resuelto desctivando el DHCP en el router secundario con objeto de que el principal asigne los IPs (con lo que el router secundario,  en cierto sentido, hace de hub). El secundario puede tener distinto nombre y clave, en eso no hay problema. La cosa mejora todavia mas si se asigna manualmente un IP fijo al ordenador. Cuando se pasa de un router a otro el ordenador busca la red que mas le gusta automaticamente. Con este sistema se aconseja que los routers esten en canales que no se interfieran, maxime si estan cerca.
Ya me direis.
En línea
jmcabgam
**
Desconectado Desconectado

Mensajes: 42


Ver Perfil
« Respuesta #5 : 16-01-2018, 19:27 (Martes) »

Pues ayer tarde estuve enredando con un HG556a y LEDE, con el protocolo 802.11s pero no conseguí nada...

Seguí esta info (https://wiki.openwrt.org/doc/howto/mesh.80211s) pero no hubo suerte.El último comando (iw dev $MESH_IFACE station dump) me tiraba error

Raphik, has avanzado algo?
En línea
raphik
******
Desconectado Desconectado

Mensajes: 481



Ver Perfil
« Respuesta #6 : 16-01-2018, 23:40 (Martes) »

He  estado enredando con tres HG553 y LEDE, pero tampoco he conseguido nada.

Para facilitar las cosas a futuros participantes en el post, creo que es interesante dejar claro qué se quiere consequir. Básicamente, se trata de utilizar más de un AP para dar cobertura de calidad a una zona wifi utilizando topología Mesh (en la que los nodos de infraestructura se interconectan directa, dinámica y no jerárquicamente a tantos nodos como sea posible y cooperan entre sí para enrutar datos de manera eficiente desde / hasta los dispositivos cliente). https://en.wikipedia.org/wiki/Mesh_networking

Una red wifi tradicional está formada por varios APs conectados por cable a la red principal. La cobertura inalámbrica se expande añadiendo nuevos APs que habrá que cablear hasta la red principal.

Imágen tomada de http://www.ieee802.org/802_tutorials/06-November/802.11s_Tutorial_r5.pdf, diapositiva 7.

Una red Mesh también está formada por uno o más APs conectados por cable a red principal. A difertencia de la red wifi tradicional, la cobertura inalámbrica se expande añadiendo nuevos APs conectados inalámbricamente a los nodos ya existentes. La red Mesh se autogestiona buscando la ruta más eficiente en cada momento.

Imágen tomada de http://www.ieee802.org/802_tutorials/06-November/802.11s_Tutorial_r5.pdf, diapositiva 19.

En una red Mesh coexisten nodos de tres tipos: Mesh Portal, Mesh Point y Mesh AP.
En línea
raphik
******
Desconectado Desconectado

Mensajes: 481



Ver Perfil
« Respuesta #7 : 16-01-2018, 23:47 (Martes) »

Sin tener un objetivo claro, estuve siguiendo sin éxito este post https://www.gl-inet.com/forums/topic/simple-802-11s-meshing/.

Ahora me he centrado en montar un nodo tipo Mesh Portal en un router HG553 con LEDE. Por un lado irá cableado al router principal (ISP) y por otro irá conectado inalámbricamente a futuros nodos Mesh (ya veremos si Mesh Point o Mesh AP).
« Última modificación: 16-01-2018, 23:55 (Martes) por raphik » En línea
jmcabgam
**
Desconectado Desconectado

Mensajes: 42


Ver Perfil
« Respuesta #8 : 17-01-2018, 00:29 (Mi?rcoles) »

Muy bien explicado, Raphik, es lo que me gustaría probar. Yo dispongo de dos HG556a para hacer pruebas, ambos montan atheros.

Iré publicando avances.

En línea
eduperez
*****
Desconectado Desconectado

Mensajes: 199


Ver Perfil
« Respuesta #9 : 17-01-2018, 17:54 (Mi?rcoles) »

Digamos que buscaba algo semejante al Aimesh de asus... ya que actualmente tengo un HG556a generando una wifi en el fondo de la casa y otro al principio, pero tengo que cambiar manualmente de la wifi del primer router al segundo (o viceversa) cuando me muevo entre las diversas coberturas wifis. La idea es que esto se haga automáticamente y sea transparente para el cliente.

Fíjate en el esquema que ha puesto @raphik: una red de tipo mesh (802.11s) te sirve para gestionar el tráfico entre APs, pero los clientes se seguirán conectando a las APs como siempre, y tendrás los mismos problemas que ahora. Lo que tú necesitas es poder hacer roaming (802.11r). Mira si esta guía te sirve: https://www.reddit.com/r/openwrt/comments/515oea/finally_got_80211r_roaming_working/
En línea
raphik
******
Desconectado Desconectado

Mensajes: 481



Ver Perfil
« Respuesta #10 : 18-01-2018, 18:42 (Jueves) »

@eduperez. Efectivamente, el problema se puede resolver cableando varios APs, todos con el mismo SSID, misma encriptación, misma contraseña, distintas IPs dentro de la misma subred, y distintos canales no solapables. Muy importante no solapar canales: El mito de los once canales. Pero de esto ya se ha hablado en en algún qué otro post.

O también se podría utilizar el tema de la ampliación de la cobertura y de la itinerancia como simple pretexto para aprender y compartir conocimientos sobre tecnología Mesh en LEDE, de la que tan poca información hay en Internet.
En línea
raphik
******
Desconectado Desconectado

Mensajes: 481



Ver Perfil
« Respuesta #11 : 18-01-2018, 20:13 (Jueves) »

Comando para determinar si nuestro router soporta el modo Mesh (802.11s):
FUENTE: https://wiki.openwrt.org/doc/howto/mesh.80211s
Código:
iw list
Hay que mirar que en la sección "Supported interface modes:" aparezca la línea "* mesh point"

HG556a (version B)
Citar
Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * WDS
         * monitor
         * mesh point
         * P2P-client
         * P2P-GO

HG553:
Citar
Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * monitor
         * mesh point


En línea
eduperez
*****
Desconectado Desconectado

Mensajes: 199


Ver Perfil
« Respuesta #12 : 19-01-2018, 09:09 (Viernes) »

O también se podría utilizar el tema de la ampliación de la cobertura y de la itinerancia como simple pretexto para aprender y compartir conocimientos sobre tecnología Mesh en LEDE, de la que tan poca información hay en Internet.

Sí, por supuesto; para eso estamos aquí, no? Simplemente quería aclarar el tema, para que el compañero que ha abierto el hilo no se lleve una decepción.
En línea
raphik
******
Desconectado Desconectado

Mensajes: 481



Ver Perfil
« Respuesta #13 : 19-01-2018, 21:08 (Viernes) »

Después de algunas pruebas fallidas con HG553, he conseguido conectar dos nodos tipo Mesh Point montados sobre dos routers HG556a tipo B (Atheros) con LEDE 17.01.4.
FUENTE: https://wwwvs.cs.hs-rm.de/vs-wiki/images/9/9a/11sMesh_SoHoRoutern_OpenWRT.pdf

Partimos de un router router principal con conexión a Internet e IP estática 192.168.1.2. Este router no forma parte de la red Mesh.

Instalación del primer nodo Mesh Point:
- Conectar el router por cable al router principal.
- Instalar LEDE.
- Ponerle IP estática 192.168.1.3, puerta de enlace 192.168.1.2 y DNS 192.168.1.2.
- Eliminar el paquete wpad-mini e instalar los paquetes wpad y authsae.
- Crear una interfaz inalámbrica en modo mesh sobre el radio0 (editar fichero /etc/config/wireless).
Citar
config wifi-iface
   option device 'radio0'
   option mode 'mesh'
   option network 'interfaz_mesh'
   option ssid 'Nodo 1'
   option mesh_id 'mi-red-mesh'
   option encryption 'authsae'
   option key 'MiClaveSuperSecreta'

- Configurar la interfaz inalámbrica recién creada (editar fichero /etc/config/network).
Citar
config interface 'interfaz_mesh'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.88.3'

Instalación del segundo nodo Mesh Point:
- Conectar el router por cable al router principal.
- Instalar LEDE.
- Ponerle IP estática 192.168.1.4, puerta de enlace 192.168.1.2 y DNS 192.168.1.2.
- Eliminar el paquete wpad-mini e instalar los paquetes wpad y authsae.
- Crear una interfaz inalámbrica en modo mesh sobre el radio0 (editar fichero /etc/config/wireless).
Citar
config wifi-iface
   option device 'radio0'
   option mode 'mesh'
   option network 'interfaz_mesh'
   option ssid 'Nodo 2'
   option mesh_id 'mi-red-mesh'
   option encryption 'authsae'
   option key 'MiClaveSuperSecreta'

- Configurar la interfaz inalámbrica recién creada (editar fichero /etc/config/network).
Citar
config interface 'interfaz_mesh'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.88.4'

No olvidar levantar la wifi cada vez que se cambia el fichero /etc/config/wireless.

Las interfaces de ambos routers quedan conectadas inalámbricamente, respondiendo al ping de la otra.

Código:
root@LEDE:~# ping -I 192.168.88.3 192.168.88.4
PING 192.168.88.4 (192.168.88.4) from 192.168.88.3: 56 data bytes
64 bytes from 192.168.88.4: seq=0 ttl=64 time=5.308 ms
64 bytes from 192.168.88.4: seq=1 ttl=64 time=2.116 ms
64 bytes from 192.168.88.4: seq=2 ttl=64 time=5.304 ms



Queda pendiente:
- Nodo tipo Mesh Portal (bridge LAN-MESH).
- Nodo tipo Mesh AP (bridge MESH-AP).

Saludos.
« Última modificación: 20-01-2018, 11:03 (S?bado) por raphik » En línea
Ficht
*******
Desconectado Desconectado

Mensajes: 538



Ver Perfil
« Respuesta #14 : 20-01-2018, 11:14 (S?bado) »

Después de algunas pruebas fallidas con HG553, he conseguido conectar dos nodos tipo Mesh Point montados sobre dos routers HG556a tipo B (Atheros) con LEDE 17.01.4.
FUENTE: https://wwwvs.cs.hs-rm.de/vs-wiki/images/9/9a/11sMesh_SoHoRoutern_OpenWRT.pdf

Partimos de un router router principal con conexión a Internet e IP estática 192.168.1.2. Este router no forma parte de la red Mesh.

Instalación del primer nodo Mesh Point:
- Conectar el router por cable al router principal.
- Instalar LEDE.
- Ponerle IP estática 192.168.1.3, puerta de enlace 192.168.1.2 y DNS 192.168.1.2.
- Eliminar el paquete wpad-mini e instalar los paquetes wpad y authsae.
- Crear una interfaz inalámbrica en modo mesh sobre el radio0 (editar fichero /etc/config/wireless).
Citar
config wifi-iface
   option device 'radio0'
   option mode 'mesh'
   option network 'interfaz_mesh'
   option ssid 'Nodo 1'
   option mesh_id 'mi-red-mesh'
   option encryption 'authsae'
   option key 'MiClaveSuperSecreta'

- Configurar la interfaz inalámbrica recién creada (editar fichero /etc/config/network).
Citar
config interface 'interfaz_mesh'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.88.3'

Instalación del segundo nodo Mesh Point:
- Conectar el router por cable al router principal.
- Instalar LEDE.
- Ponerle IP estática 192.168.1.4, puerta de enlace 192.168.1.2 y DNS 192.168.1.2.
- Eliminar el paquete wpad-mini e instalar los paquetes wpad y authsae.
- Crear una interfaz inalámbrica en modo mesh sobre el radio0 (editar fichero /etc/config/wireless).
Citar
config wifi-iface
   option device 'radio0'
   option mode 'mesh'
   option network 'interfaz_mesh'
   option ssid 'Nodo 2'
   option mesh_id 'mi-red-mesh'
   option encryption 'authsae'
   option key 'MiClaveSuperSecreta'

- Configurar la interfaz inalámbrica recién creada (editar fichero /etc/config/network).
Citar
config interface 'interfaz_mesh'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.88.4'

No olvidar levantar la wifi cada vez que se cambia el fichero /etc/config/wireless.

Las interfaces de ambos routers quedan conectadas inalámbricamente, respondiendo al ping de la otra.

Código:
root@LEDE:~# ping -I 192.168.88.3 192.168.88.4
PING 192.168.88.4 (192.168.88.4) from 192.168.88.3: 56 data bytes
64 bytes from 192.168.88.4: seq=0 ttl=64 time=5.308 ms
64 bytes from 192.168.88.4: seq=1 ttl=64 time=2.116 ms
64 bytes from 192.168.88.4: seq=2 ttl=64 time=5.304 ms



Queda pendiente:
- Nodo tipo Mesh Portal (bridge LAN-MESH).
- Nodo tipo Mesh AP (bridge MESH-AP).

Saludos.
raphik ; ¿Y en este modo se tiene acceso al resto de la 'lan' una ves que nevegas desde la mesh ?

Enviado desde mi PRA-LX1 mediante Tapatalk

En línea
raphik
******
Desconectado Desconectado

Mensajes: 481



Ver Perfil
« Respuesta #15 : 20-01-2018, 11:50 (S?bado) »

@Fitch. Estás preguntando justo por el siguiente reto pendiente, que son los nodos Mesh Portal.
Supongo que habrá que establecer un puente entre la interfaz cableada y la inalámbrica y configurar el enrutado y el cortafuegos. Es cuestión de ponerse, a ver si lo logramos.


Otra cosa. Sólo tengo dos HG556a con atheros, asi que no he podido averiguar cómo se comportan los Mesh Points cuando hay más de dos . ¿Se establecerá múltiples conexiones entre ellos?


Otra cosa más que ma gustaría comprobar. Supongamos dos Mesh Points tan distantes (Nodo 1 y Nodo 3) que no hay conectividad entre ellos. ¿Un nodo intermedio (Nodo 2) los conectaría sin que haya que configurar nada más?
« Última modificación: 20-01-2018, 12:10 (S?bado) por raphik » En línea
raphik
******
Desconectado Desconectado

Mensajes: 481



Ver Perfil
« Respuesta #16 : 20-01-2018, 14:21 (S?bado) »

¡FUNCIONANDO!

ESQUEMA


Para configurar los routers, he adaptado la receta https://wiki.openwrt.org/doc/recipes/bridgedap. Al Mesh AP, le he añadido un pincho inalámbrico como segundo radio.

MESH PORTAL, IP 192.168.1.3 (Router HG556a B)
- Instalar LEDE.
- Eliminar paquete wpad-mini (opkg remove wpad-mini).
- Instalar paquetes wpad y authsae (opkg install wpad authsae).
- Fichero /etc/config/network (éste es el mío completo):
Citar
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fd35:6f7c:0e37::/48'

config interface 'lan'
   option type 'bridge'
   option ifname 'eth0.1'
   option proto 'static'
   option netmask '255.255.255.0'
   option ip6assign '60'
   option ipaddr '192.168.1.3'
   option gateway '192.168.1.2'
   option dns '192.168.1.2'

config switch
   option name 'switch0'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'switch0'
   option vlan '1'
   option ports '0 1 2 3 5t'

- Fichero /etc/config/wireless (éste es el mío completo):
Citar
config wifi-device 'radio0'
   option type 'mac80211'
   option channel '1'
   option hwmode '11ng'
   option path 'pci0000:00/0000:00:01.0'
   option htmode 'HT40'

config wifi-iface
   option device 'radio0'
   option mode 'mesh'
   option network 'lan'
   option ssid 'Nodo 1'
   option mesh_id 'mi-red-mesh'
   option encryption 'authsae'
   option key 'MiClaveSuperSecreta'

- Deshabilitar dnsmasq
Código:
root@LEDE:~# /etc/init.d/dnsmasq disable

- Y aplicar los cambios.
Código:
root@LEDE:~#  wifi

MESH AP, IP 192.168.1.4 (Router HG556a B con pincho USB DWL-G122)
- Instalar LEDE.
- Eliminar paquete wpad-mini (opkg remove wpad-mini).
- Instalar paquetes wpad y authsae (opkg install wpad authsae).
- Fichero /etc/config/network, sección "config interface lan":
Citar
config interface 'lan'
   option type 'bridge'
   option ifname 'eth0.1'
   option proto 'static'
   option ipaddr '192.168.1.4'
   option gateway '192.168.1.2'
   option dns '192.168.1.2'
   option netmask '255.255.255.0'
   option ip6assign '60'

- Fichero /etc/config/wireless, (el mío completo es así):
Citar
config wifi-device 'radio0'
   option type 'mac80211'
   option channel '1'
   option path 'pci0000:00/0000:00:01.0'
   option htmode 'HT20'
   option country '00'
   option hwmode '11g'

config wifi-iface
   option device 'radio0'
   option mode 'mesh'
   option network 'lan'
   option ssid 'MESHPOINT'
   option mesh_id 'mi-red-mesh'
   option encryption 'authsae'
   option key 'MiClaveSuperSecreta'

config wifi-device 'radio1'
   option type 'mac80211'
   option channel '11'
   option hwmode '11g'
   option path 'platform/ehci-platform/usb1/1-2/1-2:1.0'

config wifi-iface
   option device 'radio1'
   option mode 'ap'
   option network 'lan'
   option ssid 'MESHAP'
   option encryption 'psk2'
   option key 'ClaveWifi'

- Deshabilitar dnsmasq
Código:
root@LEDE:~# /etc/init.d/dnsmasq disable

- Y aplicar los cambios.
Código:
root@LEDE:~# wifi
« Última modificación: 21-01-2018, 01:20 (Domingo) por raphik » En línea
raphik
******
Desconectado Desconectado

Mensajes: 481



Ver Perfil
« Respuesta #17 : 21-01-2018, 23:28 (Domingo) »

Hay una lista de chips compatibles con mesh aquí: https://wikidevi.com/wiki/Wireless_adapters/Chipset_table


Mis pruebas:

- HG556a tipo B (Atheros). Compatible con Mesh. Como nada más que tengo dos, no he podido montar una verdadera red. Pocas pruebas he podido hacer, pero se ve que funcionan.

- HG556a tipo C (Ralink). Monta un chip RT3062F incompatible con Mesh.

- HG553. Incompatible a pesar de tener un chip Broadcom 4318, en teoría compatible.

- AR-5387un. Con un chip BCM43225 tenía que haber funcionado con el driver b43. Pero no.

- También he probado un par de pinchos wifi con chips RT2870 y RT2571W a sabiendas que no soportaban Mesh.

Saludos.
En línea
Páginas: [1] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums