Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
25-04-2017, 16:25 (Martes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.0 version final para descargar



+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  Donde configuro DNAT ?
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Ir Abajo Imprimir
Autor Tema: Donde configuro DNAT ?  (Leído 243 veces)
peperfus
*****
Desconectado Desconectado

Mensajes: 101


Ver Perfil WWW
« : 05-04-2017, 00:04 (Mi?rcoles) »

Hola, estoy intentando seguir un tutorial interesante para hacer que los usuarios de la red usen obligatoriamente las DNS del router, aunque pongan otras en su configuración...

Es este:

https://paul.is-a-geek.org/2015/06/dns-based-adblock-using-openwrt-opendns-and-dnsmasq/

Pero no encuentro en apartado del firewall de luci de Chaos Calmer, el DNAT. Sí está el SNAT, pero no el DNAT.

¿Hay alguna forma de configurarlo (DNAT) mediante luci?

Gracias.
En línea
eduperez
*****
Desconectado Desconectado

Mensajes: 150


Ver Perfil
« Respuesta #1 : 05-04-2017, 18:14 (Mi?rcoles) »

Yo tampoco lo encontré, pero en la sección "custom rules" puedes poner las llamadas a IPTABLES que quieras:
Código:
iptables -t nat -A PREROUTING -i eth0 -p udp --dport 53 -j DNAT --to 192.168.1.254
iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 53 -j DNAT --to 192.168.1.254
Obviamente, tendrás que adaptarlo a tus parámetros de red.
En línea
peperfus
*****
Desconectado Desconectado

Mensajes: 101


Ver Perfil WWW
« Respuesta #2 : 05-04-2017, 22:40 (Mi?rcoles) »

Gracias
En línea
peperfus
*****
Desconectado Desconectado

Mensajes: 101


Ver Perfil WWW
« Respuesta #3 : 22-04-2017, 01:08 (S?bado) »

Supuestamente, al poner cualquier dirección IP en las dns del cliente, debería redirigir las peticiones al propio router, sin embargo, no me va.

Lo que he hecho es añadir esas dos líneas que me has puesto al apartado custom rules, darle a submit y luego reiniciarlo (no sabía si era necesario, pero por si a caso).

Luego he configurado 2 DNS incorrectas en un ordenador cliente de la red:
DNS1 = 11.22.33.44
DNS2 = 55.66.77.88

He intentado resolver una petición y me ha dado error.
(por ejemplo, ping www.google.es).

No sé por qué está pasando esto. Debería funcionar. ¿Alguna idea?


EDITO:
Ok, creo que ya sé lo que es. Es que mi interfaz de red no se llama eth0, puesto que tengo configuradas 2 vlans (wan y lan) (router neutro).
Supongo que si cambio eth0 por br-lan (eth0.2+wifi)...

MOLA.
 Angry Angry Angry
« Última modificación: 22-04-2017, 01:27 (S?bado) por peperfus » En línea
Páginas: [1] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums