Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
26-09-2017, 05:44 (Martes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt & LEDE (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)
0 Usuarios y 2 Visitantes están viendo este tema. « anterior próximo »
Páginas: 1 ... 57 58 59 60 61 [62] Ir Abajo Imprimir
Autor Tema: [Tutorial] Movistar FTTH con OpenWrt (VOIP e Imagenio)  (Leído 500706 veces)
deskect
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #1220 : 01-07-2017, 14:56 (S?bado) »

Buenas,

TL;DR;

TP-Link TL-WR1043ND V1 no levanta WAN PPPoE configurado con script Noltari y FW LEDE (17.1.02 y snapshot).

El log es como siguie (ojo, hay dos 'uci: Entry not found' que no se si pueden ser importantes o no):

Yo estoy usando la ultima snapshot de lede la .02, y me funciona bien. Pero yo no utilizo el script, simplemente meto la config a mano para tener internet, me descargo los paquetes para que funcione la television y luego edito la config del mcproxy y demás a mano tmb.

Puedes pegar tu /etc/config/network, a ver si hay algo raro.
En línea
jrierab
**
Desconectado Desconectado

Mensajes: 7


Ver Perfil
« Respuesta #1221 : 01-07-2017, 21:29 (S?bado) »

Yo estoy usando la ultima snapshot de lede la .02, y me funciona bien. Pero yo no utilizo el script, simplemente meto la config a mano para tener internet, me descargo los paquetes para que funcione la television y luego edito la config del mcproxy y demás a mano tmb.

Puedes pegar tu /etc/config/network, a ver si hay algo raro.

Sí, yo también lo había configurado a mano, pero al no conseguirlo probé con el script. Este es el archivo network

Código:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fddf:8e3f:d0c6::/48'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 5t'

config switch_vlan
option device 'switch0'
option vlan '6'
option ports '0t 5t'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ip6assign '60'
option ipaddr '192.168.32.1'
option netmask '255.255.255.0'

config interface 'wan'
option ifname 'eth0.6'
option proto 'pppoe'
option username 'adslppp@telefonicanetpa'
option password 'adslppp'
option ipv6 '1'
# option mtu '1492'
option pppd_options 'debug'

config interface 'wan6'
option ifname 'eth0.6'
option proto 'dhcpv6'

@deskect gracias por echarle un ojo, a ver si ves algo raro.  Grin
En línea
deskect
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #1222 : 02-07-2017, 03:36 (Domingo) »

@deskect gracias por echarle un ojo, a ver si ves algo raro.  Grin

Lo tenemos practicamente igual, el mtu que me imagino que lo habrias comentado tu y añadido el debug, yo si tengo activado la opcion del mtu.

Y mi config del switch es:

Código:
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 6t'

config switch_vlan
        option device 'switch0'
        option vlan '6'
        option ports '1t 6t'


Pero mi router es un tp link archer c7, puedes probar con esa distribución de vlan a ver si da resultado, pero suele variar dependiendo del router y quizas por eso es por lo que la tenemos distinta.
En línea
jrierab
**
Desconectado Desconectado

Mensajes: 7


Ver Perfil
« Respuesta #1223 : 05-07-2017, 18:04 (Mi?rcoles) »

Lo tenemos prácticamente igual, el mtu que me imagino que lo habrias comentado tu y añadido el debug, yo si tengo activado la opcion del mtu.

El mtu lo tuve que quitar porque me saltaba un error:

Código:
Tue Jun 27 19:27:04 2017 daemon.err pppd[1838]: Interface eth0.6 has MTU of 1492 -- should be at least 1500.

Y el switch lo tenemos igual, salvando el tema puertos por ser distinto router, pero tageado igual. Me imagino que será un bug, porqué he visto alguien más con problemas por ahí.

De todos modos, ahora mismo no puedo probar nada, porque he brickeado el router haciendo pruebas. A ver si me acuerdo de como se soldaba y puedo recuperarlo por UART... Undecided
En línea
jrierab
**
Desconectado Desconectado

Mensajes: 7


Ver Perfil
« Respuesta #1224 : 05-07-2017, 21:37 (Mi?rcoles) »

Recuperado y funcionando con una Gargoyle 1.4.7 (antiiiigua) y la config que tenía entonces.

Código:
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option dns '192.168.33.1'
        option ipaddr '192.168.33.1'

config interface 'wan'
        option proto 'pppoe'
        option username 'adslppp@telefonicanetpa'
        option password ' adslppp'
        option keepalive '3 5'
        option ifname 'eth0.6'

config switch
        option name 'rtl8366rb'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '6'
        option ports '0t 5t'

WAN y LAN son casi idénticas a las que no me funcionaban en versiones más modernas y el switch está igual.  Undecided

Lo único que no veo por ahí es ni rastro del IPv6. Me parece que va a ser eso lo que está enredando...  Azn

Creo que voy a tener que dejarlo para alguien que tenga más conocimientos en IPV6 y sus mandangas con Movistar.
En línea
jrierab
**
Desconectado Desconectado

Mensajes: 7


Ver Perfil
« Respuesta #1225 : 07-07-2017, 21:18 (Viernes) »

Funcionando con la última de LEDE y Fast Path activado !!!

Al final, todo era un tontería. Se ve que en algún momento se cambió la opción por defecto del mtu_fix en la WAN y se puso a cero, por lo que no negociaba correctamente el MTU.

Total, que lo único que hay que hacer es editar /etc/config/firewall y ponerlo en la zona wan:

Código:
...
config zone
option name wan
list   network 'wan'
list   network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
        option mtu_fix 1
...


Le he puesto la versión experimental de LEDE con Fast Path activado. Más info en https://forum.lede-project.org/t/qualcomm-fast-path-for-lede/4582 y los FW más recientes (para algunos routers) están en https://github.com/gwlim/Fast-Path-LEDE-OpenWRT/tree/master/Fast-Path/July-2017.

Con esto he pasado de 70MB / 10MB en test de velocidad a 300MB / 250 MB, !!! Con el antiguo 1043NDv1. No está nada mal  Angry
En línea
deskect
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #1226 : 09-07-2017, 19:57 (Domingo) »

Funcionando con la última de LEDE y Fast Path activado !!!

Al final, todo era un tontería. Se ve que en algún momento se cambió la opción por defecto del mtu_fix en la WAN y se puso a cero, por lo que no negociaba correctamente el MTU.

Total, que lo único que hay que hacer es editar /etc/config/firewall y ponerlo en la zona wan:

Código:
...
config zone
option name wan
list   network 'wan'
list   network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
        option mtu_fix 1
...


Le he puesto la versión experimental de LEDE con Fast Path activado. Más info en https://forum.lede-project.org/t/qualcomm-fast-path-for-lede/4582 y los FW más recientes (para algunos routers) están en https://github.com/gwlim/Fast-Path-LEDE-OpenWRT/tree/master/Fast-Path/July-2017.

Con esto he pasado de 70MB / 10MB en test de velocidad a 300MB / 250 MB, !!! Con el antiguo 1043NDv1. No está nada mal  Angry

He estado leyendo el hilo del fastpath y parece muy interesante, aunque para los que tenemos tele habria que compilar lede con dichos parches + los paquetes de kmod-bridge y kmod-ipt-nathelper-rtsp, ya incluidos directamente en la build, puesto que debido a las modificaciones de dichos parches para fastpath despues no es posible instalar ningun kmod desde opkg, por lo que no funcionaria la television.
En línea
bruneleski
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #1227 : 25-07-2017, 20:13 (Martes) »

Hola a todos,

Acabo de planchar mi TP-LINK TL-WR841N/ND v8 con Chaos Calmer 15.05.1 y seguidamente he ejecutado el script de Noltari v21 sin VOIP (tengo el teléfono por cobre) y sin IPTV.
(Muchas gracias Noltari, qué gran trabajo!)

Tengo la ONT en el puerto Wan, el de color gris.

Después del reinicio tengo internet por wifi sin problemas PERO no soy capaz de conectar nada por los puertos Ethernet y lo necesito para conectar una NAS.

El router no me asigna una IP por DHCP por la lan, he probado con el PC fijando una IP y tampoco es capaz de comunicarse (falla el ping a la 192.168.1.1 del router)

Sabeis que puede estar pasando?

Este es el log del movistar.log:


Código:
root@OpenWrt:/etc# cat movistar.log
system type : Atheros AR9341 rev 3
machine : TP-LINK TL-WR841N/ND v8
processor : 0
cpu model : MIPS 74Kc V4.12
BogoMIPS : 266.64
wait instruction : yes
microsecond timers : yes
tlb_entries : 32
extra interrupt vector : yes
hardware watchpoint : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
isa : mips1 mips2 mips32r1 mips32r2
ASEs implemented : mips16 dsp dsp2
shadow register sets : 1
kscratch registers : 0
package : 0
core : 0
VCED exceptions : not available
VCEI exceptions : not available

Movistar FTTH Configuration Script r21
OpenWrt Chaos Calmer 15.05.1 (ar71xx/generic)
Alvaro Fernandez Rojas (noltari@gmail.com)
---
Router not supported.
You need to set the switch config manually.
switch0: eth1(AR934X built-in switch), ports: 5 (cpu @ 0), vlans: 16
     --switch
Attribute 1 (int): enable_vlan (Enable VLAN mode)
Attribute 2 (none): apply (Activate changes in the hardware)
Attribute 3 (none): reset (Reset the switch)
     --vlan
Attribute 1 (int): vid (VLAN ID)
Attribute 2 (ports): ports (VLAN port mapping)
     --port
Attribute 1 (int): pvid (Primary VLAN ID)
Attribute 2 (string): link (Get port link information)
Found: switch0 - eth1
Switch Info
Switch Ports: 5 [0 1 2 3 4]
Switch CPU Port: 0
Switch WAN Port: Unknown
Switch LAN Ports: Unknown
---
Please specify WAN port number
1
---
Switch Info
Switch Ports: 5 [0 1 2 3 4]
Switch CPU Port: 0
Switch WAN Port: 1
Switch LAN Ports: 2 3 4
---
Customize LAN Network? (def 192.168.1.1/24) (y/n)
n
---
Enable VOIP? (y/n)
n
Enable IPTV? (y/n)
n
WAN
---
---
Network config erased
cfg043777
cfg051ec7
cfg061ec7
Network config loaded
Network config applied
uci: Entry not found
uci: Entry not found
cfg1edc81
cfg1fdc81
cfg20ad58

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config rule
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'wan'
list network 'wan6'

config forwarding
option src 'lan'
option dest 'wan'

Firewall config saved
DNS rebind protection enabled
---
Configuration done!
Make log persistent? (y/n)
y
root@OpenWrt:/etc

Por más que miro no doy con ello.

Muchas gracias de antemano!
En línea
bruneleski
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #1228 : 06-08-2017, 20:30 (Domingo) »

Hola a todos,

Acabo de planchar mi TP-LINK TL-WR841N/ND v8 con Chaos Calmer 15.05.1 y seguidamente he ejecutado el script de Noltari v21 sin VOIP (tengo el teléfono por cobre) y sin IPTV.
(Muchas gracias Noltari, qué gran trabajo!)

Tengo la ONT en el puerto Wan, el de color gris.

Después del reinicio tengo internet por wifi sin problemas PERO no soy capaz de conectar nada por los puertos Ethernet y lo necesito para conectar una NAS.

El router no me asigna una IP por DHCP por la lan, he probado con el PC fijando una IP y tampoco es capaz de comunicarse (falla el ping a la 192.168.1.1 del router)

Sabeis que puede estar pasando?

Este es el log del movistar.log:


Código:
root@OpenWrt:/etc# cat movistar.log
system type : Atheros AR9341 rev 3
machine : TP-LINK TL-WR841N/ND v8
processor : 0
cpu model : MIPS 74Kc V4.12
BogoMIPS : 266.64
wait instruction : yes
microsecond timers : yes
tlb_entries : 32
extra interrupt vector : yes
hardware watchpoint : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
isa : mips1 mips2 mips32r1 mips32r2
ASEs implemented : mips16 dsp dsp2
shadow register sets : 1
kscratch registers : 0
package : 0
core : 0
VCED exceptions : not available
VCEI exceptions : not available

Movistar FTTH Configuration Script r21
OpenWrt Chaos Calmer 15.05.1 (ar71xx/generic)
Alvaro Fernandez Rojas (noltari@gmail.com)
---
Router not supported.
You need to set the switch config manually.
switch0: eth1(AR934X built-in switch), ports: 5 (cpu @ 0), vlans: 16
     --switch
Attribute 1 (int): enable_vlan (Enable VLAN mode)
Attribute 2 (none): apply (Activate changes in the hardware)
Attribute 3 (none): reset (Reset the switch)
     --vlan
Attribute 1 (int): vid (VLAN ID)
Attribute 2 (ports): ports (VLAN port mapping)
     --port
Attribute 1 (int): pvid (Primary VLAN ID)
Attribute 2 (string): link (Get port link information)
Found: switch0 - eth1
Switch Info
Switch Ports: 5 [0 1 2 3 4]
Switch CPU Port: 0
Switch WAN Port: Unknown
Switch LAN Ports: Unknown
---
Please specify WAN port number
1
---
Switch Info
Switch Ports: 5 [0 1 2 3 4]
Switch CPU Port: 0
Switch WAN Port: 1
Switch LAN Ports: 2 3 4
---
Customize LAN Network? (def 192.168.1.1/24) (y/n)
n
---
Enable VOIP? (y/n)
n
Enable IPTV? (y/n)
n
WAN
---
---
Network config erased
cfg043777
cfg051ec7
cfg061ec7
Network config loaded
Network config applied
uci: Entry not found
uci: Entry not found
cfg1edc81
cfg1fdc81
cfg20ad58

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config rule
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'wan'
list network 'wan6'

config forwarding
option src 'lan'
option dest 'wan'

Firewall config saved
DNS rebind protection enabled
---
Configuration done!
Make log persistent? (y/n)
y
root@OpenWrt:/etc

Por más que miro no doy con ello.

Muchas gracias de antemano!

Nadie sabe por donde puede ir el problema de los puertos ethernet?..
En línea
eduperez
*****
Desconectado Desconectado

Mensajes: 181


Ver Perfil
« Respuesta #1229 : 22-08-2017, 08:58 (Martes) »

Pon aquí el contenido de /etc/config/network, por favor.
En línea
bruneleski
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #1230 : 22-08-2017, 20:54 (Martes) »

Pon aquí el contenido de /etc/config/network, por favor.

Hola eduperez, esto es la configuració que hay:

Código:
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd07:6047:4f66::/48'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '2 3 4 0t'

config switch_vlan
option device 'switch0'
option vlan '6'
option ports '1t 0t'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ip6assign '60'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

config interface 'wan'
option ifname 'eth0.6'
option proto 'pppoe'
option username 'adslppp@telefonicanetpa'
option password 'adslppp'
option ipv6 '1'
option mtu '1492'

config interface 'wan6'
option ifname 'eth0.6'
option proto 'dhcpv6'

root@OpenWrt:~#

Gracias
En línea
eduperez
*****
Desconectado Desconectado

Mensajes: 181


Ver Perfil
« Respuesta #1231 : 25-08-2017, 15:52 (Viernes) »

Pon aquí el contenido de /etc/config/network, por favor.

Hola eduperez, esto es la configuració que hay:

Código:
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd07:6047:4f66::/48'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '2 3 4 0t'

config switch_vlan
option device 'switch0'
option vlan '6'
option ports '1t 0t'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ip6assign '60'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

config interface 'wan'
option ifname 'eth0.6'
option proto 'pppoe'
option username 'adslppp@telefonicanetpa'
option password 'adslppp'
option ipv6 '1'
option mtu '1492'

config interface 'wan6'
option ifname 'eth0.6'
option proto 'dhcpv6'

root@OpenWrt:~#

Gracias

Estás seguro de que tienes esa versión y ese dispositivo?

Según la descripción en https://wiki.openwrt.org/toh/tp-link/tl-wr841nd, tu router tiene conectado el puerto WAN directamente a uno de los puertos de la CPU (eth0 en v8, y eth1 en v9 / v10). Cuando esto ocurre, no es posible configurar las VLANs en el puerto WAN, y lo que se hace es apartar uno de los puertos LAN para este propósito. Aparentemente, esto es lo que se ha hecho en la configuración que comentas; pero veo que se está usando eth0, lo que indicaría que WAN está en eth1, y por tanto es un v9 o v10.

En cualquier caso, tendrías que conectar la ONT al puerto LAN reservado (LAN 4, si no estoy equivocado) para tener internet, y los clientes wifi no deberían tener internet tal y como lo has conectado ahora (¿tienes internet en los clientes wifi?). Los demás puertos de LAN sí te deberían funcionar normalmente, pero si conectas un PC a ese puerto reservado no tendrás DHCP ni podrás conectar con el router, porque está configurado como WAN.

EDITO: Veo que en el log del script dice que detecta el switch en eth1... eso cuadraría con un v8, pero entonces en la configuración de los interfaces de LAN y WAN se debería usar eth1.x en lugar de eth0.x; y sigo sin entender que tengas internet por wifi.

EDITO2: si realmente tienes un TP-LINK TL-WR841N/ND v8 y los clientes wifi tienen red pero no internet (y sólo si se cumplen estas condiciones, porque de lo contrario estoy equivocado), haz lo siguiente:
  • Cambia los eth0.x por eth1.x en la configuración de LAN y WAN.
  • Conecta la ONT al puerto LAN4.
  • Comprueba que tengas internet en los dispositivos wifi.
  • Conecta los demás dispositivos a los otros puertos LAN, y comprueba que tengas internet también.
« Última modificación: 25-08-2017, 16:09 (Viernes) por eduperez » En línea
bruneleski
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #1232 : 25-08-2017, 19:05 (Viernes) »

Pon aquí el contenido de /etc/config/network, por favor.

Hola eduperez, esto es la configuració que hay:

Código:
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd07:6047:4f66::/48'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '2 3 4 0t'

config switch_vlan
option device 'switch0'
option vlan '6'
option ports '1t 0t'

config interface 'lan'
option ifname 'eth0.1'
option type 'bridge'
option proto 'static'
option ip6assign '60'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

config interface 'wan'
option ifname 'eth0.6'
option proto 'pppoe'
option username 'adslppp@telefonicanetpa'
option password 'adslppp'
option ipv6 '1'
option mtu '1492'

config interface 'wan6'
option ifname 'eth0.6'
option proto 'dhcpv6'

root@OpenWrt:~#

Gracias

Estás seguro de que tienes esa versión y ese dispositivo?

Según la descripción en https://wiki.openwrt.org/toh/tp-link/tl-wr841nd, tu router tiene conectado el puerto WAN directamente a uno de los puertos de la CPU (eth0 en v8, y eth1 en v9 / v10). Cuando esto ocurre, no es posible configurar las VLANs en el puerto WAN, y lo que se hace es apartar uno de los puertos LAN para este propósito. Aparentemente, esto es lo que se ha hecho en la configuración que comentas; pero veo que se está usando eth0, lo que indicaría que WAN está en eth1, y por tanto es un v9 o v10.

En cualquier caso, tendrías que conectar la ONT al puerto LAN reservado (LAN 4, si no estoy equivocado) para tener internet, y los clientes wifi no deberían tener internet tal y como lo has conectado ahora (¿tienes internet en los clientes wifi?). Los demás puertos de LAN sí te deberían funcionar normalmente, pero si conectas un PC a ese puerto reservado no tendrás DHCP ni podrás conectar con el router, porque está configurado como WAN.

EDITO: Veo que en el log del script dice que detecta el switch en eth1... eso cuadraría con un v8, pero entonces en la configuración de los interfaces de LAN y WAN se debería usar eth1.x en lugar de eth0.x; y sigo sin entender que tengas internet por wifi.

EDITO2: si realmente tienes un TP-LINK TL-WR841N/ND v8 y los clientes wifi tienen red pero no internet (y sólo si se cumplen estas condiciones, porque de lo contrario estoy equivocado), haz lo siguiente:
  • Cambia los eth0.x por eth1.x en la configuración de LAN y WAN.
  • Conecta la ONT al puerto LAN4.
  • Comprueba que tengas internet en los dispositivos wifi.
  • Conecta los demás dispositivos a los otros puertos LAN, y comprueba que tengas internet también.

Hola eduperez,

Gracias. Pues confirmo que tengo un TP-LINK TL-WR841N/ND v8.2, con el cable a la ONT en el puerto de WAN (el puerto gris) y con Internet por wifi sin ningún problema :S

No poder conectarme por los 4 puertos LAN es lo que me deja perplejo, entonces está todo correcto?? Confirmado que no es un fallo físico de los puertos ya que no funcionan después de ejecutar el script de de Noltari v21, antes de ejecutarlo puedo conectar por cable sin problema alguno (es de configuración...)

No se por donde tirar ya...
En línea
eduperez
*****
Desconectado Desconectado

Mensajes: 181


Ver Perfil
« Respuesta #1233 : 25-08-2017, 19:08 (Viernes) »

Hola eduperez,

Gracias. Pues confirmo que tengo un TP-LINK TL-WR841N/ND v8.2, con el cable a la ONT en el puerto de WAN (el puerto gris) y con Internet por wifi sin ningún problema :S

No poder conectarme por los 4 puertos LAN es lo que me deja perplejo, entonces está todo correcto?? Confirmado que no es un fallo físico de los puertos ya que no funcionan después de ejecutar el script de de Noltari v21, antes de ejecutarlo puedo conectar por cable sin problema alguno (es de configuración...)

No se por donde tirar ya...

Sube por favor el fichero /etc/config/network que tenías antes de usar el script, a ver si averiguamos qué está pasando.
En línea
bruneleski
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #1234 : 26-08-2017, 00:25 (S?bado) »

Hola eduperez,

Gracias. Pues confirmo que tengo un TP-LINK TL-WR841N/ND v8.2, con el cable a la ONT en el puerto de WAN (el puerto gris) y con Internet por wifi sin ningún problema :S

No poder conectarme por los 4 puertos LAN es lo que me deja perplejo, entonces está todo correcto?? Confirmado que no es un fallo físico de los puertos ya que no funcionan después de ejecutar el script de de Noltari v21, antes de ejecutarlo puedo conectar por cable sin problema alguno (es de configuración...)

No se por donde tirar ya...

Sube por favor el fichero /etc/config/network que tenías antes de usar el script, a ver si averiguamos qué está pasando.

No tengo acceso al TP-LINK en unos días Sad, postearé la configuración al hacerme con ella.

Gracias!
En línea
Páginas: 1 ... 57 58 59 60 61 [62] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums