Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
19-10-2017, 13:03 (Jueves)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt & LEDE (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] 2 3 4 5 6 ... 19 Ir Abajo Imprimir
Autor Tema: [Tutorial] Modo Cliente/Repetidor/WDS con OpenWrt  (Leído 279994 veces)
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« : 09-07-2012, 23:44 (Lunes) »

[Tutorial] Modo Cliente/Repetidor/WDS con Openwrt
En este tutorial se explica cómo configurar cualquier router con openwrt en modo wds/cliente/repetidor de otra red WLAN.

Advertencias
Sed pacientes a la hora de que el router guarde y aplique los cambios con LuCI, a veces suele tardar un rato...
Puede que durante el tutorial diga expresamente que algo se realice de una forma concreta. Si sabes lo que estás haciendo puede ser que quieras configurarlo de otra forma Wink.
Las direcciones MAC del tutorial han sido eliminadas para proteger la privacidad de sus dueños.

Terminología
Router Principal: router con conexión a internet al que nos queremos conectar.
Router Secundario: router con openwrt que queremos configurar como cliente/repetidor.

Información adicional
Resetear el router a la configuración por defecto:
Interfaz de Comandos
Código:
mtd -r erase rootfs_data



Parte 1 :: Modo cliente enrutado (Routed Client Mode)

LuCI (Interfaz "WEB GUI")
0.- Iniciar sesión en el router a través de la "WEB GUI" LuCI.
Para ello ir a la url http://192.168.1.1/ y loguearse en el formulario de acceso.


1.- Si existe alguna interfaz WAN ya definida, eliminarla.
Para ello iremos a "Network->Interfaces" y pulsaremos el botón "Delete" en la interfaz WAN. Al presionar el botón nos saldrá un popup de confirmación en el que seleccionaremos "Aceptar".


2.- Cambiar la subred de la interfaz LAN del router a una distinta a la del router principal.
Después del paso 1, deberíamos seguir en la sección "Network->Interfaces". Pulsamos el botón "Edit" de la interfaz LAN.

Si el router principal tiene la subred "192.168.1.0/24" (192.168.1.x para los amigos Grin), pondremos por ejemplo la subred "192.168.2.0/24" en el router secundario. Para ello hay que cambiar las siguientes opciones:
Código:
IPv4 address: 192.168.2.1
IPv4 netmask: 255.255.255.0
Use custom DNS servers: 8.8.8.8
Accept router advertisements: sí
Advanced Settings/Physical Settings/Firewall Settings: dejarlo tal cual está por defecto, es decir activado sin tocar las opciones.
DHCP Server: Activar la opción "Dynamic DHCP" para que el servidor DHCP funcione.
Pulsar "Save & Apply" para guardar y aplicar los cambios.

Una vez aplicados los cambios el router habrá cambiado de dirección IP, por lo que pasado un tiempo prudencial (30-45 segundos) id a la siguiente URL, dependiendo de la subred que hayáis configurado: http://192.168.2.1/.
Tenéis que volver a iniciar sesión en el router.

3.- Conexión en modo cliente por WLAN al router principal.
Para ello iremos a "Network->Wifi". Una vez en la sección de configuración del Wifi el método más sencillo hacer un "Scan" y seleccionar la red WLAN del router principal.
Pulsamos el botón "Scan".

Pasados unos segundos el router nos mostrará todas las redes WLAN a su alcance. Pulsamos el botón "Join network" de la red del router principal. En mi caso es "WLAN".

Introducimos la contraseña de la red de nuestro router principal y dejamos el resto de opciones tal cual vienen por defecto. Pulsamos el botón "Submit".

El router nos llevará a otra página de configuración del wifi que es más bien una "confirmación" de lo ya hecho. Por ello hay que dejar todo como está (si nos fijamos la contraseña ya estará escrita).

Nos limitamos a darle al botón "Save & Apply".

Pasados unos segundos el router debería recargar la misma página después de aplicar los cambios.
Después de esto, el router ya debería tener conexión a internet, así como cualquier ordenador que conectemos por cable ethernet a él.


UCI (Interfaz de Comandos)
0.- Iniciar sesión en el router a través de Telnet/SSH.
Código:
telnet 192.168.1.1
Código:
ssh root@192.168.1.1

1.- Si existe alguna interfaz WAN ya definida, eliminarla.
Código:
uci del network.wan

2.- Cambiar la subred de la interfaz LAN del router a una distinta a la del router principal.
Código:
uci set network.lan.ipaddr=192.168.2.1
uci set network.lan.netmask=255.255.255.0
uci set network.lan.dns=8.8.8.8
uci set network.lan.nat=1
uci set network.lan.accept_ra=1

3.- Permitir las concesiones dinámicas en el servidor DHCP:
Código:
uci set dhcp.lan.dynamicdhcp=1

4.- Crear una interfaz para el WLAN.
Código:
uci set network.wan=interface
uci set network.wan.proto=dhcp

5.- Mostar la configuración wireless:
Código:
uci show wireless

6.- Habilitar la interfaz wireless: En mi caso, el dispositivo a editar es el "radio0" (Driver OpenSource de Broadcom)
Código:
uci set wireless.radio0.disabled=0
uci commit wireless
wifi

7.- Cambiar la configuración del wifi:
En mi caso, el dispositivo a editar es el "radio0" (Driver OpenSource de Broadcom).
El canal depende de la configuración wireless del router principal, siendo en mi caso el 1.
Código:
uci set wireless.radio0.channel=1
La red wifi a la que me quiero conectar se llama "WLAN", por tanto ése será el ssid.
Código:
uci set wireless.@wifi-iface[0].ssid=WLAN
Ponemos el modo cliente y cambiamos el network a WAN:
Código:
uci set wireless.@wifi-iface[0].mode=sta
uci set wireless.@wifi-iface[0].network=wan
En mi caso, la red a la que me quiero conectar tiene encriptación WPA2-PSK "psk2", para WPA-PSK utilizar "psk".
Código:
uci set wireless.@wifi-iface[0].encryption=psk2
Por último introducimos la contraseña:
Código:
uci set wireless.@wifi-iface[0].key=contraseña

8.- Cambiar la configuración del firewall:
Permitir el tráfico proveniente de la zona WAN:
Código:
uci set firewall.@zone[1].input=ACCEPT
uci set firewall.@zone[1].masq=1

9.- Aplicar todos los cambios y reiniciar el router:
Código:
uci commit
reboot

Ficheros de Configuración
En construcción...



Parte 2 :: Modo repetidor sobre cliente enrutado

LuCI (Interfaz "WEB GUI")
0.- Iniciar sesión en el router a través de la "WEB GUI" LuCI.
Para ello ir a la url http://192.168.1.1/ y loguearse en el formulario de acceso.


1.a-Router con 2+ tarjetas wifi
Si existe una segunda configuración para la interfaz radio0, eliminarla.
Para ello iremos a "Network->Wifi" y pulsaremos el botón "Remove" en la segunda configuración de la interfaz radio0. Al presionar el botón nos saldrá un popup de confirmación en el que seleccionaremos "Aceptar".
Una vez eliminada la configuración existente, crearemos una configuración nueva como punto de acceso. Para ello, pulsad el botón "Add".

1.b-Router con una única tarjeta wifi (Atheros)
Si existe alguna configuración para la interfaz radio1, eliminarla.
Para ello iremos a "Network->Wifi" y pulsaremos el botón "Remove" en la interfaz radio1. Al presionar el botón nos saldrá un popup de confirmación en el que seleccionaremos "Aceptar".
Una vez eliminada la configuración existente, crearemos una configuración nueva como punto de acceso. Para ello, pulsad el botón "Add".


2.- En este punto, explico la configuración crítica. Si queréis más información sobre la configuración de una red wifi como punto de acceso, buscad en Openwrt.
El canal, la transmisión y el ESSID lo podéis configurar a vuestro gusto.
El Modo tiene que estar en Access Point y el checkbox de la interfaz LAN ha de estar seleccionado obligatoriamente.
El resto de la configuración no hace falta tocarlo, podéis dejarlo tal como está.
Si queréis también podéis configurar el filtro por MAC y la contraseña del Wifi.


3.a-Router con 2+ tarjetas wifi
Una vez configurado el wifi, si vamos a "Network->Wifi" debería aparecer algo parecido a esto:

3.b-Router con una única tarjeta wifi (Atheros)
Una vez configurado el wifi, si vamos a "Network->Wifi" debería aparecer algo parecido a esto:


UCI (Interfaz de Comandos)
En construcción...

Ficheros de Configuración
En construcción...



Parte 3 :: WDS

LuCI (Interfaz "WEB GUI")

Para poder enlazar dos equipos mediante WDS hay algunos requisitos.

  • Ambos routers deben tener el mismo chipset wifi: atheros o broadcom (que yo sepa, son los únicos que dan soporte a este protocolo de interconexión)
  • Mismo firmware. Será muy difícil (o imposible) unirlos si uno de ellos tiene el original del fabricante, y el otro OpenWrt

En este tutorial vamos a usar 2 Huawei hg556a con wifi atheros y OpenWrt (Barrier Breaker).

Configuración del router 'maestro' o principal.

Abrimos LuCi y vamos a la pestaña Red/Wifi. Configuramos de acuerdo a nuestro gusto (canal y nombre de red).
Lo esencial es, escoger en Configuración del interfaz el Modo Punto de Acceso (WDS) y en Red asociar el interfaz a lan




Pinchamos en Configuración avanzado y en Seguridad inalámbrica.

Si queremos que la conexión entre ambos routers sea lo más rápida posible (hasta 300 Mbit/s), además de escoger en Modo 802.11g+n debemos seleccionar en el Modo HT:  40 MHZ 2º canal por encima (podemos poner también 2º canal por debajo, dependiendo del canal principal escogido)

En Encriptado, seleccionaremos WPA-PSK (o WPA2-PSK) y escribimos la clave (mínimo de 8 caracteres y lo más 'complicada' posible: que incluya alguna mayúsculas, letras y números). Finalmente le damos al botón Guardar y aplicar.




Configuración del router 'secundario' o cliente.

Lo primero será configurarlo en el mismo rango de red (si no lo estaba ya) que el router principal, así que desde LuCi  pinchamos en Red/Interfaces/LAN. En Protocolo seleccionamos Dirección estática y rellenamos los diferentes apartados de acuerdo a los parámetros de nuestra red (La Ip de mi router principal es 10.0.0.1). En Servidor DHCP/Ignorar interfaz marcamos Desactivar DHCP para esta interfaz.

Guardar y aplicar




Importante, como acabamos de desactivar el DHCP, es posible que temporalmente tengamos que configurar manualmente la IP del PC desde el que estamos trabajando.


Vamos a configurar el enlace wireless, así que desde LuCi (recordad que le habéis cambiado la IP al router que estáis configurando), nos vamos a Red/Wifi y le damos al botón Explorar




Tras unos segundos de espera, veremos un listado con las redes cercanas. En la nuestra, le damos a Unirse a Red




Nos cargará una nueva pantalla en la que pondremos nuestra clave. En Crear/Asingar zona de seguridad marcaremos lan
Por último le damos a Guardar




Otra vez, tendremos una nueva pantalla. En Configuración del Interfaz, en Modo, seleccionaremos Cliente (WDS) y en Red marcaremos lan.




Pinchamos en Configuración avanzada y de nuevo pondremos Modo HT  40 MHZ 2º canal por encima (como en el router principal). En Seguridad inalámbrica ya debería estar seleccionada la encriptación WPA-PSK y la clave correctamente (si queréis ver la clave podéis pinchar sobre el dibujito verde de la derecha).
Le damos al botón Guardar y aplicar.




IMPORTANTE: si habíais configurado el PC con IP fija, volverlo a ponder para que la coja por DHCP

Si lo hemos hecho todo correctamente, y después de unos segundos de espera, ya deberíamos tener ambos routers enlazados. Para probarlo, podéis hacer un ping a la IP del principal o abrir una página web.

Ahora, y como nuestra idea inicial es aumentar el alcance de la red, vamos a hacer que el router secundario, amplifique (o repita) nuestra red.

Desde LuCi, Red/Wifi le damos a Añadir




Si os fijáis en la nueva ventana, veréis que no nos permite cambiar el canal. Esto es debido a que ya tenemos la wifi (en modo Cliente WDS) usando el canal 1. Así que la nueva red, obligatoriamente, usará el mismo.

Configuramos el nombre de la nueva red en ESSID, en Modo, escogemos Punto de Acceso (WDS) y en red, marcamos lan.




Para terminar, en Configuración avanzada ponemos nuevamente Modo HT  40 MHZ 2º canal por encima. En Seguridad inalámbrica, escogemos el mismo Encriptado y Clave que en la red principal y le damos a Guardar y aplicar.




Esperamos unos segundos hasta que se apliquen los cambios, y vamos a Red/Wifi. Veremos que tenemos dos interfaces, uno en Modo Cliente y otro en modo Master (Punto de Acceso). Ahora podremos conectar desde cualquier dispositivo tanto a la red wifi principal, como a la secundaria.



Nota (gracias a Bastinazo); para realizar este tipo de enlace entre DD-WRT (Router principal) y OpenWRT (Router secundario) es necesario:
  • Crear otra interface wlan virtual en el router principal con DDWRT, esta será la que el firm Openwrt del otro router repita.
  • La encriptacion si es WPA2 ha de ser AES forzosamente.

UCI (Interfaz de Comandos)
En construcción...

Ficheros de Configuración
En construcción...


Espero que este tutorial te haya resultado útil. Si tienes cualquier duda, ¡pregunta!
Saludos!

Editado por jar229: añadida la configuración de LuCi en el apartado WDS y la nota de Bastinazo.
« Última modificación: 23-08-2014, 21:45 (S?bado) por Noltari » En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


sERASEr
*******
Desconectado Desconectado

Mensajes: 4155


Ver Perfil
« Respuesta #1 : 09-07-2012, 23:48 (Lunes) »

Gracias Noltari, chinchetazo. Wink
En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #2 : 09-07-2012, 23:54 (Lunes) »

Gracias Noltari, chinchetazo. Wink
Muchas gracias. A ver si con este tutorial ayudo a la gente a configurar los routers en modo cliente/repetidor sin utilizar "relayd".

P.D: Estaba por ponerme el chinchetazo yo, pero me daba palo jaja.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


zaphkiel
**
Desconectado Desconectado

Mensajes: 9


Ver Perfil
« Respuesta #3 : 10-07-2012, 00:06 (Martes) »

Muchas gracias por tu trabajo, por cierto como va eso de los chinchetazos a ver que ponga uno, ajajajajaja.
En línea
sanson
Moderador Global
*
Desconectado Desconectado

Mensajes: 8356


Ver Perfil
« Respuesta #4 : 10-07-2012, 00:28 (Martes) »

Hola

Nunca escibo por aqui,  aunque os leo todos los dias, estoy esperando a sacar tiempo ( cosa que veo realmemte dificil ahora )  para tastear un poco.

 Pero la verdad que con la actividad que teneis ultimamente os mereceis un gran reconocimiento.

Ademas es un foro ejemplar nunca hay problemas de ningun tipo  ( nos ha jodio no saben de que hablais jejeje)

gran trabajo el vuestro, felicidades.

Saludos

si sale este mensaje, es que estoy en el movil
En línea

Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #5 : 10-07-2012, 00:29 (Martes) »

Malas noticias, mi Comtrend 5365 pasa de mi cara a la hora de configurar el modo repetidor.
Me tira un error al intentar cargar el driver para dicha configuración.

Voy a intentar con la última versión de Openwrt con el driver propietario de broadcom, en lugar del driver b43.
A ver qué tal se me da y os cuento. Si vuelve a fallar va a ser que el modo repetidor no se va a poder configurar en dispositivos con WLAN Broadcom. Quizás sí se pueda hacer en un router con Ralink...

De cualquier forma el modo cliente es funcional al 100% y debería ser genérico para todo dispositivo con Openwrt.
Sé de gente que simplemente necesita convertir la señal de WLAN a cable Wink.

Saludos!

Hola

Nunca escibo por aqui,  aunque os leo todos los dias, estoy esperando a sacar tiempo ( cosa que veo realmemte dificil ahora )  para tastear un poco.

 Pero la verdad que con la actividad que teneis ultimamente os mereceis un gran reconocimiento.

Ademas es un foro ejemplar nunca hay problemas de ningun tipo  ( nos ha jodio no saben de que hablais jejeje)

gran trabajo el vuestro, felicidades.

Saludos

si sale este mensaje, es que estoy en el movil
Muchas gracias por el reconocimiento ^^.
Espero ser da ayuda en todo lo que pueda.

P.D: (nos ha jodio no saben de que hablais jejeje) -> ¿Quizás debería comprar un traductor automático de binario a español Cheesy?
« Última modificación: 10-07-2012, 00:33 (Martes) por Noltari » En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


zaphkiel
**
Desconectado Desconectado

Mensajes: 9


Ver Perfil
« Respuesta #6 : 10-07-2012, 09:14 (Martes) »

Malas noticias, mi Comtrend 5365 pasa de mi cara a la hora de configurar el modo repetidor.
Me tira un error al intentar cargar el driver para dicha configuración.

Voy a intentar con la última versión de Openwrt con el driver propietario de broadcom, en lugar del driver b43.
A ver qué tal se me da y os cuento. Si vuelve a fallar va a ser que el modo repetidor no se va a poder configurar en dispositivos con WLAN Broadcom. Quizás sí se pueda hacer en un router con Ralink...

De cualquier forma el modo cliente es funcional al 100% y debería ser genérico para todo dispositivo con Openwrt.
Sé de gente que simplemente necesita convertir la señal de WLAN a cable Wink.

Saludos!


Buenos días compañeros,
gracias al fabuloso aporte de Noltari, he conseguido realizar el modo repetidor (de momento en dos fases), tal como nos indica en el tuto, el router ct-5365 (con firmware openwrt) recibe perfectamente la señal inhalambrica del router original conectado a internet, y llegados a este punto ya tenemos internet en el, pero solo conectando nuestros pcs con cable al mismo.

Para repetir también via wifi dicha señal, Noltari está trabajando para solucionarlo, pero para salir del paso ayer apuntó una posibilidad conectando con un cable el ct-5365, que recibe, con otro router de los que tengamos por ahi, el cual estará en un rango de red LAN igual al ct-5365 y, en mi caso con un ar-5381u, cambiando la wan del mismo quitando la que lleva original adsl por otra bridge; así se ha conseguido repetir, completamente wifi, la señal con los dos routers.

Gracias por los aportes Noltari, esperamos impacientes a ver si podemos ahorrarnos dos cacharros para hacerlo todo con uno. jajaja.
En línea
tool
****
Desconectado Desconectado

Mensajes: 86


Ver Perfil
« Respuesta #7 : 10-07-2012, 09:39 (Martes) »

Debería ponerse el modo Cliente transparente, permanecer en la misma red. Muy útil para consolas y HTPC sin wifi en el salón. Al menos es un uso que yo le doy a un 5365 de Jazztel.

Fácil y sencillo de configurar, desde el openwrt por cable, es fácil hacer ping a las otras máquinas, por lo que no es "tan malo", siempre puedes conectar al servidor FTP desde el HTPC.

Muy currado LuCi, pero al final siempre acabas haciendo hibrido, Luci + editar archivos por SSH.
En línea
jar229
Moderador
*
Desconectado Desconectado

Mensajes: 4563



Ver Perfil
« Respuesta #8 : 10-07-2012, 11:43 (Martes) »

El modo repetidor, en la mayoría de los routers con broadcom no funciona  Azn
Sin embargo con atheros, funciona estupendamente  Wink
El modo 'no gráfico' está explicado aquí: https://foro.seguridadwireless.net/openwrt/huawei-hg556a-modo-repetidor-(-openwrt)/

Por otro lado, llevo unos días de prueba con 2 routers hg556a asociados con WDS (encriptación WPA2) y estoy encantado  Grin
Es muy fácil de configurar, ambos están en la misma red y sin necesidad de soft adicional (relayd) ni de añadir 'ruteos' al router principal  Grin

Buen trabajo Noltari  Wink
En línea

En venta:

Portátiles Dell Latitude E6420. i5 vPro con SSD

Intel Core i5-2520M vPro a 2.5 GHz (3.2 GHz en modo turbo)
Chipset Intel QM67 Express
RAM 4 GB DDR3
Disco SSD de 128 GB
Pantalla panorámica mate de 14 pulgadas 1366x768
Intel HD Graphics 3000
NVIDA NVS 4200M 512 MB DDR3
Sonido Stereo
DVDRW
Webcam
Bluetooth 3.0
Lan Gigabit
Wifi Intel Centrino Advanced-N 6205 a/g/n
1 x ExpressCard/54
3 x USB 2.0
1 x HDMI, VGA, USB 2.0/eSATA
Teclado RETROILUMINADO alemán convertido en español con vinilos de alta calidad
Batería de 6 celdas en buen estado
Cargador

Instalado Windows 10 Pro 64 original

Precio 210 € incluido envío
tool
****
Desconectado Desconectado

Mensajes: 86


Ver Perfil
« Respuesta #9 : 11-07-2012, 01:27 (Mi?rcoles) »

El modo repetidor, lo he probado yo, pero no deja de ser con diferente SSID.

Es decir me conecto como cliente al AP, creo mi propia señal Wifi con mi SSID y todos felices y contentos.

No como un Repetidor invisible de mismo SSID, y ageno a todo.

El WDS tengo que probarlo yo, pero con el de Vodafone con firm vodafone (HG556a atheros SP03 (admin)).

No me imagino haciendo el siguiente setup:
1-- HG556a ---- Vodafone ADSL + VOIP (wifi Principal)
2-- TP link WR1043ND Gigabit (openWRT) Samknows.eu Whitebox, Bridge transparente.( funciona como Switch Gigabit lan y benchmark continuo del adsl).

3--- Ahora sería el colmo, HG556a  openWRT WIFI  (WDS master). (ralink o atheros)
4---  HG556a OpenWRT WDS Slave. (ralink )
5 ---- Extra HG556a OpenWRT WDS slave  (ralink).



La segunda parte con 3 HG556a Puede ser divertida. Tener todo en la misma lan pfff. Uso mucho VNC  (ScreenSharing OSX), compartir ficheros SMB, y SSH entre equipos, FTP igual. 

Asignando el DHCP en el Router principal, puedes tener tus propias "dns internas", para ir directamente a cada equipo, HT.PC  Mac.Book Ser.Ver  Hack.Pro x360.jasper x360.slim  Muy útil.
En línea
foncubierta
**
Desconectado Desconectado

Mensajes: 14


Ver Perfil
« Respuesta #10 : 13-07-2012, 04:28 (Viernes) »

Muy buen tutorial y bastante bien explicado porque aqui un novato lo consiguio xD Espero con ansias esa 2 Parte para conseguir mandar por el wifi que por cable no mola tanto xD
En línea
zaphkiel
**
Desconectado Desconectado

Mensajes: 9


Ver Perfil
« Respuesta #11 : 18-07-2012, 11:43 (Mi?rcoles) »

Malas noticias, mi Comtrend 5365 pasa de mi cara a la hora de configurar el modo repetidor.
Me tira un error al intentar cargar el driver para dicha configuración.

Voy a intentar con la última versión de Openwrt con el driver propietario de broadcom, en lugar del driver b43.
A ver qué tal se me da y os cuento. Si vuelve a fallar va a ser que el modo repetidor no se va a poder configurar en dispositivos con WLAN Broadcom. Quizás sí se pueda hacer en un router con Ralink...

De cualquier forma el modo cliente es funcional al 100% y debería ser genérico para todo dispositivo con Openwrt.
Sé de gente que simplemente necesita convertir la señal de WLAN a cable Wink.

Saludos!


Hola Noltari, que tal llevas ese "dolor de cabeza"  Grin , a ver si nos sorprendes pronto con el driver propietario "destripado" jajajaja.
Saludos.
En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #12 : 18-07-2012, 12:50 (Mi?rcoles) »

Malas noticias, mi Comtrend 5365 pasa de mi cara a la hora de configurar el modo repetidor.
Me tira un error al intentar cargar el driver para dicha configuración.

Voy a intentar con la última versión de Openwrt con el driver propietario de broadcom, en lugar del driver b43.
A ver qué tal se me da y os cuento. Si vuelve a fallar va a ser que el modo repetidor no se va a poder configurar en dispositivos con WLAN Broadcom. Quizás sí se pueda hacer en un router con Ralink...

De cualquier forma el modo cliente es funcional al 100% y debería ser genérico para todo dispositivo con Openwrt.
Sé de gente que simplemente necesita convertir la señal de WLAN a cable Wink.

Saludos!


Hola Noltari, que tal llevas ese "dolor de cabeza"  Grin , a ver si nos sorprendes pronto con el driver propietario "destripado" jajajaja.
Saludos.
De momento siento decir que no he conseguido nada nuevo, pero tampoco le he dedicado mucho tiempo porque ando liado con otras cosas. Matrícula de la universidad y demás problemas varios... En mi universidad han cambiado el grado en ingeniería informática ya no sé cuantas veces y ahora resulta que o faltan o sobran créditos con la adaptación a la última versión, que si queremos terminar el grado el curso que viene hay que hacer sí o sí prácticas en empresas porque las optativas no se imparten, etc.

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


zaphkiel
**
Desconectado Desconectado

Mensajes: 9


Ver Perfil
« Respuesta #13 : 18-07-2012, 13:38 (Mi?rcoles) »

Malas noticias, mi Comtrend 5365 pasa de mi cara a la hora de configurar el modo repetidor.
Me tira un error al intentar cargar el driver para dicha configuración.

Voy a intentar con la última versión de Openwrt con el driver propietario de broadcom, en lugar del driver b43.
A ver qué tal se me da y os cuento. Si vuelve a fallar va a ser que el modo repetidor no se va a poder configurar en dispositivos con WLAN Broadcom. Quizás sí se pueda hacer en un router con Ralink...

De cualquier forma el modo cliente es funcional al 100% y debería ser genérico para todo dispositivo con Openwrt.
Sé de gente que simplemente necesita convertir la señal de WLAN a cable Wink.

Saludos!


Hola Noltari, que tal llevas ese "dolor de cabeza"  Grin , a ver si nos sorprendes pronto con el driver propietario "destripado" jajajaja.
Saludos.
De momento siento decir que no he conseguido nada nuevo, pero tampoco le he dedicado mucho tiempo porque ando liado con otras cosas. Matrícula de la universidad y demás problemas varios... En mi universidad han cambiado el grado en ingeniería informática ya no sé cuantas veces y ahora resulta que o faltan o sobran créditos con la adaptación a la última versión, que si queremos terminar el grado el curso que viene hay que hacer sí o sí prácticas en empresas porque las optativas no se imparten, etc.

Saludos.

OK, pues eso es lo importante, lo primero tienen que ser los estudios; si más adelante te sobra algún minutillo para el tema pues ya nos lo dedicas.
Saludos.
En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #14 : 27-08-2012, 17:13 (Lunes) »

Añadido el modo repetidor sobre cliente enrutado.

Para realizar esta configuración he utilizado un router TP-Link WDR4300, que tiene dos tarjetas wifi, una para 2.4GHz y otra para 5GHz.

Esta configuración se puede realizar con una única tarjeta wifi atheros (no sirven tarjetas broadcom), o con dos tarjetas wifi (en este caso sí se pueden utilizar tarjetas broadcom).

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


tedascuen
**
Desconectado Desconectado

Mensajes: 15


Ver Perfil
« Respuesta #15 : 29-08-2012, 12:48 (Mi?rcoles) »

Noltari, he probado a configurar el modo repetidor sobre cliente enrutado según tu manual en un linksys wrt160nl y funciona perfecto, pero tengo algunos problemas.
Funciona perfecto con la versión squash del backfire 10.3.1, teniendo el kernel 2.6.noseque...
Funciona perfecto con la versión squash y la versión jffs2 del trunk, en concreto he usado esta: OpenWrt Attitude Adjustment r33276 / LuCI Trunk (trunk+svn9138), instalando el luci que no viene por defecto. Con estas versiones tengo el kernel 3.3.8.
Pero con la versión jffs2 del backfire 10.3.1 nunca consigo que arranque, siempre me da kernel panic.
Mi duda está en que no se que kernel es más recomendable para este router, si el 2.6 o el 3.3.8.
Lo digo por que yo quiero usar la jffs2 y si me dices que el kernel 3.3.8 va mejor, pues dejo de pelearme con el 2.6.
A ver si me puedes orientar...
Gracias y un saludo.
En línea
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #16 : 29-08-2012, 12:56 (Mi?rcoles) »

Noltari, he probado a configurar el modo repetidor sobre cliente enrutado según tu manual en un linksys wrt160nl y funciona perfecto, pero tengo algunos problemas.
Funciona perfecto con la versión squash del backfire 10.3.1, teniendo el kernel 2.6.noseque...
Funciona perfecto con la versión squash y la versión jffs2 del trunk, en concreto he usado esta: OpenWrt Attitude Adjustment r33276 / LuCI Trunk (trunk+svn9138), instalando el luci que no viene por defecto. Con estas versiones tengo el kernel 3.3.8.
Pero con la versión jffs2 del backfire 10.3.1 nunca consigo que arranque, siempre me da kernel panic.
Mi duda está en que no se que kernel es más recomendable para este router, si el 2.6 o el 3.3.8.
Lo digo por que yo quiero usar la jffs2 y si me dices que el kernel 3.3.8 va mejor, pues dejo de pelearme con el 2.6.
A ver si me puedes orientar...
Gracias y un saludo.
No te recomiendo usar la versión jffs2. Para mi gusto es mejor usar la versión con squashfs, ya que ahorras mucho espacio con respecto a la versión jffs2, que es bastante necesario en algunos routers con poca flash.

Sobre si usar un kernel u otro, depende más bien en el hardware del router. Sólo recomiendo usarlo en routers con hardware antiguo (poca CPU, poca RAM, etc.), ya que cuanto más actualizado más fixes tendrá (por norma general, pero no siempre Tongue).
Este router debería soportar fácilmente el kernel 3.3.

Saludos!
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


tedascuen
**
Desconectado Desconectado

Mensajes: 15


Ver Perfil
« Respuesta #17 : 29-08-2012, 13:19 (Mi?rcoles) »

Ok, pues me quedo con el 3.3.8 y paso del 2.6.
Respecto al jffs2, prefiero usarlo por que quiero acceso de lectura/escritura en todo. Conozco linux desde hace muchos años, aunque siempre lo use sobre pc's, nunca en routers...
Ya me he agenciado un disco duro ssd de 64 gb y se lo meteré al puerto usb para aumentar el swap y poder instalar lo que quiera sin problemas de espacio... Cuando lo tenga todo ok, ya os informaré del rendimiento del ssd.
Salu2 y gracias
En línea
Elnef
****
Desconectado Desconectado

Mensajes: 93


Ver Perfil
« Respuesta #18 : 04-09-2012, 07:24 (Martes) »

Estoy intentando realizar este tutorial paso a paso pero no consigo configurar la parte 1, el cliente enrutado.

Estoy usando un HG556a con el firmware r33275. Desconozco si es Atheros o Ralink. Durante unos cuantos días lo he estado usando de router neutro para generar una red con wifi n y funciona perfecto. Pero quería ver que otras cosas se podían hacer con él.

He seguido todos los pasos y los he comparados con el wiki del openwrt y la verdad es que no entiendo porque no tengo internet en los equipos que conecto a los Ethernet del router.

Mi router principal tiene la dirección 192.168.1.1. Con eél genero una red Wifi (Wicap) con encriptación PSK-TKIP con wifi G. Pongo aquí los archivos de configuración quje tengo para ver si véis algo que se me haya escapado.

- Wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr '64:16:f0:ed:bb:71'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '27'
        option country 'US'
        option disabled '0'
        option channel '9'

config wifi-iface
        option ssid 'Wicap'
        option encryption 'psk'
        option device 'radio0'
        option mode 'sta'
        option key 'XXXXXXXXX'
        option network 'wwan'

- Network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option dns '8.8.8.8'
        option ipaddr '192.168.2.1'

config interface 'wwan'
        option proto 'dhcp'

- Firewall:

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wwan'
        option input 'REJECT'
        option forward 'REJECT'

config forwarding
        option src 'lan'
        option dest 'wan'

He probado tanto con LuCi como por SSH y editando los archivos a mano, y no hay forma. Escaneo la red wifi (Wicap) parece que el router la acepta pero luego no tengo internet en los equipos que conecto por ethernet.

Como posible pista, en el status del router en LuCi a mí no me aparece nada en el campo "Network-> Ipv4 WAN Status" como sí aparece en el ejemplo.



Como posibles pistas que se me ocurren. es posible que sea problema de la encriptación PSK-TKIP ¿Ganaría algo poniendo en el principal AES? ¿Puede ser cosa de que sea una red G y el HG556a esté configurado en "ng"?

La verdad es que estoy dando palos de ciego y no veo dónde puede estar el problema en algo tan, relativamente, simple.
« Última modificación: 04-09-2012, 07:25 (Martes) por Elnef » En línea
jar229
Moderador
*
Desconectado Desconectado

Mensajes: 4563



Ver Perfil
« Respuesta #19 : 04-09-2012, 07:55 (Martes) »

Citar
config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option dns '8.8.8.8'
        option ipaddr '192.168.2.1'

Te falta el gateway ??

option gateway '192.168.1.1'
En línea

En venta:

Portátiles Dell Latitude E6420. i5 vPro con SSD

Intel Core i5-2520M vPro a 2.5 GHz (3.2 GHz en modo turbo)
Chipset Intel QM67 Express
RAM 4 GB DDR3
Disco SSD de 128 GB
Pantalla panorámica mate de 14 pulgadas 1366x768
Intel HD Graphics 3000
NVIDA NVS 4200M 512 MB DDR3
Sonido Stereo
DVDRW
Webcam
Bluetooth 3.0
Lan Gigabit
Wifi Intel Centrino Advanced-N 6205 a/g/n
1 x ExpressCard/54
3 x USB 2.0
1 x HDMI, VGA, USB 2.0/eSATA
Teclado RETROILUMINADO alemán convertido en español con vinilos de alta calidad
Batería de 6 celdas en buen estado
Cargador

Instalado Windows 10 Pro 64 original

Precio 210 € incluido envío
Páginas: [1] 2 3 4 5 6 ... 19 Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums