Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
15-12-2017, 01:34 (Viernes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt & LEDE (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  [Desarrollo] OpenWrt en Astoria ARV7510PW22
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: 1 2 3 [4] Ir Abajo Imprimir
Autor Tema: [Desarrollo] OpenWrt en Astoria ARV7510PW22  (Leído 28563 veces)
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1762


Ver Perfil
« Respuesta #60 : 31-05-2016, 10:18 (Martes) »

I did some tests and I found an interesting issue:
on the modem there are three usb port.. looking from the back, one in the upper left (where can be attached the data usb key), one in the edge of the lower and another on the edge of the right.
If I plug an usb drive  in ther upper left port, I have this from the dmeg:

[  432.559583] usb 2-1: new high-speed USB device number 2 using ifxusb_hcd
[  432.760960] usb-storage 2-1:1.0: USB Mass Storage device detected
[  432.770923] scsi host0: usb-storage 2-1:1.0
[  433.849902] scsi 0:0:0:0: Direct-Access     TDK LoR  TF10             PMAP PQ: 0 ANSI: 4
[  434.797023] sd 0:0:0:0: [sda] 15122432 512-byte logical blocks: (7.74 GB/7.21 GiB)
[  434.804625] sd 0:0:0:0: [sda] Write Protect is off
[  434.808031] sd 0:0:0:0: [sda] Mode Sense: 23 00 00 00
[  434.809618] sd 0:0:0:0: [sda] No Caching mode page found
[  434.813540] sd 0:0:0:0: [sda] Assuming drive cache: write through
[  434.853763]  sda: sda1
[  434.868819] sd 0:0:0:0: [sda] Attached SCSI removable disk

so, it seems to work, but using the usb ports on the edge of the board, I see nothing on the dmesg.


looking at the dmesg, there are few differences from the 14.07 and 15.05:

from 15.05
[    0.186422] usbcore: registered new interface driver usbfs
[    0.192056] usbcore: registered new interface driver hub
[    0.197479] usbcore: registered new device driver usb
[    6.789902] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    6.812682] ehci-pci 0000:00:0f.2: new USB bus registered, assigned bus number 1
[    6.835589] ehci-pci 0000:00:0f.2: USB 2.0 started, EHCI 1.00
[    6.841916] hub 1-0:1.0: USB hub found
[    6.853599] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    6.868678] uhci_hcd: USB Universal Host Controller Interface driver
[    6.908941] IFXUSB: ifxusb_hcd: version 3.2 B110801
[    7.416233] IFXUSB: USB core #0 soft-reset
[    7.620144] IFXUSB: USB core #0 soft-reset
[    7.622782] ifxusb_hcd ifxusb_hcd: IFX USB Controller
[    7.627776] ifxusb_hcd ifxusb_hcd: new USB bus registered, assigned bus number 2
[    7.634937] ifxusb_hcd ifxusb_hcd: irq 62, io mem 0xbe101000
[    7.640378] IFXUSB: Mode Mismatch Interrupt: currently in Host mode
[    7.646454] IFXUSB: Mode Mismatch Interrupt: currently in Host mode
[    7.652541] IFXUSB: Init: Power Port (0)
[    7.667230] hub 2-0:1.0: USB hub found
[    7.674212] ifxusb_hcd ifxusb_hcd: requested GPIO 488

from the 14.07
[    0.128000] usbcore: registered new interface driver usbfs
[    0.132000] usbcore: registered new interface driver hub
[    0.136000] usbcore: registered new device driver usb
[    7.000000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    7.020000] ehci-pci 0000:00:0f.2: new USB bus registered, assigned bus number 1
[    7.044000] ehci-pci 0000:00:0f.2: USB 2.0 started, EHCI 1.00
[    7.048000] hub 1-0:1.0: USB hub found
[    7.060000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    7.068000] uhci_hcd: USB Universal Host Controller Interface driver
[    7.080000] uhci_hcd 0000:00:0f.0: new USB bus registered, assigned bus number 2
[    7.092000] hub 2-0:1.0: USB hub found
[    7.104000] uhci_hcd 0000:00:0f.1: new USB bus registered, assigned bus number 3
[    7.120000] hub 3-0:1.0: USB hub found
[    7.132000] IFXUSB: ifxusb_hcd: version 3.2 B110801
[    7.640000] IFXUSB: USB core #0 soft-reset
[    7.844000] IFXUSB: USB core #0 soft-reset
[    7.848000] ifxusb_hcd ifxusb_hcd: IFX USB Controller
[    7.852000] ifxusb_hcd ifxusb_hcd: new USB bus registered, assigned bus number 4
[    7.860000] ifxusb_hcd ifxusb_hcd: irq 62, io mem 0xbe101000
[    7.864000] IFXUSB: Mode Mismatch Interrupt: currently in Host mode
[    7.868000] IFXUSB: Mode Mismatch Interrupt: currently in Host mode
[    7.876000] IFXUSB: Init: Power Port (0)
[    7.880000] hub 4-0:1.0: USB hub found
[    7.888000] ifxusb_hcd ifxusb_hcd: requested GPIO 232
[    7.900000] usbcore: registered new interface driver usb-storage
[    9.328000] usb 3-2: new full-speed USB device number 2 using uhci_hcd

I have no more ideas. It seems something releated to the kernel.

Cheers,
Angelo

This maybe related to the problem: https://dev.openwrt.org/ticket/18369. Another router, but same platform.
There are two patches to apply and compile. If you are brave enough to compile, maybe those patches resolve the issue.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
teicors
**
Desconectado Desconectado

Mensajes: 7


Ver Perfil
« Respuesta #61 : 31-05-2016, 14:05 (Martes) »

Very interesting !!
I patched and rebuilt the kernel and this noon i'll test for both kernel 3.18.29 and 4.4.7.
I hope to install the latest version.

I'll giv you a feedback about my test later.

TIA
Angelo
En línea
teicors
**
Desconectado Desconectado

Mensajes: 7


Ver Perfil
« Respuesta #62 : 01-06-2016, 08:16 (Mi?rcoles) »

It worked !!!

BusyBox v1.23.2 (2016-05-21 12:29:36 CEST) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Chaos Calmer, r49363)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:/# lsusb
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Thanks a lot ! I have no more words !  Angry  Angry  Angry

Angelo
En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1762


Ver Perfil
« Respuesta #63 : 01-06-2016, 13:23 (Mi?rcoles) »

It worked !!!

BusyBox v1.23.2 (2016-05-21 12:29:36 CEST) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 CHAOS CALMER (Chaos Calmer, r49363)
 -----------------------------------------------------
  * 1 1/2 oz Gin            Shake with a glassful
  * 1/4 oz Triple Sec       of broken ice and pour
  * 3/4 oz Lime Juice       unstrained into a goblet.
  * 1 1/2 oz Orange Juice
  * 1 tsp. Grenadine Syrup
 -----------------------------------------------------
root@OpenWrt:/# lsusb
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Thanks a lot ! I have no more words !  Angry  Angry  Angry

Angelo

Nice!!!  Grin
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
medber
****
Desconectado Desconectado

Mensajes: 58


Ver Perfil
« Respuesta #64 : 08-07-2016, 22:33 (Viernes) »

Hola a todos.

Comparto con vosotros la imagen LEDE r917 (8 Julio 2016).

Detalles:
* LEDE r917 + LuCI + IPv6 + QoS + DnsCrypt/DNSSec + iperf3 + cURL + endurecida con opciones de seguridad (SSP/RELRO/..)  .



.
En línea
driversat
**
Desconectado Desconectado

Mensajes: 26


Ver Perfil
« Respuesta #65 : 18-11-2016, 17:24 (Viernes) »

hola chicos  Grin

i have done all what is said in the tutorial but my router keeps rebooting  :'(
log:
ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X


U-Boot 2013.10-openwrt4 (Jun 19 2014 - 19:45:31) ARV7510PW22

Board: Arcadyan ARV7510PW22
SoC:   Lantiq Danube-S v1.5
CPU:   333.333 MHz
IO:    166.667 MHz
BUS:   83.333 MHz
BOOT:  NOR
DRAM:  64 MiB
Flash: 16 MiB
In:    serial
Out:   serial
Err:   serial
Net:   ltq-eth
Hit any key to stop autoboot:  0
## Booting kernel from Legacy Image at b0060000 ...
   Image Name:   MIPS OpenWrt Linux-3.18.23
   Created:      2016-02-02  12:40:51 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1530532 Bytes = 1.5 MiB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

[    0.000000] Linux version 3.18.23 (buildbot@builder1) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r47269) ) #1 Sun Jan 31 12:02:45 CET 2016
[    0.000000] SoC: Danube rev 1.5
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019641 (MIPS 24KEc)
[    0.000000] MIPS: machine is ARV7510PW22 - Astoria Networks
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x03ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x03ffffff]
[    0.000000] Initmem setup node 0 [mem 0x00000000-0x03ffffff]
[    0.000000] Primary instruction cache 16kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line: console=ttyLTQ0,115200 init=/etc/preinit
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Writing ErrCtl register=0007fc70
[    0.000000] Readback ErrCtl register=0007fc70
[    0.000000] Memory: 60148K/65536K available (3433K kernel code, 151K rwdata, 768K rodata, 172K init, 194K bss, 5388K reserved)
[    0.000000] NR_IRQS:256
[    0.000000] CPU Clock: 333MHz
[    0.000000] Calibrating delay loop... 221.18 BogoMIPS (lpj=442368)
[    0.040000] pid_max: default: 32768 minimum: 301
[    0.044000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.048000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.056000] pinctrl core: initialized pinctrl subsystem
[    0.064000] NET: Registered protocol family 16
[    0.076000] pinctrl-xway 1e100b10.pinmux: Init done
[    0.080000] dma-xway 1e104100.dma: Init done - hw rev: 3, ports: 5, channels: 20
[    0.088000] PCI host bridge /fpi@10000000/pci@E105400 ranges:
[    0.092000]  MEM 0x0000000018000000..0x0000000019ffffff
[    0.096000]   IO 0x000000001ae00000..0x000000001affffff
[    0.112000] usbcore: registered new interface driver usbfs
[    0.116000] usbcore: registered new interface driver hub
[    0.120000] usbcore: registered new device driver usb
[    0.124000] PCI host bridge to bus 0000:00
[    0.128000] pci_bus 0000:00: root bus resource [mem 0x18000000-0x19ffffff]
[    0.132000] pci_bus 0000:00: root bus resource [io  0xffffffff]
[    0.136000] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.140000] pci 0000:00:0e.0: BAR 0: assigned [mem 0x18000000-0x1800ffff]
[    0.144000] pci 0000:00:0f.2: BAR 0: assigned [mem 0x18010000-0x180100ff]
[    0.148000] pci 0000:00:0f.0: BAR 4: no space for [io  size 0x0020]
[    0.152000] pci 0000:00:0f.0: BAR 4: failed to assign [io  size 0x0020]
[    0.156000] pci 0000:00:0f.1: BAR 4: no space for [io  size 0x0020]
[    0.160000] pci 0000:00:0f.1: BAR 4: failed to assign [io  size 0x0020]
[    0.164000] Switched to clocksource MIPS
[    0.168000] NET: Registered protocol family 2
[    0.176000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.184000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.188000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.196000] TCP: reno registered
[    0.200000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.204000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.212000] NET: Registered protocol family 1
[    0.216000] PCI: Enabling device 0000:00:0f.2 (0000 -> 0002)
[    0.224000] gptu: totally 6 16-bit timers/counters
[    0.228000] gptu: misc_register on minor 63
[    0.232000] gptu: succeeded to request irq 126
[    0.236000] gptu: succeeded to request irq 127
[    0.240000] gptu: succeeded to request irq 128
[    0.244000] gptu: succeeded to request irq 129
[    0.248000] gptu: succeeded to request irq 130
[    0.256000] gptu: succeeded to request irq 131
[    0.264000] lantiq,vmmc 1f103000.vmmc: requested GPIO 489
[    0.272000] lantiq,vmmc 1f103000.vmmc: reserved 1MB at 0x03a00000
[    0.280000] ralink,eeprom ralink_eep: using RT2860.eeprom as eeprom
[    0.288000] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.296000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.300000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.332000] msgmni has been set to 117
[    0.344000] io scheduler noop registered
[    0.348000] io scheduler deadline registered (default)
[    0.352000] 1e100c00.serial: ttyLTQ0 at MMIO 0x1e100c00 (irq = 112, base_baud = 0) is a lantiq,asc
[    0.364000] console [ttyLTQ0] enabled
[    0.364000] console [ttyLTQ0] enabled
[    0.368000] bootconsole [early0] disabled
[    0.368000] bootconsole [early0] disabled
[    0.380000] lantiq nor flash device: 01000000 at 10000000
[    0.384000] ltq_nor: Found 1 x16 devices at 0x0 in 16-bit bank. Manufacturer ID 0x0000c2 Chip ID 0x00227e
[    0.392000] Amd/Fujitsu Extended Query Table at 0x0040
[    0.396000]   Amd/Fujitsu Extended Query version 1.3.
[    0.404000] number of CFI chips: 1
[    0.408000] 4 ofpart partitions found on MTD device ltq_nor
[    0.412000] Creating 4 MTD partitions on "ltq_nor":
[    0.416000] 0x000000000000-0x000000040000 : "uboot"
[    0.424000] 0x000000040000-0x000000060000 : "uboot_env"
[    0.428000] 0x000000060000-0x000000fe0000 : "firmware"
[    0.492000] 2 uimage-fw partitions found on MTD device firmware
[    0.496000] 0x000000060000-0x0000001d5ae4 : "kernel"
[    0.504000] 0x0000001d5ae4-0x000000fe0000 : "rootfs"
[    0.508000] mtd: device 4 (rootfs) set to be root filesystem
[    0.512000] 1 squashfs-split partitions found on MTD device rootfs
[    0.516000] 0x0000004e0000-0x000000fe0000 : "rootfs_data"
[    0.572000] 0x000000fe0000-0x000001000000 : "board_config"
[    0.596000] switch0: Atheros AR8216 rev. 1 switch registered on 1e180000.etop-ff
[    0.636000] libphy: ltq_mii: probed
[    0.672000] eth0: attached PHY [Atheros AR8216/AR8236/AR8316] (phy_addr=1e180000.etop-ff:00, irq=-1)
[    0.680000] wdt 1f8803f0.watchdog: Init done
[    0.688000] TCP: cubic registered
[    0.688000] NET: Registered protocol family 17
[    0.692000] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    0.704000] Bridge firewalling registered
[    0.708000] 8021q: 802.1Q VLAN Support v1.8
[    0.720000] UBIFS error (pid 1): ubifs_mount: cannot open "ubi0:rootfs", error -19
[    0.732000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    0.740000] Freeing unused kernel memory: 172K (80445000 - 80470000)
[    3.108000] init: Console is alive
[    3.112000] init: - watchdog -
[    6.104000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    6.108000] ehci-platform: EHCI generic platform driver
[    6.116000] ehci-pci: EHCI PCI platform driver
[    6.120000] ehci-pci 0000:00:0f.2: EHCI Host Controller
[    6.124000] ehci-pci 0000:00:0f.2: new USB bus registered, assigned bus number 1
[    6.132000] ehci-pci 0000:00:0f.2: irq 135, io mem 0x18010000
[    6.148000] ehci-pci 0000:00:0f.2: USB 2.0 started, EHCI 1.00
[    6.152000] hub 1-0:1.0: USB hub found
[    6.156000] hub 1-0:1.0: 4 ports detected
[    6.164000] uhci_hcd: USB Universal Host Controller Interface driver
[    6.168000] uhci_hcd 0000:00:0f.0: init 0000:00:0f.0 fail, -16
[    6.172000] uhci_hcd: probe of 0000:00:0f.0 failed with error -16
[    6.180000] uhci_hcd 0000:00:0f.1: init 0000:00:0f.1 fail, -16
[    6.184000] uhci_hcd: probe of 0000:00:0f.1 failed with error -16
[    6.196000] IFXUSB: ifxusb_hcd: version 3.2 B110801
[    6.704000] IFXUSB: USB core #0 soft-reset
[    6.908000] IFXUSB: USB core #0 soft-reset
[    6.908000] ifxusb_hcd ifxusb_hcd: IFX USB Controller
[    6.916000] ifxusb_hcd ifxusb_hcd: new USB bus registered, assigned bus number 2
[    6.920000] ifxusb_hcd ifxusb_hcd: irq 62, io mem 0xbe101000
[    6.928000] IFXUSB: Mode Mismatch Interrupt: currently in Host mode
[    6.932000] IFXUSB: Mode Mismatch Interrupt: currently in Host mode
[    6.940000] IFXUSB: Init: Power Port (0)
[    6.944000] hub 2-0:1.0: USB hub found
[    6.948000] hub 2-0:1.0: 1 port detected
[    6.952000] ifxusb_hcd ifxusb_hcd: requested GPIO 488
[    7.944000] init: - preinit -
[    8.464000] random: mktemp urandom read with 33 bits of entropy available
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[   11.864000] mount_root: jffs2 not ready yet, using temporary tmpfs overlay
[   11.892000] procd: - early -
[   11.892000] procd: - watchdog -
[   12.656000] procd: - ubus -
[   13.664000] procd: - init -
Please press Enter to activate this console.
[   15.116000] IFXOS, Version 1.5.14 (c) Copyright 2009, Lantiq Deutschland GmbH

[   15.152000] NET: Registered protocol family 10
[   15.168000] Lantiq TAPI device driver, version 3.13.0.2, (c) 2001-2010 Lantiq Deutschland GmbH
[   15.188000] NET: Registered protocol family 8
[   15.192000] NET: Registered protocol family 20
[   15.208000] PPP generic driver version 2.4.2
[   15.220000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   15.248000] IFX MEI Version 5.00.00
[   15.264000] Infineon CPE API Driver version: DSL CPE API V3.24.4.4
[   15.276000] Loading modules backported from Linux version master-2015-03-09-0-g141f155
[   15.284000] Backport generated by backports.git backports-20150129-0-gdd4a670
[   15.308000] Lantiq MIPS24KEc MPS driver, version 2.2.2.5, (c) 2006-2010 Lantiq Deutschland GmbH
[   15.316000] request_timer(3, 0x000001AE, 1)...successful!
[   15.320000] Lantiq VMMC device driver, version 1.9.0.3, (c) 2006-2010 Lantiq Deutschland GmbH
[   15.332000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   15.348000] ATM1.0.26    ATM (A1) firmware version 0.17
[   15.352000] ifxmips_atm: ATM init succeed
[   15.372000] nf_conntrack version 0.5.0 (942 buckets, 3768 max)
[   15.428000] NET: Registered protocol family 24
[   15.468000] xt_time: kernel timezone is -0000
[   15.556000] cfg80211: Calling CRDA to update world regulatory domain
[   15.560000] cfg80211: World regulatory domain updated:
[   15.564000] cfg80211:  DFS Master region: unset
[   15.568000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   15.580000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   15.584000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz, 92000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   15.596000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   15.604000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   15.612000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   15.620000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   15.628000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   15.636000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   15.836000] PCI: Enabling device 0000:00:0e.0 (0000 -> 0002)
[   15.840000] rt2800pci 0000:00:0e.0: failed to load eeprom property
[   15.848000] ieee80211 phy0: rt2x00lib_request_eeprom_file: Info - Loading EEPROM data from 'RT2860.eeprom'.
[   15.856000] rt2800pci 0000:00:0e.0: Direct firmware load for RT2860.eeprom failed with error -2
[   15.864000] rt2800pci 0000:00:0e.0: Falling back to user helper
En línea
teicors
**
Desconectado Desconectado

Mensajes: 7


Ver Perfil
« Respuesta #66 : 25-11-2016, 12:25 (Viernes) »

Hi,
in my opinion you lost the firmaware file
[   15.848000] ieee80211 phy0: rt2x00lib_request_eeprom_file: Info - Loading EEPROM data from 'RT2860.eeprom'.
[   15.856000] rt2800pci 0000:00:0e.0: Direct firmware load for RT2860.eeprom failed with error -2

(imo the error 2 means "file not found")

in make menuconfig under firmware I have the following scenario:

 │ │                                  < > r8188eu-firmware.............................. RealTek RTL8188EU firmware                           │ │ 
  │ │                                  -*- rt2800-pci-firmware.................. Ralink RT28xx/3xxx PCI/SoC firmware                           │ │ 
  │ │                                  {M} rt2800-usb-firmware...................... Ralink RT28xx/3xxx USB firmware                           │ │ 
  │ │                                  < > rt61-pci-firmware................................. Ralink RT2561 firmware                           │ │ 
  │ │                                  {M} rt73-usb-firmware................................. Ralink RT2573 firmware                           │ │ 
  │ │                                  -*- rtl8192ce-firmware............................ RealTek RTL8192CE firmware                           │ │ 


I don't know if you compiled or not OpenWRT, but if you compiled the kernel you have to check those items.

Cheers,
Angelo
En línea
javier_tci
**
Desconectado Desconectado

Mensajes: 2


Ver Perfil
« Respuesta #67 : 06-06-2017, 00:21 (Martes) »

Buenas, desde la más absoluta ignorancia, no sería posible que alguien dejase un fichero, con el firmware que contenga el openwrt para cargarlo directamente vía actualización?
Gracias y perdón si he dicho una tontería.
En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1762


Ver Perfil
« Respuesta #68 : 06-06-2017, 20:00 (Martes) »

Buenas, desde la más absoluta ignorancia, no sería posible que alguien dejase un fichero, con el firmware que contenga el openwrt para cargarlo directamente vía actualización?
Gracias y perdón si he dicho una tontería.

Tontería has dicho, si no actualizado el u-boot has, pequeño padawan.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
tustis42
**
Desconectado Desconectado

Mensajes: 2


Ver Perfil
« Respuesta #69 : 11-06-2017, 18:27 (Domingo) »

Hola,
Lo primero agradecer a Tki2000 su tuto de como instalar el uboot y openwrt en este router: Es realmente para 'tontos' (osease, yo mismo)  Grin

El tema es que tengo un problema una vez cargado openwrt 15.05 (he probado varias versiones de openwrt: 14, 15, lede, y todas les pasa igual), no me tiran los interfaces de red! Ni ping, ni nada.

Creo que el problema esta en el uboot que no es capaz de inicializar la parte de net, pero realmente no tengo ni idea... Además creo que la version de uboot es un poco antigua?

ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X


U-Boot 2013.01 (Mar 08 2013 - 20:25:21) ARV7510PW

Board: Arcadyan ARV7510PW
SoC:   Lantiq Danube-S v1.5
CPU:   333.333 MHz
IO:    166.667 MHz
BUS:   83.333 MHz
BOOT:  NOR
DRAM:  32 MiB
Flash: 16 MiB
In:    serial
Out:   serial
Err:   serial
Net:   Board Net Initialization Failed
ltq-eth
Hit any key to stop autoboot:  0
## Booting kernel from Legacy Image at b0060000 ...
   Image Name:   MIPS OpenWrt Linux-3.10.36
   Created:      2014-06-20   7:58:32 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1495132 Bytes = 1.4 MiB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

[    0.000000] Linux version 3.10.36 (tki2k@tki2k-Ubuntu) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r41240) ) #5 Fri Jun 20 09:58:09 CEST 2014


Sin embargo, el cacharro se entera de que fisicamente le he quitado/puesto un cable de red:

root@OpenWrt:/sys/devices/virtual/net/br-lan# [ 4724.624000] Atheros AR8216/AR8236/AR8316 1e180000.etop-ff:00: Port 3 is down
[ 4732.628000] Atheros AR8216/AR8236/AR8316 1e180000.etop-ff:00: Port 3 is up

Alguien que me pueda dar alguna pista de por donde tirar?

Gracias!

En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1762


Ver Perfil
« Respuesta #70 : 12-06-2017, 16:06 (Lunes) »

Hola,
Lo primero agradecer a Tki2000 su tuto de como instalar el uboot y openwrt en este router: Es realmente para 'tontos' (osease, yo mismo)  Grin

El tema es que tengo un problema una vez cargado openwrt 15.05 (he probado varias versiones de openwrt: 14, 15, lede, y todas les pasa igual), no me tiran los interfaces de red! Ni ping, ni nada.

Creo que el problema esta en el uboot que no es capaz de inicializar la parte de net, pero realmente no tengo ni idea... Además creo que la version de uboot es un poco antigua?

ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X


U-Boot 2013.01 (Mar 08 2013 - 20:25:21) ARV7510PW

Board: Arcadyan ARV7510PW
SoC:   Lantiq Danube-S v1.5
CPU:   333.333 MHz
IO:    166.667 MHz
BUS:   83.333 MHz
BOOT:  NOR
DRAM:  32 MiB
Flash: 16 MiB
In:    serial
Out:   serial
Err:   serial
Net:   Board Net Initialization Failed
ltq-eth
Hit any key to stop autoboot:  0
## Booting kernel from Legacy Image at b0060000 ...
   Image Name:   MIPS OpenWrt Linux-3.10.36
   Created:      2014-06-20   7:58:32 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1495132 Bytes = 1.4 MiB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

[    0.000000] Linux version 3.10.36 (tki2k@tki2k-Ubuntu) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r41240) ) #5 Fri Jun 20 09:58:09 CEST 2014


Sin embargo, el cacharro se entera de que fisicamente le he quitado/puesto un cable de red:

root@OpenWrt:/sys/devices/virtual/net/br-lan# [ 4724.624000] Atheros AR8216/AR8236/AR8316 1e180000.etop-ff:00: Port 3 is down
[ 4732.628000] Atheros AR8216/AR8236/AR8316 1e180000.etop-ff:00: Port 3 is up

Alguien que me pueda dar alguna pista de por donde tirar?

Gracias!



El u-boot de mi compilación creo que es "U-Boot 2013.10", y hay por lo menos alguien en este hilo, que ha publicado un log en el que funciona.
Mira si puedes actualizar el u-boot, con esa versión, y comprueba que al router le pones la dirección MAC. Puede que la red no se inicie por eso.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
tustis42
**
Desconectado Desconectado

Mensajes: 2


Ver Perfil
« Respuesta #71 : 13-06-2017, 09:58 (Martes) »

Hola,
Lo primero agradecer a Tki2000 su tuto de como instalar el uboot y openwrt en este router: Es realmente para 'tontos' (osease, yo mismo)  Grin

El tema es que tengo un problema una vez cargado openwrt 15.05 (he probado varias versiones de openwrt: 14, 15, lede, y todas les pasa igual), no me tiran los interfaces de red! Ni ping, ni nada.

Creo que el problema esta en el uboot que no es capaz de inicializar la parte de net, pero realmente no tengo ni idea... Además creo que la version de uboot es un poco antigua?

ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X


U-Boot 2013.01 (Mar 08 2013 - 20:25:21) ARV7510PW

Board: Arcadyan ARV7510PW
SoC:   Lantiq Danube-S v1.5
CPU:   333.333 MHz
IO:    166.667 MHz
BUS:   83.333 MHz
BOOT:  NOR
DRAM:  32 MiB
Flash: 16 MiB
In:    serial
Out:   serial
Err:   serial
Net:   Board Net Initialization Failed
ltq-eth
Hit any key to stop autoboot:  0
## Booting kernel from Legacy Image at b0060000 ...
   Image Name:   MIPS OpenWrt Linux-3.10.36
   Created:      2014-06-20   7:58:32 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1495132 Bytes = 1.4 MiB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK

Starting kernel ...

[    0.000000] Linux version 3.10.36 (tki2k@tki2k-Ubuntu) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r41240) ) #5 Fri Jun 20 09:58:09 CEST 2014


Sin embargo, el cacharro se entera de que fisicamente le he quitado/puesto un cable de red:

root@OpenWrt:/sys/devices/virtual/net/br-lan# [ 4724.624000] Atheros AR8216/AR8236/AR8316 1e180000.etop-ff:00: Port 3 is down
[ 4732.628000] Atheros AR8216/AR8236/AR8316 1e180000.etop-ff:00: Port 3 is up

Alguien que me pueda dar alguna pista de por donde tirar?

Gracias!



El u-boot de mi compilación creo que es "U-Boot 2013.10", y hay por lo menos alguien en este hilo, que ha publicado un log en el que funciona.
Mira si puedes actualizar el u-boot, con esa versión, y comprueba que al router le pones la dirección MAC. Puede que la red no se inicie por eso.

Solucionado!
He actualizado el uboot con tu version (la que quemé inicialmente la pillé de la web de openwrt), y ha empezado a cargar el net a la primera pero daba error en el CRC: solucionado haciendo un saveenv en el uboot y a tirar!

Ya disfruto de mi bonito openwrt en casa, ahora peleandome con el wifi pero pinta muy bien...

Gracias por la ayuda!!!
En línea
marot
**
Desconectado Desconectado

Mensajes: 8


Ver Perfil
« Respuesta #72 : 23-08-2017, 12:39 (Mi?rcoles) »

Hola a todos agradeceria que me echaran una mano con este tema estoy demaciado verde y no me entero de nada ¿algun tuto para tontos?  tengoel router desmontado tengo instalado el Tera tengo el conversor TTL y conectado y lo detecta tengo los archivos en dos partes descargados de aqui  pero no tengo ni idea de programacion ni nada  llevo ya un mes repasandome el tutorial pero no me entero
  alluda porfavor  gracias
a perdonar si tengo faltas de ortografia y ademas el teclado me falla gracias
« Última modificación: 23-08-2017, 12:42 (Mi?rcoles) por marot » En línea
marot
**
Desconectado Desconectado

Mensajes: 8


Ver Perfil
« Respuesta #73 : 23-08-2017, 14:04 (Mi?rcoles) »

no tengo ni idea de donde dejar la flash ni como ejecutar xmodem ni que comandos ni comillas poner
¿en el directorio raiz? por ejemplo? o acerlo todo con el Tera y como?
« Última modificación: 23-08-2017, 14:06 (Mi?rcoles) por marot » En línea
marot
**
Desconectado Desconectado

Mensajes: 8


Ver Perfil
« Respuesta #74 : 24-08-2017, 12:26 (Jueves) »

ningun alma caritativa ke me allude? soy casi un abuelito mi mente ya no procesa tanta informacion y ni idea de comandos en programacion por favor una alludita   gracias
 Tki2000 lo aesplicado muy bien pero hay ke tener algun conocimiento de programacion en consola
« Última modificación: 24-08-2017, 12:31 (Jueves) por marot » En línea
marot
**
Desconectado Desconectado

Mensajes: 8


Ver Perfil
« Respuesta #75 : 24-08-2017, 18:15 (Jueves) »

al final e consegido algo  pero el router no puedo abrirlo via lan  algo seme habra escapado  pero lo e echo todo paso `por paso segun Tki2000
esto es lo que sale via hyperterminal
ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X


U-Boot 2013.10-openwrt4 (Jun 19 2014 - 19:45:31) ARV7510PW22

Board: Arcadyan ARV7510PW22
SoC:   Lantiq Danube-S v1.5
CPU:   333.333 MHz
IO:    166.667 MHz
BUS:   83.333 MHz
BOOT:  NOR
DRAM:  64 MiB
Flash: 16 MiB
In:    serial
Out:   serial
Err:   serial
Net:   ltq-eth
Hit any key to stop autoboot:  0
Wrong Image Format for bootm command
ERROR: can't get kernel image!
ARV7510PW22 #
una alludita por favor
« Última modificación: 24-08-2017, 18:18 (Jueves) por marot » En línea
marot
**
Desconectado Desconectado

Mensajes: 8


Ver Perfil
« Respuesta #76 : 24-08-2017, 21:59 (Jueves) »

al final me quedo como estoy  el conversor ttl a muerto con3 dias de uso  (cosas de chinos)  a esperar otro mes hasta ke llege uno nuevo  ¿alguna sugerencia en como se a kedado? gracias
« Última modificación: 25-08-2017, 14:55 (Viernes) por marot » En línea
marot
**
Desconectado Desconectado

Mensajes: 8


Ver Perfil
« Respuesta #77 : 05-10-2017, 16:19 (Jueves) »

Hola a todos de nuevo  con mi segundo ttl roto e octado por donar este router a la ciensia   asi que si lo quereis lo tengo disponible

Encontre una tienda en mi ciudad que vende el Huawei HG556a por 5 euros y ya tengo unos cuantos modificados con OPENWRT
Gracias por la alluda y tutoriales
En línea
cheche
**
Desconectado Desconectado

Mensajes: 14


Ver Perfil
« Respuesta #78 : 10-12-2017, 04:30 (Domingo) »

¿Cual de las imágenes de openwrt/Lede recomendáis?

por un lado la estable openwrt:
https://downloads.openwrt.org/chaos_calmer/15.05.1/lantiq/xway/

por otro lado una snapshot de lede que por alguna razón no esta es el directorio 17.1.4 "estable"
http://downloads.lede-project.org/snapshots/targets/lantiq/xway/

Por otra parte, el echo que la imagen LEDE tenga sysupgrade no significa que se pueda instalar directamente. 
Entiendo que igualmente se tiene que realizar el cambio de bootloader a uboot a traves del puerto de serie.
En línea
Páginas: 1 2 3 [4] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums