Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
29-06-2017, 10:52 (Jueves)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada LiveCD Wifiway 3.5 versión final

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Openwrt (Moderadores: jar229, Noltari, Pteridium, Tki2000)
| | | |-+  [Desarrollo] OpenWrt en Astoria ARV7510PW22
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: 1 [2] 3 4 Ir Abajo Imprimir
Autor Tema: [Desarrollo] OpenWrt en Astoria ARV7510PW22  (Leído 24012 veces)
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #20 : 19-06-2014, 14:25 (Jueves) »

He compilado los u-boot directamente del trunk de openwrt y me estoy encontrando con un problema a la hora de arrancar la imagen.
¿A alguien más le pasa o sabe por qué puede estar pasando?

Código:
ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X


U-Boot 2013.10-openwrt4 (Jun 18 2014 - 14:34:57) ARV7510PW22

Board: Arcadyan ARV7510PW22
SoC:   Lantiq Danube-S v1.5
CPU:   333.333 MHz
IO:    166.667 MHz
BUS:   83.333 MHz
BOOT:  NOR
DRAM:  64 MiB
Flash: 16 MiB
In:    serial
Out:   serial
Err:   serial
Net:   ltq-eth
Hit any key to stop autoboot:  0
## Booting kernel from Legacy Image at b0060000 ...
   Image Name:   MIPS OpenWrt Linux-3.10.36
   Created:      2014-06-18  13:25:34 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1412477 Bytes = 1.3 MiB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... LZMA: uncompress or overwrite error 6 - must R
ESET b
ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X

Pasa eso contínuamente en un ciclo sin fin. Intenta descomprimir la imagen y como no puede se resetea, una y otra vez.
Pasa tanto con mi imagen compilada como con la de Noltari del primer post.
El u-boot es compilado por mí del último trunk ya que no he encontrado los u-boot para este router por ninguna parte.

¿Es cosa del u-boot o de la imagen?

Es cosa del uboot del trunk, que tiene un bug para el que necesita un parche que quitaron no sé por qué...

No has podido encontrar los uboot compilados por ninguna parte?
Me pediste que arreglara los enlaces y arreglados están en el primer post...
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1686


Ver Perfil
« Respuesta #21 : 19-06-2014, 14:36 (Jueves) »

He compilado los u-boot directamente del trunk de openwrt y me estoy encontrando con un problema a la hora de arrancar la imagen.
¿A alguien más le pasa o sabe por qué puede estar pasando?

Código:
ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X


U-Boot 2013.10-openwrt4 (Jun 18 2014 - 14:34:57) ARV7510PW22

Board: Arcadyan ARV7510PW22
SoC:   Lantiq Danube-S v1.5
CPU:   333.333 MHz
IO:    166.667 MHz
BUS:   83.333 MHz
BOOT:  NOR
DRAM:  64 MiB
Flash: 16 MiB
In:    serial
Out:   serial
Err:   serial
Net:   ltq-eth
Hit any key to stop autoboot:  0
## Booting kernel from Legacy Image at b0060000 ...
   Image Name:   MIPS OpenWrt Linux-3.10.36
   Created:      2014-06-18  13:25:34 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1412477 Bytes = 1.3 MiB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... LZMA: uncompress or overwrite error 6 - must R
ESET b
ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X

Pasa eso contínuamente en un ciclo sin fin. Intenta descomprimir la imagen y como no puede se resetea, una y otra vez.
Pasa tanto con mi imagen compilada como con la de Noltari del primer post.
El u-boot es compilado por mí del último trunk ya que no he encontrado los u-boot para este router por ninguna parte.

¿Es cosa del u-boot o de la imagen?

Es cosa del uboot del trunk, que tiene un bug para el que necesita un parche que quitaron no sé por qué...

No has podido encontrar los uboot compilados por ninguna parte?
Me pediste que arreglara los enlaces y arreglados están en el primer post...

Sí, si los enlaces funcionan, pero los ficheros de mediafire no tienen los u-boot, y como ponías que el router tenía soporte oficial, me fui directo a por el trunk.
Ahora me estoy bajando el git uboot-lantiq-2010_03 para intentar compilar el u-boot de ahí.
¿Entonces el u-boot de ese git sí funciona y los del trunk no?

Un saludo.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Noltari
Moderador
*
Desconectado Desconectado

Mensajes: 1245



Ver Perfil WWW
« Respuesta #22 : 19-06-2014, 18:14 (Jueves) »

He compilado los u-boot directamente del trunk de openwrt y me estoy encontrando con un problema a la hora de arrancar la imagen.
¿A alguien más le pasa o sabe por qué puede estar pasando?

Código:
ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X


U-Boot 2013.10-openwrt4 (Jun 18 2014 - 14:34:57) ARV7510PW22

Board: Arcadyan ARV7510PW22
SoC:   Lantiq Danube-S v1.5
CPU:   333.333 MHz
IO:    166.667 MHz
BUS:   83.333 MHz
BOOT:  NOR
DRAM:  64 MiB
Flash: 16 MiB
In:    serial
Out:   serial
Err:   serial
Net:   ltq-eth
Hit any key to stop autoboot:  0
## Booting kernel from Legacy Image at b0060000 ...
   Image Name:   MIPS OpenWrt Linux-3.10.36
   Created:      2014-06-18  13:25:34 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1412477 Bytes = 1.3 MiB
   Load Address: 80002000
   Entry Point:  80002000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... LZMA: uncompress or overwrite error 6 - must R
ESET b
ROM VER: 1.0.3
CFG 01
Read EEPROMX
 X

Pasa eso contínuamente en un ciclo sin fin. Intenta descomprimir la imagen y como no puede se resetea, una y otra vez.
Pasa tanto con mi imagen compilada como con la de Noltari del primer post.
El u-boot es compilado por mí del último trunk ya que no he encontrado los u-boot para este router por ninguna parte.

¿Es cosa del u-boot o de la imagen?

Es cosa del uboot del trunk, que tiene un bug para el que necesita un parche que quitaron no sé por qué...

No has podido encontrar los uboot compilados por ninguna parte?
Me pediste que arreglara los enlaces y arreglados están en el primer post...

Sí, si los enlaces funcionan, pero los ficheros de mediafire no tienen los u-boot, y como ponías que el router tenía soporte oficial, me fui directo a por el trunk.
Ahora me estoy bajando el git uboot-lantiq-2010_03 para intentar compilar el u-boot de ahí.
¿Entonces el u-boot de ese git sí funciona y los del trunk no?

Un saludo.
Mira bien en el primer post:
Versión 2010.03: https://github.com/openwrt-es/uboot-lantiq-2010_03/commits/master
Versión 2013.01: https://github.com/openwrt-es/barrier-breaker-openwrt/commits/barrier-breaker_13.12

Si compilas el que hay en el último trunk añade este parche:
https://dev.openwrt.org/browser/trunk/package/boot/uboot-lantiq/patches/0041-lzam-fixup.patch?rev=40520

Saludos.
En línea

Movistar FTTH 300/300 Mbps @ Linksys WRT3200ACM


Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1686


Ver Perfil
« Respuesta #23 : 19-06-2014, 20:05 (Jueves) »


Si compilas el que hay en el último trunk añade este parche:
https://dev.openwrt.org/browser/trunk/package/boot/uboot-lantiq/patches/0041-lzam-fixup.patch?rev=40520

Saludos.

Tenías razón, ese patch arregla el u-boot del trunk. Ya arranca.

Gracias.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1686


Ver Perfil
« Respuesta #24 : 20-06-2014, 15:04 (Viernes) »

     Cómo quemar openwrt en ARV7510PW22

Lo primero que debemos hacer es sustituir el bootloader actual (brnboot) por u-boot. Después de eso ya podemos quemar openwrt en el router.

Aunque podemos sustituir brnboot con el modo UART, yo voy a describir cómo hacerlo desde el propio brnboot, ya que lo anterior implica soldar o puentear la placa en sitios bastante pequeños. Para sustituir brnboot desde el propio brnboot sólo vamos a necesitar un adaptador USB/TTL para conectarnos al puerto serie del router.

       

El puerto serie del router se encuentra aproximadamente en el centro y el pin 1 es VCC (el marcado con el triangulito):

       

Los datos de conexión son 115200 8N1 OFF

Como ya he dicho, el proceso de quemar el nuevo u-boot se puede hacer desde el propio brnboot, pero hemos de tener en cuenta un par de cosas.
El mapa de memoria que hay registrado en el brnboot no es el mismo que el mapa de memoria que hay registrado en el u-boot. La primera zona de brnboot (el bootloader en sí) tiene un alongitud de 128K, mientras que el u-boot que hayamos generado con el openwrt tiene una longitud mayor.

Código:
---------------------------------------
    Area            Address      Length
---------------------------------------
[0] Boot            0xB0000000     128K
[1] Configuration   0xB0020000     384K
[2] None            0xB0080000     128K
[3] Special Area    0xB00A0000     128K
[4] Primary Setting 0xB00C0000     128K
[5] Code Image 0    0xB00E0000    7680K
[6] Code Image 1    0xB0860000    7680K
[7] Boot Params     0xB0FE0000     128K
[8] Flash Image     0xB0000000    16384K
---------------------------------------

Si subimos el u-boot con la opción "U" del brnboot, a la zona 0, sólo quemaremos las 128 primeras KB y como resultado obtendremos un bonito ladrillo del que sólo será posible salir con el modo UART.

Para conseguir quemar el u-boot completo en la flash, hemos de partir el u-boot en dos, la primera de 128KB de longitud exactas, y la segunda con el resto.
A la hora de quemar el u-boot en la flash mediante brnboot, tendremos que encadenar dos subidas de ficheros (la primera y la segunda parte) a las zonas de memoria 0 y 1, PERO SIN RESETEAR EL ROUTER. Si reseteamos el router nos encontraremos con el bonito ladrillo.

Parte 1 :
Preparación del u-boot para subirlo en dos partes.

Nos bajamos la utilidad MCOPY para hacer copias parciales de ficheros de este sitio web : http://rayer.g6.cz/programm/programe.htm
Copiamos el fichero que contenga el u-boot arv7510pw22_nor.bin a una carpeta y la utilidad MCOPYW.exe en esa carpeta también.
Abrimos una consola con el "Símbolo de Sistema" y nos vamos a esa carpeta.
Tecleamos
Código:
MCOPYW.EXE "arv7510pw22_nor.img" "1.img" 0x00000 0x20000
MCOPYW.EXE "arv7510pw22_nor.img" "2.img" 0x20000 0x20000

Cambiar el nombre arv7510pw22_nor.img por el nombre del fichero que contenga el u-boot para la flash.
Ahora tendremos dos ficheros nuevos 1.bin y 2.bin con las dos partes que tendremos que quemar en la flash con brnboot. La primera parte tendrá 128KB exactas, y la segunda el resto.


Parte 2:
Quemamos u-boot en el router

Necesitamos algún programa para interactuar con al puerto serie/TTL del router. Yo lo he hecho con el Hyperterminal de Windows que además permite enviar los ficheros con protocolo XModem que vamos a necesitar.

Tras obtener las dos partes a quemar en el router en el apartado anterior ahora procedemos con los siguientes pasos:

  • Encendemos el router con el USB/TTL y paramos la ejecución pulsando 3 veces el espacio.
  • Entramos en modo administrador pulsando !
  • Pulsamos U para subir a la flash
  • Escogemos la zona 0
  • Mediante protocolo XModem subimos el fichero con la primera parte 1.bin (las primeras 128KB)
Cuando termine y SIN RESETEAR.
  • Pulsamos U para subir a la flash
  • Escogemos la zona 1
  • Mediante protocolo XModem subimos el fichero con la segunda parte 2.bin (el resto del bootloader)

Cuando haya terminado ya podemos resetear el router y arrancará u-boot.


Parte 3:
Configurando u-boot

Ya que uboot tiene por defecto unos parámetros genéricos, debemos configurar los parámetros de arranque.

Encendemos el router con el USB/TTL y paramos la ejecución pulsando el espacio.
Tecleamos
Código:
setenv ipaddr 192.168.1.1
setenv serverip 192.168.1.100
setenv ethaddr 34:9C:A6:xx:xx:xx
saveenv

Cambiar ethaddr por la dirección que aparezca en la pegatina de atrás del router, en la parte inferior titulado como MAC, separando cada dos dígitos por :

Con esto le decimos al router que la dirección del router en el bootloader es la 192.168.1.1, que el servidor TFTP para cargar imágenes lo espera en la dirección 192.168.1.100, y que su matrícula de internet es la MAC que hayamos puesto. Recordad que la MAC debe ser distinta para cada router.

Tecleamos reset y dejamos que el router se reinicie


Parte 4:
Quemando openwrt desde u-boot.
      Escoged a) o b)

a) Por la vía rápida (requiere configurar un servidor de TFTP)

Tenemos que tener preparado un servidor TFTP en la dirección 192.168.1.100, que es la que le hemos configurado anteriormente al router. TFTPD32.exe nos puede servir.
Conectamos el router por cable LAN y ponemos al PC la IP 192.168.1.100.
Ponemos el fichero con la imagen openwrt-squashfs en el directorio a servir por TFTP, renombramos el fichero con algún nombre más corto, por ejemplo openwrt.bin y arrancamos TFTPD.
Encendemos el router con el USB/TTL y paramos la ejecución pulsando el espacio.
Tecleamos lo siguiente:
Código:
tftp openwrt.bin
veremos que se hace la transferencia del fichero a la memoria del router.
Ahora lo tenemos que transferir de la memoria del router a la memoria flash para que se quede grabado.
Código:
protect off all
era $kernel_addr +$filesize
cp.b $loadaddr $kernel_addr $filesize

Cuando haya terminado hacemos
Código:
reset

b) Por la vía lenta, no necesitamos configurar nada nuevo.

Encendemos el router con el USB/TTL y paramos la ejecución pulsando el espacio.
Tecleamos lo siguiente:
Código:
loadx
Ahora le mandamos al router la imagen openwrt de la misma forma que antes le mandamos u-boot. Escogemos enviar el fichero con la imagen mediante el protocolo xmodem
Veremos que se hace la transferencia del fichero a la memoria del router, mucho más lento que mediante cable de red, pero no necesitamos nada más.
Ahora lo tenemos que transferir de la memoria del router a la memoria flash para que se quede grabado.
Código:
protect off all
era $kernel_addr +$filesize
cp.b $loadaddr $kernel_addr $filesize

Cuando haya terminado hacemos
Código:
reset


Si todo ha ido bien, arrancará openwrt.


Para agilizar la parte de generar un u-boot, partirlo y quemarlo, dejo un enlace con el último u-boot que he hecho y que funciona. Contiene tanto el u-boot completo (por si lo necesitamos) como las dos partes ya hechas con numeración <fichero>_1.bin y <fichero>_2.bin, además del resto de u-boots para memoria y modo UART.

También dejo la última compilación que he hecho de openwrt, r41240
Si váis a necesitar módulos para cargar con la imagen yo me descargaría el repositorio de http://downloads.openwrt.org/snapshots/trunk/lantiq/packages/ antes de que actualicen el kernel y los módulos dejen de ser compatibles con esta imagen.

u-boot: ARV7510PW22 uboot
Imagen : openwrt r41240


Como siempre, si os decidís a utilizar esta información es bajo vuestra cuenta y riesgo.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
oktay50000
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #25 : 15-07-2014, 15:19 (Martes) »

alguien tiene copia de seguridad de firmware original por favor darme un enlace
Tengo que poner el firmware original de nuevo
« Última modificación: 15-07-2014, 15:21 (Martes) por oktay50000 » En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1686


Ver Perfil
« Respuesta #26 : 15-07-2014, 17:32 (Martes) »

alguien tiene copia de seguridad de firmware original por favor darme un enlace
Tengo que poner el firmware original de nuevo

Firmware original (menos la partición con la MAC y el número de serie) : Firmware ARV7510PW22
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
oktay50000
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #27 : 15-07-2014, 19:41 (Martes) »

bootloader brn incluido? sólo parpadeará este al router?
En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1686


Ver Perfil
« Respuesta #28 : 15-07-2014, 19:51 (Martes) »

bootloader brn incluido? sólo parpadeará este al router?

Es la memoria flash al completo, menos la partición que contiene los datos propios del router. Incluye brnboot.
No entiendo el resto del mensaje.

You may post in english if you wish.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
oktay50000
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #29 : 16-07-2014, 01:51 (Mi?rcoles) »

oh okay Grin
thanks for firmware dump but its old one (Firmware Version:00.03.39)
i forgot to backup my firmware and my version was 00.03.42
anyone got newer version dump...
thanks
En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1686


Ver Perfil
« Respuesta #30 : 16-07-2014, 07:40 (Mi?rcoles) »

oh okay Grin
thanks for firmware dump but its old one (Firmware Version:00.03.39)
i forgot to backup my firmware and my version was 00.03.42
anyone got newer version dump...
thanks

That's the only one I have and it's for Vodafone Spain (so passwords and configs stored are in spanish). I only turned the router on once before flashing, just for knowing if it worked ok. Never updated anything nor know if Vodafone has ever released a newer firmware version. But I think you should be able to burn the firmware and update it later if you find whatever version you're looking for.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
oktay50000
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #31 : 16-07-2014, 10:58 (Mi?rcoles) »

oh okay Grin
thanks for firmware dump but its old one (Firmware Version:00.03.39)
i forgot to backup my firmware and my version was 00.03.42
anyone got newer version dump...
thanks

That's the only one I have and it's for Vodafone Spain (so passwords and configs stored are in spanish). I only turned the router on once before flashing, just for knowing if it worked ok. Never updated anything nor know if Vodafone has ever released a newer firmware version. But I think you should be able to burn the firmware and update it later if you find whatever version you're looking for.

thanks for the file
i flashed it and it restored to offcial firmware
but im not on spain nor using vodafone as provider
and i cant find firmware for this router on internet
there is no firmware for this modem i think vodafone updating it remotely for his own customers
so i need dumped version for newer version if anyone got it
En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1686


Ver Perfil
« Respuesta #32 : 16-07-2014, 18:36 (Mi?rcoles) »

oh okay Grin
thanks for firmware dump but its old one (Firmware Version:00.03.39)
i forgot to backup my firmware and my version was 00.03.42
anyone got newer version dump...
thanks

That's the only one I have and it's for Vodafone Spain (so passwords and configs stored are in spanish). I only turned the router on once before flashing, just for knowing if it worked ok. Never updated anything nor know if Vodafone has ever released a newer firmware version. But I think you should be able to burn the firmware and update it later if you find whatever version you're looking for.

thanks for the file
i flashed it and it restored to offcial firmware
but im not on spain nor using vodafone as provider
and i cant find firmware for this router on internet
there is no firmware for this modem i think vodafone updating it remotely for his own customers
so i need dumped version for newer version if anyone got it


I have not found any official firmware for this router anywhere else. Vodafone is updating it remotely so there's no file anywhere.
You should tell what version and provider (beside Vodafone) you're expecting to find so anyone with it may make a backup for you.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
oktay50000
**
Desconectado Desconectado

Mensajes: 5


Ver Perfil
« Respuesta #33 : 31-08-2014, 12:20 (Domingo) »

oh okay Grin
thanks for firmware dump but its old one (Firmware Version:00.03.39)
i forgot to backup my firmware and my version was 00.03.42
anyone got newer version dump...
thanks

That's the only one I have and it's for Vodafone Spain (so passwords and configs stored are in spanish). I only turned the router on once before flashing, just for knowing if it worked ok. Never updated anything nor know if Vodafone has ever released a newer firmware version. But I think you should be able to burn the firmware and update it later if you find whatever version you're looking for.

thanks for the file
i flashed it and it restored to offcial firmware
but im not on spain nor using vodafone as provider
and i cant find firmware for this router on internet
there is no firmware for this modem i think vodafone updating it remotely for his own customers
so i need dumped version for newer version if anyone got it


I have not found any official firmware for this router anywhere else. Vodafone is updating it remotely so there's no file anywhere.
You should tell what version and provider (beside Vodafone) you're expecting to find so anyone with it may make a backup for you.



yes you are right my friend
im looking for Firmware Version: 00.03.42 or newer dump...if anyone got it please ...
i need it badly
En línea
ruyinato
**
Desconectado Desconectado

Mensajes: 3


Ver Perfil
« Respuesta #34 : 06-09-2014, 16:35 (S?bado) »

Hola. Antes de nada dar las gracias por el trabajo que haceis aqui. Tengo un problema con el router. He estado leyendo el hilo varias veces, pero a la hora de actualizar a u-bot, he copiado solo el primer archivo de 128Kb sin poner el segundo y ahora tengo un ladrillo muy bonito. Ha sido un error si, es la primera vez que me meto en esto y me he liado. Se me ha quedado el router bloqueado y no me deja hacer nada mas. Esto es lo unico que sale:

ROM VER: 1.0.3
CFG 01
Read EEPROMX
  X

Asi se queda en hyperterminal sin posibilidad de hacer nada. Hay algun milagro que pueda hacer para resucitarlo?. Muchas gracias.

EDITO: No se enciende ninguna luz.
« Última modificación: 06-09-2014, 16:40 (S?bado) por ruyinato » En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1686


Ver Perfil
« Respuesta #35 : 09-09-2014, 13:59 (Martes) »

Hola. Antes de nada dar las gracias por el trabajo que haceis aqui. Tengo un problema con el router. He estado leyendo el hilo varias veces, pero a la hora de actualizar a u-bot, he copiado solo el primer archivo de 128Kb sin poner el segundo y ahora tengo un ladrillo muy bonito. Ha sido un error si, es la primera vez que me meto en esto y me he liado. Se me ha quedado el router bloqueado y no me deja hacer nada mas. Esto es lo unico que sale:

ROM VER: 1.0.3
CFG 01
Read EEPROMX
  X

Asi se queda en hyperterminal sin posibilidad de hacer nada. Hay algun milagro que pueda hacer para resucitarlo?. Muchas gracias.

EDITO: No se enciende ninguna luz.

La única posibilidad que te queda es ponerlo en modo UART y volver a quemar el bootloader. Te toca puentear o soldar las zonas con un cable con jumper para poner y quitar. En el segundo post de Noltari está explicado: Cambio del bootloader a uboot (usando el modo UART)
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
ruyinato
**
Desconectado Desconectado

Mensajes: 3


Ver Perfil
« Respuesta #36 : 14-09-2014, 15:25 (Domingo) »

Hola. Al final he podido hacer lo del modo UART. Cuento mi experiencia.  Al principio no me funcionaba, flaseaba los archivos que ha colgado tki2000 en otro post, pero no arrancaba ni con el que va entero de 94kb ni los que van en dos partes. Calentandome la cabeza se me ha ocurrido cargar la copia de seguridad del router que he sacado antes de empezar, pero flasear solo la parte del boot 81000000 B0000000 0x60000. Con eso lo he podido revivir para poder despues cargar ubot a traves de brnboot y posteriormente el firmware openwrt. Una vez terminado, configurando el router veo que da muchos problemas, se bloquea el acceso por cable aunque no por wifi, pero no es lo que buscaba. Al final he optado por coger mi copia de seguridad y despues de tanto trabajo y follon, volver al principio instalando otra vez el software vodafone. Si mas adelante lo necesito para algun adsl, simplemente utilizare la clave de administrador que he encontrado por ahi. Mi idea en un principio era a ver si se podia utilizar de alguna manera el router combinandolo con el mio (modem cable) o el solo, para el tema de compartir un disco duro en red y utilizarlo con la television LG desde la red, pero mientras no se solucionen los bloqueos, prefiero dejarlo tal cual.
« Última modificación: 14-09-2014, 15:31 (Domingo) por ruyinato » En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1686


Ver Perfil
« Respuesta #37 : 14-09-2014, 18:33 (Domingo) »

Hola. Al final he podido hacer lo del modo UART. Cuento mi experiencia.  Al principio no me funcionaba, flaseaba los archivos que ha colgado tki2000 en otro post, pero no arrancaba ni con el que va entero de 94kb ni los que van en dos partes.

En el archivo que colgué no hay ningún fichero de 94Kb. ¿Cuál estabas intentando flashear?

Calentandome la cabeza se me ha ocurrido cargar la copia de seguridad del router que he sacado antes de empezar, pero flasear solo la parte del boot 81000000 B0000000 0x60000. Con eso lo he podido revivir para poder despues cargar ubot a traves de brnboot y posteriormente el firmware openwrt.

Si no te ha funcionado el ninguno de los tutoriales que hay puestos, ¿podrías decir cómo quemaste u-boot desde brnboot, por si alguien más tiene esos problemas?

Una vez terminado, configurando el router veo que da muchos problemas, se bloquea el acceso por cable aunque no por wifi, pero no es lo que buscaba. Al final he optado por coger mi copia de seguridad y despues de tanto trabajo y follon, volver al principio instalando otra vez el software vodafone. Si mas adelante lo necesito para algun adsl, simplemente utilizare la clave de administrador que he encontrado por ahi. Mi idea en un principio era a ver si se podia utilizar de alguna manera el router combinandolo con el mio (modem cable) o el solo, para el tema de compartir un disco duro en red y utilizarlo con la television LG desde la red, pero mientras no se solucionen los bloqueos, prefiero dejarlo tal cual.

¿Qué versión de openwrt has intentado instalar y qué problemas en concreto dices que te han surgido con el cable?

Un saludo.
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
ruyinato
**
Desconectado Desconectado

Mensajes: 3


Ver Perfil
« Respuesta #38 : 15-09-2014, 23:22 (Lunes) »

Hola. Tienes razon, no hay ninguno de 94Kb. Al ver el archivo para escribir el mensaje me equivoque y puse la longitud comprimida. Los archivos son los de la respuesta 24 en este tema. He usado el programa Tera Term para el proceso. Lo que he hecho es:
- He cargado el archivo u-boot arv7510pw22_ram.asc en modo UART
- loadx para cargar el archivo u-boot arv7510pw22_nor_flash_bootstrap.img
- protect off all
- erase B0000000 +0060000
- cp.b 81000000 B0000000 $filesize

Apago el router, desactivo modo UART y resultado: NEGATIVO.

- Vuelvo a cargar el archivo u-boot arv7510pw22_ram.asc en modo UART
- loadx para cargar el archivo u-boot arv7510pw22_nor_flash_bootstrap_1.img
- protect off all
- erase B0000000 +0x0060000
- cp.b 81000000 B0000000 $filesize
- loadx para cargar el archivo u-boot arv7510pw22_nor_flash_bootstrap_2.img
- cp.b 81000000 B0020000 $filesize

Apago el router, desactivo modo UART y resultado: NEGATIVO.

Despues de dos dias con esto una y otra vez estudiandome el foro, se me ocurre la idea de cargar mi copia de seguridad de 16Mb que saque al router antes de empezar, pero flasear solo la parte del boot.

- Cargo el archivo u-boot arv7510pw22_ram.asc en modo UART
- loadx copia seguridad router 16MB (tarda un huevo en cargar)
- erase B0000000 +0x0060000
- cp.b 81000000 B0000000 0x0060000

Apago el router, desactivo modo UART y: PREMIO!, arranca brnboot

- Pulso espacio tres veces rapido
- pulso ! para entrar en modo administrador
- pulso U para subir archivos
- elijo la opcion 0 y cargo u-boot arv7510pw22_nor_flash_bootstrap_1.img
- vuelvo a pulsar U
- elijo la opcion 1 y cargo u-boot arv7510pw22_nor_flash_bootstrap_2.img
- Apago el router y al encenderlo arranca perfectamente u-boot, anteriormente cargando estos mismos archivos de forma manual (ver mas arriba), no me funcionaron.

- arranco desde U-boot ya en memoria
- loadx para cargar el archivo openwrt-lantiq-xway-ARV7510PW22-squashfs-r41240.image (tarda 1/2 huevo en cargar)
- protect off all
- erase $kernel_addr +$filesize
- cp.b $loadaddr $kernel_addr $filesize
- Apago el router y al encenderlo arranca openwrt

Una vez que me pongo a configurar el router, probar las opciones, no se como decirlo, los conectores rj-45, se me bloquea el acceso al router por cable, pero funcionando perfectamente por wifi, mas arriba otro usuario comenta el mismo problema, teniendo que hacerle reset para solucionarlo.
Mi idea de flasearlo era para intentar de alguna manera, el router solo o en combinacion con el mio, montar un disco en red para utilizarlo con la television lg por dlna. No se si sera o no posible, pero viendo que iba a darme mas penas que alegrias, he decidido volver atras en el firmware y volver a poner el de casa. Yo tengo operador de cable, pero mi hermano, con la clave de administrador ( admin - VF-ESavr75 )si podria utilizarlo algun dia con algun adsl diferente, pero que es una pena que no me haya ido bien, podia haberlo utilizado.

Para volver atras en el firmware he entrado en brnboot
- pulso espacio tres veces seguidas
- pulso ! para entrar como administrador
- pulso U para subir archivos
- pulso opcion 8: Flash Image     0xB0000000    16384K
- selecciono mi copia de seguridad de 16Mb
- arranco normalmente el router y me pide un archivo de proveedor
- escribo en el navegador http://192.168.1.1/undoc_upgrade.stm
- vuelvo a cargar mi archivo de copia de seguridad y en 3-4 minutos, se resetea y ya esta, funcionando como si nada hubiera pasado.

Escribiendo esa direccion en el navegador, se salta el sistema de firmas del archivo que estamos cargando, volviendo a flasearlo como estaba en un principio. Si intentamos cargarlo desde la ip por defecto, dice que el archivo no es valido y no funcionara.


Espero que se me entienda bien en el mensaje y que pueda servir de ayuda a alguien que se haya atrancado en donde yo, este es mi caso concreto y como he salido del atasco. Tal vez me haya liado mas de la cuenta, pero es la primera vez que he hecho algo de esto, me compre el programador por ebay solo para esto y me cabrea haberlo puesto como al principio, pero bueno, despues de esto he decidido comprarme un router d-link N300 DIR-657 HD Media Router que lleva el DLNA que buscaba y lo mejor de todo, por ebay, nuevo con sus plasticos protectores y su caja en perfecto estado, lo unico que ha estado de exposicion en una tienda que ha cerrado y por solo 16 euros, o sea, que a fin de cuentas, de una forma u otra, he conseguido el DLNA que queria, gastando poco dinero. Un saludo.
« Última modificación: 15-09-2014, 23:38 (Lunes) por ruyinato » En línea
Tki2000
Moderador
*
Desconectado Desconectado

Mensajes: 1686


Ver Perfil
« Respuesta #39 : 16-09-2014, 08:23 (Martes) »

Hola ruyinato.

Entonces por lo que veo, el método de flashear el u-boot en dos partes desde brnboot te funcionó.
El problema de que no te funcionara al quemar la imagen del bootloader seguramente sea que borrabas demasiada flash para la imagen. Yo hubiera borrado 0x30000 (192Kb) en lugar de 0x60000, ya  que eso es lo que ocupa el u-boot (3 bloques de 64Kb). Es una suposición, porque no lo he probado.
Para cargar el openwrt en lugar de loadx podías haber utilizado el método de TFTP que tarda nada y menos...  Grin
Es muy raro lo que te pasa con el cable LAN. Juraría que a mi no me pasaba en las pruebas y lo tuve varios días funcionando siempre por cable...

Tip: para partir un archivo en partes más pequeñas lo puedes hacer con dd desde linux o con MCOPYW.EXE si lo haces desde Windows, por si no quieres esperar a subir 16MB cuando sólo vas a quemar 384Kb...
En línea

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Páginas: 1 [2] 3 4 Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums