Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
29-04-2017, 13:22 (S?bado)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.0 version final para descargar



+  Seguridad Wireless - Wifi
|-+  Equipos y materiales
| |-+  Puntos de acceso, routers, switchs y bridges
| | |-+  Mikrotik (Moderador: Samuelongui)
| | | |-+  Manual: control remoto de Winbox sin IP fija
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Ir Abajo Imprimir
Autor Tema: Manual: control remoto de Winbox sin IP fija  (Leído 27016 veces)
Samuelongui
Moderador
*
Desconectado Desconectado

Mensajes: 1137


masquerade


Ver Perfil
« : 07-03-2011, 22:17 (Lunes) »

En este pequeño manual, vamos a ver como acceder por control remoto a nuestro routerboard a través de Winbox, y sin IP fija, a través de dyndns.

- Lo primero que debemos hacer es crearnos una cuenta dyndns, para eso, seguimos los pasos de este manual que he encontrado por internet:

Cómo crear una cuenta dyndns

- Una vez tengamos la cuenta creada y activada, accedemos a nuestro routerboard por Winbox de manera local para ver que IP tiene asignada. Para ello vamos a IP>Addresses y vemos la IP.


En mi caso, mi routerboard tiene asignada la IP 192.168.2.121

- Ahora accedemos a nuestro router y buscamos un apartado que se llame DNS o DDNS (esto puede variar dependiendo de la marca del router y el modelo) y una vez allí, configuramos la dyndns tal y como habíamos creado la cuenta:


He introducido tanto el nombre del host, el e-mail y la contraseña tal y como usé a la hora de crear mi cuenta en dyndns.

- Ahora solo debemos abrir el puerto 8291 para la IP de nuestro routerboard. En mi caso abro el 8291 para la IP 192.168.2.121. El mecanismo es el mismo que usaríais para abrir el puerto del emule o un juego, pero para vuestro routerboard.

- Para entrar desde remoto, abrimos el archivo Winbox.exe (como hacíamos de normal para local) y ponemos los datos usados en vuestra cuenta de dyndns, ejemplo:


Mis datos para entrar en remoto a mi routerboard

Para que veáis la diferencia, aquí una imagen de como sale el Winbox según nos logueamos desde local o remoto:


Diferencia entre logueo local (arriba) y remoto (abajo)

Si quereis tambien podéis entrar a vuestro routerboard mediante interface web (webbox), para ello solo debéis abrir vuestro navegador y poner la dirección de vuestro dyndns, en mi caso sería http://mikrotikrb450g.dyndns.org

Y esto es todo, espero que os sirva y así podáis controlar en todo momento y desde cualquier parte el funcionamiento de vuestro routerboard.
En línea

Sugarsync: 5'5 Gb almacenamiento gratis: click aquí

I'm Specialized
linuchero
**
Desconectado Desconectado

Mensajes: 7


Ver Perfil
« Respuesta #1 : 30-12-2011, 09:18 (Viernes) »

Muy buen tutorial y mas aun cuando no podemos ir fisicamente al lugar con facilidad  Angry

Tengo una duda, si tengo el modem en BRIDGE tendria que poner el script para que actualice la ip (si es dinamica), cierto?
En línea
Samuelongui
Moderador
*
Desconectado Desconectado

Mensajes: 1137


masquerade


Ver Perfil
« Respuesta #2 : 01-01-2012, 05:17 (Domingo) »

Muy buen tutorial y mas aun cuando no podemos ir fisicamente al lugar con facilidad  Angry

Tengo una duda, si tengo el modem en BRIDGE tendria que poner el script para que actualice la ip (si es dinamica), cierto?
no tiene sentido, creo que te has confundido con el balanceo de carga o no te he entendido
En línea

Sugarsync: 5'5 Gb almacenamiento gratis: click aquí

I'm Specialized
linuchero
**
Desconectado Desconectado

Mensajes: 7


Ver Perfil
« Respuesta #3 : 03-01-2012, 18:38 (Martes) »

Siiiiiiiiiiii disculpenme me equivoqueeee!!!!!!!  Embarrassed
En línea
frankromerodj
**
Desconectado Desconectado

Mensajes: 3


Ver Perfil
« Respuesta #4 : 08-02-2012, 21:03 (Mi?rcoles) »

mi pregunta es esta configuracion cuando hablas de router es si tenemos algo como esto:

moden de servicio cableado hasta un router cableado hasta nuestro mikrotik?
En línea
Samuelongui
Moderador
*
Desconectado Desconectado

Mensajes: 1137


masquerade


Ver Perfil
« Respuesta #5 : 09-02-2012, 01:08 (Jueves) »

modem router ADSL
En línea

Sugarsync: 5'5 Gb almacenamiento gratis: click aquí

I'm Specialized
Romicas
**
Desconectado Desconectado

Mensajes: 2


Ver Perfil
« Respuesta #6 : 26-11-2013, 15:19 (Martes) »

Hola a todos, haber si me pueden ayudar, tengo una Mikrotik RB 751U con ip fija de la misma manera estoy dando el srvicio de internet a los profesores del colegio con ip fija y sucede que del rango de ip's que tengo asignadas existe un compañero que prueba varias ip's y me crea confictos, como puedo hacer para bloquearlo y que no pueda acceder al internet por otra ip que no sea la que le asigne?
Por otrolado quiero acceder a mi Mikrotic desde una tables Andriod y me sale el error de coneccion Unable to connect. To connect using this tool, you need to enable the API port an yut router
En línea
tomamontaje
****
Desconectado Desconectado

Mensajes: 80


Ver Perfil
« Respuesta #7 : 27-11-2013, 18:48 (Mi?rcoles) »

La primera pregunta no es aquí, pero...

Si les das servicio a los profesores de un colegio con IP fija quiere decir que los equipos que usan son siempre los mismos (no me los imagino toqueteando en las opciones de conexión), por lo cual deberías utilizar un amarre por IP/MAC y velocidad por QUEUES. De esta manera, aunque esa persona cambie las IP, si la relacion IP/MAC no están autorizadas en el MiKrotik, no le sirve de nada.


La segunda pregunta...

La opcion mas sencilla es acceder por winbox de alguna manera que no sea el tablet y haces lo siguiente;

Desde IP > Services > IP Service List
     Seleccionas la fila que dice “api” y la habilitas.

O mediante el terminal para habilitar el servicio API en el puerto 3128 (protocolo TCP)

/ip service enable api

Si tienes alguna regla de bloqueo en el firewall, no tendrás comunicación. Entonces aplica las siguientes reglas:

/ip firewall filter add chain=input protocol=tcp dst-port=8728 action=accept
/ip firewall filter mo x 0

Donde “x” representa la posición de la regla recientemente agregada al firewall.

....después de esto, aclaro que no soy un experto en Mikrotik, sólo he tardado 30 segundos en buscar una referencia en Gugle (por no dar propaganda Grin)
« Última modificación: 27-11-2013, 19:05 (Mi?rcoles) por tomamontaje » En línea
Romicas
**
Desconectado Desconectado

Mensajes: 2


Ver Perfil
« Respuesta #8 : 29-11-2013, 19:15 (Viernes) »

Mil gracias tomamontaje excelente idea me funciona a millon  Angry
En línea
rouchrace
**
Desconectado Desconectado

Mensajes: 2


Ver Perfil
« Respuesta #9 : 31-03-2014, 20:22 (Lunes) »

Hola, ante todo felicitaciones por la sección que me parece muy interesante, así que no la dejes de lado Samuelongui.
Mi duda, tengo un modem motorola SB5100i --> conectado directamente a la WAN de una RB951 2n y necesito el acceso remoto. Claro este tutorial no me serviria ya que en la configuración de mi modem no tengo opción de cuenta DDNS.
He leido por algun sitio ya no recuerdo bien sobre un script para el Mikrotik que hacia la función, pero sin conocimientos tan avanzados no me gustaria liarla por que no estoy físicamente allí por ahora me conecto por Teamviewer.
Me puedes aconsejar al respecto? Desde ya muchas gracias.
Saludos.
En línea
Samuelongui
Moderador
*
Desconectado Desconectado

Mensajes: 1137


masquerade


Ver Perfil
« Respuesta #10 : 27-04-2014, 20:08 (Domingo) »

Prueba este script con change IP:

Código:
# Set your specific ChangeIP.com preferences here.
:global ddnsuser "YourChangeIPUserID"
:global ddnspass "PASSWORD"
:global ddnshost "MyRouterHostname.example.org"
:global ddnsinterface "ether2"

# Get ChangeIP.com server IP address.
:global ddnsserver [:resolve "nic.changeip.com"];
:global ddnsfip [:resolve "ip.changeip.com"]

# Change ddnsport to 8245 to bypass proxy.
:local ddnsport 80

# Do not edit anything below this line.  You have been warned.
# Abusive updates to the system will cause firewall blocks.

# Please be considerate and
# do not let this script run more than once per 3-5 minutes.

:log info "DDNS: Starting."

# Initialize checkpoint
:global ddnscheckpoint
:if ([:typeof $ddnscheckpoint] = "time") do={
   :log info ("DDNS: Last check was " . ([/system clock get time] - $ddnscheckpoint))
} else={
   :log info "DDNS: Cannot determine checkpoint, set now."
   :global ddnscheckpoint ( [/system clock get time] - 1d )
}

# Set route for ChangeIP.com server
:if ([:len [/ip route find comment="DDNS Server"]] > 0) do={
   :if ([/ip route get [find comment="DDNS Server"] dst-address] != [$ddnsserver . "/32"]) do={
      /ip route set [find comment="DDNS Server"] dst-address=$ddnsserver
      :log info "DDNS: Route to server was updated."
   }
} else={
   /ip route add dst-address=$ddnsserver gateway=$ddnsinterface comment="DDNS Server"
   :log info "DDNS: Route to server was added."
}

# Set route for ChangeIP.com IP finder
:if ([:len [/ip route find comment="DDNS IP"]] > 0) do={
   :if ([/ip route get [find comment="DDNS IP"] dst-address] != [$ddnsfip . "/32"]) do={
      /ip route set [find comment="DDNS IP"] dst-address=$ddnsfip
      :log info "DDNS: Route to IP was updated."
   }
} else={
   /ip route add dst-address=$ddnsfip gateway=$ddnsinterface comment="DDNS IP"
   :log info "DDNS: Route to IP was added."
}

# Get the current IP
:if ([/system clock get time] - $ddnscheckpoint > [:totime 180s] || [/system clock get time] - $ddnscheckpoint < [:totime 0s]) do={
   :log info "DDNS: Performing remote IP detection."
   /tool fetch address="ip.changeip.com" host="ip.changeip.com" src-path=("/?" . [/int eth get [find name=$ddnsinterface] mac-address ]) dst-path="ip.changeip.com.txt" mode=http port=$ddnsport
   :global ddnscheckpoint [/system clock get time]
} else={
   :log info "DDNS: Please be considerate and wait a few seconds longer."
   :break
}

# Parse the IP address received from fetch script.
   :global ddnslastip
   :local html [/file get "ip.changeip.com.txt" contents]
   :local ddnsip [:pick $html ([:find $html "<!--IPADDR="] + 11) [:find $html "-->"] ]

# Is it a valid IP and is it different than the last one?
   :if ([:typeof [:toip $ddnsip]] = "ip" AND $ddnsip != $ddnslastip ) do={
      :log info "DDNS: Sending UPDATE with $ddnsip"
      :log info [/tool dns-update name=$ddnshost address=$ddnsip key-name=$ddnsuser key=$ddnspass ]
      :global ddnslastip $ddnsip
   } else={
      :log info "DDNS: No update required."
   }
}
En línea

Sugarsync: 5'5 Gb almacenamiento gratis: click aquí

I'm Specialized
Páginas: [1] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums