Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
26-09-2017, 00:23 (Martes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Suite Seguridad Wireless
| |-+  Live wifislax (Moderador: USUARIONUEVO)
| | |-+  wifislax64 1.1 dirty flag disk
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] 2 Ir Abajo Imprimir
Autor Tema: wifislax64 1.1 dirty flag disk  (Leído 786 veces)
lupox
*******
Desconectado Desconectado

Mensajes: 519


volver....


Ver Perfil
« : 10-09-2017, 20:34 (Domingo) »

En modo live al cerrar el sistema no desmonta de forma apropiada el disco en el que se encuentra la carpeta wifislax64.

Si ocurre esto el kernel linux marca el disco.

Le pone un flag [bandera (un bit pasa 01)] al disco para que sea reparado por windows en el siguiente inicio.

screenshot

inicio live con la carpeta en usb E:
y en HDD particion D:

lecturas de fsutil en ambos discos ---- datos inconsistentes



flag en ofset 41 disco E:



syslog



En realidad no existen datos corruptos y al pasar chkdsk no encuentra ningún error.

Pero el disco es marcado para reparar cada vez que inicies wifislax64
« Última modificación: 10-09-2017, 21:08 (Domingo) por lupox » En línea
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13732



Ver Perfil
« Respuesta #1 : 11-09-2017, 00:07 (Lunes) »

Bueno , esto fue reportado hace mucho por pepe10000

El caso es que como se que en realidad no se ha corrompido nada, pues no hice mucho caso.

¿por que sucede?

En linux , el kernel marca dicho flag , cuando el dispositivo es montado como "rw"  read-write , ya que es factible la modificacion por ese hecho , se puede escribir o borrar en dicha particion.

Si la particion o pendrive fuese montada como "ro"  read-only , dicho flag no seria metido.

La teoria , es que se mete el flag , y se saca dicho flag al desmontar la particion , ..
He estado probado y es asi , ..el problema creo que radica a la hora de salir del modo live desde el usb...ya que el sistema de ficheros al salir es desmontado y remontado como "ro"  , la cosa es que dicha orden es para la raiz del sistema, pensando en un sistema en hdd.

Código:
echo "[+] Unmounting local file systems: "
/bin/umount -v -a -t no,proc,sysfs &> /dev/null

Código:
echo "[+] Remounting root filesystem read-only: "
/bin/mount -v -n -o remount,ro / &> /dev/null


en las dos , se hace referencia a la raiz

Código:
/

Tal vez , deberia incluir el dispositivo desde el que se arranco si esta en live ... habria que mirarlo.

En liveslack , no afecta ,por que monta el dispositivo como "ro" , pero para wifislax, es mejor que este como rw , ya que posiblemente queremos guardar cosas alli. (en el usb) , ya sean documentos txt , capturas ,o lo que sea ... por ese motivo lo cambie a rw , si se monta como rw , pero no se desmonta ni remonta como ro , se queda el dirty flag.


Se el problema , pero no se si podre fixearlo.

Código:
/etc/rc.d/rc.6
En línea

lupox
*******
Desconectado Desconectado

Mensajes: 519


volver....


Ver Perfil
« Respuesta #2 : 11-09-2017, 00:31 (Lunes) »

ya era conocedor, como sugiero en el post de la politica del kernel linux, y de este bug desde la primera version     que basaste en liveslak.
Tanto las primeras wifislax64 de desarrolo y wifislax de 32 bits  no presentaban dicho bug.

Creo haberte reportado hace bastante tiempo que "Bugs" en el montaje hdd como rw si tiene la carpeta wifislax64.

El problema principal de este flag es que si el disco tuviese algun daño, al repararlo windows vas a perder datos.



« Última modificación: 11-09-2017, 00:35 (Lunes) por lupox » En línea
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13732



Ver Perfil
« Respuesta #3 : 11-09-2017, 00:35 (Lunes) »

ya era conocedor, como sugiero en el post de la politica del kernel linux, y de este bug desde la primera version     que basaste en liveslak.
Tanto las primeras wifislax64 de desarrolo y wifislax de 32 bits  no presentaban dicho bug.

Creo haberte reportado hace bastante tiempo que "Bugs" en el montaje hdd como rw si tiene la carpeta wifislax64.



ok , la cosa es ... si podre o no hacer algo.

de momento no consigo nada , por que no puedo remontar el pincho al salir como ro ... que seria lo ideal.



En línea

USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13732



Ver Perfil
« Respuesta #4 : 11-09-2017, 00:40 (Lunes) »

queria explicarlo tambien ,para que el resto de usuarios sepan de que se habla en este hilo , por que sucede y como intentar arreglarlo.


En línea

lupox
*******
Desconectado Desconectado

Mensajes: 519


volver....


Ver Perfil
« Respuesta #5 : 11-09-2017, 00:55 (Lunes) »

Cita  Erik

The ${SUPERMNT} is currently always mounted read-only (for security) so I would have to add an option to mount the partition r/w instead.

Es una dificultad que heredas de liveslak. y del overlay

En línea
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13732



Ver Perfil
« Respuesta #6 : 11-09-2017, 01:24 (Lunes) »

Cita  Erik

The ${SUPERMNT} is currently always mounted read-only (for security) so I would have to add an option to mount the partition r/w instead.

Es una dificultad que heredas de liveslak. y del overlay



si , lo se , modifique eso , para que el pendrive fuese montado rw ...  por que se que si lo dejo solo read-only ,la gente va a pedir poder escribir en su pendrive, que por otra parte es logico.


si montas en el arranque como read-only , no aparece despues el bad block ..

por eso ya en su dia ignore este tema, no es un problema real..y resolverlo puede ser bastante complicado.

el overlay , en el fondo no tiene culpa de nada..

si montas fat como "ro"  no hay bad block
si lo montas como "rw" , entonces si se escribe el bad block ...  que solo es suprimido manualmente con fsck o remontando como "ro"
« Última modificación: 11-09-2017, 01:27 (Lunes) por USUARIONUEVO » En línea

USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13732



Ver Perfil
« Respuesta #7 : 11-09-2017, 01:33 (Lunes) »

sistema hdd,

montas pincho ... se activa el flag
desmontas pincho ... se deberia desactivar el flag ..pero no es asi

si lo pinchas y sin montarlo , compruebas, veras que sigue alli el flag..

conclusion , ...  da igual lo que hagas .. a la primera que montes el pincho te mete el flag ... y no lo quita aunque desmontes de forma segura.

solo desmarca el flag ,si montas el pincho como solo lectura... asi que va a estar complicado.

por curiosidad ,probare otros sistemas linux. . . aunque ya se que pasara lo mismo , ya que es el kernel el que decide cuando poner/quitar el flag ...  y solo lo quita si por alguna de aquellas, montas el pincho en solo lectura, y dudo bastante que algun linux por defecto haga eso ...  solo por consola y a peticion explicita, montara en solo lectura.
« Última modificación: 11-09-2017, 02:02 (Lunes) por USUARIONUEVO » En línea

lupox
*******
Desconectado Desconectado

Mensajes: 519


volver....


Ver Perfil
« Respuesta #8 : 11-09-2017, 02:30 (Lunes) »

ya...
ademas tpco es comun que se monte un live en modo rw.

De todas formas creo que hay varios que lo realizan de forma correcta.
empiezan montando todo como ro y cuando clikeas en la particion la  montan como rw.

...la dificultad siempre reside en donde se monte el live. claro si se copia a ram fin del problema.
« Última modificación: 11-09-2017, 02:36 (Lunes) por lupox » En línea
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13732



Ver Perfil
« Respuesta #9 : 11-09-2017, 02:36 (Lunes) »

ya... tpco es comun que monte en modo rw.

de todas formas creo que hay varios que lo realizan de forma correcta.
empiezan montando todo como ro y cuando clikeas en la particion la  montan como rw.

la dificultad siempre reside en donde se monte el live. claro si se copia a ram fin del problema.

tampoco te libras...

el flag solo es suprimido ... si montas  read-only antes de despincharlo.

parece un bug en el kernel..ya que deberia hacerlo al hacer umount, sin necesidad de remontarlo como solo-lectura.


de hecho puedes hacer las pruebas..

monat el pincho ..

fsck /dev/sdX

y veras que pone el drity flag ...  ahora haz

umount /dev/sdX

saca y vuelve a pinchar el usb sin montarlo ...  y haz fsck ..

sigue hay el flag ... al hacer umount no se suprimio.

asi que no me voy a calentar la cabeza  Grin
« Última modificación: 11-09-2017, 02:38 (Lunes) por USUARIONUEVO » En línea

lupox
*******
Desconectado Desconectado

Mensajes: 519


volver....


Ver Perfil
« Respuesta #10 : 11-09-2017, 02:42 (Lunes) »

bueno me voy para el sobre, sabía que te iba a dar entretenimiento para un rato.

tienes un enigma de dificil solucion.

habra que poner un concurso con recompensa.

No me parece que sea un bug esta reportado como politica del kernel linux.
En línea
lupox
*******
Desconectado Desconectado

Mensajes: 519


volver....


Ver Perfil
« Respuesta #11 : 11-09-2017, 10:35 (Lunes) »

El flag en teoría funciona de la siguiente manera:
Si un disco presenta el flag Linux lo montará sólo como lectura para evitar daños en el sistema de archivos.
Si no tiene flag lo montará como escritura pero le pondrá el flag que quitará sólo si se desmonta correctamente.
Una vez marcado no quitará la marca hasta que lo haga Windows.

Windows por su parte si encuentra la bandera reparará  el disco al inicio. Haciendo un chkdsk.

Y lo pondrá cuando encuentre inconsistencia de datos.



Si montas cualquier disco en el que no este el Live, al salir lo desmonta y quita el flag pero si esta la carpeta de wifislax64, el Live no puede desmontarla, (esta en uso) y sale dejando la bandera puesta.

Un byte 01 en el disco duro.

La única manera de quitar dicho flag es reparar el disco desde Windows.
o con un editor hexadecimal.

La primera es peligrosa, pues si Windows encuentra errores los repara y pierdes información.
y la segunda solo esta disponible para expertos, y es más peligrosa que la primera.

Citar

Conclusión wifislax64 marca el disco, en principio no corrompe ningún dato y al repararlo Windows al siguiente inicio, no debería producir ningún daño.

Sent from my RM-914_eu_spain_360 using Tapatalk
« Última modificación: 11-09-2017, 11:16 (Lunes) por lupox » En línea
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13732



Ver Perfil
« Respuesta #12 : 11-09-2017, 11:32 (Lunes) »

Citar
Si un disco presenta el flag Linux lo montará sólo como lectura

NO , lo monta siempre como rw , solo lo monta como lectura si el usuario lo hace a manopla ..

Citar
La única manera de quitar dicho flag es reparar el disco desde Windows.

TAMPOCO

yo lo reparo en wifislax... fsck da la opcion.
En línea

lupox
*******
Desconectado Desconectado

Mensajes: 519


volver....


Ver Perfil
« Respuesta #13 : 11-09-2017, 17:11 (Lunes) »

No estamos de acuerdo si tienes un disco duro marcado como dirty. Lo monta como ro y yo solo utilizaria fsck para sistemas de archivos Linux nunca windows.

Desde Linux se puede utilizar para borrar el flag en una partición ntfs.

ntfsfix -d /dev/sdX.



Sent from my RM-914_eu_spain_360 using Tapatalk
« Última modificación: 11-09-2017, 20:50 (Lunes) por lupox » En línea
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13732



Ver Perfil
« Respuesta #14 : 11-09-2017, 22:57 (Lunes) »

hemos empezado hablando de FAT y ahora vienes con NTFS , yo lo dejo aqui.

no soy de complicarme la vida absurdamente , JAMAS , he tenido nunca ningun problema de que algo se monte como solo lectura.

Este marcado como dirty , o como lo que sea , lo unico el mensaje paranoia de windows cuando pinchas un usb , despues de haberlo usado en linux , ignorar y ya esta.

Si un disco o particion se te monta como solo lectura..mira a ver que le pasa. ..  si eso fuera asi generalizado , el foro estaria inundado de gente quejandose de no poder escribir en sus discos duros, y no es el caso.
En línea

USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13732



Ver Perfil
« Respuesta #15 : 17-09-2017, 07:45 (Domingo) »

 Grin

kernel 4.14-rc1

montas , marca el flag ...
desmontas ... desmarca el flag

pinchas sin montar y miras si el flag sigue alli ..

en mi caso

Código:
fsck /dev/sdb1

y dice que ..OK  Grin

Osea SI se comporta como deberia...  marca el flag al montar , y lo desmarca al desmontar.
En línea

USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13732



Ver Perfil
« Respuesta #16 : 17-09-2017, 20:18 (Domingo) »

Pues al final va ser que no.

Monta , y marca y desmonta y desmarca , esta parte esta ok.

El caso es al arrancar live , al salir no se puede desmontar y queda marcada.

Como dije , la solucion seria montar como solo lectura , pero ..seria incomodo.
En línea

drvalium
Moderador Global
*
Desconectado Desconectado

Mensajes: 17487


Misántropo


Ver Perfil
« Respuesta #17 : 17-09-2017, 21:14 (Domingo) »

hi

yo no arranco nunca como live USB, pero he tenido que hacerlo por lo del chip rtl8812au y he visto que no me aparece la partición de Windows, solo la partición D.

no se, si os sirve de algo, este apunte.


un saludo
En línea
rvs
**
Desconectado Desconectado

Mensajes: 12


Ver Perfil
« Respuesta #18 : 20-09-2017, 09:25 (Mi?rcoles) »

Me pasa exactamente lo mismo con mi USB autoarrancable con wifislax.
Gracias a este hilo he podido entenderlo (bug que no desmarca el dirty byte cuando se monta en rw -yo por supuesto lo quiero en rw para guardar cosas en el propio USB-).
No me queda otra que ignorar el mensaje de incosistencia (irreal) del USB cuando lo uso en Windows, o limpiar el dirty byte de vez en cuando (ejemplo de instrucciones aquí).

Aprovecho que en relación con esto, siempre que tengais en un HD un sistema multiarranque con Windows 8/10 y otros sistemas operativos, desactivar el arranque híbrido en Windows 8/10 para evitar incosistencias (reales) de datos.
En línea
lupox
*******
Desconectado Desconectado

Mensajes: 519


volver....


Ver Perfil
« Respuesta #19 : 20-09-2017, 16:33 (Mi?rcoles) »

Yo lo tengo más o menos claro. No desmonta porque los archivos se ejecutan desde la partición que queremos desmontar, vamos que hay archivos en uso.
Por eso la salida de las instrucciones no es cero y consecuentemente no desmarca.
Soluciones que se me ocurren:
Montar como ro..... No podremos guardar nada en el usb.
Ignorar el flag y q Windows lo repare cuando sea.

Cargar el Live en RAM con esto el usb se puede montar como rw y debería ser desmontado de forma correcta.

Todo depende de la RAM q tenga el user.

Por cierto no se que pasa con este post, que no puedo leerlo desde el móvil.

Sent from my RM-914_eu_spain_360 using Tapatalk
« Última modificación: 20-09-2017, 16:58 (Mi?rcoles) por lupox » En línea
Páginas: [1] 2 Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums