Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
29-06-2017, 16:07 (Jueves)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada LiveCD Wifiway 3.5 versión final

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Suite Seguridad Wireless
| |-+  Live wifislax (Moderador: USUARIONUEVO)
| | |-+  Problema con wifislax e intel 3165
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Ir Abajo Imprimir
Autor Tema: Problema con wifislax e intel 3165  (Leído 849 veces)
NullReference
Visitante
« : 01-03-2017, 23:44 (Mi?rcoles) »

Hola, buenas a todos.

Antes de nada, dar las gracias por adelantado a quien se moleste en leer el post, y presentarme, ya que es mi primer post en la pagina, aunque soy un lector habitual del foro.

Abro este hilo debido a que estoy teniendo problemas en wifislax con mi tarjeta de red, en concreto, una Intel Dual Band Wireless-AC 3165.

He consultado mediante el buscador, filtrando por el modelo de tarjeta de red, y no he encontrado ningun post similar, con lo cual, interpreto que es correcto abrir un hilo nuevo, de no ser así, lo cierro sin ningún tipo de problema.

Parto de la base de que estoy utilizando la ultima version de wifislax (4-12 final), en version live sobre usb.

Sin más, paso a detallar el problema:

Puedo poner la tarjeta en modo monitor sin problemas (aunque creo me detecta un driver diferente, puesto que indica que se pone en modo monitor con el driver 4xxx,5xxx, etc). El problema viene cuando realizo cualquier tipo de des-autenticacion, en ese momento, algo en la tarjeta de red falla, y dejo de recibir beacons.

No se si es algo que le haya ocurrido a alguien mas y por lo tanto puede ayudarme.

Si alguien necesita cualquier tipo de informacion adicional, solicitarmelo sin ningún tipo de problema.

Un saludo y muchas gracias.
En línea
NullReference
Visitante
« Respuesta #1 : 02-03-2017, 00:56 (Jueves) »

Adjunto mas información:

lspci:
wifislax ~ # lspci | grep 3165
02:00.0 Network controller: Intel Corporation Wireless 3165 (rev 81)

Puesta en modo monitor con modprobe iwlwifi:

INFO INTERFAZ

                 Interfaz = mon0 / modo Monitor
                 Chipset/Driver = Intel AC -

De esta forma, la tarjeta de red no me detecta ninguna red.

Puesta en modo monitor con modprobe iwldvm:

                 Interfaz = mon0 / modo Monitor
                 Chipset/Driver = Intel AC -

Realmente, antes he probado varios consejos que he leido por diferentes webs, y he conseguido poner la tarjeta en modo monitor, de ahi que me cargaba con el driver 4XXX, pero ahora, soy incapaz de volver a hacerlo.

Mañana seguiré probando y si soy capaz de volver a poner la tarjeta en modo monitor, os comentaré como lo he hecho.

Un saludo y muchas gracias,

En línea
NullReference
Visitante
« Respuesta #2 : 02-03-2017, 01:02 (Jueves) »

Mas info:
wifislax ~ # dmesg | grep iwl
[   11.197336] iwlwifi 0000:02:00.0: Unsupported splx structure
[   11.257179] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-19.ucode failed with error -2
[   11.257221] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-18.ucode failed with error -2
[   11.584892] iwlwifi 0000:02:00.0: loaded firmware version 17.352738.0 op_mode iwlmvm
[   11.770740] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 3165, REV=0x210
[   11.770787] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   11.770942] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   11.840752] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[   25.574044] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   25.574201] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   25.634003] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   25.634159] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
wifislax ~ # modprobe iwldvm
wifislax ~ # dmesg | grep iwl
[   11.197336] iwlwifi 0000:02:00.0: Unsupported splx structure
[   11.257179] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-19.ucode failed with error -2
[   11.257221] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-18.ucode failed with error -2
[   11.584892] iwlwifi 0000:02:00.0: loaded firmware version 17.352738.0 op_mode iwlmvm
[   11.770740] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 3165, REV=0x210
[   11.770787] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   11.770942] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   11.840752] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[   25.574044] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   25.574201] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   25.634003] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   25.634159] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
En línea
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13437



Ver Perfil
« Respuesta #3 : 02-03-2017, 03:27 (Jueves) »

basandome en el ultimo de tus mensjaes, veo un error al cargar un firmware , (creo que ese no esta en el sistema)

Direct firmware load for iwlwifi-7265D-18.ucode failed with error -2

baja este fichero , y ponlo en tu usb , en la carpeta "modules" ..despues arranca wifislax.

http://www.mediafire.com/file/id5f3griy9xf8ct/023-Firmwares-20170227-noarch-2wifislax.xzm
« Última modificación: 02-03-2017, 03:27 (Jueves) por USUARIONUEVO » En línea

NullReference
Visitante
« Respuesta #4 : 02-03-2017, 12:19 (Jueves) »

Perfecto! Muchas gracias.

Esta tarde pruebo, y te comento el resultado.

Un saludo.
En línea
NullReference
Visitante
« Respuesta #5 : 02-03-2017, 20:41 (Jueves) »

Buenas tardes,

He descargado el fichero y lo he puesto en la carpeta modules, tal como indicabas.

El mensaje al que hacias referencia, ha desaparecido, sin embargo, la tarjeta de red sigue siendo incapaz de detectar redes en modo monitor.

Adjunto informacion:

wifislax ~ # dmesg | grep iw
[   10.928126] iwlwifi 0000:02:00.0: Unsupported splx structure
[   11.038412] iwlwifi 0000:02:00.0: loaded firmware version 19.324151.0 op_mode iwlmvm
[   11.168118] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 3165, REV=0x210
[   11.168167] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   11.168322] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   11.237589] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[   27.073906] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   27.074063] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   27.133882] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[   27.134040] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled

Cuando intento poner la tarjeta en modo monitor (compat wireless):

INFO INTERFAZ
           Interfaz = mon0 / modo Monitor
           Chipset/Driver = Intel AC -

Cuando intento poner la tarjeta en modo monitor (otros drivers):

INFO INTERFAZ
           Interfaz = wlan0 / modo Managed
           Chipset/Driver = Intel AC

He probado tambien a realizar el comando: modprobe iwlmvm, ya que en la salida del dsmeg, indica lo siguiente:

[   11.038412] iwlwifi 0000:02:00.0: loaded firmware version 19.324151.0 op_mode iwlmvm

Pero tampoco ha dado resultado.

No sé muy bien cual puede ser la causa de estos problemas, mientras tanto, voy a seguir buscando informacion a ver si consigo algo.

Un saludo y muchas gracias por la ayuda.
En línea
NullReference
Visitante
« Respuesta #6 : 02-03-2017, 21:59 (Jueves) »

Buenas noches,

Algo he conseguido avanzar, al parecer el servicio NetworkManager provoca que la tarjeta aun poniendose en modo monitor, no reciba ninguna señal wifi.

He parado el servicio, y por lo menos, consigo seleccionar mi wifi y detectar mi telefono movil como cliente.

EL problema de la des-autenticacion persiste. En cuanto des-autentico, dejo de recibir paquetes.

Todo esto, utilizando airoscript.

Con Goyscript WPA, no consigo recibir señales, además, al cerrar el script, se vuelve a levantar networkmanager, supongo que el propio script levantará el servicio.

Por otra parte, cuando pongo la tarjeta en modo monitor, en el driver sigue indicando "Intel AC -", supongo que esto también es incorrecto, y que al poner la tarjeta en modo monitor, deberia hacerlo con el driver propio de la tarjeta.

También he probado a descargar el ultimo driver desde la página de intel e instalarlo, y tampoco da resultado.

Adjunto la salida de dmesg, creo que el error está reflejado, aunque no consigo interpretar qué significa. Espero que alguien me pueda ayudar.

[  235.595519] iwlwifi 0000:02:00.0:        CSR_HW_IF_CONFIG_REG: 0X00c89200
[  235.595527] iwlwifi 0000:02:00.0:          CSR_INT_COALESCING: 0X00000040
[  235.595533] iwlwifi 0000:02:00.0:                     CSR_INT: 0X00000000
[  235.595540] iwlwifi 0000:02:00.0:                CSR_INT_MASK: 0X00000000
[  235.595546] iwlwifi 0000:02:00.0:           CSR_FH_INT_STATUS: 0X00000000
[  235.595553] iwlwifi 0000:02:00.0:                 CSR_GPIO_IN: 0X00000000
[  235.595559] iwlwifi 0000:02:00.0:                   CSR_RESET: 0X00000000
[  235.595566] iwlwifi 0000:02:00.0:                CSR_GP_CNTRL: 0X080403c5
[  235.595573] iwlwifi 0000:02:00.0:                  CSR_HW_REV: 0X00000210
[  235.595580] iwlwifi 0000:02:00.0:              CSR_EEPROM_REG: 0Xd55555d5
[  235.595586] iwlwifi 0000:02:00.0:               CSR_EEPROM_GP: 0X00000000
[  235.595593] iwlwifi 0000:02:00.0:              CSR_OTP_GP_REG: 0Xd55555d5
[  235.595599] iwlwifi 0000:02:00.0:                 CSR_GIO_REG: 0X00080044
[  235.595606] iwlwifi 0000:02:00.0:            CSR_GP_UCODE_REG: 0X00000000
[  235.595612] iwlwifi 0000:02:00.0:           CSR_GP_DRIVER_REG: 0X00000000
[  235.595619] iwlwifi 0000:02:00.0:           CSR_UCODE_DRV_GP1: 0X00000000
[  235.595625] iwlwifi 0000:02:00.0:           CSR_UCODE_DRV_GP2: 0X00000000
[  235.595631] iwlwifi 0000:02:00.0:                 CSR_LED_REG: 0X00000060
[  235.595638] iwlwifi 0000:02:00.0:        CSR_DRAM_INT_TBL_REG: 0X88025a9a
[  235.595644] iwlwifi 0000:02:00.0:        CSR_GIO_CHICKEN_BITS: 0X27800200
[  235.595651] iwlwifi 0000:02:00.0:             CSR_ANA_PLL_CFG: 0Xd55555d5
[  235.595657] iwlwifi 0000:02:00.0:      CSR_MONITOR_STATUS_REG: 0Xd3b7fff7
[  235.595664] iwlwifi 0000:02:00.0:           CSR_HW_REV_WA_REG: 0X0001001a
[  235.595670] iwlwifi 0000:02:00.0:        CSR_DBG_HPET_MEM_REG: 0Xffff0000
[  235.595674] iwlwifi 0000:02:00.0: FH register values:
[  235.595689] iwlwifi 0000:02:00.0:         FH_RSCSR_CHNL0_STTS_WPTR_REG: 0X023f8200
[  235.595704] iwlwifi 0000:02:00.0:        FH_RSCSR_CHNL0_RBDCB_BASE_REG: 0X0023f810
[  235.595719] iwlwifi 0000:02:00.0:                  FH_RSCSR_CHNL0_WPTR: 0X00000018
[  235.595734] iwlwifi 0000:02:00.0:         FH_MEM_RCSR_CHNL0_CONFIG_REG: 0X00801114
[  235.595749] iwlwifi 0000:02:00.0:          FH_MEM_RSSR_SHARED_CTRL_REG: 0X000000fc
[  235.595764] iwlwifi 0000:02:00.0:            FH_MEM_RSSR_RX_STATUS_REG: 0X03030000
[  235.595779] iwlwifi 0000:02:00.0:    FH_MEM_RSSR_RX_ENABLE_ERR_IRQ2DRV: 0X00000000
[  235.595794] iwlwifi 0000:02:00.0:                FH_TSSR_TX_STATUS_REG: 0X07ff0001
[  235.595808] iwlwifi 0000:02:00.0:                 FH_TSSR_TX_ERROR_REG: 0X00000000
[  235.595921] iwlwifi 0000:02:00.0: Start IWL Error Log Dump:
[  235.595926] iwlwifi 0000:02:00.0: Status: 0x00000000, count: 6
[  235.595930] iwlwifi 0000:02:00.0: Loaded firmware version: 19.324151.0
[  235.595935] iwlwifi 0000:02:00.0: 0x00000084 | NMI_INTERRUPT_UNKNOWN       
[  235.595940] iwlwifi 0000:02:00.0: 0x000002F0 | uPc
[  235.595943] iwlwifi 0000:02:00.0: 0x00000000 | branchlink1
[  235.595947] iwlwifi 0000:02:00.0: 0x0004296A | branchlink2
[  235.595951] iwlwifi 0000:02:00.0: 0x000433A0 | interruptlink1
[  235.595955] iwlwifi 0000:02:00.0: 0x000433A0 | interruptlink2
[  235.595959] iwlwifi 0000:02:00.0: 0x00000000 | data1
[  235.595963] iwlwifi 0000:02:00.0: 0x00000080 | data2
[  235.595967] iwlwifi 0000:02:00.0: 0x07030000 | data3
[  235.595971] iwlwifi 0000:02:00.0: 0x00000000 | beacon time
[  235.595975] iwlwifi 0000:02:00.0: 0x009908A5 | tsf low
[  235.595978] iwlwifi 0000:02:00.0: 0x00000000 | tsf hi
[  235.595982] iwlwifi 0000:02:00.0: 0x00000000 | time gp1
[  235.595986] iwlwifi 0000:02:00.0: 0x009908A6 | time gp2
[  235.595990] iwlwifi 0000:02:00.0: 0x00000000 | time gp3
[  235.595994] iwlwifi 0000:02:00.0: 0x00000013 | uCode version major
[  235.595998] iwlwifi 0000:02:00.0: 0x0004F237 | uCode version minor
[  235.596002] iwlwifi 0000:02:00.0: 0x00000210 | hw version
[  235.596005] iwlwifi 0000:02:00.0: 0x00C89200 | board version
[  235.596009] iwlwifi 0000:02:00.0: 0x0923002C | hcmd
[  235.596013] iwlwifi 0000:02:00.0: 0x00022000 | isr0
[  235.596017] iwlwifi 0000:02:00.0: 0x00000000 | isr1
[  235.596021] iwlwifi 0000:02:00.0: 0x00000002 | isr2
[  235.596025] iwlwifi 0000:02:00.0: 0x004000C0 | isr3
[  235.596028] iwlwifi 0000:02:00.0: 0x00000000 | isr4
[  235.596032] iwlwifi 0000:02:00.0: 0x00000110 | isr_pref
[  235.596036] iwlwifi 0000:02:00.0: 0x00000000 | wait_event
[  235.596040] iwlwifi 0000:02:00.0: 0x00000080 | l2p_control
[  235.596044] iwlwifi 0000:02:00.0: 0x00000000 | l2p_duration
[  235.596047] iwlwifi 0000:02:00.0: 0x00000000 | l2p_mhvalid
[  235.596051] iwlwifi 0000:02:00.0: 0x00000000 | l2p_addr_match
[  235.596055] iwlwifi 0000:02:00.0: 0x00000007 | lmpm_pmg_sel
[  235.596059] iwlwifi 0000:02:00.0: 0x09051911 | timestamp
[  235.596063] iwlwifi 0000:02:00.0: 0x00341830 | flow_handler

[  235.738139] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[  235.738295] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[  235.798678] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[  235.798849] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[  243.695480] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[  243.695637] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[  243.756177] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
[  243.756340] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled

Un saludo y muchas gracias por vuestra ayuda.
En línea
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13437



Ver Perfil
« Respuesta #7 : 02-03-2017, 23:21 (Jueves) »

¿Y por que no pruebas un poco con comandos a mano?

airmon-ng start
airodump-ng

joeer , ojala pudiera tener todas estas tarjetas que dan problemas ...  Wink

Lo del networkmanager me deja un poco extrañado , en teoria , "ignora", las interfaces en modo monitor , pero puede estar fastidiando , manejando la interface real (wlanX ).

No se si sabes , que no debes estar conectado , para no interferir en la auditoria.

Por eso para salir de dudas , poner a mano en modo monitor

Código:
airmon-ng start wlan0

y escanear a mano

Código:
airodump-ng -i mon0

En línea

jar229
Colaborador
*
Desconectado Desconectado

Mensajes: 4554



Ver Perfil
« Respuesta #8 : 03-03-2017, 11:06 (Viernes) »

Yo tengo una Intel Dual Band Wireless-N 7260 que tampoco me muestra nada (ni redes ni clientes) en modo monitor.

Si quieres alguna info, avisa  Wink
En línea

En venta:

Portátil Fujitsu Lifebook E734

Intel Core i5 4300M a 2.6 GHz (hasta 3.3 GHz en modo turbo)
Mobile Intel QM87 Express
4 GB DDR3 PC3-12800 (ampliable a 16 GB)
Disco duro de 500 GB SATA
Pantalla panorámica MATE de 13,3 pulgadas 1366x768
Intel HD Graphics 4600
Sonido Stereo
Intel Dual Band Wireless-N 7260
Bluetooth 4.0
LAN Gigabit
Lector de tarjetas
Lector de tarjetas inteligentes
Webcam
3 x USB 3.0
1 x DisplayPort, VGA
Batería de 6 celdas en magnífico estado (más de 4 horas de autonomía, dependiendo de configuración y uso)
Cargador original
Teclado italiano convertido en español con vinilos de alta calidad

250€ envío incluido
sol666
*******
Desconectado Desconectado

Mensajes: 1275



Ver Perfil
« Respuesta #9 : 03-03-2017, 15:24 (Viernes) »

¿Y por que no pruebas un poco con comandos a mano?

airmon-ng start
airodump-ng

joeer , ojala pudiera tener todas estas tarjetas que dan problemas ...  Wink

Lo del networkmanager me deja un poco extrañado , en teoria , "ignora", las interfaces en modo monitor , pero puede estar fastidiando , manejando la interface real (wlanX ).

No se si sabes , que no debes estar conectado , para no interferir en la auditoria.

Por eso para salir de dudas , poner a mano en modo monitor

Código:
airmon-ng start wlan0

y escanear a mano

Código:
airodump-ng -i mon0


jeje,el -i sobra,airodump-ng mon0 -W y salen con informacion WPS por cierto¿alguna iso de desarrollo por ahi para probar?
En línea
NullReference
Visitante
« Respuesta #10 : 03-03-2017, 19:55 (Viernes) »

Buenas tardes,

Definitivamente, es networkmanager el que interfiere en la captura de datos, la secuencia es la siguiente:

Código:
airmon-ng start wlan0
- Modo monitor en mon0, con driver INTEL AC-.

Código:
airodump -i mon0
- No se recibe ninguna señal.

Código:
/etc/rc.d/rc.networkmanager stop

Código:
airodump -i mon0
- Recibo señales wifi.

Código:
/etc/rc.d/rc.networkmanager start

Código:
airodump -i mon0
- Vuelvo a no recibir ninguna señal.

Es algo un poco extraño, llevo bastantes años utilizando las diferentes versiones de wifislax y nunca habia tenido este problema, aunque bien es cierto que era con mi ordenador anterior, el cual, creo que tenia una Inter Pro WIreless 2200 (hablo de memoria, no estoy seguro).

Adicionalmente, el problema de la desautenticación sigue estando independientemente del estado del sercicio nerworkmanager.

No sé, supongo que será un problema con el driver especifico de esta tarjeta, si se puede solucionar en alguna versión futura mejor, si no, no pasa nada, intentaré realizar la auditoria en mi otro ordenador, aunque me intriga bastante el problema y voy a seguir buscando una solucion solo por curiosidad y de paso, aprendo algo  Grin

Si alguien quiere aportar algo, o alguna experiencia similar, mejor!

Un saludo y muchas gracias,
En línea
villanovano
**
Desconectado Desconectado

Mensajes: 2


Ver Perfil
« Respuesta #11 : 15-06-2017, 11:48 (Jueves) »

Hola a tod@s:

Estoy siguiendo con mucha atención este hilo porque yo tengo este mismo problema con el mismo driver iwlwifi de la tarjeta integrada Intel 3165, cuando lanzo Goyscript no me encuentra ninguna red.

He probado el procedimiento que comenta NullReference y efectivamente tengo la misma respuesta, sólo encuentra redes cuando he detenido manualmente el networkmanager.

Pero lo que me inquieta es que con Linset sí que encuentra redes por lo que me pregunto ¿por qué no con Goyscript y sí con Linset? Ahora mismo estoy cotilleando el código de ambos scripts a ver si descubro alguna solución válida y la posteo para resolver este tema que me está consumiendo.

No tengo grandes conocimientos de programación así que emplazo a los valientes a ayudarme en esta aventura
para desatascar este hilo de una vez por todas.

Gracias a todos los que habéis contribuido a la causa. Saludos!!!
En línea
Páginas: [1] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums