Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
21-08-2017, 12:09 (Lunes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Suite Seguridad Wireless
| |-+  Live wifislax (Moderador: USUARIONUEVO)
| | |-+  Actualizaciones de wifislax ¿las instalo o no?
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Ir Abajo Imprimir
Autor Tema: Actualizaciones de wifislax ¿las instalo o no?  (Leído 4460 veces)
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13648



Ver Perfil
« : 06-08-2016, 01:12 (S?bado) »

Bien , a raiz de una consulta , creo oportuno crear un tema especifico para intertar dar luz a las dudas que podais tener acerca de si aplicar o no las actualizaciones que se ofrecen.


* Partire de la base dividiendo los tipos de usurios en 2.

Tipo 1 , que son la mayoria , gente que usa el live , ocasionalmente , pero no lo instalan y se conectan a internet desde el en "rara ocasion".

A este tipo de usuario , diria que en ningun momento le va a interesar actualizar nada , por que usandolo ocasinalmente en modo live y no estando conectado a una red , es muy dificil que vaya a tener ningun tipo de problema de seguridad , al no estar dentro de una red.

Tipo 2 , el que por alguna razon desea instalarla al hdd y la utiliza bastante.

Este tipo de usuario seguramente si va a querer estar al dia , y se preocupara cuando vea las actualizaciones disponibles, de averguar de que se trata cada una de ellas.

El actualizador automatico , esta por defecto activado ... asi que buscara actualizaciones automaticamente y las ofrecera de haber alguna.

Se puede configurar esto , de varias formas ...

Código:
sistema --> wifislax updater gui





Podemos observar tres opciones , la primera es la que permite que se busquen actualizaciones al inicio del sistema .... podemos desmarcarla .. y se desactivara la busqueda al inicio , siempre podremos acudir manualmente a la seccion sistema y lanzarlo desde alli a interes, para ver "que hay de nuevo viejo"  Wink


Luego tenemos dos opciones mas ,

Actualizar paquetes de wifislax
Esta opcion se encargara de revisar actualizaciones para los paquetes añadidos por nosotros al sistema base , como por ejemplo wireshark ,aircrack-ng y demas.

Los paquetes compilados por nosotros llevan al final del nombre el TAG  "sw"   de "seguridadwireless"

Se puede saber exactamente cuales son ejecutando en consola
Código:
ls /var/log/packages|grep [0-9]sw

esos paquetes son los que reciben actualizacion como "paquetes de wifislax"  , estos no son realmente esenciales , nunca van a romper el sistema , a lo mas que puedes llegar es a romper un programa especifico , de los que se listan como extras ...es decir , podreis romper wireshark , pero eso no hace que el sistema no funcione, solo no arrancaria wireshark.


el actualizador al acabar ofrece la accion "escanear en busca de dependencias rotas" , si detecta que se rompio wireshark ... pues lo compilara de nuevo para arreglarlo...ningun drama.

Actualizar paquetes de slackware (solo-expertos)

Bien , antes se utilizaba para la base del sistema la rama slackware-current , es como si fuese la rama "experimental" , en esa rama es ciertamente facil , romper por completo el sistema , de hay el aviso (solo-expertos) , pero desde wifislax-4.12 , se usa una rama "estable"   , slackware 14.2 como base , en las ramas estables, no hay paquetes experimentales ...solo "parches de seguridad" , por lo que dejar esta opcion activada, ya no es mayor problema ...nunca vais a romper wifislax-4.12 por ese tema.

Quiero tenerlo activado , pero me agovia que me presente actualizaciones de programas que ni utilizo.

En este punto , podemos hacer dos cosas ...blacklistar el paquete en el actualizador para que sea ignorado.

Nos vamos a
Código:
/etc/WifislaxUpdaterGUI/

y en el fichero blacklist , añadimos lo que deseamos que sea ignorado ..

por ejemplo . no queremos updates de smplayer

añadiriamos al fichero blacklist

Código:
smplayer_updater

La opcion 2

Si es un programa que no usamos , probablemente tanpoco nos interese en el sistema...

por ejemplo , no quieres en el sistema "audacity"

pues facil ... lo fulminas asi.

Código:
removepkg audacity



¡¡¡¡  muchisimo ojito ... eso solo podeis hacerlo con paquetes "sw" !!!

osea podeis eliminar programas extras , pero si no llevan en el nombre 1sw o similar ..es que es un paquete de la base ...y si lo eliminais, seguramente rompais algo .. y arriesgais a romper sistema si desinstalais por ejemplo glib2.


Si en la seccion  "actualizadores" ...hay una entrada para dicho programa/libreria  es por que es de los añadidos por nosotros y el riesgo es minimo , y ademas siempre lo podreis reinstalar desde ese mismo menu ...que no solo sirve para actualizar paquetes si no para añadir algunos como vlc , clementine , openoffice metasploit o tantos otros.


### CONCLUSIONES Y PALABRAS FINALES ###

¿eres usuario de tipo 1?

No toques ...el esfuerzo no te vale la pena y te va a dar igual si hay o no actualizaciones,si no conectas a internet o solo esporadicamente y en modo live.

Mantener el sistema "LIVE" , con las actualizaciones no es tan sencillo ni tan limpio como desde una instalacion en hdd.

¿eres del tipo 2 que instala al hdd?

Mi recomendacion es que dejes todo como esta , o al menos activado el escaneo al inicio para paquetes slackware , que es donde vas a recibir los parches de seguridad ,al menos los mas significativos...la busqueda de paquetes slackware se hace solo una vez al dia ... no es un drama.

Paquetes como java o flashplayer , son añadidos como extras , y ya sabeis que son dos minas de problemas de seguridad ... el sistema lo deje por defecto pensando en lo mejor para la mayoria ..pero dejando opciones, para los que quieran manejar la situacion de otra forma..a su manera.

Espero haber disipado al menos la mayor parte de dudas al respecto ... romper un programa no es un drama , se recompila se instala de nuevo y todos contentos , pero tras wifislax-4.11.1 que usaba la linea "experimetal" ... y que se rompio mas de una vez, comprendo el miedo y la reticencia de la gente al tema de actualizar cosas.

Por eso , decidi no usar mas esa linea en las versiones oficiales, y ofreceros algo mas estable y facil de mantener.  Wink


Si veis actualizaciones slackware , como son de tipo de "parche de seguridad" , es probable que querais saber mas.
En la siguiente url , podeis ver cada parche y sus CVE correspondientes, en algunos una breve explicacion del problema , aunque suelen ser temas bastante complejos y tecnicos, si quieres informarte aqui puedes verlo.

Miras a partir de
Thu Jun 30 20:26:57 UTC 2016
Slackware 14.2 x86 stable is released!


Hay se cerro el sistema a "estable", y de hay hacia arriba solo parches de seguridad.

http://www.slackware.com/changelog/stable.php?cpu=i386
« Última modificación: 06-08-2016, 01:29 (S?bado) por USUARIONUEVO » En línea

USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13648



Ver Perfil
« Respuesta #1 : 06-08-2016, 01:41 (S?bado) »

PARTE 2

Quiero un programa que no esta en la seccion de actualizadores

Bien , lo primero que dire es que si se trata de algun programa wifi/pentest , la llevas clara  Grin
Pero si buscas instalar algun programa , o juego ... o algo mas estandard , puedes mirar si esta disponible en slackbuilds.org

https://slackbuilds.org/

si estubiera disponible , puedes intentar la via "automatica" ...  que compilara e instalara las dependencias si no las tienes aun , para dicha tarea yo utilizo ahora mucho

Código:
slapt-src

paso 1 , sinconizar con slackbuilds para que tenga la lista de cosas que hay disponibles.


Código:
slapt-src -u

y para instalar por ejemplo el juego warzone2100 , haria esto

Código:
slatp-src -i warzone2100


si miramos slackbuilds vemos que tiene tres dependencias

https://slackbuilds.org/repository/14.2/games/warzone2100/?search=warzone

This requires: OpenAL, physfs, quesoglc

si alguna no la tienes se compilara e instalara primero automaticamente sin tu hacer nada.

Los paquetes resultantes por si quieres guardartelos estaran en

Código:
/usr/src/slapt-src/

buscas los que acaben con extension  .txz  y te los guardas, o los conviertes a xzm


Recomendado borrar lo que haya en
Código:
/usr/src/slapt-src/
despues de instalar algo ...asi nos sera mas facil encontrar despues lo que acabamos de instala y sus dependencias.
« Última modificación: 06-08-2016, 01:43 (S?bado) por USUARIONUEVO » En línea

Shyraz
******
Desconectado Desconectado

Mensajes: 299



Ver Perfil
« Respuesta #2 : 06-08-2016, 10:49 (S?bado) »

Muy didáctico USUARIONUEVO, gracias por el curro. Al final me veo usando wifislax para todo, mi portátil es viejo y se empieza a trabar con W7, para lo poco q lo uso ( prácticamente todo lo hago con el móvil), no tengo en mente comprarme otro, así q tengo wifislax en hdd y lo uso ya más q Windows, además cuando me aburro siempre está la opción de distraerte con las auditorias.

Desde mi Note3neo

En línea

Si crees que los pobres votan a la izquierda y los ricos a la derecha ¿Quién crees que intentará que haya más pobres? ¿Y más ricos?. Pues eso.
luky503
**
Desconectado Desconectado

Mensajes: 45

auuu


Ver Perfil
« Respuesta #3 : 28-09-2016, 23:42 (Mi?rcoles) »

Una pregunta se podran guardar las actualizaciones en una live usb en modo persistente?
En línea
Páginas: [1] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums