Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
22-08-2014, 13:46 (Viernes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Test de potencia en milivatios/dbm de adaptadores usb wifi

+  Seguridad Wireless - Wifi
|-+  Suite Seguridad Wireless
| |-+  Live CD wifiway (Moderador: USUARIONUEVO)
| | |-+  Instalacion de wifiway, windows 7 y Ubuntu.
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Ir Abajo Imprimir
Autor Tema: Instalacion de wifiway, windows 7 y Ubuntu.  (Leído 22409 veces)
honorios
**
Desconectado Desconectado

Mensajes: 13


Ver Perfil
« : 26-05-2010, 10:35 (Mircoles) »

Bueno compañeros, pues depués de leer y requeteleer, no soy capaz de hacer ni la primera parte de lo que quiero hacer. Os comento.
1º--> Quiero instalar wifiway y win7
2º--> Luego instalar ubuntu, bien desde windows con wubi o bien, como me digais.
He instalado el wifiway en el hd, sin ningún problema, gracias por supuesto, al gran manual del compañero, que sin el, no lo hubiese podido hacer. Hasta aquí todo ok.
He dejado el hdd completamente vacio y con una única partición que luego con el cdfisk he ido haciendo paso a paso como se indica.
Una vez con el wifiway instalado y a la hora de arrancar me salía para seleccionar el so con el quería iniciar, en este caso solo wifiway.
Luego he dicho, "cojonudo", vamos a cargar win7, y ha comenzado el "problema", que seguro viene por la inutilidad del que os suscribe.
He empezado a instalar, he seleccionado la partición que estaba sin usar, la he formateado y ha seguido toda la instalación perfectamente, hasta terminar y funcionar correctamente win7.
Lo bueno es, que al iniciar no me aparece el wifiway, he aquí el kit de  la cuestión. NO os quiero contar si tambien pongo el ubuntu ya entonces seguro que no funciona nada.
No sé, si esto tendrá solución, a ver que me decis y como puedo realizar la instalación para poder tener los tres sistemas.
Añado, que me he bajado la apli supergrub, he iniciado con ella, y solo ve el arranque de win7, wifiway no existe.
Perdonaz todo el rollo, y por supuesto perdonaz mi torpeza.
Un saludo y Muchas racias






En línea
chinitiw
*******
Desconectado Desconectado

Mensajes: 5532

][game 0ver][


Ver Perfil
« Respuesta #1 : 26-05-2010, 10:57 (Mircoles) »

me imagino que tu problema lo ha generado el bootloader de win7 que "probalemente" ha machacado el grub de wifiway y por eso no te da opción de arrancarlo de ninguna manera , por rematar el clavo yo probaría a instalar ubuntu porque lo que hará "seguramente" es crear un nuevo grub que te permita arrancar los tres sistemas (eso si lo más probable es que debas de tocar el grub.conf para que todo esté como debe)

Saludos

P.D. eso si si en Win7 tienes algo de importancia relevante hazte una copias de seguridad para no perder cosas importantes si no sale como tu quieres Wink
En línea
honorios
**
Desconectado Desconectado

Mensajes: 13


Ver Perfil
« Respuesta #2 : 26-05-2010, 11:27 (Mircoles) »

Muchisimas gracias por tu respuesta compañero. Seguro que tienes razon. Voy a hacer lo que me has dicho. Pero lo instalo con wubi o desde el cd ?? Tendre que hacer otra particion del hdd del win7 y formatearla en ext3 para instalar ubuntu o como lo ves tu??
En línea
chinitiw
*******
Desconectado Desconectado

Mensajes: 5532

][game 0ver][


Ver Perfil
« Respuesta #3 : 26-05-2010, 12:03 (Mircoles) »

lo de particionar está claro , quizás si redimensionas la partición de windows 7 tengas problemas , pero lo optimo es que tubieras tres particiones distintas desde el principio:

1-windows
2-wifiway
3-ubuntu

 Wink
En línea
honorios
**
Desconectado Desconectado

Mensajes: 13


Ver Perfil
« Respuesta #4 : 26-05-2010, 12:45 (Mircoles) »

Okeis. Entonces voy a empezar desde 0. Cual orden sigo?
1. Instalacion wifiway y creo desde cfdisk las particiones?? Cuales, cuantas y que extensiones. Mi hdd es de 320gb. 
2. Luego instalo win7 en que particion??
3. Por ultimo ubuntu desde el cd o desde el wubi??

Muchas gracias
En línea
frakc
****
Desconectado Desconectado

Mensajes: 69


Ver Perfil
« Respuesta #5 : 26-05-2010, 14:34 (Mircoles) »

Lo de instalar ubuntu en ultimo me salvo de situaciones similares, a saber lios en el GRUB
  Si haces todo desde zero, haz lo  como te dice chinitiw, respectando bien el orden, es decir:
 - en primero, en el C:, el windows ( formato NTFS). Por lo del tamaño, no se que decir con windows 7, nunce lo he probado, pero vamos, que con 320 GB de disco duro, tienes espacio de sobra para los tres SO y hacerte una particion guapa mas en NTFS o FAT32 para almacenar...
 - en segundo, el wifiway, con su SWAP (formato linux-swap) en D: (hda5 usando cfdisk), y su particion en ext3 en lo que seria el E: o el hda6 usando cfdisk. Con 4 GB rula, yo le pondria unos 10, historia de tener un poco de margen. Sigues los pasos de este exelente manual, solo que lo haces instalando wifiway no como sistema operativo unico sino que en dual-boot.
 - Al final el ubuntu, yo lo hago desde el CD, y para ser el mas vago, le digo de usar el espacio continuo libre mas grande para instalar el ubuntu, asi el lo hace todo solo... luego, si quieres hacer una particion de almacenamiento  siempre puedes redimensionar la particion del ubuntu con el Gparted o imagino con el cfdisk siempre que no este montada (o sea en modo live con el cd de ubuntu usando G-parted o desde el wifiway)
  Asi es muy facil de hacerlo sin liarla. Hay un punto que no me gusta, es que si he bien entendido, todo esso podria funcionar con una sola y unica particion SWAP y asi se nos queda con dos particiones SWAP... Pero bo, si tienes 320 GB de disco, no pasa na..
  Saludos y pasa te lo bien montando tu maquina tricefala... mirra, la podrias llamar cerbere.
En línea
drvalium
Colaborador
*
Desconectado Desconectado

Mensajes: 15504


Misantrópico


Ver Perfil
« Respuesta #6 : 26-05-2010, 15:18 (Mircoles) »

buenas

el orden es:

   Windows 7 (partición NTFS mínima 40gb)

   Wifiway (partición EXT3 6gb y sin hacer partición SWAP)

   Ubuntu (mínimo 10gb, la SWAP la crea automáticamente)

mejor instala Ubuntu desde el CD, así podrás hacer la partición desde el mismo instalador, Ubuntu se encarga de formatearla en EXT4, todo muy fácil.

de esta forma funciona todo sin necesidad de configurar nada, yo he configurado el GRUB pero solo para cambiarle los colores, el orden y el nombre con los que me aparecen los sistemas en el selector de arranque.


un saludo

Pd: para redimensionar particiones: http://foro.seguridadwireless.net/manuales-de-wifislax-wifiway/redimensionar-particion-activa/
« Última modificación: 26-05-2010, 15:24 (Mircoles) por drvalium » En línea

Cambio Pitbull por mano ortopédica.

ME HE IDO DE VACACIONES, SI ESPERABAS ALGUNA RESPUESTA POR MI PARTE TE PIDO DISCULPAS, VOY A ESTAR DESAPARECIDO UNOS CUANTOS DÍAS.
honorios
**
Desconectado Desconectado

Mensajes: 13


Ver Perfil
« Respuesta #7 : 26-05-2010, 16:00 (Mircoles) »

Muchisimas gracias por todas las explicaciones, de verdad. Voy a dejar el hdd a 0 y voy comenzar instalando windows, luego wifiway y por ultimo ubuntu. Una questión.
Voy a instalar win en 100gb, luego me quedarán 200gb libres sin formato, ¿los dejo sin formato, hasta que en el cfdisk del wifiway los cree o como lo hago? y otra questión. Cuando este dentro del cfdisk creando particiones para el wifiway, tengo que crearle la swap de 2gb y otra de 10gb en formato linux para instalarlo en esa misma y luego tengo que crear otra para instalar en esa ubuntu?? o lo dejo como espacio libre. Si tengo que crearla que formato le doy y la pongo como primaria, logica, iniciable??
Gracias otra vez.

Post Merge: 26-05-2010, 19:23 (Mircoles)
bueno compañeros, he instalado paso a paso todo, tal y como me dijisteis.
Primero windows7, luego wifiway en las particiones pertinentes y por ultimo, en el espacio que me quedaba vacio y sin partionar, ubuntu. La instalacion ha ido perfectamente, hasta el momento que me ha dicho si instalar o no el Grub. Le he dicho que no, porque yo pensaba que al tener instalado el wifiway ya tenia un grub y no debía meterle otro. El caso es, que al iniciar el sistema no me aparece para arrancar desde ubuntu. Solo pone windows y wifiway.
He puesto la aplicacion supergrub, y solo me detecta las dos que os estoy comentando, es como  si el ubuntu no se hubiese instalado.
¿ Como veis el tema, que solución puede tener ?
Gracias
« Última modificación: 26-05-2010, 19:23 (Mircoles) por honorios » En línea
frakc
****
Desconectado Desconectado

Mensajes: 69


Ver Perfil
« Respuesta #8 : 26-05-2010, 23:46 (Mircoles) »

Decir le si a instalar el GRUB y dejar el ubuntu dar la ultima capa... raro, no me acuerdo que me preguntara esso especificamente, de dejar le manipular el grub, pero si que te ha de funcionar dando le a "instalar de forma automatica en el espacio continuo libre mas grande" o algo asi. De hecho es logico: si no dejas el ultimo SO tocar el GRUB, el GrUB se va a quedar como estaba antes de instalar el ultimo SO entonces lo va a ignorar. Que tengas suerte
En línea
honorios
**
Desconectado Desconectado

Mensajes: 13


Ver Perfil
« Respuesta #9 : 27-05-2010, 10:57 (Jueves) »

Bueno amigos, pues después de darle unas cuantas vueltas no soy capaz de hacer que en el primer arranque me aparezcan los 3 sistemas operativos. WIN7, WIFIWAY y UBUNTU. Me aparace de esta manera.
Lo primero que sale es a elegir entre win7 y wifiway. Si le doy a win 7 sale otro arranque que me pone win7 y ubuntu y si pulso en ubuntu me sale ubunto y wifiway. Vamos un lio de pelotas. jejeje. A ver si me podeis hechar una manilla.
En línea
frakc
****
Desconectado Desconectado

Mensajes: 69


Ver Perfil
« Respuesta #10 : 27-05-2010, 15:52 (Jueves) »

Por lo menos tienes los tres SO y puedes aceder a ellos. Wink.. no, en serio, no veo lo que falla. Parece que es al momento de editar el GRUB de wifiway que halgo falla... Has probado arrancar cuando tenias solo windows y wifiway instalado? Que pasaba?
Quisas has hecho un errorcito en la instalacion de wifiway y lo has instalado como sistema operativo unico y no en dual-boot...
En tu caso intentaria asi: Dejaria el windows que es el mas pesado de instalar y borraria los dos linux, dejando el C con windows y todo lo demas como espacio virgen. Y reempezar instalando el wifiway que creo que es aqui que fallas, normal, es la unica parte del proceso que "no se hace todo sola".
Esso hecho, arrancar y ver si esta bien, con un menu de inicio que te propone arrancar desde windows 7 o desde wifiway. Porque si llegas ahi bien, lo ultimo, instalar ubuntu, esta chupado.
Suerte y cuenta nos.
En línea
honorios
**
Desconectado Desconectado

Mensajes: 13


Ver Perfil
« Respuesta #11 : 27-05-2010, 20:52 (Jueves) »

Muchas gracias frak por responder. Pues te comento. Cuando solamente tenía win7 y wifiway todo estaba perfecto, lo instale como segundo sistema operativo y al arrancar me salían los dos sistemas, y podía seleccionar el que quisiese. Luego instalé ubuntu y todo se mezclo. Algo he hecho mal seguro, pero la verdad que no se que puedo hacer. No me importa volver a empezar desde 0. El ubunto desde el cd, no se instalarlo, y lo tengo que instalar desde el wubi. Como lo veis.
En línea
drvalium
Colaborador
*
Desconectado Desconectado

Mensajes: 15504


Misantrópico


Ver Perfil
« Respuesta #12 : 27-05-2010, 22:20 (Jueves) »

buenas

no se que manía tenéis de pensar que los que usamos Linux también tenemos la facultad de la clarividencia.

1º cuando uno tiene problemas con el GRUB hay una cosa imprescindible para poder ayudarlo y es que ponga aquí la tabla de particiones que tiene (fdisk -l) y el contenido del GRUB.

2º tienes que configurar el GRUB de Ubuntu, el de Wifiway no sirve por que Wifiway no es capaz de manejar particiones EXT4 y te dará un error.


GRUB Ubuntu 10.4 (tendras que cambiar las particiones por las tuyas)

Citar
###Principio Windows 7###

menuentry "Windows 7 Ultimate" {
   insmod ntfs
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 208cfa648cfa33be
   chainloader +1
}
###Final Windows 7###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Wifiway 1.0 Final" {
   insmod ext2
   set root='(hd0,5)'
   search --no-floppy --fs-uuid --set cd629001-4f67-4634-aa1c-557f6c04ca32
   linux /boot/vmlinuz root=/dev/sda6 ro vga=789
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu 10.4 Lucid Lynx (2.6.32.22)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,8)'
   search --no-floppy --fs-uuid --set a56d0dd9-7341-4a47-9561-e27faff76a7c
   linux   /boot/vmlinuz-2.6.32-22-generic root=UUID=a56d0dd9-7341-4a47-9561-e27faff76a7c ro   quiet splash
   initrd   /boot/initrd.img-2.6.32-22-generic
}
menuentry 'Ubuntu 10.4 Lucid Lynx (2.6.32.22 modo recuperacion)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,8)'
   search --no-floppy --fs-uuid --set a56d0dd9-7341-4a47-9561-e27faff76a7c
   echo   'Cargando Linux 2.6.32-22-generic ...'
   linux   /boot/vmlinuz-2.6.32-22-generic root=UUID=a56d0dd9-7341-4a47-9561-e27faff76a7c ro single
   echo   'Cargando el disco RAM inicial...'
   initrd   /boot/initrd.img-2.6.32-22-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
   insmod ext2
   set root='(hd0,8)'
   search --no-floppy --fs-uuid --set a56d0dd9-7341-4a47-9561-e27faff76a7c
   linux16   /boot/memtest86+.bin
}
### END /etc/grub.d/20_memtest86+ ###


un saludo


En línea

Cambio Pitbull por mano ortopédica.

ME HE IDO DE VACACIONES, SI ESPERABAS ALGUNA RESPUESTA POR MI PARTE TE PIDO DISCULPAS, VOY A ESTAR DESAPARECIDO UNOS CUANTOS DÍAS.
frakc
****
Desconectado Desconectado

Mensajes: 69


Ver Perfil
« Respuesta #13 : 27-05-2010, 22:57 (Jueves) »

Como que no sabes instalar el ubuntu desde el CD? Pero hombre, instalar el wifiway es mas "dificil' que instalar el ubuntu. Has de hacer lo mismo que con wifiway, tener la BIOS para que arrenca desde el CD Driver, pones el CD de ubuntu gravado como imagen, ISO, y a seguir los 5-7 pasos del menu de instalacion... proba solo re-instalar el ubuntu sobre el mismo, solo que est vez desde el CD...Suerte

Post Merge: 31-05-2010, 02:37 (Lunes)
Lo conseguiste? Creo que tu fallo esta en usar esso de wubi: me parece, no estoy seguro para nada, que esso es para hacer esta instilacion un poco rara que tiene el ubuntu, a saber que se reserva unos 4 giga en un a particon ya hecha y se queda ahi, medio fantasma con rendimiento menor que si esta instalado en su particion. Mirra bien (por ejemplo con el norton magic partition, que es super facil de usar) si has realmente instalado el ubuntu en su propia particion en ext4. Si no es el caso es normal que tu GRUB este asi.
Suerte...
« Última modificación: 31-05-2010, 02:37 (Lunes) por frakc » En línea
Páginas: [1] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Powered by SMF 1.1.19 | SMF © 2006-2008, Simple Machines