Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
17-01-2018, 08:17 (Mi?rcoles)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Suite Seguridad Wireless
| |-+  Colaboracion y desarrollo de nuestras lives (Moderadores: 5.1, USUARIONUEVO)
| | |-+  Wifislax Updater GUI
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: 1 [2] 3 4 5 6 7 ... 18 Ir Abajo Imprimir
Autor Tema: Wifislax Updater GUI  (Leído 102549 veces)
maurimuy
****
Desconectado Desconectado

Mensajes: 78



Ver Perfil
« Respuesta #20 : 03-01-2015, 00:03 (S?bado) »

y con un "reload" "update"

y que cante!!!

ejemplo:

En línea

USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13786



Ver Perfil
« Respuesta #21 : 03-01-2015, 01:12 (S?bado) »

Bug ,  Grin

Si activo debug , al acabar la xterm no se cierra  Grin, y si la cierro yo ,no pasa nada, se queda en ..instalando actualizacion ,pero no hace nada ... Grin

creo que active debug + xzm

edit: si . estaba activado debug+xzm por que en ele scritorio esta la carpeta actualizaciones con el xzm de smtube , pero como digo , el proceso se ha quedado hay congelado-


________________

voy a crear un updater para yad , visto el potencial , mejor estar al dia si salen nuevas.
« Última modificación: 03-01-2015, 01:25 (S?bado) por USUARIONUEVO » En línea

USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13786



Ver Perfil
« Respuesta #22 : 03-01-2015, 02:28 (S?bado) »

Otro bug  Wink


Si el sistema arranca y NO TIENE INTERNET , ..aun asi se pone a buscar updates ,  antes de ponerse a buscar deberia verificar que tiene salida a internet , si no , aparece esto

En línea

pepe10000
*******
Desconectado Desconectado

Mensajes: 534


Ver Perfil
« Respuesta #23 : 03-01-2015, 08:46 (S?bado) »

A mi también me da algún que otro fallito.

Si inicio en KDE me dice que hay una actualización del smtube, le digo que la instale y se queda ejecutando (picar en las imágenes para ampliar):





Lo cierro y lo ejecuto desde el menú de inicio, busca las actualizaciones y me dice que todo está actualizado:









En XFCE unas veces me dice que hay una actualización del smtube y otras que del smtube y del aircrack pero también se queda ejecutando:



Después intento llamarlo en XFCE desde el menú de inicio y no se abre.

Un saludo.
« Última modificación: 03-01-2015, 08:47 (S?bado) por pepe10000 » En línea
Fr3dY
******
Desconectado Desconectado

Mensajes: 476


Ver Perfil
« Respuesta #24 : 03-01-2015, 13:36 (S?bado) »

Muy bueno, geminis_demon!!!



Saludos
En línea
Nexus89
*******
Desconectado Desconectado

Mensajes: 724

Wifislax 4.6


Ver Perfil
« Respuesta #25 : 03-01-2015, 15:52 (S?bado) »

Esta fuera de linea el enlance para el Updater.
En línea
geminis_demon
Colaborador
*
Desconectado Desconectado

Mensajes: 2400


Prácticas precisas precisan práctica


Ver Perfil
« Respuesta #26 : 03-01-2015, 17:07 (S?bado) »

Version 0.3: https://mega.co.nz/#!BtRTTCwR!le0tcA35KaSlsH2WYhVPz3Pkyug-lzxBivMxgi2p_Fg

Solucionados los errores reportados (o eso creo).
« Última modificación: 03-01-2015, 17:07 (S?bado) por geminis_demon » En línea


La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.
teik
*******
Desconectado Desconectado

Mensajes: 528


Ver Perfil
« Respuesta #27 : 03-01-2015, 17:17 (S?bado) »

lo tengo autoinstalado en HDD y no me inicia desde el menu? porque puede ser? hay forma de lanzarlo mediante terminal y ver que errores da?
En línea
geminis_demon
Colaborador
*
Desconectado Desconectado

Mensajes: 2400


Prácticas precisas precisan práctica


Ver Perfil
« Respuesta #28 : 03-01-2015, 18:40 (S?bado) »

Cuando inicias el sistema se ejecuta solo, y mientras se está ejecutando en segundo plano no se puede ejecutar desde el menú.

Si no tienes conexión a internet seguirá en ejecución esperando a que haya conexión, y mientras tanto no podrás ejecutarlo desde el menú.

Lo he hecho así porque al ejecutarlo elimina el directorio temporal, y si lo ejecutas dos veces se producirán conlictos y saltarán errores por todos lados.

Para la próxima versión le añadiré un mensaje que te avise de que no se puede ejecutar porque ya se está ejecutando en segundo plano, así evitaremos estas confusiones.
En línea


La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.
pepe10000
*******
Desconectado Desconectado

Mensajes: 534


Ver Perfil
« Respuesta #29 : 03-01-2015, 19:05 (S?bado) »

He probado la nueva versión y ya no se atasca, me ha detectado una nueva versión del smtube y la ha instalado.

Pero no se si debería de haber creado algún módulo (no lo he visto por el escritorio) para el modo LiveUSB o simplemente actualiza y ya está.

El problema es que en XFCE funciona bien al inicio, también me ha detectado una actualización de smtube y la ha instalado, pero si lo llamas desde el menú no aparece.

He probado a llamarlo desde una terminal en XFCE y aparece esto (picar en la imagen para ampliar):



Un saludo.
En línea
geminis_demon
Colaborador
*
Desconectado Desconectado

Mensajes: 2400


Prácticas precisas precisan práctica


Ver Perfil
« Respuesta #30 : 03-01-2015, 19:39 (S?bado) »

Versión 0.4: https://mega.co.nz/#!YxJwVRIb!9xu9XNRqhpnQaU3QRTflM5Ei6pCdDC2XW66rHZu20XE

Añadido mensaje de aviso cuando se intenta ejecutar el programa y ya se está ejecutando, y solucionado conflicto cuando un log de paquete está repetido.

@pepe10000 si quieres que guarde las actualizaciones en módulos tienes que activarlo en las opciones, y lo de que no se ejecuta desde el menú ya lo he explicado arrriba.
En línea


La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.
pepe10000
*******
Desconectado Desconectado

Mensajes: 534


Ver Perfil
« Respuesta #31 : 03-01-2015, 20:15 (S?bado) »

Código:
si quieres que guarde las actualizaciones en módulos tienes que activarlo en las opciones

Oído cocina, comprobado y funciona, me crea un modulo con la actualización del smtube, lo meto en la carpeta modules del USB, reinicio y me vuelve a decir que hay una actualización del smtube  Azn

Código:
y lo de que no se ejecuta desde el menú ya lo he explicado arrriba

Ya lo había leído, pero arrancada en XFCE con la versión anterior, actualizaba, terminaba el proceso, esperaba un rato y al llamarlo desde el acceso directo del menú no se ejecutaba.
Con la nueva versión ya se ejecuta sin problemas desde el menú.

Un saludo y va a ser una magnifica herramienta.
En línea
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13786



Ver Perfil
« Respuesta #32 : 03-01-2015, 20:34 (S?bado) »

lo de smtube , es raro , yo lo actualice desde la version 0.2 del updater y salio perfecto.


parece que esta atastacado , pero no es asi ,..esta compilando en segundo plano , para ver la compilacion en opciones activar "modo debug", entonces lo hara todo en consola y podreis ir viendolo.


bajo y pruebo.


se que lo de avisar del kernel no l ocontemplas , ... por el tema compilacion ,  pero podria avisar ...y que si quieres compialr el kernel uses el updater y tal.

asi quito el mio definitivamente por que solo es eso , lo que necesito solo es el aviso de que hay uno nuevo.
« Última modificación: 03-01-2015, 20:36 (S?bado) por USUARIONUEVO » En línea

geminis_demon
Colaborador
*
Desconectado Desconectado

Mensajes: 2400


Prácticas precisas precisan práctica


Ver Perfil
« Respuesta #33 : 03-01-2015, 21:11 (S?bado) »

@pepe10000 Ok, no te había entendido bien. Miraré lo de smtube a ver que pasa.

@USUARIONUEVO puedo poner en el menú de opciones, una opción para que no actualice el kernel, pero creo que el notify sigue siendo necesario, porque creo que hay mas updaters que no cumplen con el estandar, no estoy seguro, habría que revisarlos...

Con cumplir el estadar me refiero a que utilice las variables "WEB, VERSION, DOWNLOAD, ARCHIVO" para determinar la última versión disponible.

El programa recorre todos los updaters grepeando esas variables para comprobar si hay actualizaciones, si un updater utiliza otras variables que no sean esas no es reconocido por el programa.
En línea


La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13786



Ver Perfil
« Respuesta #34 : 03-01-2015, 21:36 (S?bado) »

el problema es que nosbaemos cuales estan excluidos ahora mismo ...


por que si no , tal vez pudiera arreglarlo.


pero , por ejemplo  driver ati  , ...ese no ...la version esta fijada
kernel tampoco por que no es plan , es algo de estar controlando el proceso y tarda demasiado

luego ...  no se si hashcat  , ...


estoy escribiendo el updater del driver nvidia , los de driver se excluyen , por que siempre van a tener version fijada , cuando hashcat permita una version mas alta de driver , subo al ftp el updater con la version subida y listo ...  Grin Grin Grin  ese es el plan respecto a alguno de los raritos.

el unico rarito sin version fijada es el de kernel ...demas , solo deberia mirar el de kernel_linux  , que es el que mira para la misma rama del sistema , ...el de kernelstable esperto ,debe ignorarlo ...


el estable es sencillo ..simplemente dandole entr enter enter ...acabas con el kernel hecho ya que no necesita configurar nada , el estable SI , siempre, por eso pone esperto.
En línea

geminis_demon
Colaborador
*
Desconectado Desconectado

Mensajes: 2400


Prácticas precisas precisan práctica


Ver Perfil
« Respuesta #35 : 03-01-2015, 22:12 (S?bado) »

Código:
#!/bin/bash

# Buscar updaters incompatibles con WifislaxUpdaterGUI

for UPDATER in $(find /opt/wifislax-updaters -type f -iname "*_updater"); do

egrep "PRGNAM=|WEB=|VERSION=|DOWNLOAD=|ARCHIVO=" "$UPDATER" >/tmp/$$.tmp && source /tmp/$$.tmp 2>/dev/null
[ ! "$VERSION" ] && echo "$(basename "$UPDATER")"
unset PRGNAM INSTALADA WEB VERSION
rm -f /tmp/$$.tmp
done

Este script busca las ultimas versiones de la misma forma que lo hace WifislaxUpdaterGUI, si no consigue determinar la última versión muestra el nombre del updater por pantalla.

Me salen estos:

Código:
pokerth_updater
linux_updater
firmwares_updater
linux_stable_updater
sigram_updater
firefox_multi_updater
mixxx_updater
brasero_updater
LibreOffice_updater
funciones_updater

El de sigram no es que sea incompatible es que la web la han movido de sitio y por eso no encuentra la última versión, puede que a alguno mas le pase lo mismo..
« Última modificación: 03-01-2015, 22:16 (S?bado) por geminis_demon » En línea


La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.
USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13786



Ver Perfil
« Respuesta #36 : 03-01-2015, 22:17 (S?bado) »

Código:
#!/bin/bash

# Buscar updaters incompatibles con WifislaxUpdaterGUI

for UPDATER in $(find /opt/wifislax-updaters -type f -iname "*_updater"); do

egrep "PRGNAM=|WEB=|VERSION=|DOWNLOAD=|ARCHIVO=" "$UPDATER" >/tmp/$$.tmp && source /tmp/$$.tmp 2>/dev/null
[ ! "$VERSION" ] && echo "$(basename "$UPDATER")"
unset PRGNAM INSTALADA WEB VERSION
rm -f /tmp/$$.tmp
done

Este script busca las ultimas versiones de la misma forma que lo hace WifislaxUpdaterGUI, si no consigue determinar la última versión muestra el nombre del updater por pantalla.

Me salen estos:

Código:
pokerth_updater
linux_updater
firmwares_updater
linux_stable_updater
sigram_updater
firefox_multi_updater
mixxx_updater
brasero_updater
LibreOffice_updater
funciones_updater

El de sigram no es que sea incompatible es que la web la han movido de sitio y por eso no encuentra la última versión, puede que a alguno mas le pase lo mismo..

OK , sigram , ya hace un par de semanas que me di cuenta que algo fallaba ... pero pense tenian el ftp caido o algo ... lo arreglare entonces.
En línea

USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13786



Ver Perfil
« Respuesta #37 : 03-01-2015, 22:21 (S?bado) »

, de todas formas creo que en mi buscador de updates, sigram no estaba  Wink

En línea

USUARIONUEVO
Moderador
*
Desconectado Desconectado

Mensajes: 13786



Ver Perfil
« Respuesta #38 : 03-01-2015, 23:58 (S?bado) »

otro bug ,,,  Grin


justamente despues de mas de  un mes , aircrack-ng a actualizado ..


el updater actualiza ,pero no elimina el paquete anterior, lo se por que me ha dejado en log packages los 2

el nuevo y el viejo ..eso a probacado un caos en el updater al tener dos ..se ha hecho la picha un lio.


no se si habras visto esta parte en el funciones.sh

Código:
  if [ $PRGNAM = aircrack-ng ]; then
      INSTALADA=$(grep -r -i "package name" /var/log/packages/$PRGNAM-[0-9]* | awk '{print $3}' | sed "s/$PRGNAM-//g" | cut -d- -f-3)
   else
      INSTALADA=$(grep -r -i "package name" /var/log/packages/$PRGNAM-[0-9]*-* | awk '{print $3}' | sed "s/$PRGNAM//g" | cut -d- -f2)
   fi
     
« Última modificación: 04-01-2015, 00:00 (Domingo) por USUARIONUEVO » En línea

geminis_demon
Colaborador
*
Desconectado Desconectado

Mensajes: 2400


Prácticas precisas precisan práctica


Ver Perfil
« Respuesta #39 : 04-01-2015, 00:37 (Domingo) »

Ok, arreglaré eso.

En el funciones.sh puedes sustituir esas 5 líneas por esta:

Código:
INSTALADA="$(ls /var/log/packages/$PRGNAM-[0-9]*-* 2>/dev/null|cut -d '/' -f5-|sed "s/^${PRGNAM}-//"|rev|cut -d'-' -f3-|rev|tail -1)"

Así no te hace falta poner un "if" para aircrack-ng, y de esa forma tampoco se hará la picha un lio cuando un log esté repetido, cogerá como referencia la versión mas alta.
En línea


La luz cree que viaja más rápido que cualquier otra cosa, pero se equivoca; da lo mismo lo rápido que pueda viajar, porque al final, la luz descubre que la oscuridad ha llegado antes que ella, y la está esperando.
Páginas: 1 [2] 3 4 5 6 7 ... 18 Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums