Bienvenido(a), Visitante. Por favor, ingresa o regístrate.
¿Perdiste tu email de activación?
23-10-2017, 17:07 (Lunes)
Inicio Ayuda Reglas Buscar Ingresar Registrarse
Noticias:
Liberada wifislax64-1.1 version final para descargar

Videos Downloader




+  Seguridad Wireless - Wifi
|-+  Suite Seguridad Wireless
| |-+  Colaboracion y desarrollo de nuestras lives (Moderadores: 5.1, USUARIONUEVO)
| | |-+  Como averiguar las dependencias de un ejecutable
0 Usuarios y 1 Visitante están viendo este tema. « anterior próximo »
Páginas: [1] Ir Abajo Imprimir
Autor Tema: Como averiguar las dependencias de un ejecutable  (Leído 7422 veces)
USUARIONUEVO
Moderador
*
Conectado Conectado

Mensajes: 13747



Ver Perfil
« : 18-06-2013, 04:58 (Martes) »

Bueno pues , mas de una vez , me he visto en la tesitura de encontrarme algun binario ( ejecutable ) , que al lanzarlo da error , sin mas ... sin decirme "me falta esta libreria".


con lo que me puse a buscar un poco por google , y  encontre el comando


ldd


el uso es

Código:
ldd /ruta-absoluta-del-binario

por ejemplo para saber las dependencias de crda

Código:
ldd /sbin/crda


de devolvera algo similar a esto

Código:
wifislax ~ # ldd /sbin/crda
        linux-gate.so.1 (0xb77d7000)
        libgcrypt.so.11 => /lib/libgcrypt.so.11 (0xb772e000)
        libnl.so.1 => /usr/lib/libnl.so.1 (0xb76ec000)
        libc.so.6 => /lib/libc.so.6 (0xb7567000)
        libgpg-error.so.0 => /lib/libgpg-error.so.0 (0xb7563000)
        libm.so.6 => /lib/libm.so.6 (0xb7536000)
        /lib/ld-linux.so.2 (0xb77d8000)
wifislax ~ #

como vemos hay se muestra las librerias que necesita ese ejecutable.





En línea

joss
****
Desconectado Desconectado

Mensajes: 89


Ver Perfil
« Respuesta #1 : 18-06-2013, 07:13 (Martes) »

No conocia ese comando lo probe y funciona excelente

Gracias  Angry
En línea
Garcad
*******
Desconectado Desconectado

Mensajes: 925


Ver Perfil
« Respuesta #2 : 16-12-2013, 01:35 (Lunes) »

Yo uso slackyd me permite ver si tengo todas las dependencias de los paquetes instalados o de un paquete en concreto

Código:
http://www.slacky.eu/wikislack/index.php?title=Slackyd,_lo_slacky_downloader_che_risolve_le_dipendenze_dei_pacchetti

wifislax ~ # slackyd
Usage: slackyd <options> <package>            

Options:                                            
 -5: Skip md5 verify.                                
 -b: Try to download package build sources.          
 -B: Try to build package from sources.              
 -c: Use alternate config file.                      
 -d: Search missing shared libraries of installed packages.
 -D: Search missing required packages (packager-indicated).
 -e: Use regex.                                      
 -f: Force update or packages download. Assume yes to all question.
 -g: Download package.                              
 -h: Show this help.                                
 -I: Skip packages status check.                    
 -l: List all packages installed.                    
 -L: List all non-slackware packages installed.      
 -m: Case insensitive.                              
 -n: Only notify broken dependencies.                
 -O: List all orphan packages.                      
 -p: Clean slackyd directory (only packages and sources).
 -P: Clean slackyd directory (all).                  
 -q: Quiet, disable some warnings.                  
 -r: Search not official replaceable packages.      
 -R: Show repositories statistics.                  
 -s: Search package.                                
 -S: Skip dependencies check.                        
 -u: Update packages list and md5 hash list.        
 -U: Search new packages.                            
 -v: Verbose mode.                                  
 -V: Show slackyd info.                              
 -w: View package info.                              
 -x: Disable blacklist.                              
 -X: Show packages available and blacklisted.        
wifislax ~ #

wifislax ~ #  slackyd -d

Código:
Found 79 missing dependencies:
libGLEW.so.1.5 required by:
 --> Package: Matrix-screensaver-i486-1sw (/usr/bin/matrixview)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.opengl.glsl.so)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.opengl.glsl.so.0)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.opengl.glsl.so.0.0.0)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.opengl.so)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.opengl.so.0)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.opengl.so.0.0.0)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.sdl.so)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.sdl.so.0)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.sdl.so.0.0.0)
libMagickWand.so.5 required by:
 --> Package: Matrix-screensaver-i486-1sw (/usr/bin/matrixview)
 --> Package: php-imagick-3.1.0RC2-i486-1sw (/usr/lib/php/extensions/imagick.so)
libMagickCore.so.5 required by:
 --> Package: Matrix-screensaver-i486-1sw (/usr/bin/matrixview)
 --> Package: php-imagick-3.1.0RC2-i486-1sw (/usr/lib/php/extensions/imagick.so)
libwbclient.so.0 required by:
 --> Package: cifs-utils-5.5-i486-2 (/usr/bin/setcifsacl)
 --> Package: cifs-utils-5.5-i486-2 (/usr/bin/getcifsacl)
 --> Package: cifs-utils-5.5-i486-2 (/usr/sbin/cifs.idmap)
libcuda.so.1 required by:
 --> Package: cpyrit_cuda-0.4.1_dev-i486-1sw (/usr/lib/python2.7/site-packages/cpyrit/_cpyrit_cuda.so)
libOpenCL.so.1 required by:
 --> Package: cpyrit_opencl-0.4.1_dev-i486-1sw (/usr/lib/python2.7/site-packages/cpyrit/_cpyrit_opencl.so)
libhunspell-1.3.so.0 required by:
 --> Package: enchant-1.6.0-i486-1 (/usr/lib/enchant/libenchant_myspell.so)
libxmms.so.1 required by:
 --> Package: faad2-2.7-i486-9sl (/usr/lib/xmms/Input/libmp4.so)
 --> Package: flac-1.2.1-i486-3 (/usr/lib/xmms/Input/libxmms-flac.so)
 --> Package: kde-workspace-4.10.5-i486-2 (/usr/lib/kde4/plasma_engine_nowplaying.so)
libgmime-2.4.so.2 required by:
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.mime.so)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.mime.so.0)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.mime.so.0.0.0)
libpoppler.so.26 required by:
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.pdf.so)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.pdf.so.0)
 --> Package: gambas3-runtime-3.4.1-i486-1sw (/usr/lib/gambas3/gb.pdf.so.0.0.0)
libgcj.so.14 required by:
 --> Package: gettext-tools-0.18.2.1-i486-2 (/usr/lib/gettext/gnu.gettext.GetURL)
 --> Package: gettext-tools-0.18.2.1-i486-2 (/usr/lib/gettext/gnu.gettext.DumpResource)
libsmbclient.so.0 required by:
 --> Package: gnome-vfs-2.24.4-i486-2sl (/usr/lib/gnome-vfs-2.0/modules/libsmb.so)
 --> Package: gvfs-1.16.3-i486-2 (/usr/libexec/gvfsd-smb)
 --> Package: gvfs-1.16.3-i486-2 (/usr/libexec/gvfsd-smb-browse)
 --> Package: kde-runtime-4.10.5-i486-1 (/usr/lib/kde4/kio_smb.so)
 --> Package: xine-lib-1.1.21-i686-2 (/usr/lib/xine/plugins/1.30/xineplug_inp_smb.so)
libguile-2.0.so.22 required by:
 --> Package: gnutls-3.1.16-i486-1 (/usr/lib/guile/2.0/guile-gnutls-v-2.so.0)
 --> Package: gnutls-3.1.16-i486-1 (/usr/lib/guile/2.0/guile-gnutls-v-2.so)
 --> Package: gnutls-3.1.16-i486-1 (/usr/lib/guile/2.0/guile-gnutls-v-2.so.0.0.0)
libgc.so.1 required by:
 --> Package: gnutls-3.1.16-i486-1 (/usr/lib/guile/2.0/guile-gnutls-v-2.so.0)
 --> Package: gnutls-3.1.16-i486-1 (/usr/lib/guile/2.0/guile-gnutls-v-2.so)
 --> Package: gnutls-3.1.16-i486-1 (/usr/lib/guile/2.0/guile-gnutls-v-2.so.0.0.0)
libmtp.so.9 required by:
 --> Package: gvfs-1.16.3-i486-2 (/usr/libexec/gvfsd-mtp)
 --> Package: kio-mtp-fae62fc_20121225git-i486-1 (/usr/lib/kde4/kio_mtp.so)
libnfnetlink.so.0 required by:
 --> Package: iptables-1.4.20-i486-1 (/usr/sbin/nfnl_osf)
 --> Package: iptables-1.4.20-i486-1 (/usr/lib/xtables/libxt_connlabel.so)
libnetfilter_conntrack.so.3 required by:
 --> Package: iptables-1.4.20-i486-1 (/usr/lib/xtables/libxt_connlabel.so)
libavcodec.so.52 required by:
 --> Package: jre-7u45-i586-1sw (/usr/lib/java/lib/i386/fxavcodecplugin-52.so)
libavformat.so.52 required by:
 --> Package: jre-7u45-i586-1sw (/usr/lib/java/lib/i386/fxavcodecplugin-52.so)
libavcodec.so.53 required by:
 --> Package: jre-7u45-i586-1sw (/usr/lib/java/lib/i386/fxavcodecplugin-53.so)
libavformat.so.53 required by:
 --> Package: jre-7u45-i586-1sw (/usr/lib/java/lib/i386/fxavcodecplugin-53.so)
libtidy-0.99.so.0 required by:
 --> Package: kde-baseapps-4.10.5-i486-1 (/usr/lib/kde4/validatorsplugin.so)
libakonadiprotocolinternals.so.1 required by:
 --> Package: kdepim-runtime-4.10.5-i486-1 (/usr/bin/akonaditray)
 --> Package: kdepim-runtime-4.10.5-i486-1 (/usr/lib/libakonadi-filestore.so)
 --> Package: kdepim-runtime-4.10.5-i486-1 (/usr/lib/libakonadi-filestore.so.4)
 --> Package: kdepim-runtime-4.10.5-i486-1 (/usr/lib/kde4/akonadi_serializer_mail.so)
 --> Package: kdepim-runtime-4.10.5-i486-1 (/usr/lib/kde4/kcm_akonadi_server.so)
 --> Package: kdepim-runtime-4.10.5-i486-1 (/usr/lib/libakonadi-filestore.so.4.10.5)
 --> Package: kdepimlibs-4.10.5-i486-1 (/usr/lib/libakonadi-kde.so.4.10.5)
 --> Package: kdepimlibs-4.10.5-i486-1 (/usr/lib/libakonadi-kde.so)
 --> Package: kdepimlibs-4.10.5-i486-1 (/usr/lib/libakonadi-kde.so.4)
libcddb.so.2 required by:
 --> Package: libcdio-0.83-i486-1 (/usr/bin/cdda-player)
 --> Package: libcdio-0.83-i486-1 (/usr/bin/cd-info)
libperl.so required by:
 --> Package: libproxy-0.4.11-i486-2 (/usr/lib/perl5/vendor_perl/auto/Net/Libproxy/Libproxy.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDEUi4/KDEUi4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KIO4/KIO4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/NepomukQuery/NepomukQuery.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KTextEditor/KTextEditor.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KHTML/KHTML.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KParts/KParts.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Soprano/Soprano.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KFile/KFile.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoServer/SopranoServer.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDECore4/KDECore4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Solid/Solid.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Okular/Okular.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoClient/SopranoClient.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Nepomuk/Nepomuk.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff3/KNewStuff3.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Attica/Attica.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Akonadi/Akonadi.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Plasma4/Plasma4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Kate/Kate.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff2/KNewStuff2.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KUtils/KUtils.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/kde4/kperlpluginfactory.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtOpenGL4/QtOpenGL4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDBus4/QtDBus4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtGui4/QtGui4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qt3Support4/Qt3Support4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXmlPatterns4/QtXmlPatterns4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtHelp4/QtHelp4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtCore4/QtCore4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtWebKit4/QtWebKit4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSql4/QtSql4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Phonon/Phonon.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDeclarative4/QtDeclarative4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXml4/QtXml4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtScript4/QtScript4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtTest4/QtTest4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtUiTools4/QtUiTools4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSvg4/QtSvg4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QImageBlitz/QImageBlitz.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtNetwork4/QtNetwork4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qsci/Qsci.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtMultimedia4/QtMultimedia4.so)
libanthy.so.0 required by:
 --> Package: m17n-lib-1.6.1-i486-1 (/usr/lib/m17n/1.0/libmimx-anthy.so)
 --> Package: scim-anthy-1.2.4-i486-2 (/usr/lib/scim-1.0/1.4.0/IMEngine/anthy.so)
libanthydic.so.0 required by:
 --> Package: m17n-lib-1.6.1-i486-1 (/usr/lib/m17n/1.0/libmimx-anthy.so)
 --> Package: scim-anthy-1.2.4-i486-2 (/usr/lib/scim-1.0/1.4.0/IMEngine/anthy.so)
libruby.so.1.9 required by:
 --> Package: obexftp-0.23-i486-9 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/obexftp.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtuitools.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtruby4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qttest.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtwebkit.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/phonon.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtscript.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtdeclarative.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2.0.0)
libspectre.so.1 required by:
 --> Package: okular-4.10.5-i486-1 (/usr/lib/kde4/okularGenerator_ghostview.so)
libchm.so.0 required by:
 --> Package: okular-4.10.5-i486-1 (/usr/lib/kde4/kio_msits.so)
 --> Package: okular-4.10.5-i486-1 (/usr/lib/kde4/okularGenerator_chmlib.so)
libavutil.so.51 required by:
 --> Package: openal-soft-1.15.1-i486-2sw (/usr/bin/alstream)
 --> Package: openal-soft-1.15.1-i486-2sw (/usr/bin/allatency)
 --> Package: openal-soft-1.15.1-i486-2sw (/usr/bin/alreverb)
libmysqlclient.so.18 required by:
 --> Package: perl-5.18.1-i486-1 (/usr/lib/perl5/vendor_perl/auto/DBD/mysql/mysql.so)
 --> Package: qt-4.8.5-i486-2 (/usr/lib/qt/plugins/sqldrivers/libqsqlmysql.so)
 --> Package: redland-1.0.16-i486-1 (/usr/lib/redland/librdf_storage_mysql.so)
libsmokekdeui.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDEUi4/KDEUi4.so)
QtCore4.so required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDEUi4/KDEUi4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KIO4/KIO4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/NepomukQuery/NepomukQuery.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KTextEditor/KTextEditor.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KHTML/KHTML.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KParts/KParts.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Soprano/Soprano.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KFile/KFile.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoServer/SopranoServer.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDECore4/KDECore4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Solid/Solid.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Okular/Okular.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoClient/SopranoClient.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Nepomuk/Nepomuk.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff3/KNewStuff3.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Attica/Attica.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Akonadi/Akonadi.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Plasma4/Plasma4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Kate/Kate.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff2/KNewStuff2.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KUtils/KUtils.so)
libsmokebase.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDEUi4/KDEUi4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KIO4/KIO4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/NepomukQuery/NepomukQuery.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KTextEditor/KTextEditor.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KHTML/KHTML.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KParts/KParts.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Soprano/Soprano.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KFile/KFile.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoServer/SopranoServer.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDECore4/KDECore4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Solid/Solid.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Okular/Okular.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoClient/SopranoClient.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Nepomuk/Nepomuk.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff3/KNewStuff3.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Attica/Attica.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Akonadi/Akonadi.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Plasma4/Plasma4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Kate/Kate.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff2/KNewStuff2.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KUtils/KUtils.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtOpenGL4/QtOpenGL4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDBus4/QtDBus4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtGui4/QtGui4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qt3Support4/Qt3Support4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXmlPatterns4/QtXmlPatterns4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtHelp4/QtHelp4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtCore4/QtCore4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtWebKit4/QtWebKit4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSql4/QtSql4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Phonon/Phonon.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDeclarative4/QtDeclarative4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXml4/QtXml4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtScript4/QtScript4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtTest4/QtTest4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtUiTools4/QtUiTools4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSvg4/QtSvg4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QImageBlitz/QImageBlitz.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtNetwork4/QtNetwork4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qsci/Qsci.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtMultimedia4/QtMultimedia4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtuitools.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtruby4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qttest.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtwebkit.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/phonon.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtscript.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtdeclarative.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2.0.0)
libsmokeqtcore.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDEUi4/KDEUi4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KIO4/KIO4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/NepomukQuery/NepomukQuery.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KTextEditor/KTextEditor.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KHTML/KHTML.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KParts/KParts.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Soprano/Soprano.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KFile/KFile.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoServer/SopranoServer.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDECore4/KDECore4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Solid/Solid.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Okular/Okular.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoClient/SopranoClient.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Nepomuk/Nepomuk.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff3/KNewStuff3.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Attica/Attica.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Akonadi/Akonadi.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Plasma4/Plasma4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Kate/Kate.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff2/KNewStuff2.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KUtils/KUtils.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtOpenGL4/QtOpenGL4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDBus4/QtDBus4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtGui4/QtGui4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qt3Support4/Qt3Support4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXmlPatterns4/QtXmlPatterns4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtHelp4/QtHelp4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtCore4/QtCore4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtWebKit4/QtWebKit4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSql4/QtSql4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Phonon/Phonon.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDeclarative4/QtDeclarative4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXml4/QtXml4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtScript4/QtScript4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtTest4/QtTest4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtUiTools4/QtUiTools4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSvg4/QtSvg4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QImageBlitz/QImageBlitz.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtNetwork4/QtNetwork4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qsci/Qsci.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtMultimedia4/QtMultimedia4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtuitools.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtruby4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qttest.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtwebkit.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/phonon.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtscript.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtdeclarative.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2.0.0)
libsmokeqtgui.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDEUi4/KDEUi4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KIO4/KIO4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/NepomukQuery/NepomukQuery.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KTextEditor/KTextEditor.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KHTML/KHTML.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KParts/KParts.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Soprano/Soprano.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KFile/KFile.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoServer/SopranoServer.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDECore4/KDECore4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Solid/Solid.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Okular/Okular.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoClient/SopranoClient.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Nepomuk/Nepomuk.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff3/KNewStuff3.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Attica/Attica.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Akonadi/Akonadi.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Plasma4/Plasma4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Kate/Kate.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff2/KNewStuff2.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KUtils/KUtils.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtOpenGL4/QtOpenGL4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDBus4/QtDBus4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtGui4/QtGui4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qt3Support4/Qt3Support4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXmlPatterns4/QtXmlPatterns4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtHelp4/QtHelp4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtCore4/QtCore4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtWebKit4/QtWebKit4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSql4/QtSql4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Phonon/Phonon.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDeclarative4/QtDeclarative4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXml4/QtXml4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtScript4/QtScript4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtTest4/QtTest4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtUiTools4/QtUiTools4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSvg4/QtSvg4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QImageBlitz/QImageBlitz.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtNetwork4/QtNetwork4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qsci/Qsci.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtMultimedia4/QtMultimedia4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtuitools.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtruby4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qttest.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtwebkit.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/phonon.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtscript.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtdeclarative.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2.0.0)
libsmokeqtnetwork.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDEUi4/KDEUi4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KIO4/KIO4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/NepomukQuery/NepomukQuery.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KTextEditor/KTextEditor.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KHTML/KHTML.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KParts/KParts.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Soprano/Soprano.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KFile/KFile.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoServer/SopranoServer.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDECore4/KDECore4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Solid/Solid.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Okular/Okular.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoClient/SopranoClient.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Nepomuk/Nepomuk.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff3/KNewStuff3.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Attica/Attica.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Akonadi/Akonadi.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Plasma4/Plasma4.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Kate/Kate.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff2/KNewStuff2.so)
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KUtils/KUtils.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtOpenGL4/QtOpenGL4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDBus4/QtDBus4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtGui4/QtGui4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qt3Support4/Qt3Support4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXmlPatterns4/QtXmlPatterns4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtHelp4/QtHelp4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtCore4/QtCore4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtWebKit4/QtWebKit4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSql4/QtSql4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Phonon/Phonon.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDeclarative4/QtDeclarative4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXml4/QtXml4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtScript4/QtScript4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtTest4/QtTest4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtUiTools4/QtUiTools4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSvg4/QtSvg4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QImageBlitz/QImageBlitz.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtNetwork4/QtNetwork4.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qsci/Qsci.so)
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtMultimedia4/QtMultimedia4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtuitools.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtruby4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qttest.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtwebkit.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/phonon.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtscript.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtdeclarative.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2.0.0)
libsmokekio.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KIO4/KIO4.so)
libsmokenepomukquery.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/NepomukQuery/NepomukQuery.so)
libsmokektexteditor.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KTextEditor/KTextEditor.so)
libsmokekhtml.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KHTML/KHTML.so)
libsmokekparts.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KParts/KParts.so)
libsmokesoprano.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Soprano/Soprano.so)
libsmokekfile.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KFile/KFile.so)
libsmokesopranoserver.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoServer/SopranoServer.so)
libsmokekdecore.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KDECore4/KDECore4.so)
libsmokesolid.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Solid/Solid.so)
libsmokeokular.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Okular/Okular.so)
libsmokesopranoclient.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/SopranoClient/SopranoClient.so)
libsmokenepomuk.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Nepomuk/Nepomuk.so)
libsmokeknewstuff3.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff3/KNewStuff3.so)
libsmokeattica.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Attica/Attica.so)
libsmokeakonadi.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Akonadi/Akonadi.so)
libsmokeplasma.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Plasma4/Plasma4.so)
libsmokekate.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Kate/Kate.so)
libsmokeknewstuff2.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KNewStuff2/KNewStuff2.so)
libsmokekutils.so.3 required by:
 --> Package: perlkde-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/KUtils/KUtils.so)
libsmokeqtopengl.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtOpenGL4/QtOpenGL4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtuitools.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtruby4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qttest.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtwebkit.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/phonon.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtscript.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtdeclarative.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2.0.0)
libsmokeqtdbus.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDBus4/QtDBus4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtuitools.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtruby4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qttest.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtwebkit.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/phonon.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtscript.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtdeclarative.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2.0.0)
libsmokeqt3support.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qt3Support4/Qt3Support4.so)
libsmokeqtxmlpatterns.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXmlPatterns4/QtXmlPatterns4.so)
libsmokeqthelp.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtHelp4/QtHelp4.so)
libsmokeqtwebkit.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtWebKit4/QtWebKit4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtwebkit.so)
libsmokeqtsql.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSql4/QtSql4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtuitools.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtruby4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qttest.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtwebkit.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/phonon.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtscript.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtdeclarative.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2.0.0)
libsmokephonon.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Phonon/Phonon.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/phonon.so)
libsmokeqtdeclarative.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtDeclarative4/QtDeclarative4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtdeclarative.so)
libsmokeqtxml.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtXml4/QtXml4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtuitools.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtruby4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qttest.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtwebkit.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/phonon.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtscript.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtdeclarative.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2.0.0)
libsmokeqtscript.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtScript4/QtScript4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtscript.so)
libsmokeqttest.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtTest4/QtTest4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qttest.so)
libsmokeqtuitools.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtUiTools4/QtUiTools4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtuitools.so)
libsmokeqtsvg.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtSvg4/QtSvg4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtuitools.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtruby4.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qttest.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtwebkit.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/phonon.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtscript.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qtdeclarative.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/libqtruby4shared.so.2.0.0)
libsmokeqimageblitz.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QImageBlitz/QImageBlitz.so)
libsmokeqsci.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/Qsci/Qsci.so)
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
libsmokeqtmultimedia.so.3 required by:
 --> Package: perlqt-4.10.5-i486-1 (/usr/lib/perl5/vendor_perl/auto/QtMultimedia4/QtMultimedia4.so)
libsane.so.1 required by:
 --> Package: pil-1.1.7-i486-4 (/usr/lib/python2.7/site-packages/_sane.so)
libqscintilla2.so.8 required by:
 --> Package: qtruby-4.10.5-i486-1 (/usr/lib/ruby/site_ruby/1.9.1/i486-linux/qscintilla.so)
librasqal.so.3 required by:
 --> Package: redland-1.0.16-i486-1 (/usr/lib/librdf.so)
 --> Package: redland-1.0.16-i486-1 (/usr/lib/librdf.so.0)
 --> Package: redland-1.0.16-i486-1 (/usr/lib/librdf.so.0.0.0)
 --> Package: redland-1.0.16-i486-1 (/usr/bin/rdfproc)
 --> Package: redland-1.0.16-i486-1 (/usr/bin/redland-db-upgrade)
libraptor2.so.0 required by:
 --> Package: redland-1.0.16-i486-1 (/usr/lib/librdf.so)
 --> Package: redland-1.0.16-i486-1 (/usr/lib/librdf.so.0)
 --> Package: redland-1.0.16-i486-1 (/usr/lib/librdf.so.0.0.0)
 --> Package: redland-1.0.16-i486-1 (/usr/bin/rdfproc)
 --> Package: redland-1.0.16-i486-1 (/usr/bin/redland-db-upgrade)
 --> Package: soprano-2.9.0-i486-1 (/usr/lib/soprano/libsoprano_raptorparser.so)
 --> Package: soprano-2.9.0-i486-1 (/usr/lib/soprano/libsoprano_raptorserializer.so)

Searching libGLEW.so.1.5: nothing found.
Searching libMagickWand.so.5: nothing found.
Searching libMagickCore.so.5: nothing found.
Searching libwbclient.so.0: found 1 package.
Searching libcuda.so.1: nothing found.
Searching libOpenCL.so.1: nothing found.
Searching libhunspell-1.3.so.0: found 1 package.
Searching libxmms.so.1: found 1 package.
Searching libgmime-2.4.so.2: nothing found.
Searching libpoppler.so.26: nothing found.
Searching libgcj.so.14: found 1 package.
Searching libsmbclient.so.0: found 1 package.
Searching libguile-2.0.so.22: found 1 package.
Searching libgc.so.1: found 1 package.
Searching libmtp.so.9: found 1 package.
Searching libnfnetlink.so.0: found 1 package.
Searching libnetfilter_conntrack.so.3: found 1 package.
Searching libavcodec.so.52: nothing found.
Searching libavformat.so.52: nothing found.
Searching libavcodec.so.53: nothing found.
Searching libavformat.so.53: nothing found.
Searching libtidy-0.99.so.0: found 1 package.
Searching libakonadiprotocolinternals.so.1: found 1 package.
Searching libcddb.so.2: found 1 package.
Searching libperl.so: found 1 package.
Searching libanthy.so.0: found 1 package.
Searching libanthydic.so.0: found 1 package.
Searching libruby.so.1.9: found 1 package.
Searching libspectre.so.1: found 1 package.
Searching libchm.so.0: found 1 package.
Searching libavutil.so.51: nothing found.
Searching libmysqlclient.so.18: found 1 package.
Searching libsmokekdeui.so.3: found 1 package.
Searching QtCore4.so: found 1 package.
Searching libsmokebase.so.3: found 1 package.
Searching libsmokeqtcore.so.3: found 1 package.
Searching libsmokeqtgui.so.3: found 1 package.
Searching libsmokeqtnetwork.so.3: found 1 package.
Searching libsmokekio.so.3: found 1 package.
Searching libsmokenepomukquery.so.3: found 1 package.
Searching libsmokektexteditor.so.3: found 1 package.
Searching libsmokekhtml.so.3: found 1 package.
Searching libsmokekparts.so.3: found 1 package.
Searching libsmokesoprano.so.3: found 1 package.
Searching libsmokekfile.so.3: found 1 package.
Searching libsmokesopranoserver.so.3: found 1 package.
Searching libsmokekdecore.so.3: found 1 package.
Searching libsmokesolid.so.3: found 1 package.
Searching libsmokeokular.so.3: found 1 package.
Searching libsmokesopranoclient.so.3: found 1 package.
Searching libsmokenepomuk.so.3: found 1 package.
Searching libsmokeknewstuff3.so.3: found 1 package.
Searching libsmokeattica.so.3: found 1 package.
Searching libsmokeakonadi.so.3: found 1 package.
Searching libsmokeplasma.so.3: found 1 package.
Searching libsmokekate.so.3: found 1 package.
Searching libsmokeknewstuff2.so.3: found 1 package.
Searching libsmokekutils.so.3: found 1 package.
Searching libsmokeqtopengl.so.3: found 1 package.
Searching libsmokeqtdbus.so.3: found 1 package.
Searching libsmokeqt3support.so.3: found 1 package.
Searching libsmokeqtxmlpatterns.so.3: found 1 package.
Searching libsmokeqthelp.so.3: found 1 package.
Searching libsmokeqtwebkit.so.3: found 1 package.
Searching libsmokeqtsql.so.3: found 1 package.
Searching libsmokephonon.so.3: found 1 package.
Searching libsmokeqtdeclarative.so.3: found 1 package.
Searching libsmokeqtxml.so.3: found 1 package.
Searching libsmokeqtscript.so.3: found 1 package.
Searching libsmokeqttest.so.3: found 1 package.
Searching libsmokeqtuitools.so.3: found 1 package.
Searching libsmokeqtsvg.so.3: found 1 package.
Searching libsmokeqimageblitz.so.3: found 1 package.
Searching libsmokeqsci.so.3: found 1 package.
Searching libsmokeqtmultimedia.so.3: found 1 package.
Searching libsane.so.1: found 1 package.
Searching libqscintilla2.so.8: found 1 package.
Searching librasqal.so.3: found 1 package.
Searching libraptor2.so.0: found 1 package.

Download QScintilla-2.6.1-i486-4.txz [from slackware] ? [y/N] n
Download akonadi-1.9.2-i486-1.txz [from slackware] ? [y/N] n
Download anthy-9100h-i486-1.txz [from slackware] ? [y/N] n
Download chmlib-0.40-i486-2.txz [from slackware] ? [y/N] n
Download gc-7.2d-i486-1.txz [from slackware] ? [y/N] n
Download gcc-java-4.8.2-i486-1.txz [from slackware] ? [y/N] n
Download guile-2.0.9-i486-1.txz [from slackware] ? [y/N] n
Download hunspell-1.3.2-i486-1.txz [from slackware] ? [y/N] n
Download kdewebdev-4.10.5-i486-1.txz [from slackware] ? [y/N] n
Download libcddb-1.3.2-i486-2.txz [from slackware] ? [y/N] n
Download libmtp-1.1.6-i486-1.txz [from slackware] ? [y/N] n
Download libnetfilter_conntrack-1.0.4-i486-1.txz [from slackware] ? [y/N] n
Download libnfnetlink-1.0.1-i486-1.txz [from slackware] ? [y/N] n
Download libspectre-0.2.7-i486-1.txz [from slackware] ? [y/N] n
Download mariadb-5.5.32-i486-1.txz [from slackware] ? [y/N] n
Download perl-5.18.1-i486-1.txz [from slackware] ? [y/N] n
Download perlqt-4.10.5-i486-1.txz [from slackware] ? [y/N] n
Download raptor2-2.0.9-i486-1.txz [from slackware] ? [y/N] n
Download rasqal-0.9.30-i486-1.txz [from slackware] ? [y/N] n
Download ruby-1.9.3_p448-i486-1.txz [from slackware] ? [y/N] n
Download samba-4.1.1-i486-1.txz [from slackware] ? [y/N] n
Download sane-1.0.24-i486-1.txz [from slackware] ? [y/N] n
Download smokegen-4.10.5-i486-1.txz [from slackware] ? [y/N] n
Download smokekde-4.10.5-i486-1.txz [from slackware] ? [y/N] n
Download smokeqt-4.10.5-i486-1.txz [from slackware] ? [y/N] n
Download xmms-1.2.11-i486-5.txz [from slackware] ? [y/N] n

Nothing was choosed.

wifislax ~ #

Instalando todo lo descargado.

# upgradepkg --install-new /var/slackyd/*.t*z

Borrando todos los archivos descargados.

# rm /var/slackyd/*.t*z

Salu2
« Última modificación: 16-12-2013, 02:17 (Lunes) por Garcad » En línea

El conocimiento por sí solo no genera valor. El valor sólo es creado cuando la sabiduría encauza y orienta los conocimientos. Daisaku Ikeda

Modulos WifiSlax 64Bits

Modulos Wifiway

Modulos 4.10.alfa1
USUARIONUEVO
Moderador
*
Conectado Conectado

Mensajes: 13747



Ver Perfil
« Respuesta #3 : 16-12-2013, 01:40 (Lunes) »

WOOOWWW

slackyd al poder ....
En línea

chinitiw
*******
Desconectado Desconectado

Mensajes: 5522

][game 0ver][


Ver Perfil
« Respuesta #4 : 29-12-2013, 19:53 (Domingo) »

Gracias por el aporte Garcad , muy muy interesante.

Saludos
En línea
USUARIONUEVO
Moderador
*
Conectado Conectado

Mensajes: 13747



Ver Perfil
« Respuesta #5 : 29-12-2013, 21:55 (Domingo) »

Gracias por el aporte Garcad , muy muy interesante.

Saludos

tan interesante que lo metere en wifislax-4.8 , ya estubo anteriormente en otras verisones pero desconocia la utilidad de encontrar "dependencias" ,perdidas.

lo he estado ya usando en el desarrollo actual , para dejar la iso con cero dependencias rotas.   Angry
En línea

Garcad
*******
Desconectado Desconectado

Mensajes: 925


Ver Perfil
« Respuesta #6 : 02-02-2014, 03:41 (Domingo) »

He encontrado otras herramientas que ayudaran a encontrar dependencias rotas.

http://download.salixos.org/i486/14.1/salix/ap/

depfinder: encuentra las dependencias de paquetes Slackware

Código:
wifislax ~ # depfinder -h
depfinder: encuentra las dependencias de paquetes Slackware

Uso: depfinder [OPCIONES] <paquete.tgz|.txz|.tlz|.tbz o directorio-de-empaquetado>

OPCIONES:
    -f,         Redirigir las dependencias de la salida estándar a un archivo.
                Por defecto crea un archivo .dep. Ver también la opción -s.
    -s,         Muestra las dependencias con información de la versión. Si se
                combina con la opción -f, crea un archivo 'slack-required'.
    -a,         Verificar todos los archivos en el árbol de directorios en lugar del
                siguiente FHS.
    -p,          Intentos de detección de dependencias de Python.
    -j [jobs],  La cantidad de procesos depfinder en paralelo a ejecutar. Más rápido
                si coincide la cantidad de sus procesadores/núcleos.
                (por defecto: 1)
    -v,          Mostrar la versión.
    -h,          Mostrar este mensaje de ayuda.
wifislax ~ #

depcheck (una herramienta para comprobar *.DEP contra el sistema)

Código:
wifislax ~ # depcheck -h
USAGE: depcheck [OPTIONS]

OPTIONS:
   -f, --file         use a local .dep/.sug/.con file
   -u, --url          use a URL to a .dep/.sug/.con file
   -n, --no-color     do not color missing dependencies red
   -h, --help         this help message
wifislax ~ #


Wifislax ~ # depfinder -f /mnt/live/memory/images/031-Multimedia_pack2_wifislax_4.8-1.0-i486-2sw.xzm && depcheck -f 031-Multimedia_pack2_wifislax_4.8-1.0-i486-2sw.xzm.dep

jack......................................NOT FOUND

EDITADO:Limpiando un poco

Wifislax ~ # slapt-get -d jack --install
Leyendo listas de paquetes...Hecho
Se instalarán los siguientes paquetes NUEVOS:
  opus jack
0 actualizados, 0 reinstalados, 2 recién instalados, 0 para quitar, 0 no actualizados.
Se necesita obtener 753,0kB de archivos.
1/2 Obtener http://download.salixos.org/i486/14.1/ opus 1.1-i486-2gv [299,0kB]...Hecho
2/2 Obtener http://download.salixos.org/i486/14.1/ jack 1.9.9.5-i486-1dj [454,0kB]...Hecho

wifislax ~ # slapt-get jack --install
Leyendo listas de paquetes...Hecho
Se instalarán los siguientes paquetes NUEVOS:

Executing install script for opus-1.1-i486-2gv.txz.
Package opus-1.1-i486-2gv.txz installed.

Executing install script for jack-1.9.9.5-i486-1dj.txz.
Package jack-1.9.9.5-i486-1dj.txz installed.

wifislax ~ # depfinder -f /mnt/live/memory/images/031-Multimedia_pack2_wifislax_4.8-1.0-i486-2sw.xzm && depcheck -f 031-Multimedia_pack2_wifislax_4.8-1.0-i486-2sw.xzm.dep

jack......................................jack-1.9.9.5-i486-1dj

wifislax ~ #

Salu2
« Última modificación: 03-02-2014, 17:42 (Lunes) por Garcad » En línea

El conocimiento por sí solo no genera valor. El valor sólo es creado cuando la sabiduría encauza y orienta los conocimientos. Daisaku Ikeda

Modulos WifiSlax 64Bits

Modulos Wifiway

Modulos 4.10.alfa1
vk496
*******
Desconectado Desconectado

Mensajes: 2192



Ver Perfil WWW
« Respuesta #7 : 01-07-2015, 01:41 (Mi?rcoles) »

nm tambien podría ser de interés.

Me fue de gran ayuda para averiguar en que fichero objeto se encontraba una función concreta.

http://www.thegeekstuff.com/2012/03/linux-nm-command/

Salu2
En línea
Páginas: [1] Ir Arriba Imprimir 
« anterior próximo »
Ir a:  


Ingresar con nombre de usuario, contraseña y duración de la sesión

Las cookies de este sitio web se usan para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Además, compartimos información sobre el uso que haga del sitio web con nuestros partners de redes sociales, publicidad y análisis web, quienes pueden combinarla con otra información que les haya proporcionado o que hayan recopilado a partir del uso que haya hecho de sus servicios
Si continúa navegando consideramos que acepta su uso. OK Más información | Y más
Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines
SMFAds for Free Forums