TP-LINK TL-WN422G ¿Funciona o no funciona?
<< < (11/19) > >>
frakc:
 ;DTengo una WN722N que lleva el mismo chipset y me funcionna con ubuntu 9.10(de momento en mode managed, no he provado aun en mode monitor). Ni siquiera sale aun en la lista des harwares compatibles mientras que la TP-Link W422G si y tambien el WN721N.
He seguido los mismos pasos que los descritos en la misma pagina:
http://maximi89.blogspot.com/2010_03_01_archive.html
Por si hace falta y explico lo que hizo:
Descargue los drivers desde  http://files.iniza.org/ath9k_htc/
Una vez descargado lo descomprimi en el mismo excritorio, asi me aparece una carpeta llamada "compat-eireless 2010-03-19"-
Abri un terminal y escribi:
cd '/home/kcdtv/Escritorio/compat-wireless-2010-03-19/'    (kcdtv es mi nombre de usuario, poner el vuestro)
luego:
sudo make
y por fin:
sudo make install

La ventana te dice que hay que desactivar (unload) los drivers wireless y bluetoth. Haz-lo y luego activa el ath9k_httc con el commando load, en la misma ventana de terminal

Una vez hecho esso, hay que descargar y copiar el firmware en la carpeta apropriada: /lib/firmeware.
El firmware lo podeis obtener aqui: http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=blob_plain;f=ar9271.fw;hb=35b308409dc18991ec833c
En mi caso, para copier el firmeware descargado en mi escritorio y pegar lo en la carpeta /lib/firmware hizo asi:
sudo cp -r '/home/kcdtv/Escritorio/ar9271.fw' /lib/firmware

Y ya esta >:(:
kcdtv@kcdtv-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11bg  Mode:Managed  Frequency:2.462 GHz 
          Access Point: Not-Associated   Bit Rate:0 kb/s   Tx-Power=20 dBm   
          Sensitivity=8/0 
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wlan0     IEEE 802.11bgn  ESSID:"JAZZTEL_xx" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:1A:2B:51:7B:xx   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=29/70  Signal level=-81 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

el eth1 es una ipw2200bg y el wlan0 es my TP-Link WN722N

kcdtv@kcdtv-laptop:~$ lsusb
Bus 001 Device 002: ID 0cf3:9271 Atheros Communications, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

De momento va bien en managed, lo tengo enchufado directo al portatil y pilla mas o menos igual que la ipw2200bg, que no es sorda. Luego probare con aircrack y tambien probare con wifiway 1.0 final y os conto. suerte

Post Merge: 20-04-2010, 02:33 (Martes)Y funciona en mode monitor... ;D

kcdtv-laptop:~$ sudo airmon-ng start wlan0
[sudo] password for kcdtv:


Found 4 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID   Name
747   NetworkManager
749   avahi-daemon
752   avahi-daemon
854   wpa_supplicant


Interface   Chipset      Driver

eth1      Intel 2200BG   ipw2200 - [phy0]
wlan0      Unknown    usb - [phy1]
            (monitor mode enabled on mon0)

kcdtv@kcdtv-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11bg  Mode:Managed  Frequency:2.462 GHz 
          Access Point: Not-Associated   Bit Rate:0 kb/s   Tx-Power=20 dBm   
          Sensitivity=8/0 
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wlan0     IEEE 802.11bgn  Mode:Managed  Frequency:2.462 GHz 
          Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
mon0      IEEE 802.11bgn  Mode:Monitor  Frequency:2.462 GHz  Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
kcdtv@kcdtv-laptop:~$ airodump-ng -w captura mon0
socket(PF_PACKET) failed: Operation not permitted
This program requires root privileges.
kcdtv@kcdtv-laptop:~$ sudo airodump-ng -w captura mon0


CH  5 ][ Elapsed: 8 s ][ 2010-04-20 03:12                                     
                                                                               
 BSSID              PWR  Beacons    #Data, #/s  CH  MB   ENC  CIPHER AUTH ESSID
                                                                               
 00:02:CF:76:43:22   -1        0        2    0 143  -1   WEP  WEP         <leng
 00:1A:2B:0C:BA:0B  -68        2        0    0   7  11   WEP  WEP         WILLY
 00:1E:4C:56:BD:EC  -75        3        0    0  11  54e  WPA  TKIP   PSK  Liveb
 00:02:CF:66:A5:91  -86        4        0    0   1  54 . WEP  WEP         WLAN_
 00:01:38:F3:B1:63  -89        2        0    0  12  54 . WEP  WEP         WLAN_
                                                                               
 BSSID              STATION            PWR   Rate    Lost  Packets  Probes     
                                                                               
 00:02:CF:76:43:22  00:02:72:5F:4A:2A  -87    0 - 2      1        3             
 (not associated)   00:16:6F:A3:80:8A  -34    0 - 1      0       41             
 (not associated)   00:24:F3:10:97:16  -92    0 - 1     84        3  WLAN_44   
 00:1A:2B:0C:BA:0B  00:80:5A:51:D9:ED  -16    0 -11      0        2             

yessssssssssss >:(             

GC_:
¿Que ha de ser? Yo le he intentado en Debian (Lenny/Squeeze) Ubuntu 9.10, con este WN422G y nada, en la página que citas tambien usaron un WN722N pero sobre Fedora 12, será que tú adaptador está soportado y este (WN422G) aunque es el mismo chipset (ar9271) no lo está.

Aca los pasos que segui:
http://maximi89.blogspot.com/2010/03/how-to-get-support-for-chip-ar9271-como.html?showComment=1271567617028#c8425273826983701039
Post Merge: 20-04-2010, 08:37 (Martes)Ya me di cuenta, se debia a un problema en el ID de dispositivo, hasta el compat-wireless del 28 de marzo, que era el que se podia compilar bien no venia corregido ese problema, solo tenia soporte para los que si ID era 0x9271, pero no para 0x1006 que es el que trae el TL-WN422G v2.
Pues bien, habia intentado compilar con versiones de abril sin éxito, hasta hoy que use la version compat-wireless-2010-03-28. Y ya, ya funciona, de hecho estoy usando el adaptador ahorita mismo  >:(

Gracias a google que me llevo por aca:
https://patchwork.kernel.org/patch/89102/
frakc:
Si, muy importante esso de bien actualizar su S.O. y su kernel! LLevaba un tiempo sin usar ubuntu y primero no me funciono... hasta que me di cuenta que hacia falta actualisar >:D. Ahora que me puedo conectar con el TP-Link WN722N, no pasara mas ;D
GC_:
Como que actualizar el kernel?. Según la página requieres un kernel >= 2.6.25.
Lo he comprobado en Debian Lenny (Linux 2.6.26-2-686) y funciona, también en modo monitor  :D

http://wireless.kernel.org/en/users/Download#Requirements_for_bleeding_edge
Post Merge: 20-04-2010, 19:44 (Martes)Edito:
La versión que use es la compat-wireless-2010-04-19, con esa ha funcionado en linux este bicho que no me servía.
Me di cuenta de que escribí compat-wireless-2010-03-28, pero esa no me funcionó.
frakc:
Tenia el penultimo kernel puesto cuando empeze la instalacion, y no me funciono hasta que hizo las actualisaciones y cuando reinicie, paso al ultimo kernel y funciono... No se mas.
¿Que tal va el WN422G?
Con el TP-Link WN722N me parece o que en algo he fallado - que es muy probable - o que el driver no esta aun aprovechando del todo los recursos de este adaptador
Hoy he ido mirrando como se pordaba y aunque me da una lista de redes mas  grande bajo ubuntu, la connecion no es tam buena que bajo windows. Tiene unos brotes y se desconecta a menudo. Uso el wireless assitant que viene por defecto en ubuntu, quisas sea el problema... aunque con la ipw2200 no va mal.
En mode monitor, pues parece bien, ahi a primera vista, pero no se si es tan bueno que esso, ve muchas pero no me parece mui estable en captura de paquetes. Tampoco he probado mucho...mas tarde os cuento saludos!
Navegación
Índice de Mensajes
Página Siguiente
Página Anterior